<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="It isn&#039;t too often an player posts his best statistical season to date -- leading the NFL in rushing TDs -- and struggles to find a job the next season. It was the perfect storm for LeGarrette Blount after his 1,161-yard, 18-touchdown season in New England last year." />
<meta name="keywords" content="player movement, darren sproles, fantasy football, legarrette blount, philadelphia eagles, ryan mathews" />
<title>Eagles add LeGarrette Blount to further cloud their backfield | The Huddle</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1495086374&amp;back=http%3A%2F%2Fthehuddle.com%2F2017%2F05%2F17%2Fphiladelphia-eagles-legarrette-blount-fantasy-football%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Feed" href="http://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Comments Feed" href="http://thehuddle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Eagles add LeGarrette Blount to further cloud their backfield Comments Feed" href="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1488818651h&ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJylUMtuAyEM/KFSK20SKYeq1/5Bz17WZZ3YgIDNKn9fNqskSh/00AuaMTPMGJiiscEX8gV0NFFGxz7DFG1Qk5WFTl/Yo835AX62CR8ow55KRHswZ9aS25CozjVimRVKPSMJaZW1bBq3F9cMh5rVjFnqd11MlLOpp/Kopgw16I96OldZ9oAqvJ8sVgYfCld3voJvby5RcOQIY8YSejwZwSmRt3S5fMeMHf/DCm9j3wu1FnIUjASLhYO/I+ZDkFPLmqiT4Cp054+40d8aD2twEjqUWfCqL6v17vlps9ustvtPUpTrmg==' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"","ads":[],"tlmurl":"https:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJytketqwzAMhV9ojmloWf6UPYvqKJkS32bJybKnnzvSQmlZWygYbHS+cyzLeo6KvLG5RdZDWV8Z07Ju1cBv+j9AOeoTCFaO/Ak2wQt6ObIuHMiiyowJ+lIrQV24wcXA4pC5QDfUy5bIT4TzXWxAiWBGlZDp5ypVPrHcpyeKOjNIaGFR0eaePGuIpHqwFhMVBJhR/h4uCJayW7XlFZGZ21jqc5HUtKnqRzItzAm9waOfR4rKkh9VF0xm1dH3sxHruBxcf+A9q6XDyc5CZnxoJBftU5vOCeVc/B9uv9k273XTbHf18AsNuPwN'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:thehuddle","priority_asset":"","blogname":"","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"428185","headline":"Eagles add LeGarrette Blount to further cloud their backfield","byline":"Cory Bonini","taxonomykeywords":"Darren Sproles, Fantasy Football, LeGarrette Blount, Philadelphia Eagles, Ryan Mathews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/thehuddle3/prod/utag.js?ver=4.7.5'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2rqPPXv' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=json&amp;url=http%3A%2F%2Fthehuddle.com%2F2017%2F05%2F17%2Fphiladelphia-eagles-legarrette-blount-fantasy-football%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=xml&amp;url=http%3A%2F%2Fthehuddle.com%2F2017%2F05%2F17%2Fphiladelphia-eagles-legarrette-blount-fantasy-football%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Eagles add LeGarrette Blount to further cloud their backfield" />
<meta property="og:url" content="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/" />
<meta property="og:description" content="It isn&#8217;t too often an player posts his best statistical season to date &#8212; leading the NFL in rushing TDs &#8212; and struggles to find a job the next season. It was the perfect storm for…" />
<meta property="article:published_time" content="2017-05-17T16:08:38+00:00" />
<meta property="article:modified_time" content="2017-05-17T16:09:59+00:00" />
<meta property="og:site_name" content="The Huddle" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=1200" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="701" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:image:src" content="https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="http://thehuddle.com/osd.xml" title="The Huddle" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<script type="text/javascript">!function(t,e,n){function a(t){var a=e.createElement("script");a.type="text/javascript",a.async=!0,a.src=("https:"===e.location.protocol?"https":"http")+":"+n,(t||e.body||e.head).appendChild(a)}function o(){var t=e.getElementsByTagName("script"),n=t[t.length-1];return n.parentNode} var p=o();t.spotId="sp_HiauZ6ow",t.parentElement=p,a(p)}(window.SPOTIM={},document,"//www.spot.im/launcher/bundle.js");</script><style type="text/css">
.articleBody a,
.author__description a,
.error404 .entry-content a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.error404 .entry-content h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.error404 .entry-content .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.error404 .entry-content blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.article__back,
.newsletter__input {
	border-color: #dd9933;
}

.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.error404 .entry-content:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Huddle" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Fantasy Football Cheat Sheets, Rankings, Sleepers &amp; Award Winning Draft Advice" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://thehuddle.com/feed/;icon-uri=http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false;
	var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
</script>

</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["Darren Sproles","Fantasy Football","LeGarrette Blount","Philadelphia Eagles","Ryan Mathews","Cory Bonini","Player Movement"],"category":"Player Movement","isMobile":"0"};
googletag_cmd_push(function() {
window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();
try { amznads.setTargetingForGPTAsync( 'amznslots' ); } catch(e) { /*ignore*/ }
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>
<link rel="amphtml" href="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-428185 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	
	
<div id="wrapper">

	<div id="header-ad" class="">
	</div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="http://thehuddle.com"
				title="The Huddle"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="The Huddle"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Huddle" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-424405" class="nav__item nav__item--draft-kit"><a href="/fantasy_football_draft_kit.php">Draft Kit</a></li>
<li id="menu-item-424406" class="nav__item nav__item--in-season"><a href="/in-season-fantasy-football/">In Season</a></li>
<li id="menu-item-424407" class="nav__item nav__item--dfs"><a href="/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-427411" class="nav__item nav__item--articles"><a href="/fantasy_football_articles.php">Articles</a></li>
<li id="menu-item-424408" class="nav__item nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li id="menu-item-424409" class="nav__item nav__item--stats"><a href="/fantasy_football_statistics.php">Stats</a></li>
<li id="menu-item-424410" class="nav__item nav__item--depth-charts"><a href="/2016/nfl/nfl-depth-charts.php">Depth Charts</a></li>
<li id="menu-item-424627" class="nav__item nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li id="menu-item-424411" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-424412" class="nav__item nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li id="menu-item-424413" class="nav__item nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li id="menu-item-424995" class="nav__item nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
							<li class="nav__item nav__item--social nav__item--facebook">
					<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
				</li>
							<li class="nav__item nav__item--social nav__item--twitter">
					<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
				</li>
					</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-428185" class="post-428185 post type-post status-publish format-standard has-post-thumbnail hentry category-player-movement tag-darren-sproles tag-fantasy-football tag-legarrette-blount tag-philadelphia-eagles tag-ryan-mathews article--no-image" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title article__title--no-image ">
	<h1 class="article__headline">Eagles add LeGarrette Blount to further cloud their backfield</h1>

	</div>
<h1 class="article__headline article__headline--mobile">Eagles add LeGarrette Blount to further cloud their backfield</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://thehuddle.com/category/player-movement/" class="" itemprop="articleSection">Player Movement</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Eagles add LeGarrette Blount to further cloud their backfield</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a> 
		<span class="post-date updated">May 17, 2017</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
					Follow					@Cory_Bonini				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					
				</header>

				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">14</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
		data-short-url=""
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
		data-short-url=""
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
		data-short-url=""
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
		data-short-url=""
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
			data-short-url=""
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>		| May 17, 2017		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
		Follow @Cory_Bonini	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><div id="attachment_428186" class="wp-caption aligncenter"><img data-attachment-id="428186" data-permalink="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/nfl-super-bowl-li-new-england-patriots-vs-atlanta-falcons-2/" data-orig-file="https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=1000&#038;h=701" data-orig-size="3823,2679" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Mark J. Rebilas-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X&quot;,&quot;caption&quot;:&quot;Feb 5, 2017; Houston, TX, USA; New England Patriots running back LeGarrette Blount (29) against the Atlanta Falcons during Super Bowl LI at NRG Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1486340251&quot;,&quot;copyright&quot;:&quot;Mark J. Rebilas&quot;,&quot;focal_length&quot;:&quot;70&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;NFL: Super Bowl LI-New England Patriots vs Atlanta Falcons&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NFL: Super Bowl LI-New England Patriots vs Atlanta Falcons" data-image-description="&lt;p&gt;Feb 5, 2017; Houston, TX, USA; New England Patriots running back LeGarrette Blount (29) against the Atlanta Falcons during Super Bowl LI at NRG Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=1000&#038;h=701?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=1000&#038;h=701?w=1000" class="size-full wp-image-428186" src="https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=1000&#038;h=701" alt="" width="1000" height="701" srcset="https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=1000&amp;h=701 1000w, https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=2000&amp;h=1402 2000w, https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=150&amp;h=105 150w, https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=300&amp;h=210 300w, https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=768&amp;h=538 768w, https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=1024&amp;h=718 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /><p class="wp-caption-text">(Mark J. Rebilas, USA TODAY Sports)</p></div>
<p>It isn&#8217;t too often an player posts his best statistical season to date &#8212; leading the NFL in rushing TDs &#8212; and struggles to find a job the next season. It was the perfect storm for LeGarrette Blount after his 1,161-yard, 18-touchdown season in New England last year.</p>
<p>The 30-year-old (31 in December) entered free agency with practically no attention and waited until mid-May before signing with the Philadelphia Eagles. Being such a one-dimensional back, and quickly approaching the end of his career, Blount was relegated to find a committee situation in need of a battering ram.</p>
<p>The Eagles may have the messiest backfield in America after this signing. At least each player&#8217;s role should become compartmentalized, and it looks like the potential for a three-pronged attack is quite realistic.</p>
<p style="text-align:center;"><strong><a href="http://thehuddle.com/2017/05/16/2017-fantasy-football-rookie-rankings/" target="_blank" rel="noopener noreferrer">Rookie fantasy football rankings</a></strong></p>
<p>In a nutshell, this move is smart for the real-life Eagles but troubling for fantasy purposes. Ryan Mathews&#8217; is the biggest loser, as his only real value came around the goal line. Now, he&#8217;s probably the primary guy between the 20-yard lines, and that&#8217;s about it. Darren Sproles has the third-down and obvious aerial situations on lockdown. Blount becomes the &#8220;goal-to-go&#8221; guy for any ground work.</p>
<p>It removes any speculative value from second-year back Wendell Smallwood, although such an argument could have been made after the fourth-round selection of San Diego State&#8217;s Donnel Pumphrey.</p>
<h3>Fantasy football spin</h3>
<p>The Eagles&#8217; backfield is a mine field for fantasy purposes. Accurately assessing each player on a weekly matchup basis will be a nightmare. The passing-game personnel was improved over the offseason, which suggests Philly may throw more and run less than last year (10th most rushing attempts).</p>
<p>Sproles is the safest of the trio &#8212; and that says something given he enters an age-34 season. Like Mathews, Blount is injury-prone and comes with ample risk. Should Mathews go down long term, Blount has a major uptick in opportunities awaiting. This scenario alone makes Blount worthy of a late-round add in standard scoring, but his value depreciates significantly in point-per-reception setups.</p>
<p>Someone will own each of these players in 2017, and it is fine if that person happens to be you. Don&#8217;t be overly aggressive in drafting or expecting anything remotely close to last year&#8217;s production from Blount.</p>
<p>The rough-cut verdict: Blount is an RB4 with matchup worthiness and upside if Mathews is shelved. Sproles is an RB3 in PPR and a safer fourth choice, while Mathews is merely an upside-free body for depth in the RB4 territory.</p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://thehuddle.com/tag/darren-sproles/" rel="tag">Darren Sproles</a>, <a href="http://thehuddle.com/tag/fantasy-football/" rel="tag">Fantasy Football</a>, <a href="http://thehuddle.com/tag/legarrette-blount/" rel="tag">LeGarrette Blount</a>, <a href="http://thehuddle.com/tag/philadelphia-eagles/" rel="tag">Philadelphia Eagles</a>, <a href="http://thehuddle.com/tag/ryan-mathews/" rel="tag">Ryan Mathews</a>, <a href="http://thehuddle.com/category/player-movement/" rel="category tag">Player Movement</a></p>
						<div class="story-share-buttons">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">14</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
		data-short-url=""
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
		data-short-url=""
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
		data-short-url=""
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
		data-short-url=""
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/"
			data-short-url=""
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>Related News <span></span></h2>
	</div>
	
		<div class="holder-column">
			<div class="column">
				
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/04/12/teams-looking-to-draft-top-running-backs/" data-track="featuredstories" title="Teams looking to draft a top running back" class="link fixed-height-img-holder short responsiveshort " rel="nofollow" style="background-image: url('https://usathuddle.files.wordpress.com/2016/05/nfl-2015-marshawn-lynch-rb-seahawks-sidelines.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
		<img src="https://usathuddle.files.wordpress.com/2016/05/nfl-2015-marshawn-lynch-rb-seahawks-sidelines.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Teams looking to draft a top running back" itemprop="image">
				<span class="ie-overlay-hack"></span>
	</a>

	<div class="text-block ">
		<h2>
			<a href="http://thehuddle.com/category/positional-analysis/" class="category" itemprop="articleSection">Positional Analysis</a>					</h2>

		<p><a data-track="featuredstories" href="http://thehuddle.com/2017/04/12/teams-looking-to-draft-top-running-backs/" title="Teams looking to draft a top running back" itemprop="url" >Teams looking to draft a top running back</a></p>

			</div>
</article>

<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/04/24/fantasy-football-mike-gillislee-new-england-patriots/" data-track="featuredstories" title="Mike Gillislee joins the Patriots after Buffalo declines to match offer" class="link fixed-height-img-holder responsiveshort " rel="nofollow" style="background-image: url('https://usathuddle.files.wordpress.com/2017/04/usatsi_9767368-e1493069034959.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
		<img src="https://usathuddle.files.wordpress.com/2017/04/usatsi_9767368-e1493069034959.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Mike Gillislee joins the Patriots after Buffalo declines to match offer" itemprop="image">
				<span class="ie-overlay-hack"></span>
	</a>

	<div class="text-block ">
		<h2>
			<a href="http://thehuddle.com/category/player-analysis/" class="category" itemprop="articleSection">Player Analysis</a>					</h2>

		<p><a data-track="featuredstories" href="http://thehuddle.com/2017/04/24/fantasy-football-mike-gillislee-new-england-patriots/" title="Mike Gillislee joins the Patriots after Buffalo declines to match offer" itemprop="url" >Mike Gillislee joins the Patriots after Buffalo declines to match offer</a></p>

			</div>
</article>

<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/" data-track="featuredstories" title="Fantasy football rookie preview: Running backs" class="link fixed-height-img-holder short responsiveshort " rel="nofollow" style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10043068.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
		<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10043068.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Fantasy football rookie preview: Running backs" itemprop="image">
				<span class="ie-overlay-hack"></span>
	</a>

	<div class="text-block ">
		<h2>
			<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>					</h2>

		<p><a data-track="featuredstories" href="http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/" title="Fantasy football rookie preview: Running backs" itemprop="url" >Fantasy football rookie preview: Running backs</a></p>

			</div>
</article>
			</div>
		</div>

	</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>Recent News</h2>
	</div>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017-nfl-player-movement-tracker/"
						title="2017 Player Movement Tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2016/05/nfl-2015-jamaal-charles-rb-chiefs.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2016/05/nfl-2015-jamaal-charles-rb-chiefs.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2017 Player Movement Tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017-nfl-player-movement-tracker/"
								title="2017 Player Movement Tracker"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017-nfl-player-movement-tracker/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017-nfl-player-movement-tracker/"
			title="2017 Player Movement Tracker"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				16hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">16hr ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017-nfl-player-movement-tracker/"
						title="2017 Player Movement Tracker"
						itemprop="url" 						>
							2017 Player Movement Tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 17, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017-top-nfl-free-agent-tracker/"
						title="2017 Top Free-agent Tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/03/usatsi_9036804-e1489185304527.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/03/usatsi_9036804-e1489185304527.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2017 Top Free-agent Tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017-top-nfl-free-agent-tracker/"
								title="2017 Top Free-agent Tracker"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017-top-nfl-free-agent-tracker/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017-top-nfl-free-agent-tracker/"
			title="2017 Top Free-agent Tracker"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				16hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">16hr ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017-top-nfl-free-agent-tracker/"
						title="2017 Top Free-agent Tracker"
						itemprop="url" 						>
							2017 Top Free-agent Tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 17, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/16/2017-fantasy-football-rookie-rankings/"
						title="2017 fantasy football rookie rankings"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10045137-e1494962554942.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10045137-e1494962554942.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2017 fantasy football rookie rankings" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/05/16/2017-fantasy-football-rookie-rankings/"
								title="2017 fantasy football rookie rankings"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/05/16/2017-fantasy-football-rookie-rankings/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/05/16/2017-fantasy-football-rookie-rankings/"
			title="2017 fantasy football rookie rankings"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/16/2017-fantasy-football-rookie-rankings/"
						title="2017 fantasy football rookie rankings"
						itemprop="url" 						>
							2017 fantasy football rookie rankings					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 16, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Looking for fantasy football rookie rankings for your dynasty or partial-keeper league? We have you covered. Of course, injuries and (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/11/fantasy-football-rookie-tight-ends/"
						title="Fantasy football rookie preview: Tight ends"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10034445.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10034445.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Tight ends" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/05/11/fantasy-football-rookie-tight-ends/"
								title="Fantasy football rookie preview: Tight ends"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/05/11/fantasy-football-rookie-tight-ends/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/05/11/fantasy-football-rookie-tight-ends/"
			title="Fantasy football rookie preview: Tight ends"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/11/fantasy-football-rookie-tight-ends/"
						title="Fantasy football rookie preview: Tight ends"
						itemprop="url" 						>
							Fantasy football rookie preview: Tight ends					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 11, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Now that we have had some time to digest the NFL draft and its aftermath, us fantasy footballers are excitedly waiting to add some of (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/09/fantasy-football-rookie-wide-receivers/"
						title="Fantasy football rookie preview: Wide receivers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10034548-e1494262039180.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10034548-e1494262039180.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Wide receivers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/05/09/fantasy-football-rookie-wide-receivers/"
								title="Fantasy football rookie preview: Wide receivers"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/05/09/fantasy-football-rookie-wide-receivers/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/05/09/fantasy-football-rookie-wide-receivers/"
			title="Fantasy football rookie preview: Wide receivers"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/09/fantasy-football-rookie-wide-receivers/"
						title="Fantasy football rookie preview: Wide receivers"
						itemprop="url" 						>
							Fantasy football rookie preview: Wide receivers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 9, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Now that we have had some time to digest the NFL draft and its aftermath, us fantasy footballers are excitedly waiting to add some of (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-linebackers/"
						title="Fantasy football rookie preview: Linebackers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/haason-reddick-lb-cardinals-draft.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/05/haason-reddick-lb-cardinals-draft.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Linebackers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-linebackers/"
								title="Fantasy football rookie preview: Linebackers"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-linebackers/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-linebackers/"
			title="Fantasy football rookie preview: Linebackers"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-linebackers/"
						title="Fantasy football rookie preview: Linebackers"
						itemprop="url" 						>
							Fantasy football rookie preview: Linebackers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 8, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/t-j-ford/" title="Posts by T.J. Ford" class="author url fn" rel="author">T.J. Ford</a>													</span>
					</p>
				</footer>

				<p><strong>Haason Reddick &#8211; 3-4 ILB</strong> <strong>6’1” 234 lbs Temple </strong><strong>Pick 13, Round 1 (13)  Cardinals (&#8230;)</strong></p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-backs/"
						title="Fantasy football rookie preview: Defensive backs"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/jamal-adams-db-jets-rookie-minicamp.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/05/jamal-adams-db-jets-rookie-minicamp.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Defensive backs" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-backs/"
								title="Fantasy football rookie preview: Defensive backs"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-backs/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-backs/"
			title="Fantasy football rookie preview: Defensive backs"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-backs/"
						title="Fantasy football rookie preview: Defensive backs"
						itemprop="url" 						>
							Fantasy football rookie preview: Defensive backs					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 8, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/stevegallonfl/" title="Posts by Steve Gallo" class="author url fn" rel="author">Steve Gallo</a>													</span>
					</p>
				</footer>

				<p>The DB position is the deepest position in all of fantasy and quite honestly, one that I don’t invest much in whatsoever. If you are in (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-linemen/"
						title="Fantasy football rookie preview: Defensive linemen"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/myles-garrett-dl-browns-presser.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/05/myles-garrett-dl-browns-presser.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Defensive linemen" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-linemen/"
								title="Fantasy football rookie preview: Defensive linemen"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-linemen/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-linemen/"
			title="Fantasy football rookie preview: Defensive linemen"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/08/fantasy-football-rookie-preview-defensive-linemen/"
						title="Fantasy football rookie preview: Defensive linemen"
						itemprop="url" 						>
							Fantasy football rookie preview: Defensive linemen					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 8, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/stevegallonfl/" title="Posts by Steve Gallo" class="author url fn" rel="author">Steve Gallo</a>													</span>
					</p>
				</footer>

				<p>Last year I wasn’t very high on the incoming defensive linemen and normally I won’t be. Why? Well mainly because DL is a position that (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/"
						title="Fantasy football rookie preview: Running backs"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10043068.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10043068.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Running backs" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/"
								title="Fantasy football rookie preview: Running backs"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/"
			title="Fantasy football rookie preview: Running backs"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/"
						title="Fantasy football rookie preview: Running backs"
						itemprop="url" 						>
							Fantasy football rookie preview: Running backs					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 6, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Now that we have had some time to digest the NFL draft and its aftermath, us fantasy footballers are excitedly waiting to add some of (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/04/fantasy-football-rookies-quarterbacks/"
						title="Fantasy football rookie preview: Quarterbacks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10034395.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10034395.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Quarterbacks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/05/04/fantasy-football-rookies-quarterbacks/"
								title="Fantasy football rookie preview: Quarterbacks"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/05/04/fantasy-football-rookies-quarterbacks/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/05/04/fantasy-football-rookies-quarterbacks/"
			title="Fantasy football rookie preview: Quarterbacks"
			class="reply" rel="nofollow"
			>reply </a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/05/04/fantasy-football-rookies-quarterbacks/"
						title="Fantasy football rookie preview: Quarterbacks"
						itemprop="url" 						>
							Fantasy football rookie preview: Quarterbacks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 4, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p> Now that we have had some time to digest the NFL draft and its aftermath, us fantasy footballers are excitedly waiting to add some of (&#8230;)</p>

				
				
			</div>
		</article>
	</div>
<a href="http://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
					</div>

		
		<div class="widget widget--login widget--box" id="login_widget-3"><div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget--newsletter widget--box" id="newsletter_widget-3"><div class="heading-small">
	<h2>Newsletter</h2>
</div>

<div class="newsletter__wrapper">

	<form action="http://thehuddle.com/wp-json/usat/v1/gems/subscribe/">

		<h3 class="newsletter__header">Sign up for our free newsletter and get great tips and updates.</h3>

		<input
			type="email"
			class="newsletter__input"
			placeholder="Enter your email address"
			name="email"
			required
		>
		<button
			type="submit"
			class="newsletter__button"
		>Sign up</button>

		<p class="newsletter__text">Always fresh, no spam, guaranteed!</p>

	</form>

	<div class="newsletter__state newsletter__state--success">

		<h3 class="newsletter__header">Success</h3>

		<p class="newsletter__text">
			Thanks for signing up.<br>
			You'll be waking up a little more awesome tomorrow.
		</p>

	</div>

	<div class="newsletter__state newsletter__state--error">

		<h3 class="newsletter__header">Whoa!</h3>

		<p class="newsletter__text newsletter__text--error">
			Something went wrong.
		</p>

		<button class="newsletter__button newsletter__button--reset">
			Try again?
		</button>

	</div>
</div>
</div><div class="widget widget_image" id="image-3"><div style="overflow:hidden;"><a href="http://www.thehuddle.com/podcast/"><img src="http://usathuddle.files.wordpress.com/2016/10/blitzed_logo_med.png?w=300&amp;h=300" alt="The Blitzed Podcast From The Huddle" class="alignnone" width="300" height="300" /></a></div>
</div><div class="widget widget--forum widget--box" id="forum_widget-4"><div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="http://www.thehuddle.com/stats/2016/plays_std.php">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="http://www.thehuddle.com/stats/2016/plays_weekly.php">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="http://www.thehuddle.com/stats/2016/gamescan.php">Weekly Team Game Scans</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="http://www.thehuddle.com/stats/2016/tpr.php">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="http://www.thehuddle.com/stats/2016/tpm.php">Team Position Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="http://www.thehuddle.com/stats/2016/gsm.php">Game Stats Matchups</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="http://thehuddle.com/myHuddle/sos.php">Strength of Schedule Tool</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget--forum widget--box" id="forum_widget-3"><div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_usat_sidebar_top_posts_widget" id="usat_sidebar_top_posts_widget-2">		<div class="col1 right" id="sticky-sidebar">
				<div class="heading-small">
		<h2>Popular <span>Now</span></h2>
	</div>
				
					<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10045137-e1494962554942.jpg?w=408');" data-track="mostshared" href="http://thehuddle.com/2017/05/16/2017-fantasy-football-rookie-rankings/" title="2017 fantasy football rookie rankings" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10045137-e1494962554942.jpg?w=100&#038;h=100&#038;crop=1" alt="2017 fantasy football rookie rankings" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">	
												<p><a data-track="mostshared" href="http://thehuddle.com/2017/05/16/2017-fantasy-football-rookie-rankings/" title="2017 fantasy football rookie rankings" itemprop="url" >2017 fantasy football rookie rankings</a></p>
				<p class="widget-date">May 16, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10043068.jpg?w=480');" data-track="mostshared" href="http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/" title="Fantasy football rookie preview: Running backs" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10043068.jpg?w=100&#038;h=100&#038;crop=1" alt="Fantasy football rookie preview: Running backs" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				2w			</div>
			<div class="text-block">	
												<p><a data-track="mostshared" href="http://thehuddle.com/2017/05/06/fantasy-football-rookie-running-backs/" title="Fantasy football rookie preview: Running backs" itemprop="url" >Fantasy football rookie preview: Running backs</a></p>
				<p class="widget-date">May 6, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=480');" data-track="mostshared" href="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/" title="Eagles add LeGarrette Blount to further cloud their backfield" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_9925757.jpg?w=100&#038;h=100&#038;crop=1" alt="Eagles add LeGarrette Blount to further cloud their backfield" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				13hr			</div>
			<div class="text-block">	
												<p><a data-track="mostshared" href="http://thehuddle.com/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/" title="Eagles add LeGarrette Blount to further cloud their backfield" itemprop="url" >Eagles add LeGarrette Blount to further cloud their backfield</a></p>
				<p class="widget-date">May 17, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/05/usatsi_10034548-e1494262039180.jpg?w=416');" data-track="mostshared" href="http://thehuddle.com/2017/05/09/fantasy-football-rookie-wide-receivers/" title="Fantasy football rookie preview: Wide receivers" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/05/usatsi_10034548-e1494262039180.jpg?w=100&#038;h=100&#038;crop=1" alt="Fantasy football rookie preview: Wide receivers" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				2w			</div>
			<div class="text-block">	
												<p><a data-track="mostshared" href="http://thehuddle.com/2017/05/09/fantasy-football-rookie-wide-receivers/" title="Fantasy football rookie preview: Wide receivers" itemprop="url" >Fantasy football rookie preview: Wide receivers</a></p>
				<p class="widget-date">May 9, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
					
		</div>
		</div><div class="widget widget--links widget--box" id="links_widget-7"><div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="http://www.thehuddle.com/2017/nfl/nfl-depth-charts.php">2017 Fantasy Depth Charts</a></li>
<li id="menu-item-424716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424716"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-grid.php">2017 NFL Schedule Grid</a></li>
<li id="menu-item-424717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424717"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-wk-grid.php">2017 NFL Schedule Weekly Grid</a></li>
<li id="menu-item-424718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424718"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-wk-txt.php">2017 NFL Full Weekly Schedule</a></li>
<li id="menu-item-428116" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428116"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-round/">2017 NFL Draft by round</a></li>
<li id="menu-item-428117" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428117"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-team/">2017 NFL Draft by team</a></li>
<li id="menu-item-428118" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428118"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-position/">2017 NFL Draft by position</a></li>
<li id="menu-item-427599" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427599"><a href="http://thehuddle.com/2017/02/09/2017-nfl-important-dates/">2017 NFL Important Dates</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-8"><div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="http://www.thehuddle.com/2017/nfl/nfl-depth-charts.php">2017 Fantasy Depth Charts</a></li>
<li id="menu-item-427710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-427710"><a href="http://thehuddle.com/2017-top-nfl-free-agent-tracker/">2017 Top Free-agent Tracker</a></li>
<li id="menu-item-427509" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427509"><a href="http://thehuddle.com/2017-nfl-player-movement-tracker/">2017 Player Movement Tracker</a></li>
<li id="menu-item-427436" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427436"><a href="http://thehuddle.com/2017/01/18/2017-coaching-change-tracker/">2017 Coaching Change Tracker</a></li>
</ul></div>
		<div class="widget sidebar-ad bottom">
					</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-425040" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425040"><a href="http://www.thehuddle.com/site/fantasy_football_huddle_information.php">About The Huddle</a></li>
<li id="menu-item-424341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424341"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424340"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424342"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
		<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="The Huddle">
		<a class="mobile-nav__breadcrumb" href="http://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-kit"><a href="/fantasy_football_draft_kit.php">Draft Kit</a></li>
<li class="mobile-nav__item mobile-nav__item--in-season"><a href="/in-season-fantasy-football/">In Season</a></li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--articles"><a href="/fantasy_football_articles.php">Articles</a></li>
<li class="mobile-nav__item mobile-nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li class="mobile-nav__item mobile-nav__item--stats"><a href="/fantasy_football_statistics.php">Stats</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="/2016/nfl/nfl-depth-charts.php">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-425040" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="http://www.thehuddle.com/site/fantasy_football_huddle_information.php">About The Huddle</a></li>
<li id="menu-item-424341" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>
<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Create an Account
		</a>
		<a href="http://thehuddle.com/login.php" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201720y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="114275906" />
				<input type="hidden" id="carousel-reblog-blog-url" value="http://thehuddle.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Huddle" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="cae7d09698" /><input type="hidden" name="_wp_http_referer" value="/2017/05/17/philadelphia-eagles-legarrette-blount-fantasy-football/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVy0sOQDAUheENqVsixECshbqh1RdXsXzEhInE9D/ng80z4eyCdgFF0OEqBfo9VhTBYzKBeR16aQm0HJFgChhwaGyncf44C2fMmdiN1KVboE16/INe4YS1qZKsTDnPk7RQByLQR9I='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"0","seconds":"0","active":"1"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var huddleUser = {"nameAPI":"http:\/\/thehuddle.com\/api\/get_user_name.php","cookie":"huddle-auth"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/thehuddle.com\/wp-admin\/admin-ajax.php","nonce":"8f9e0005c8","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathuddle.wordpress.com\/wp-login.php?redirect_to=http%3A%2F%2Fthehuddle.com%2F2017%2F05%2F17%2Fphiladelphia-eagles-legarrette-blount-fantasy-football%2F","blog_id":"114275906","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=114275906&v=wpcom&tz=-4&user_id=0&subd=usathuddle","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJydUu1uwjAMfKGFbDBN6o9pz2ISqzjko4uTlr79XKYKNKqp9F/k+M7nO+uhUybFgrHocsKArHvqdGUoycKoPAwZo0HtWHs6avddMY87k9KZcOf4RT9BEIDis5iC4KkGhRdpZ0qR/zKEqjpfW4qs92ricVc6BRH8WMg8AJZGzgwDMBxpoqiF/EZohJ5aKCJ2G57J4hHyNjBk2dmvyuYRvDahGSl/6lSt9des1l3EMrYyZiXG/ZMu2EBRiTEikwtmeanUY85iF99qMwNF4+v0Mzna3fa6r/+e83zV910L8w3kJDK9dlg6MGc1FzZeCQ7ssYhoNZBtsQjNV/h8e29ePw77pjm4H9eRXV4='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-4','user_id':'0','post':'428185','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-4&user_id=0&post=428185&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6JVQ1N3pXOU14LmsvZTR1YlZrLy42U29JcXc3SlpqazQ1OUFYSEZ8a05iZHgzfkh0QVozfDdFJWYzSj91QUIsLEJTeklfb2M4YkJmbF9Jfnp5aUo4S3pySnJzT2JofC5sVVtTNUt+MjNHQ2VwV3l5WC5sLF9kVVVbcUdnN3UwJTh0UkRMYnIlZTZpL2I0R3VoTUQ='}]);
_stq.push([ 'clickTrackerInit', '114275906', '428185' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated in 0.361 seconds
	93986 bytes batcached for 300 seconds
-->
