<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Round by round breakdown of the players you should reach for in your fantasy football draft this year." />
<meta name="keywords" content="fantasy football,fantasy football draft strategy,fantasy football reach players" />
<title>Fantasy players worth a reach in your draft | The Huddle</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1503315310&amp;back=http%3A%2F%2Fthehuddle.com%2F2017%2F08%2F21%2Ffantasy-players-worth-a-reach-in-your-draft-4%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Feed" href="http://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Comments Feed" href="http://thehuddle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Fantasy players worth a reach in your draft Comments Feed" href="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1496863874h&ver=4.8.1-RC2-41203"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJylkMtSwzAMRX8II8q0PBYMW/6AteIIV61keyKHTP8ep5kC5WEWbDy68j2+kmHKzqdYKBbQ0WUZA0eDKfukzpSFDl/UpTe7gJ8x4T0Z7Khk9Ht3VC27TwPVvmYss0OpZyQhrbYWpvnmRM3ltmY1Y5bxuy4PZObqqTyqK9sa9Md4Oo+y7AHVeN5ZUIaYClfa3otvby5R8MoZRsOSejw4wWmg6Ol0+YyGHf8Dhaex74WaH8F9oGJgyTOKW6b+LFpwoOQkeSyc4plwL4I8tNCBOkmhluH4ix/yt3W3awiSOpTZ8KgPq83V9e36fnW32b0B3AkC0w==' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"","ads":[],"tlmurl":"https:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJytketuwjAMhV9oIQMx+DXtWUzqdm5zW+y0dE8/M5VJCDSYNClSIp/vnDiOnbKh6HxtkG2v66NimZdt1fOT/Q0wgboCgqtA8Qy7FAWjnNiQDuTRVMYCndY0qE03uJxYAjIrdEO9bIniSDjdxXqUDG4wBZk+r1LlHfU+O1K2lUFSA7PJvnYU2UIm04H3WEgRYEb5frggeKph0eb/iKzcZK1PKplxvdo8kulhKhgdnvw8UDae4mDa5Cqblo5/jVjGFeD6A+9ZPR3OdhZyw0MjuWifmvKToGf1v4XX9cvzZrvf7nb7/gsNW/wG'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:thehuddle","priority_asset":"","blogname":"","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"429296","headline":"Fantasy players worth a reach in your draft","byline":"Thomas Casale","taxonomykeywords":"Carlos Hyde, Dak Prescott, fantasy football draft strategy, reach players, Rob Kelley, Tyler Eifert"};
/* ]]> */
</script>
<script type='text/javascript'>
					utag_data.clickPage = sessionStorage.getItem( "clickPage" );
					sessionStorage.setItem( "clickPage", window.location.href );
					
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/thehuddle3/prod/utag.js?ver=4.8.1-RC2-41203'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2fPxQJA' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fthehuddle.com%2F2017%2F08%2F21%2Ffantasy-players-worth-a-reach-in-your-draft-4%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fthehuddle.com%2F2017%2F08%2F21%2Ffantasy-players-worth-a-reach-in-your-draft-4%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Fantasy players worth a reach in your draft" />
<meta property="og:url" content="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/" />
<meta property="og:description" content="Every year owners pour over data to figure out where they should target players. The difference on draft day sometimes comes down to the owners willing to take certain players earlier than they’re …" />
<meta property="article:published_time" content="2017-08-21T10:18:39+00:00" />
<meta property="article:modified_time" content="2017-08-21T10:18:40+00:00" />
<meta property="og:site_name" content="The Huddle" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2017/06/usatsi_9663595-e1503152439262.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:text:title" content="Fantasy players worth a reach in your draft" />
<meta name="twitter:image:src" content="https://usathuddle.files.wordpress.com/2017/06/usatsi_9663595-e1503152439262.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="http://thehuddle.com/osd.xml" title="The Huddle" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<style type="text/css">
.articleBody a,
.author__description a,
.error404 .entry-content a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.error404 .entry-content h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.error404 .entry-content .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.error404 .entry-content blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.article__back,
.newsletter__input {
	border-color: #dd9933;
}

.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.error404 .entry-content:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Huddle" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Fantasy Football Cheat Sheets, Rankings, Sleepers &amp; Award Winning Draft Advice" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://thehuddle.com/feed/;icon-uri=http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false;
	var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
</script>

</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["Carlos Hyde","Dak Prescott","fantasy football draft strategy","reach players","Rob Kelley","Tyler Eifert","Thomas Casale","Draft Strategy","Player Analysis"],"category":"Draft Strategy","isMobile":"0"};
googletag_cmd_push(function() {
window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();
try { amznads.setTargetingForGPTAsync( 'amznslots' ); } catch(e) { /*ignore*/ }
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>
<link rel="amphtml" href="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-429296 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	
	
<div id="wrapper">

	<div id="header-ad" class="sticky-header-ad-below-nav ">
	</div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="http://thehuddle.com"
				title="The Huddle"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="The Huddle"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Huddle" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-428297" class="nav__item nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li id="menu-item-428295" class="nav__item nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li id="menu-item-428296" class="nav__item nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-424408" class="nav__item nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li id="menu-item-429328" class="nav__item nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li id="menu-item-424410" class="nav__item nav__item--depth-charts"><a href="/2017/nfl/nfl-depth-charts.php">Depth Charts</a></li>
<li id="menu-item-424627" class="nav__item nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li id="menu-item-424411" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-424412" class="nav__item nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li id="menu-item-424413" class="nav__item nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li id="menu-item-424995" class="nav__item nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
							<li class="nav__item nav__item--social nav__item--facebook">
					<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
				</li>
							<li class="nav__item nav__item--social nav__item--twitter">
					<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
				</li>
					</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-429296" class="post-429296 post type-post status-publish format-standard has-post-thumbnail hentry category-draft-strategy category-player-analysis tag-carlos-hyde tag-dak-prescott tag-fantasy-football-draft-strategy tag-reach-players tag-rob-kelley tag-tyler-eifert article--no-image" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title article__title--no-image ">
	<h1 class="article__headline">Fantasy players worth a reach in your draft</h1>

	</div>
<h1 class="article__headline article__headline--mobile">Fantasy players worth a reach in your draft</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://thehuddle.com/category/player-analysis/" class="" itemprop="articleSection">Player Analysis</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Fantasy players worth a reach in your draft</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a> 
		<span class="post-date updated">August 21, 2017</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/ThePigskinGuy" class="twitter-follow-button" data-show-count="false">
					Follow					@ThePigskinGuy				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					
				</header>

				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
			data-short-url=""
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a>		| August 21, 2017		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/ThePigskinGuy" class="twitter-follow-button" data-show-count="false">
		Follow @ThePigskinGuy	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p>Every year owners pour over data to figure out where they should target players. The difference on draft day sometimes comes down to the owners willing to take certain players earlier than they’re projected to go. Here’s a list of players likely to outperform their ADPs. Don’t be afraid to reach for them when you’re on the clock.</p>
<p><em>Average Draft Position (ADP) is taken from Fantasy Calculator data as of August 17 and is based on a 12-team PPR league.</em></p>
<div id="attachment_429312" class="wp-caption aligncenter"><img data-attachment-id="429312" data-permalink="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/nfl-los-angeles-rams-at-new-orleans-saints/" data-orig-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=1000" data-orig-size="3599,1639" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Derick E. Hingle-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark III&quot;,&quot;caption&quot;:&quot;Nov 27, 2016; New Orleans, LA, USA;  New Orleans Saints quarterback Drew Brees (9) celebrates with wide receiver Michael Thomas (13) after a touchdown against the Los Angeles Rams during the third quarter of a game at the Mercedes-Benz Superdome. The Saints defeated the Rams 49-21. Mandatory Credit: Derick E. Hingle-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1480274428&quot;,&quot;copyright&quot;:&quot;Derick E. Hingle&quot;,&quot;focal_length&quot;:&quot;270&quot;,&quot;iso&quot;:&quot;4000&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;NFL: Los Angeles Rams at New Orleans Saints&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NFL: Los Angeles Rams at New Orleans Saints" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=1000?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=1000?w=1000" class="wp-image-429312 size-full" src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=1000" alt="" srcset="https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=1000 1000w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=1998 1998w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=150 150w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=300 300w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=768 768w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9709267-e1503151827659.jpg?w=1024 1024w" sizes="(max-width: 1000px) 100vw, 1000px"   /><p class="wp-caption-text">(Derick E. Hingle-USA TODAY Sports)</p></div>
<h1>Round 1</h1>
<p><strong>Michael Thomas, WR Saints (ADP 12)</strong></p>
<p>Thomas is being selected in the late first round/early second round area after a sensational rookie season that saw him put up 92 receptions, 1,137 yards and nine touchdowns. Despite playing in only 15 games and starting the year behind Brandin Cooks and Willie Snead for targets, Thomas finished 2016 as fantasy football’s No. 7 wide receiver. Thomas caught 77 percent of his targets and posted nine Top 30 fantasy weeks over his final 13 games. Drew Brees likes to spread the ball around but it’s hard to imagine Thomas will see much of a drop-off in production. He’s the complete package of size, speed, great hands and a precise route runner. Brees has thrown for at least 4,000 yards in 11 straight seasons and with Cooks gone, Thomas is set up for another big year. He’s well worth a first-round pick.</p>
<h1>Round 2</h1>
<p><strong>Rob Gronkowski, TE Patriots (ADP 21) </strong></p>
<p>Gronk has an ADP in late Round 2 because of his injury history. Based on production, he’s a first-round draft pick. Gronkowski is one of fantasy’s ultimate risk/reward players. He’s missed 24 games over the last five seasons. That’s the risk. Gronk has finished in the top-five in touchdowns and fantasy points during the past four seasons where he&#8217;s appeared in at least 11 games. He’s scored at least 10 touchdowns in five of his seven NFL seasons. That’s the reward. Gronkowski is the one tight end that can win fantasy owners weeks on his own. His on-field dominance makes Gronk worth the risk of a second-round pick.</p>
<h1>Round 3</h1>
<p><strong>Isaiah Crowell, RB Browns (ADP 32) </strong></p>
<p>Crowell had a productive fantasy season despite playing for a one-win team in 2016. He rushed for 952 yards on 198 carries (4.8 yards per carry) and seven touchdowns. Crowell also caught 40 balls. The 40 receptions more than doubled his previous career high. Duke Johnson is still the Browns primary third-down back but Crowell has proven he can stay on the field in passing situations. Cleveland is projected to be a below .500 football team again in 2017. However, the Browns shouldn’t be quite as bad as they were last season when they fell behind early in a lot of games and had to scrap the run. Crowell’s numbers would have been even better but he had 10 carries or fewer in six games. With questions still surrounding the quarterback position, Crowell will remain the focal point of the Browns offense, especially inside the red zone. He’s a strong RB2.</p>
<div id="attachment_429313" class="wp-caption aligncenter"><img data-attachment-id="429313" data-permalink="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/nfl-san-francisco-49ers-at-los-angeles-rams-2/" data-orig-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=1000" data-orig-size="2978,1525" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5&quot;,&quot;credit&quot;:&quot;Gary A. Vasquez-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D4&quot;,&quot;caption&quot;:&quot;December 24, 2016; Los Angeles, CA, USA;  San Francisco 49ers running back Carlos Hyde (28) runs the ball in for a touchdown against the Los Angeles Rams during the first half at Los Angeles Memorial Coliseum. Mandatory Credit: Gary A. Vasquez-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1482586788&quot;,&quot;copyright&quot;:&quot;Gary A. Vasquez&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;720&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;NFL: San Francisco 49ers at Los Angeles Rams&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NFL: San Francisco 49ers at Los Angeles Rams" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=1000?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=1000?w=1000" class="wp-image-429313 size-full" src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=1000" alt="" srcset="https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=1000 1000w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=2000 2000w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=150 150w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=300 300w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=768 768w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9767167-e1503151945504.jpg?w=1024 1024w" sizes="(max-width: 1000px) 100vw, 1000px"   /><p class="wp-caption-text">(Gary A. Vasquez-USA TODAY Sports)</p></div>
<h1>Round 4</h1>
<p><strong>Carlos Hyde, RB 49ers (ADP 45) </strong></p>
<p>There was talk early on in camp that Tim Hightower and rookie Joe Williams would challenge Hyde for the starting job. That talk died down after Hyde has been one of the stars of 49ers training camp. Hyde has been plagued by injuries during his career but when healthy last season he rushed for 988 yards, scored nine touchdowns and averaged 4.6 yards per carry. He finished ranked 18<sup>th</sup> in fantasy points, despite playing just 13 games. Hyde’s ADP is Round 4 because of his injury past. If he can stay healthy, he’ll put up big numbers in Kyle Shanahan’s offense. Hyde offers RB1 upside in the fourth round. That’s worth a reach.</p>
<h1>Round 5</h1>
<p><strong>Stefon Diggs, WR Vikings (ADP 62)</strong></p>
<p>Diggs is coming off a year where he caught 84 passes for 903 yards on 111 targets in just 13 games. He did only score three times but overall it was an impressive second season for the Vikings receiver. Diggs recorded a 76 percent catch rate, which was fifth best among receivers. His lack of touchdowns is a concern – he only has seven in two years – although Diggs did catch at least five passes in eight games last season. He had two games with 13 receptions. Diggs finished as fantasy’s 31<sup>st</sup> receiver in 2016. The targets, catches and yards will be there. It’s not unrealistic to think Diggs can be a Top 20 fantasy wideout if a few more scoring opportunities come his way. He’s a strong fourth or fifth round selection.</p>
<h1>Round 6</h1>
<p><strong>Tyler Eifert, TE Bengals (ADP 72)</strong></p>
<p>Like Gronk, Eifert is going a round too low because of his injury history. To be fair, it’s a long history. Outside of his rookie year in 2013, Eifert has only been healthy for one NFL season. That year in 2015, Eifert caught 52 passes for 615 yards and 13 touchdowns. He’s a terror in the red zone. Over the last two years, Eifert ranks first among tight ends in touchdowns (18) and third in red zone targets (19). However, Eifert has missed 26 games over the past three seasons. Eifert is entering the final year of his rookie contract, so he’s hoping to cash in on a big payday. If Eifert can stay healthy, he’ll cash in big for owners who rolled the dice on him.</p>
<h1>Round 7</h1>
<p><strong>Pierre Garcon, WR 49ers (ADP 76) </strong></p>
<p>If you’re looking for the best value on the board, Garcon is your guy. Garcon is coming off one of the best seasons of his career. Last year with the Redskins, he caught 79 passes for 1,041 yards and three touchdowns on 116 targets. He caught 71 percent of his targets. Garcon is reuniting with Kyle Shanahan. The last time the two worked together in Washington, Garcon was targeted an NFL-high 184 times and caught 113 passes for 1,346 yards. Garcon has little competition for targets in San Francisco. He’s the 49ers unquestioned No. 1 receiver. Shanahan’s No. 1 receiver has led the league in targets three times (2009, 2013, 2015) and finished second once (2008). The downside with Garcon is touchdowns. He’s never scored more than six times in his nine-year career. Still, Garcon should be one of the league leaders in targets and receptions this year. Owners who can grab Garcon as a WR3 in PPR formats will be sitting pretty.</p>
<div id="attachment_429314" class="wp-caption aligncenter"><img data-attachment-id="429314" data-permalink="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/nfl-washington-redskins-at-philadelphia-eagles/" data-orig-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=1000" data-orig-size="1745,973" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Bill Streicher-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Dec 11, 2016; Philadelphia, PA, USA; Washington Redskins running back Rob Kelley (32) in action against the Philadelphia Eagles at Lincoln Financial Field. The Washington Redskins won 27-22. Mandatory Credit: Bill Streicher-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1481482610&quot;,&quot;copyright&quot;:&quot;Bill Streicher&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;NFL: Washington Redskins at Philadelphia Eagles&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="NFL: Washington Redskins at Philadelphia Eagles" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=1000?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=1000?w=1000" class="wp-image-429314 size-full" src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=1000" alt="" srcset="https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=1000 1000w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=150 150w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=300 300w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=768 768w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg?w=1024 1024w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9749127-e1503152098649.jpg 1745w" sizes="(max-width: 1000px) 100vw, 1000px"   /><p class="wp-caption-text">(Bill Streicher-USA TODAY Sports)</p></div>
<h1>Round 8</h1>
<p><strong>Rob Kelley, RB Redskins (ADP 98) </strong></p>
<p>Kelley averaged 4.2 yards per carry as a rookie last season. Surprisingly though, Kelley has been undervalued all summer. His ADP has been hovering in the Round 8/9 area, while rookie Samaje Perine is going in Round 10. Until recently, Perine was going ahead of Kelley on average. This is a good example of a situation where fantasy owners want one guy to win the job but the Redskins coaching staff simply isn’t there yet. From Week 8 on last season, Kelley handled 74 percent of the Redskins designed running plays. He scored the 15<sup>th</sup> most fantasy points among running backs over the second half of the season. Kelley isn’t a dynamic runner but he’s consistent and he’s earned the trust of the coaching staff. Perine will have a role too but Kelley is the starter. He’s just not being drafted like one.</p>
<h1>Round 9</h1>
<p><strong>Tyrell Williams, WR Chargers (ADP 100) </strong></p>
<p>Williams burst onto the scene last year with 69 receptions, 1,059 yards and seven touchdowns on 120 targets. For some reason, fantasy owners still aren’t buying into Williams. His ADP is Round 9. Keenan Allen is returning and the Chargers selected Mike Williams in the first-round of the NFL Draft but Williams is out until at least early October with a back injury. There’s a chance we don’t even see the rookie this season. Williams brings a different dimension to the Chargers receiving corps because of his size (6-4, 205) and speed combination. He recorded at least 60 yards receiving in 11 games last season. There’s a belief by some that Williams’ usage will go down this year with Allen back. Don’t buy it. Williams is a steal as a WR3/4.</p>
<h1>Round 10</h1>
<p><strong>Jamaal Williams, RB Packers (ADP 124) </strong></p>
<p>There’s been a lot of preseason hype surrounding Ty Montgomery but he’s already dealing with a leg injury. Williams is taking most of the first-team reps in his absence. There’s no denying Montgomery’s talents as a receiver. However, he hasn’t shown the ability to be an every-down NFL running back. Williams is a powerful inside runner who could push Montgomery for early down work. He rushed for 3,901 yards and 35 touchdowns in college. The other thing to note about Montgomery is in two games against the Bears last year, he rushed for 222 yards, caught 12 passes and scored twice. Against the rest of the NFL, Montgomery rushed for 235 yards, caught 32 passes and scored once. At the very least, Williams is a valuable handcuff on a high-scoring offense. If Montgomery struggles or gets hurt, Williams becomes a weekly RB2.</p>
<div id="attachment_429315" class="wp-caption aligncenter"><img data-attachment-id="429315" data-permalink="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/nfl-nfc-divisional-green-bay-packers-at-dallas-cowboys-4/" data-orig-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=1000" data-orig-size="2199,1257" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;3.5&quot;,&quot;credit&quot;:&quot;Matthew Emmons-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X&quot;,&quot;caption&quot;:&quot;Jan 15, 2017; Arlington, TX, USA; Dallas Cowboys quarterback Dak Prescott (4) throws in the pocket against the Green Bay Packers in the NFC Divisional playoff game at AT&amp;T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1484522259&quot;,&quot;copyright&quot;:&quot;Matthew Emmons&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;NFL: NFC Divisional-Green Bay Packers at Dallas Cowboys&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NFL: NFC Divisional-Green Bay Packers at Dallas Cowboys" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=1000?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=1000?w=1000" class="wp-image-429315 size-full" src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=1000" alt="" srcset="https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=1000 1000w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=2000 2000w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=150 150w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=300 300w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=768 768w, https://usathuddle.files.wordpress.com/2017/08/usatsi_9814701-e1503152278760.jpg?w=1024 1024w" sizes="(max-width: 1000px) 100vw, 1000px"   /><p class="wp-caption-text">(Matthew Emmons-USA TODAY Sports)</p></div>
<h1>Round 11</h1>
<p><strong>Dak Prescott, QB Cowboys (ADP 127) </strong></p>
<p>Prescott put up one of the best rookie seasons in NFL history. He was also money for fantasy owners. Prescott was fantasy’s sixth highest-scoring quarterback in 2016. He threw for 3,667 yards, 23 touchdowns and just four interceptions. Prescott also ran for six touchdowns, which led all quarterbacks. For all the “Dak and Dunk” talk, Prescott ranked fourth in the NFL in yards per attempt (8.0). There’s constant talk about Dak declining this season, especially with Ezekiel Elliott’s suspension looming. Even if Prescott suffers a slight decline, he’s still a starting fantasy quarterback. And who says he’ll decline at all? Either way, you’re getting a QB2 in Round 11 that plays on one of the better offenses in the NFL. Don’t let all the anti-Dak sentiment talk you out of value on draft day. Getting Prescott in Round 11 will prove to be a laugher at the end of the season.</p>
<h1>Round 12</h1>
<p><strong>Alvin Kamara, RB Saints (ADP 180) </strong></p>
<p>Kamara’s ADP is Round 14 but he’s such a strong late-round selection, don’t be afraid to take him early. The Saints are going to have a backfield by committee with Kamara, Adrian Peterson and Mark Ingram. That’s obvious. However, Kamara’s role is already defined. He will be the Saints third-down/pass-catching back. Kamara is the most talented player at that position since Darren Sproles left. Sproles averaged 77 receptions in three seasons with the Saints and even Travaris Cadet caught 40 balls last year. Kamara was specifically targeted in the draft by Saints coach Sean Payton. He fits the offense like a glove. Kamara is an excellent receiver and underrated runner. The rookie caught 74 passes and averaged 6.2 yards per carry in two seasons at Tennessee. Kamara will have immediate PPR flex appeal and if Peterson or Ingram go down…watch out.</p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://thehuddle.com/tag/carlos-hyde/" rel="tag">Carlos Hyde</a>, <a href="http://thehuddle.com/tag/dak-prescott/" rel="tag">Dak Prescott</a>, <a href="http://thehuddle.com/tag/fantasy-football-draft-strategy/" rel="tag">fantasy football draft strategy</a>, <a href="http://thehuddle.com/tag/reach-players/" rel="tag">reach players</a>, <a href="http://thehuddle.com/tag/rob-kelley/" rel="tag">Rob Kelley</a>, <a href="http://thehuddle.com/tag/tyler-eifert/" rel="tag">Tyler Eifert</a>, <a href="http://thehuddle.com/category/draft-strategy/" rel="category tag">Draft Strategy</a>, <a href="http://thehuddle.com/category/player-analysis/" rel="category tag">Player Analysis</a></p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
		data-short-url=""
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/"
			data-short-url=""
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
		<div class="holder-column">
			<div class="column">
				
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/" data-track="featuredstories" title="Reviewing the best ways to draft a PPR team" class="link fixed-height-img-holder short responsiveshort " rel="nofollow" style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_10218726-e1502825756763.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
		<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_10218726-e1502825756763.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Reviewing the best ways to draft a PPR team" itemprop="image">
				<span class="ie-overlay-hack"></span>
	</a>

	<div class="text-block ">
		<h2>
			<a href="http://thehuddle.com/category/draft-strategy/" class="category" itemprop="articleSection">Draft Strategy</a>					</h2>

		<p><a data-track="featuredstories" href="http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/" title="Reviewing the best ways to draft a PPR team" itemprop="url" >Reviewing the best ways to draft a PPR team</a></p>

			</div>
</article>

<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/07/31/fantasy-football-adp-average-draft-position/" data-track="featuredstories" title="Understanding fantasy football average draft position" class="link fixed-height-img-holder short responsiveshort " rel="nofollow" style="background-image: url('https://usathuddle.files.wordpress.com/2017/07/usatsi_9831975-e1502718728302.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
		<img src="https://usathuddle.files.wordpress.com/2017/07/usatsi_9831975-e1502718728302.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Understanding fantasy football average draft position" itemprop="image">
				<span class="ie-overlay-hack"></span>
	</a>

	<div class="text-block ">
		<h2>
			<a href="http://thehuddle.com/category/draft-strategy/" class="category" itemprop="articleSection">Draft Strategy</a>					</h2>

		<p><a data-track="featuredstories" href="http://thehuddle.com/2017/07/31/fantasy-football-adp-average-draft-position/" title="Understanding fantasy football average draft position" itemprop="url" >Understanding fantasy football average draft position</a></p>

			</div>
</article>

<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/08/14/fantasy-position-battles/" data-track="featuredstories" title="Fantasy position battles" class="link fixed-height-img-holder short responsiveshort " rel="nofollow" style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_10182072-e1502728148269.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
		<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_10182072-e1502728148269.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Fantasy position battles" itemprop="image">
				<span class="ie-overlay-hack"></span>
	</a>

	<div class="text-block ">
		<h2>
			<a href="http://thehuddle.com/category/player-analysis/" class="category" itemprop="articleSection">Player Analysis</a>					</h2>

		<p><a data-track="featuredstories" href="http://thehuddle.com/2017/08/14/fantasy-position-battles/" title="Fantasy position battles" itemprop="url" >Fantasy position battles</a></p>

			</div>
</article>
			</div>
		</div>

	</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/19/weekend-roundup-perfect-draft-position-battles-podcast-schedule-impact-and-more/"
						title="Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_9782130-e1503150246323.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9782130-e1503150246323.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/19/weekend-roundup-perfect-draft-position-battles-podcast-schedule-impact-and-more/"
								title="Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/19/weekend-roundup-perfect-draft-position-battles-podcast-schedule-impact-and-more/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/19/weekend-roundup-perfect-draft-position-battles-podcast-schedule-impact-and-more/"
			title="Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/weekend-roundup/" class="category" itemprop="articleSection">Weekend Roundup</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/19/weekend-roundup-perfect-draft-position-battles-podcast-schedule-impact-and-more/"
						title="Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more"
						itemprop="url" 						>
							Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 19, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/wwalters/" title="Posts by Whit Walters" class="author url fn" rel="author">Whit Walters</a>													</span>
					</p>
				</footer>

				<p>Your weekend roundup of what hit The Huddle this week:  As we move into week 2 of the NFL preseason, here were some of the important (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-running-backs/"
						title="Fantasy schedule impact: Running Backs"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_9551203-e1502976893313.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9551203-e1502976893313.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy schedule impact: Running Backs" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-running-backs/"
								title="Fantasy schedule impact: Running Backs"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/17/fantasy-schedule-impact-running-backs/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-running-backs/"
			title="Fantasy schedule impact: Running Backs"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>44</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/strength-of-schedule/" class="category" itemprop="articleSection">Strength of Schedule</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-running-backs/"
						title="Fantasy schedule impact: Running Backs"
						itemprop="url" 						>
							Fantasy schedule impact: Running Backs					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 17, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>There is no position as sensitive to the schedule as running back. None. It is the most predictive of all positions and offers a look at (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-receivers/"
						title="Fantasy schedule impact: Receivers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_9642940-e1502976471565.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9642940-e1502976471565.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy schedule impact: Receivers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-receivers/"
								title="Fantasy schedule impact: Receivers"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/17/fantasy-schedule-impact-receivers/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-receivers/"
			title="Fantasy schedule impact: Receivers"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/strength-of-schedule/" class="category" itemprop="articleSection">Strength of Schedule</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-receivers/"
						title="Fantasy schedule impact: Receivers"
						itemprop="url" 						>
							Fantasy schedule impact: Receivers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 17, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Continuing the series, the breakdown for best and worst schedules for receivers are below. Schedule strength is typically the least (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-quarterbacks/"
						title="Fantasy schedule impact: Quarterbacks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2016/10/usatsi_9628023-e1477687912821.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2016/10/usatsi_9628023-e1477687912821.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy schedule impact: Quarterbacks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-quarterbacks/"
								title="Fantasy schedule impact: Quarterbacks"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/17/fantasy-schedule-impact-quarterbacks/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-quarterbacks/"
			title="Fantasy schedule impact: Quarterbacks"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>2</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/strength-of-schedule/" class="category" itemprop="articleSection">Strength of Schedule</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-quarterbacks/"
						title="Fantasy schedule impact: Quarterbacks"
						itemprop="url" 						>
							Fantasy schedule impact: Quarterbacks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 17, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Schedules are the only guaranteed difference between one year and the next. An important difference. There are many reasons why a player (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/"
						title="Reviewing the best ways to draft a PPR team"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_10218726-e1502825756763.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_10218726-e1502825756763.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Reviewing the best ways to draft a PPR team" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/"
								title="Reviewing the best ways to draft a PPR team"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/"
			title="Reviewing the best ways to draft a PPR team"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>123</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/draft-strategy/" class="category" itemprop="articleSection">Draft Strategy</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/"
						title="Reviewing the best ways to draft a PPR team"
						itemprop="url" 						>
							Reviewing the best ways to draft a PPR team					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 16, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>While there is no clear-cut way to assemble the best team in a PPR draft, we have a few ideas to help put you in position to succeed. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/16/players-on-the-upswing-downswing/"
						title="Players on the upswing/downswing"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2016/10/usatsi_9603248-e1477082218824.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2016/10/usatsi_9603248-e1477082218824.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Players on the upswing/downswing" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/16/players-on-the-upswing-downswing/"
								title="Players on the upswing/downswing"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/16/players-on-the-upswing-downswing/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/16/players-on-the-upswing-downswing/"
			title="Players on the upswing/downswing"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>14</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-analysis/" class="category" itemprop="articleSection">Player Analysis</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/16/players-on-the-upswing-downswing/"
						title="Players on the upswing/downswing"
						itemprop="url" 						>
							Players on the upswing/downswing					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 16, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/bearswitness/" title="Posts by Ken Pomponio" class="author url fn" rel="author">Ken Pomponio</a>													</span>
					</p>
				</footer>

				<p>The tried and true draft-day bromide reads as follows: Don’t construct this year’s team around last year’s stats. It bears (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/15/the-huddles-blitzed-podcast-episode-63/"
						title="The Huddle&#039;s Blitzed Podcast: Episode 63"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_10218883-e1502813069161.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_10218883-e1502813069161.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="The Huddle&#039;s Blitzed Podcast: Episode 63" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/15/the-huddles-blitzed-podcast-episode-63/"
								title="The Huddle&#039;s Blitzed Podcast: Episode 63"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/15/the-huddles-blitzed-podcast-episode-63/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/15/the-huddles-blitzed-podcast-episode-63/"
			title="The Huddle&#039;s Blitzed Podcast: Episode 63"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>9</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/15/the-huddles-blitzed-podcast-episode-63/"
						title="The Huddle&#039;s Blitzed Podcast: Episode 63"
						itemprop="url" 						>
							The Huddle&#039;s Blitzed Podcast: Episode 63					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 15, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/stevegallonfl/" title="Posts by Steve Gallo" class="author url fn" rel="author">Steve Gallo</a> and <a href="http://thehuddle.com/author/newclearharley/" title="Posts by Harley Schultz" class="author url fn" rel="author">Harley Schultz</a>													</span>
					</p>
				</footer>

				<p>The Huddle presents another season of The Blitzed Podcast. In this episode Steve Gallo and Harley Schultz bring you the B.P.N. News as (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/15/preseason-injury-report-week-1/"
						title="Preseason injury report: Week 1"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_10193349-e1502802243677.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_10193349-e1502802243677.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Preseason injury report: Week 1" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/15/preseason-injury-report-week-1/"
								title="Preseason injury report: Week 1"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/15/preseason-injury-report-week-1/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/15/preseason-injury-report-week-1/"
			title="Preseason injury report: Week 1"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>3</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/injury-analysis/" class="category" itemprop="articleSection">Injury Analysis</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/15/preseason-injury-report-week-1/"
						title="Preseason injury report: Week 1"
						itemprop="url" 						>
							Preseason injury report: Week 1					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 15, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a>													</span>
					</p>
				</footer>

				<p>Training camps and preseason games are underway. While it’s great to see football back, unfortunately that also means injuries. As usual, (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017-nfl-player-movement-tracker/"
						title="2017 Player Movement Tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2016/05/nfl-2015-jamaal-charles-rb-chiefs.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2016/05/nfl-2015-jamaal-charles-rb-chiefs.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2017 Player Movement Tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017-nfl-player-movement-tracker/"
								title="2017 Player Movement Tracker"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017-nfl-player-movement-tracker/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017-nfl-player-movement-tracker/"
			title="2017 Player Movement Tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>25</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017-nfl-player-movement-tracker/"
						title="2017 Player Movement Tracker"
						itemprop="url" 						>
							2017 Player Movement Tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 15, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/14/fantasy-position-battles/"
						title="Fantasy position battles"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/08/usatsi_10182072-e1502728148269.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_10182072-e1502728148269.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy position battles" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="http://thehuddle.com/2017/08/14/fantasy-position-battles/"
								title="Fantasy position battles"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/08/14/fantasy-position-battles/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://thehuddle.com/2017/08/14/fantasy-position-battles/"
			title="Fantasy position battles"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>18</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-analysis/" class="category" itemprop="articleSection">Player Analysis</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
					<a
						data-track="mostrecent"
						href="http://thehuddle.com/2017/08/14/fantasy-position-battles/"
						title="Fantasy position battles"
						itemprop="url" 						>
							Fantasy position battles					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 14, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a>													</span>
					</p>
				</footer>

				<p>Determining which player wins skill position battles in training camp is crucial to fantasy football success. Here are the most important (&#8230;)</p>

				
				
			</div>
		</article>
	</div>
<a href="http://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
					</div>

		
		<div class="widget widget--login widget--box" id="login_widget-3"><div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget--newsletter widget--box" id="newsletter_widget-3"><div class="heading-small">
	<h2>Newsletter</h2>
</div>

<div class="newsletter__wrapper">

	<form action="http://thehuddle.com/wp-json/usat/v1/gems/subscribe/">

		<h3 class="newsletter__header">Sign up for our free newsletter and get great tips and updates.</h3>

		<input
			type="email"
			class="newsletter__input"
			placeholder="Enter your email address"
			name="email"
			required
		>
		<button
			type="submit"
			class="newsletter__button"
		>Sign up</button>

		<p class="newsletter__text">Always fresh, no spam, guaranteed!</p>

	</form>

	<div class="newsletter__state newsletter__state--success">

		<h3 class="newsletter__header">Success</h3>

		<p class="newsletter__text">
			Thanks for signing up.<br>
			You'll be waking up a little more awesome tomorrow.
		</p>

	</div>

	<div class="newsletter__state newsletter__state--error">

		<h3 class="newsletter__header">Whoa!</h3>

		<p class="newsletter__text newsletter__text--error">
			Something went wrong.
		</p>

		<button class="newsletter__button newsletter__button--reset">
			Try again?
		</button>

	</div>
</div>
</div><div class="widget widget_media_image" id="media_image-4"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://thehuddle.com/2017/07/31/huddle-member-discount-for-draftlab/" class="" rel="" target=""><img width="300" height="200" src="https://usathuddle.files.wordpress.com/2017/07/banner-draftlab-300x200-clean.png" class="image wp-image-428758 alignnone attachment-full size-full" alt="DraftLab discount offer for Huddle members" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2017/07/banner-draftlab-300x200-clean.png 300w, https://usathuddle.files.wordpress.com/2017/07/banner-draftlab-300x200-clean.png?w=150&amp;h=100 150w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="428758" data-permalink="http://thehuddle.com/banner-draftlab-300x200-clean/" data-orig-file="https://usathuddle.files.wordpress.com/2017/07/banner-draftlab-300x200-clean.png" data-orig-size="300,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="banner-draftlab-300&#215;200-clean" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/07/banner-draftlab-300x200-clean.png?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/07/banner-draftlab-300x200-clean.png?w=300" /></a></div><div class="widget widget_usat_sidebar_top_posts_widget" id="usat_sidebar_top_posts_widget-2">		<div class="col1 right" id="sticky-sidebar">
				<div class="heading-small">
		<h2>Popular <span>Now</span></h2>
	</div>
				
					<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2016/11/todd-gurley-rb-rams-e1502550924159.jpg?w=480');" data-track="mostshared" href="http://thehuddle.com/2017/08/07/sleepers-and-value-plays-running-backs-8/" title="Sleepers and Value Plays: Running Backs" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2016/11/todd-gurley-rb-rams-e1502550924159.jpg?w=100&#038;h=100&#038;crop=1" alt="Sleepers and Value Plays: Running Backs" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				2w			</div>
			<div class="text-block">	
												<p><a data-track="mostshared" href="http://thehuddle.com/2017/08/07/sleepers-and-value-plays-running-backs-8/" title="Sleepers and Value Plays: Running Backs" itemprop="url" >Sleepers and Value Plays: Running Backs</a></p>
				<p class="widget-date">August 7, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/08/usatsi_9782130-e1503150246323.jpg?w=480');" data-track="mostshared" href="http://thehuddle.com/2017/08/19/weekend-roundup-perfect-draft-position-battles-podcast-schedule-impact-and-more/" title="Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9782130-e1503150246323.jpg?w=100&#038;h=100&#038;crop=1" alt="Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">	
												<p><a data-track="mostshared" href="http://thehuddle.com/2017/08/19/weekend-roundup-perfect-draft-position-battles-podcast-schedule-impact-and-more/" title="Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more" itemprop="url" >Weekend roundup: Perfect draft, position battles, podcast, schedule impact and more</a></p>
				<p class="widget-date">August 19, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/08/usatsi_9551203-e1502976893313.jpg?w=480');" data-track="mostshared" href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-running-backs/" title="Fantasy schedule impact: Running Backs" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_9551203-e1502976893313.jpg?w=100&#038;h=100&#038;crop=1" alt="Fantasy schedule impact: Running Backs" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				4d			</div>
			<div class="text-block">	
												<p><a data-track="mostshared" href="http://thehuddle.com/2017/08/17/fantasy-schedule-impact-running-backs/" title="Fantasy schedule impact: Running Backs" itemprop="url" >Fantasy schedule impact: Running Backs</a></p>
				<p class="widget-date">August 17, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/08/usatsi_10218726-e1502825756763.jpg?w=480');" data-track="mostshared" href="http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/" title="Reviewing the best ways to draft a PPR team" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/08/usatsi_10218726-e1502825756763.jpg?w=100&#038;h=100&#038;crop=1" alt="Reviewing the best ways to draft a PPR team" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				5d			</div>
			<div class="text-block">	
												<p><a data-track="mostshared" href="http://thehuddle.com/2017/08/16/fantasy-football-ppr-draft-strategy-wide-receiver/" title="Reviewing the best ways to draft a PPR team" itemprop="url" >Reviewing the best ways to draft a PPR team</a></p>
				<p class="widget-date">August 16, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
					
		</div>
		</div><div class="widget widget--links widget--box" id="links_widget-8"><div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="http://www.thehuddle.com/2017/nfl/nfl-depth-charts.php">2017 Fantasy Depth Charts</a></li>
<li id="menu-item-427710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-427710"><a href="http://thehuddle.com/2017-top-nfl-free-agent-tracker/">2017 Top Free-agent Tracker</a></li>
<li id="menu-item-427509" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427509"><a href="http://thehuddle.com/2017-nfl-player-movement-tracker/">2017 Player Movement Tracker</a></li>
<li id="menu-item-427436" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427436"><a href="http://thehuddle.com/2017/01/18/2017-coaching-change-tracker/">2017 Coaching Change Tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7"><div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="http://www.thehuddle.com/2017/nfl/nfl-depth-charts.php">2017 Fantasy Depth Charts</a></li>
<li id="menu-item-424716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424716"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-grid.php">2017 NFL Schedule Grid</a></li>
<li id="menu-item-424717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424717"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-wk-grid.php">2017 NFL Schedule Weekly Grid</a></li>
<li id="menu-item-424718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424718"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-wk-txt.php">2017 NFL Full Weekly Schedule</a></li>
<li id="menu-item-428116" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428116"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-round/">2017 NFL Draft by round</a></li>
<li id="menu-item-428117" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428117"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-team/">2017 NFL Draft by team</a></li>
<li id="menu-item-428118" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428118"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-position/">2017 NFL Draft by position</a></li>
<li id="menu-item-427599" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427599"><a href="http://thehuddle.com/2017/02/09/2017-nfl-important-dates/">2017 NFL Important Dates</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-4"><div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="http://www.thehuddle.com/stats/2016/plays_std.php">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="http://www.thehuddle.com/stats/2016/plays_weekly.php">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="http://www.thehuddle.com/stats/2016/gamescan.php">Weekly Team Game Scans</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="http://www.thehuddle.com/stats/2016/tpr.php">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="http://www.thehuddle.com/stats/2016/tpm.php">Team Position Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="http://www.thehuddle.com/stats/2016/gsm.php">Game Stats Matchups</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="http://thehuddle.com/myHuddle/sos.php">Strength of Schedule Tool</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget--forum widget--box" id="forum_widget-3"><div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/" class="" rel="" target=""><img width="300" height="300" src="https://usathuddle.files.wordpress.com/2016/10/blitzed_logo_med.png?w=300" class="image wp-image-425460 alignnone attachment-300x300 size-300x300" alt="The Blitzed Podcast From The Huddle" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2016/10/blitzed_logo_med.png?w=300 300w, https://usathuddle.files.wordpress.com/2016/10/blitzed_logo_med.png?w=150 150w, https://usathuddle.files.wordpress.com/2016/10/blitzed_logo_med.png 400w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="425460" data-permalink="http://www.thehuddle.com/podcast/2016/episode50.php/blitzed_logo_med/" data-orig-file="https://usathuddle.files.wordpress.com/2016/10/blitzed_logo_med.png" data-orig-size="400,401" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="blitzed_logo_med" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2016/10/blitzed_logo_med.png?w=300" data-large-file="https://usathuddle.files.wordpress.com/2016/10/blitzed_logo_med.png?w=400" /></a></div>
		<div class="widget sidebar-ad bottom">
					</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-424341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424341"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424340"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424342"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="The Huddle">
				<a class="mobile-nav__breadcrumb" href="http://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li class="mobile-nav__item mobile-nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li class="mobile-nav__item mobile-nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="/2017/nfl/nfl-depth-charts.php">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-424341" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>
<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Create an Account
		</a>
		<a href="http://thehuddle.com/login.php" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201734y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="114275906" />
				<input type="hidden" id="carousel-reblog-blog-url" value="http://thehuddle.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Huddle" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="920fa3ddcc" /><input type="hidden" name="_wp_http_referer" value="/2017/08/21/fantasy-players-worth-a-reach-in-your-draft-4/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVy0sOQDAUheENqVsSj4lYC3VDqy+uYvmICROJ6X/OB5tnwtkF7QKKoMNVCvR7rCiCx2QC8zr00hJoOSLBFDDg0NhO4/xxFs6YM7EbqUu3QJv0+Ae9wglrUyUZT/MyKVKuDiLUR9I='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"0","seconds":"0","active":"1"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"enable":"1","maxDistance":"1300","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var huddleUser = {"nameAPI":"http:\/\/thehuddle.com\/api\/get_user_name.php","cookie":"huddle-auth"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/thehuddle.com\/wp-admin\/admin-ajax.php","nonce":"1c22fded13","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathuddle.wordpress.com\/wp-login.php?redirect_to=http%3A%2F%2Fthehuddle.com%2F2017%2F08%2F21%2Ffantasy-players-worth-a-reach-in-your-draft-4%2F","blog_id":"114275906","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=114275906&v=wpcom&tz=-4&user_id=0&subd=usathuddle","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJydUu1uwjAMfKGFDES3X9OexSRWcchHFzvt+vZLmSrQqKbSf5HjO5/vrIdOmRQFo2g5Y0DWPXW6MEiyMCoPQ8ZoUDvWnk7afRXM486kdCHcOX7RTxAEoPgsRhA8laDwu7Yzpch/GUJRnS8tRdYHNfG4K52CCH4UMg+ApZEzwwAMJ5ooipDfCI3QUwtSxW7DM1k8Qd4Ghlx39quyeQSvTWhG1j91Ltb6a1brLmIZWxizqsb9ky7YQFFVY6pMFsz1pVKPOVe7+FabGSgaX6afydHuttd9/fec56u+71qYbyCnKtNrh9KBuai5sPFKcGCPUkWrgWyLUmk+w8e+ed0fmrdj8+5+ANc+XVQ='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-4','user_id':'0','post':'429296','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-4&user_id=0&post=429296&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6K0olLXl0Wm1BWTZzaltZVVpMN2ozLzdYRzRpYWlKJVtKRDNHYTV6MnxOJjMlMldwMnMyQ3ZIZjBoZ0lnPVEwPStWRz8xKy5yZDdBWHpYQUtkLUhbZF9rZVt2RUlMcWFkYnI3ZWwsayxVWEhXY292clFzRklSZ1lBM0pXWWQw'}]);
_stq.push([ 'clickTrackerInit', '114275906', '429296' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
