<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Start your week with an in-depth analysis of the weekend’s key happenings, statistics and injuries." />
<meta name="keywords" content="fantasy football,fantasy football top players,fantasy football injuries" />
<title>Tunnel Vision &#8211; 2017 wrap up | The Huddle</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1514795573&amp;back=http%3A%2F%2Fthehuddle.com%2F2018%2F01%2F01%2Ftunnel-vision-2017-wrap-up%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Feed" href="http://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Comments Feed" href="http://thehuddle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Tunnel Vision - 2017 wrap up Comments Feed" href="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJylkNFOAyEQRX9IJE1bGx+Mr/6Bz7Mw0ukODFnYbvbvZUtarVY08YXMhXvmDqOnqIyEjCFrP6rIo6OQ9BSNeJU8Mc5f1L1J6U7fxph6TPqAOYLp1Um17EYGLPc+Ql4cHi0BMvpia2E+PpyppdyXrGZMHb/r4oApqXJ6Gr3K+xL0y3h+GaX+Qxfj9U1FSQfJVOh0Kb71rFH6SFGPCbJYmC8hqTD9rCgwBVRHsig169bDnzozTAMGg+fHV0jQ0T9Q/TJay9hcMVmHuQwthoBV3cdn0YIdimIxkEnClVBvDDS00AE7FldKd9rZh/zpu/uNdiwd8GJ49k+r7Wq93m12j9vDO4ttJXw=' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJylkNEOgjAMRX/IUSEIT8ZvqaNgxxiTbiB/70zUxDeIb01vz0lbWLzSowvkAoQbDSQws4coGMYGV+Vt7NgJoGfVobU0cRpBEQoCRiAQWo7DO1szIwf4Uxml8am/pEjNeVZscVpcJnKaXrz07JVl16t21FFUy4+9CnOPr2MGZLcXtXz94BJY95te8rM+N9PXkOrEX4ZzfjoWZV1WVW2ezJGjZA=='></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:thehuddle","priority_asset":"","blogname":"thehuddle","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"434500","headline":"Tunnel Vision - 2017 wrap up","byline":"David Dorey","taxonomykeywords":"Alex Collins, alex smith, Antonio Brown, Carson Wentz, Robby Anderson, Todd Gurley"};
/* ]]> */
</script>
<script type='text/javascript'>
					utag_data.clickPage = sessionStorage.getItem( "clickPage" );
					sessionStorage.setItem( "clickPage", window.location.href );
					
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/thehuddle3/prod/utag.js?ver=4.9.1'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2zUDgrg' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F01%2F01%2Ftunnel-vision-2017-wrap-up%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F01%2F01%2Ftunnel-vision-2017-wrap-up%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Tunnel Vision - 2017 wrap up" />
<meta property="og:url" content="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/" />
<meta property="og:description" content="Start your week with an in-depth analysis of the weekend’s key happenings, statistics and injuries." />
<meta property="article:published_time" content="2018-01-01T05:13:51+00:00" />
<meta property="article:modified_time" content="2018-01-01T05:16:09+00:00" />
<meta property="og:site_name" content="The Huddle" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2017/12/usatsi_10509400-e1514783621459.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:text:title" content="Tunnel Vision - 2017 wrap up" />
<meta name="twitter:image:src" content="https://usathuddle.files.wordpress.com/2017/12/usatsi_10509400-e1514783621459.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="http://thehuddle.com/osd.xml" title="The Huddle" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #dd9933;
}

.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Huddle" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Fantasy Football Cheat Sheets, Rankings, Sleepers &amp; Award Winning Draft Advice" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://thehuddle.com/feed/;icon-uri=http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["Alex Collins","alex smith","Antonio Brown","Carson Wentz","Robby Anderson","Todd Gurley","David Dorey","General Fantasy Analysis"],"category":"General Fantasy Analysis","referrer":"","isMobile":"0"};
googletag_cmd_push(function() {
window.lawrence_dfp_desktop_skin = googletag.defineSlot("/7103/SMG_TheHuddle/skin/sports/fantasy/football.general", [1,1], "acm-ad-tag-lawrence_dfp_desktop_skin").addService(googletag.pubads().setTargeting('kw',["Alex Collins","alex smith","Antonio Brown","Carson Wentz","Robby Anderson","Todd Gurley","David Dorey","General Fantasy Analysis"]).setTargeting('category',["General Fantasy Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["skin"]);window.lawrence_dfp_desktop_top = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.main", ['fluid',[728,90],[970,66],[970,250]], "acm-ad-tag-lawrence_dfp_desktop_top").addService(googletag.pubads().setTargeting('kw',["Alex Collins","alex smith","Antonio Brown","Carson Wentz","Robby Anderson","Todd Gurley","David Dorey","General Fantasy Analysis"]).setTargeting('category',["General Fantasy Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);window.lawrence_dfp_desktop_top_300x250 = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_1a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_top_300x250").addService(googletag.pubads().setTargeting('kw',["Alex Collins","alex smith","Antonio Brown","Carson Wentz","Robby Anderson","Todd Gurley","David Dorey","General Fantasy Analysis"]).setTargeting('category',["General Fantasy Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_1a"]);window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();

googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

bidManager.initialize();
});
</script>
<link rel="amphtml" href="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-434500 single-format-aside mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_outstream"] = googletag.defineSlot("/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", [4,1], "acm-ad-tag-lawrence_dfp_desktop_outstream").addService(googletag.pubads().setTargeting('kw',["Alex Collins","alex smith","Antonio Brown","Carson Wentz","Robby Anderson","Todd Gurley","David Dorey","General Fantasy Analysis"]).setTargeting('category',["General Fantasy Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["outstream"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_outstream' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_outstream' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
	
<div id="wrapper">

	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="http://thehuddle.com"
				title="The Huddle"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="The Huddle"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Huddle" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-428297" class="nav__item nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li id="menu-item-428295" class="nav__item nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li id="menu-item-428296" class="nav__item nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-424408" class="nav__item nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li id="menu-item-429328" class="nav__item nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li id="menu-item-424410" class="nav__item nav__item--depth-charts"><a href="/2017/nfl/nfl-depth-charts.php">Depth Charts</a></li>
<li id="menu-item-424627" class="nav__item nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li id="menu-item-424411" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-424412" class="nav__item nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li id="menu-item-424413" class="nav__item nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li id="menu-item-424995" class="nav__item nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
							<li class="nav__item nav__item--social nav__item--facebook">
					<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
				</li>
							<li class="nav__item nav__item--social nav__item--twitter">
					<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
				</li>
					</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-434500" class="post-434500 post type-post status-publish format-aside has-post-thumbnail hentry category-general-fantasy-analysis tag-alex-collins tag-alex-smith tag-antonio-brown tag-carson-wentz tag-robby-anderson tag-todd-gurley post_format-post-format-aside article--no-image" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title article__title--no-image ">
	<h1 class="article__headline">Tunnel Vision - 2017 wrap up</h1>

	</div>
<h1 class="article__headline article__headline--mobile">Tunnel Vision - 2017 wrap up</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://thehuddle.com/category/general-fantasy-analysis/" class="" itemprop="articleSection">General Fantasy Analysis</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Tunnel Vision - 2017 wrap up</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a> 
		<span class="post-date updated">January 1, 2018</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
					Follow					@DMDorey				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					
				</header>

				
				
									<div class="fullwidth-article-format">
				
				<div id="content-container">
					<div class="entry-content ">

						
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">1</span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>		| January 1, 2018		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
		Follow @DMDorey	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><h3>2017 IR/Major injuries</h3>
<table class=" alignright">
<thead>
<tr>
<th colspan="3"><strong>SUNDAY SALUTES</strong></th>
</tr>
<tr>
<th>Quarterbacks</th>
<th>Yards</th>
<th>TD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jameis Winston</td>
<td>363/32</td>
<td>2</td>
</tr>
<tr>
<td>Philip Rivers</td>
<td>387</td>
<td>3</td>
</tr>
<tr>
<td>Matthew Stafford</td>
<td>323/2</td>
<td>3</td>
</tr>
<tr>
<td>DeShone Kizer</td>
<td>314/61</td>
<td>2</td>
</tr>
<tr>
<td>Jimmy Garoppolo</td>
<td>292</td>
<td>2</td>
</tr>
<tr>
<th>Running Backs</th>
<th>Yards</th>
<th>TD</th>
</tr>
<tr>
<td>Dion Lewis</td>
<td>133</td>
<td>2</td>
</tr>
<tr>
<td>Alvin Kamara</td>
<td>128</td>
<td>2</td>
</tr>
<tr>
<td>Devonta Freeman</td>
<td>108</td>
<td>1</td>
</tr>
<tr>
<td>Latavius Murray</td>
<td>111</td>
<td>2</td>
</tr>
<tr>
<td>Carlos Hyde</td>
<td>100</td>
<td>2</td>
</tr>
<tr>
<th>Wide Receivers</th>
<th>Yards</th>
<th>TD</th>
</tr>
<tr>
<td>JuJu Smith-Schuster</td>
<td>143</td>
<td>2</td>
</tr>
<tr>
<td>Keenan Allen</td>
<td>133</td>
<td>2</td>
</tr>
<tr>
<td>Golden Tate</td>
<td>104</td>
<td>1</td>
</tr>
<tr>
<td>Doug Baldwin</td>
<td>90</td>
<td>2</td>
</tr>
<tr>
<td>Chris Godwin</td>
<td>111</td>
<td>1</td>
</tr>
<tr>
<th>Tight Ends</th>
<th>Yards</th>
<th>TD</th>
</tr>
<tr>
<td>Tyler Kroft</td>
<td>53</td>
<td>2</td>
</tr>
<tr>
<td>George Kittle</td>
<td>100</td>
<td>0</td>
</tr>
<tr>
<td>Jack Doyle</td>
<td>38</td>
<td>1</td>
</tr>
<tr>
<td>Ben Watson</td>
<td>61</td>
<td>0</td>
</tr>
<tr>
<td>Nick O&#8217;Leary</td>
<td>26</td>
<td>1</td>
</tr>
<tr>
<th>Placekickers</th>
<th>XP</th>
<th>FG</th>
</tr>
<tr>
<td>Matt Bryant</td>
<td>1</td>
<td>5</td>
</tr>
<tr>
<td>Phil Dawson</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>Robbie Gould</td>
<td>4</td>
<td>2</td>
</tr>
<tr>
<td>Steven Hauschka</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>Ryan Succop</td>
<td>0</td>
<td>3</td>
</tr>
<tr>
<th>Defense</th>
<th>Sck/TO</th>
<th>TD</th>
</tr>
<tr>
<td>Titans</td>
<td>2/4</td>
<td>0</td>
</tr>
<tr>
<td>Jaguars</td>
<td>3/1</td>
<td>1</td>
</tr>
<tr>
<td>Chiefs</td>
<td>5/3</td>
<td>1</td>
</tr>
<tr>
<td>Steelers</td>
<td>6/2</td>
<td>1</td>
</tr>
<tr>
<td>Lions</td>
<td>4/4</td>
<td>0</td>
</tr>
</tbody>
</table>
<p><strong>QUARTERBACK</strong></p>
<p>Aaron Rodgers<br />
Carson Palmer<br />
Carson Wentz<br />
DeShaun Watson<br />
Ryan Tannehill<br />
Tom Savage<br />
Trevor Siemian</p>
<p><strong>RUNNING BACK</strong></p>
<p>Adrian Peterson<br />
Chris Carson<br />
Chris Thompson<br />
Dalvin Cook<br />
Darren Sproles<br />
David Johnson<br />
D&#8217;Onta Foreman<br />
Jeremy Hill<br />
Kenneth Dixon<br />
Rob Kelley<br />
Spencer Ware<br />
Ty Montgomery</p>
<p><strong>TIGHT END</strong></p>
<p>Coby Fleener<br />
Greg Olsen<br />
Hunter Henry<br />
Jordan Reed<br />
Martellus Bennett<br />
O.J. Howard<br />
Tyler Eifert<br />
Zach Miller</p>
<p><strong>WIDE RECEIVER</strong></p>
<p>Allen Hurns<br />
Allen Robinson<br />
Brandon Marshall<br />
Cameron Meredith<br />
Chris Hogan<br />
Corey Coleman<br />
Corey Davis<br />
Donte Moncrief<br />
John Brown<br />
Jordan Matthews<br />
Julian Edelman<br />
Kevin White<br />
Odell Beckham<br />
Pierre Garcon<br />
Quincy Enunwa<br />
Terrelle Pryor<br />
Will Fuller</p>
<p><span style="font-family:'Futura Today Bold', font-sans;font-size:24px;">The Huddle Awards</span></p>
<p>Draft slots were taken from the Average Draft at MyFantasyLeague.</p>
<p><b>QUARTERBACK</b></p>
<p><b>Best Player &#8211; Russell Wilson</b></p>
<p>Wilson brought back the run with 586 yards and three touchdowns on the ground plus 3,983 yards and 34 scores via the pass. He became the offense for the Seahawks and very nearly dragged an injury-decimated team into the playoffs.<br />
<em>Runner-up: Cam Newton</em></p>
<p><b>Best Draft Pick &#8211; Carson Wentz 12.09</b></p>
<p>He ended as the No. 9 best fantasy quarterback but that was missing his final three games. By midseason, he was constantly producing three or four touchdowns per game. His injury may keep him out into next year but for the first 13 weeks, he was often a fantasy back-up turned superstar.<br />
<em>Runner-up: Cam Newton 10.02</em></p>
<p><b>Best Rookie -Deshaun Watson</b></p>
<p>The rookie only lasted for seven games but the Texans future looks very bright. He tore his ACL but his final four games totaled 16 touchdowns and he threw 402 yards in Seattle for his final action. Rookie quarterbacks are not supposed to be this good.<br />
<em>Runner-Up: DeShone Kizer</em></p>
<p><b>Worst Draft Pick &#8211; Andrew Luck 10.01</b></p>
<p>It was a speculative pick but it came in the middle of starting quarterbacks and he never played a down. But he made you keep him until well after mid-season when it was finally admitted he would be a no-show. He gave you nothing and took up a starter spot. You knew the move would prove genius or dumb, but at least you could quietly release him later on in the season.<br />
<em>Runner-up: Aaron Rodgers 3.03</em></p>
<p><b>Best Free Agent &#8211; Alex Smith</b></p>
<p>Smith would end up around No. 6 for fantasy quarterbacks but he opened the year surprisingly well until around midseason. Enough that you could benefit from the quarterback that everyone passed on for pretty much his entire career. He warmed back up at the end of the season even if you were scared to use him.<br />
<em>Runner-up: Jared Goff</em></p>
<p><b>RUNNING BACK</b></p>
<p><b>Best Player &#8211; Todd Gurley</b></p>
<p>He was everything that you hoped in 2016 and then swore not to bother. But Gurley roared back under new management and ran for 1.305 yards and 13 scores while adding 64 catches for 788 yards and six more touchdowns. And then he went super-nova in Week 16.<br />
<em>Runner-up: Le&#8217;Veon Bell</em></p>
<p><b>Best Draft Pick &#8211; Alvin Kamara 13.01</b></p>
<p>Whoa. He was plopped down into a three-man committee behind a Hall-of-fame running back and a player coming off a 10-touchdown, 1,362-yard season. No room for the rookie&#8230; well&#8230; scratch that. He sent Adrian Peterson riding off into the Arizona sunset and did not get in the way of Mark Ingram who had an even better year than 2016. The ex-Tennessee back ran for 725 yards and eight touchdowns plus caught an NFL-rookie record 81 passes for 826 yards and five more scores. While we were all gasping at Kareem Hunt early on, we should have been trading to get Kamara who hit his stride around Week 4.<br />
<em>Runner-up: Kareem Hunt 7.05</em></p>
<p><b>Best Rookie &#8211; Alvin Kamara</b></p>
<p>See above. Between Kamara, Hunt, Christian McCaffrey and almost Dalvin Cook, rest assured the freshman rushers are going to be much more highly valued this time &#8211; right or wrong.<br />
<em>Runner-up: Kareem Hunt</em></p>
<p><b>Worst Draft Pick &#8211; David Johnson 1.01<br />
</b></p>
<p>Yeah. That one left a mark. Not like he even had an advantageous back-up to own. He lasted 11 carries in Week 1. And then pushed your fantasy team down the well.<br />
<em>Runner-up: Ty Montgomery 3.02</em></p>
<p><b>Best Free Agent &#8211; Alex Collins</b></p>
<p>Just to refresh, the depth chart initially had Terrance West, Kenneth Dixon and Danny Woodhead. Collins was that guy from, um, Seattle maybe? He ran for exactly 82 yards on nine carries in Week 3 and then again in Week 4. Then he became a decent streaming option that would end with 1,106 total yards and six touchdowns while gaining 4.6 yards per carry.<br />
<em>Runner-up: Kenyan Drake</em></p>
<p><b>WIDE RECEIVER</b></p>
<p><b>Best Player &#8211; Antonio Brown</b></p>
<p>He already had 101 catches for 1,533 yards and nine scores by Week 14 when he injured his calf. Starting in Week 11, he averaged 157 yards per game before his injury. And scored six times. I know I cried. I&#8217;ll admit it. And yes, I was an owner standing in a league championship poking through a box of far less savory options that did let me down in Week 15.<br />
<em>Runner-up: DeAndre Hopkins</em></p>
<p><b>Best Draft Pick &#8211; DeAndre Hopkins 2.10</b></p>
<p>There are two great unknowns in this world. First, why is there no East Virginia? Second, how did Brock Osweiler struggle to connect with Hopkins? Was he throwing the other way? Hopkins never had worse than seven catches for 73 yards and no score. He ended with 96 receptions for 1,378 yards and 13 touchdowns as one of the most talented wideouts on the planet.<br />
<em>Runner-Up: Larry Fitzgerald 4.03</em></p>
<p><b>Best Rookie &#8211;  JuJu Smith-Schuster</b></p>
<p>Martavis who? As a rookie who would play in just 14 games, Smith-Schuster caught 58 passes for 917 yards and seven touchdowns. He was everything that we thought Bryant would be. As long as Ben Rothlisberger hangs around, Smith-Schuster is not going cheaply in any fantasy drafts.<br />
<em>Runner-Up: Cooper Kupp</em></p>
<p><b>Worst Draft Pick &#8211; Odell Beckham 1.04</b></p>
<p>Bad enough you picked after those three great running backs were gone. But then you had to have some optimism when he entered the season with a sprained ankle. He showed up in Week 2, got fined for pretending to urinate on the goal post in Week 3 and then was gone by Week 5. The sad thing is you could have had, well, most any other wideout.<br />
<em>Runner-Up: Allen Robinson 3.09</em></p>
<p><b>Best Free Agent &#8211; Robby Anderson</b></p>
<p>The Jets lost all their starting wideouts and discovered the second-year UFDA on their roster.  Where all hope was lost, Anderson rose out of the dumpster fire and caught 63 passes for 941 yards and seven touchdowns. And most of that came after Week 7 when he started a five-week stretch of touchdowns.<br />
<em>Runner-Up: Nelson Agholor</em></p>
<p><b>TIGHT END</b></p>
<p><b>Best Player &#8211;  Travis Kelce</b></p>
<p>Nice when dipping early on a tight end works out. Kelce would catch 83 passes for 1,038 yards and eight touchdowns. And he had four 100-yard games to help you win those weeks.<br />
<em>Runner-Up: Rob Gronkowski</em></p>
<p><b>Best Draft Pick &#8211; Zach Ertz 9.07</b></p>
<p>Holding out until the run on tight ends started still netted Ertz. He continued to be Carson Wentz&#8217;s best third-down outlet and ended with 74 catches for 824 yards and eight touchdowns. His role as a red zone threat set him apart from his two previous seasons with over 800 yards each.<br />
<em>Runner-Up: Evan Engram 15.11</em></p>
<p><b>Best Rookie &#8211; Evan Engram<br />
</b></p>
<p>Rookie tight ends never matter. Except, apparently, when all the wide receivers land on injured reserve and no one else can catch a pass. Then (and only then) you end up with 64 catches for 722 yards and six touchdowns,<br />
<em>Runner-Up: O.J. Howard</em></p>
<p><b>Worst Draft Pick &#8211; Jordan Reed 5.06</b></p>
<p>Yeah, I also hate players that get injured all the time and Reed outdid himself on the &#8220;sidelined&#8221; role. He only played in six games and only once had more than 48 yards. He will be much cheaper in 2018. Much.<br />
<em>Runner-Up: Greg Olsen 7.02</em></p>
<p><b>Best Free Agent &#8211; </b><b>Jared Cook<br />
</b></p>
<p>Meh. He still only had 54 catches for 688 yards and two scores but that was the best you would find on the waiver wire.<br />
<em>Runner-Up: Ben Watson</em></p>
<p><span style="font-family:'Futura Today Bold', font-sans;font-size:24px;">Huddle player of the year</span></p>
<p><strong>Todd Gurley </strong> &#8211;  So many considerations &#8211; Le&#8217;Veon Bell, Antonio Brown, DeAndre Hopkins (none of which played Week 17). But Gurley is not only the highest scoring running back, he became red hot right when fantasy playoffs were going on. And career-best game was in Week 16. If you lost your league championship with Gurley on your roster, maybe the fantasy gods were against you.</p>
<p>Salute!</p>
<h3>Drama 101 &#8211; Somebody has to laugh, somebody has to cry</h3>
<table class="table-responsive-inner">
<tbody>
<tr>
<th colspan="2">Comedy</th>
<th>Yards</th>
<th>TDs</th>
<th colspan="2">Tragedy</th>
<th>Yards</th>
<th>TDs</th>
</tr>
<tr>
<td>QB</td>
<td>Deshone Kizer</td>
<td>375</td>
<td>2</td>
<td>QB</td>
<td>Aaron Rodgers</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>RB</td>
<td>Kapri Bibs</td>
<td>100</td>
<td>0</td>
<td>RB</td>
<td>David Johnson</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>RB</td>
<td>Alfred Blue</td>
<td>75</td>
<td>2</td>
<td>RB</td>
<td>Le&#8217;Veon Bell</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>WR</td>
<td>Chris Godwin</td>
<td>111</td>
<td>1</td>
<td>WR</td>
<td>Odell Beckham</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>WR</td>
<td>Rashard Higgins</td>
<td>68</td>
<td>2</td>
<td>WR</td>
<td>Antonio Brown</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>WR</td>
<td>Tyler Boyd</td>
<td>91</td>
<td>1</td>
<td>WR</td>
<td>DeAndre Hopkins</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>TE</td>
<td>Geroge Kittle</td>
<td>100</td>
<td>0</td>
<td>TE</td>
<td>Jordan Reed</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>PK</td>
<td>Phil Dawson</td>
<td colspan="2">1 XP 5 FG</td>
<td>PK</td>
<td>Jake Elliott</td>
<td colspan="2">0</td>
</tr>
<tr>
<td colspan="4">Huddle Fantasy Points = 148</td>
<td colspan="4">Huddle Fantasy Points = 0</td>
</tr>
</tbody>
</table>
<h3>Playoff Schedule</h3>
<p>Saturday, Jan. 6</p>
<p>Titans at Kansas City<br />
Falcons at Los Angeles Rams</p>
<p>Sunday, Jan. 7</p>
<p>Bills at Jaguars<br />
Panthers at Saints</p>
<p>Byes: Patriots, Steelers, Eagles, Vikings</p>
<p>Thanks for reading along this year. May your 2018 be filled with joy, wonderment, love and whoever the next Alvin Kamara may be!</p>
<p>For the 357th time&#8230; get back to work.</p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://thehuddle.com/tag/alex-collins/" rel="tag">Alex Collins</a>, <a href="http://thehuddle.com/tag/alex-smith/" rel="tag">alex smith</a>, <a href="http://thehuddle.com/tag/antonio-brown/" rel="tag">Antonio Brown</a>, <a href="http://thehuddle.com/tag/carson-wentz/" rel="tag">Carson Wentz</a>, <a href="http://thehuddle.com/tag/robby-anderson/" rel="tag">Robby Anderson</a>, <a href="http://thehuddle.com/tag/todd-gurley/" rel="tag">Todd Gurley</a>, <a href="http://thehuddle.com/category/general-fantasy-analysis/" rel="category tag">General Fantasy Analysis</a></p>
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">1</span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/01/01/tunnel-vision-2017-wrap-up/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

									</div>
				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/12/18/tunnel-vision-of-week-15-4/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-1"
	   title="Tunnel vision of Week 15"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
	   style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10484520-e1513575142864.jpg?w=295&#038;h=231&#038;crop=1');"
	   itemprop="url">

		<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10484520-e1513575142864.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165"
		     alt="Tunnel vision of Week 15" itemprop="image">

		<span class="ie-overlay-hack"></span>

			</a>

	<div class="text-block">

		<span class="block__shares">17 shares</span><span class="block__time block__time--mobile">18 Dec 17</span>
		<h2><a href="http://thehuddle.com/category/injury-analysis/" class="category" itemprop="articleSection">Injury Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="http://thehuddle.com/2017/12/18/tunnel-vision-of-week-15-4/"
			   title="Tunnel vision of Week 15" itemprop="url">
				Tunnel vision of Week 15			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/11/20/tunnel-vision-of-week-11-4/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-2"
	   title="Tunnel vision of Week 11"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
	   style="background-image: url('https://usathuddle.files.wordpress.com/2017/11/usatsi_10426355-e1511153672608.jpg?w=295&#038;h=231&#038;crop=1');"
	   itemprop="url">

		<img src="https://usathuddle.files.wordpress.com/2017/11/usatsi_10426355-e1511153672608.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165"
		     alt="Tunnel vision of Week 11" itemprop="image">

		<span class="ie-overlay-hack"></span>

			</a>

	<div class="text-block">

		<span class="block__shares">30 shares</span><span class="block__time block__time--mobile">20 Nov 17</span>
		<h2><a href="http://thehuddle.com/category/injury-analysis/" class="category" itemprop="articleSection">Injury Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="http://thehuddle.com/2017/11/20/tunnel-vision-of-week-11-4/"
			   title="Tunnel vision of Week 11" itemprop="url">
				Tunnel vision of Week 11			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2017/11/27/tunnel-vision-of-week-12-4/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-3"
	   title="Tunnel vision of Week 12"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
	   style="background-image: url('https://usathuddle.files.wordpress.com/2017/11/usatsi_10439652-e1511751688805.jpg?w=295&#038;h=231&#038;crop=1');"
	   itemprop="url">

		<img src="https://usathuddle.files.wordpress.com/2017/11/usatsi_10439652-e1511751688805.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165"
		     alt="Tunnel vision of Week 12" itemprop="image">

		<span class="ie-overlay-hack"></span>

			</a>

	<div class="text-block">

		<span class="block__shares">14 shares</span><span class="block__time block__time--mobile">27 Nov 17</span>
		<h2><a href="http://thehuddle.com/category/player-analysis/" class="category" itemprop="articleSection">Player Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="http://thehuddle.com/2017/11/27/tunnel-vision-of-week-12-4/"
			   title="Tunnel vision of Week 12" itemprop="url">
				Tunnel vision of Week 12			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_native' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_native"] = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.general", [[640,170],[3,1]], "acm-ad-tag-lawrence_dfp_desktop_native").addService(googletag.pubads().setTargeting('kw',["Alex Collins","alex smith","Antonio Brown","Carson Wentz","Robby Anderson","Todd Gurley","David Dorey","General Fantasy Analysis"]).setTargeting('category',["General Fantasy Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_native' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_native' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_native' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/31/game-day-inactives-injuries-and-weather-week-17/"
						title="Game day inactives, injuries and weather: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498819-e1514595155745.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498819-e1514595155745.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Game day inactives, injuries and weather: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/12/31/game-day-inactives-injuries-and-weather-week-17/"
								title="Game day inactives, injuries and weather: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/12/31/game-day-inactives-injuries-and-weather-week-17/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/12/31/game-day-inactives-injuries-and-weather-week-17/"
			title="Game day inactives, injuries and weather: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>2</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				31 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/game-day/" class="category" itemprop="articleSection">Game Day</a>						<span class="block__time block__time--mobile">31 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/31/game-day-inactives-injuries-and-weather-week-17/"
						title="Game day inactives, injuries and weather: Week 17"
						itemprop="url" 						>
							Game day inactives, injuries and weather: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 31, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>List of inactive or injured players. Real-time updates from the NFL right up until kickoff each Sunday morning. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/29/friday-walkthrough-week-17/"
						title="Friday walkthrough: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10499372-e1514595314129.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10499372-e1514595314129.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Friday walkthrough: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/12/29/friday-walkthrough-week-17/"
								title="Friday walkthrough: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/12/29/friday-walkthrough-week-17/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/12/29/friday-walkthrough-week-17/"
			title="Friday walkthrough: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				29 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/injury-analysis/" class="category" itemprop="articleSection">Injury Analysis</a>						<span class="block__time block__time--mobile">29 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/29/friday-walkthrough-week-17/"
						title="Friday walkthrough: Week 17"
						itemprop="url" 						>
							Friday walkthrough: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 29, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/wwalters/" title="Posts by Whit Walters" class="author url fn" rel="author">Whit Walters</a>													</span>
					</p>
				</footer>

				<p>Final late afternoon practice and playing status report for all key fantasy football players. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/29/six-points-with-david-dorey-2018-rookies/"
						title="Six points with David Dorey: 2018 rookies"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10423259-e1514558467291.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10423259-e1514558467291.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Six points with David Dorey: 2018 rookies" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/12/29/six-points-with-david-dorey-2018-rookies/"
								title="Six points with David Dorey: 2018 rookies"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/12/29/six-points-with-david-dorey-2018-rookies/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/12/29/six-points-with-david-dorey-2018-rookies/"
			title="Six points with David Dorey: 2018 rookies"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>2</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				29 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">29 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/29/six-points-with-david-dorey-2018-rookies/"
						title="Six points with David Dorey: 2018 rookies"
						itemprop="url" 						>
							Six points with David Dorey: 2018 rookies					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 29, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>The 2017 NFL season is closing and there&#8217;s already an army of draftniks and fantasy football researchers looking into the new crop (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/29/daily-fantasy-domination-week-17-4/"
						title="Daily fantasy domination: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498047-e1514504172179.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498047-e1514504172179.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Daily fantasy domination: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/12/29/daily-fantasy-domination-week-17-4/"
								title="Daily fantasy domination: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/12/29/daily-fantasy-domination-week-17-4/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/12/29/daily-fantasy-domination-week-17-4/"
			title="Daily fantasy domination: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>13</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				29 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/dfs/" class="category" itemprop="articleSection">DFS</a>						<span class="block__time block__time--mobile">29 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/29/daily-fantasy-domination-week-17-4/"
						title="Daily fantasy domination: Week 17"
						itemprop="url" 						>
							Daily fantasy domination: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 29, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/newclearharley/" title="Posts by Harley Schultz" class="author url fn" rel="author">Harley Schultz</a>													</span>
					</p>
				</footer>

				<p>Week 17 is a real bane to DFS prognosticators. Which teams are going to rest their players the entire game? Which teams are going to rest (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=17"
						title="Start bench tool: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498425-e1514477658151.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498425-e1514477658151.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Start bench tool: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=17"
								title="Start bench tool: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=17';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=17"
			title="Start bench tool: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				28 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/lineup-management/" class="category" itemprop="articleSection">Lineup Management</a>						<span class="block__time block__time--mobile">28 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=17"
						title="Start bench tool: Week 17"
						itemprop="url" 						>
							Start bench tool: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 28, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>, <a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a> and <a href="http://thehuddle.com/author/stevegallonfl/" title="Posts by Steve Gallo" class="author url fn" rel="author">Steve Gallo</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/season/17/start-bench-list.php"
						title="Start bench list: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498608-e1514477479920.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498608-e1514477479920.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Start bench list: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/season/17/start-bench-list.php"
								title="Start bench list: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/season/17/start-bench-list.php';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/season/17/start-bench-list.php"
			title="Start bench list: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>2</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				28 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/lineup-management/" class="category" itemprop="articleSection">Lineup Management</a>						<span class="block__time block__time--mobile">28 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/season/17/start-bench-list.php"
						title="Start bench list: Week 17"
						itemprop="url" 						>
							Start bench list: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 28, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/28/daily-value-plays-and-bargain-basements-week-17/"
						title="Daily value plays and bargain basements: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498867-e1514503630103.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498867-e1514503630103.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Daily value plays and bargain basements: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/12/28/daily-value-plays-and-bargain-basements-week-17/"
								title="Daily value plays and bargain basements: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/12/28/daily-value-plays-and-bargain-basements-week-17/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/12/28/daily-value-plays-and-bargain-basements-week-17/"
			title="Daily value plays and bargain basements: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				28 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/dfs/" class="category" itemprop="articleSection">DFS</a>						<span class="block__time block__time--mobile">28 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/28/daily-value-plays-and-bargain-basements-week-17/"
						title="Daily value plays and bargain basements: Week 17"
						itemprop="url" 						>
							Daily value plays and bargain basements: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 28, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a>													</span>
					</p>
				</footer>

				<p>Everyone knows to start studs in DFS. What can bring home the money in is finding players who will produce at a lower salary that might not (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/28/red-zone-breakdown-week-17/"
						title="Red zone breakdown: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10478825-e1514478321774.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10478825-e1514478321774.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Red zone breakdown: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/12/28/red-zone-breakdown-week-17/"
								title="Red zone breakdown: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/12/28/red-zone-breakdown-week-17/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/12/28/red-zone-breakdown-week-17/"
			title="Red zone breakdown: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				28 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-analysis/" class="category" itemprop="articleSection">Player Analysis</a>						<span class="block__time block__time--mobile">28 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/28/red-zone-breakdown-week-17/"
						title="Red zone breakdown: Week 17"
						itemprop="url" 						>
							Red zone breakdown: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 28, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a>													</span>
					</p>
				</footer>

				<p>In the final red zone article of the season, we’ll look at one of the best and worst players at each position and what to expect from (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/28/office-pool-pickem-week-17-5/"
						title="Office pool pick&#039;em: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10496145-e1514432080231.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10496145-e1514432080231.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Office pool pick&#039;em: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/12/28/office-pool-pickem-week-17-5/"
								title="Office pool pick&#039;em: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/12/28/office-pool-pickem-week-17-5/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/12/28/office-pool-pickem-week-17-5/"
			title="Office pool pick&#039;em: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>3</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				28 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/game-picks/" class="category" itemprop="articleSection">Game Picks</a>						<span class="block__time block__time--mobile">28 Dec 17</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/12/28/office-pool-pickem-week-17-5/"
						title="Office pool pick&#039;em: Week 17"
						itemprop="url" 						>
							Office pool pick&#039;em: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 28, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>The Huddle staff makes its weekly game picks every Thursday. Picks are based both on which team will actually win the game and also which (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/season/17/game-prediction-DAL-PHI.php"
						title="Game predictions and player projections: Week 17"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498903-e1514303537339.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498903-e1514303537339.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Game predictions and player projections: Week 17" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2017/season/17/game-prediction-DAL-PHI.php"
								title="Game predictions and player projections: Week 17"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2017/season/17/game-prediction-DAL-PHI.php';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2017/season/17/game-prediction-DAL-PHI.php"
			title="Game predictions and player projections: Week 17"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				28 Dec 17			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/game-predictions/" class="category" itemprop="articleSection">Game Predictions</a>						<span class="block__time block__time--mobile">28 Dec 17</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2017/season/17/game-prediction-DAL-PHI.php"
						title="Game predictions and player projections: Week 17"
						itemprop="url" 						>
							Game predictions and player projections: Week 17					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">December 28, 2017 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	</div>
<a href="http://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
			<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>		</div>

		
		<div class="widget widget--login widget--box" id="login_widget-3"><div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget--newsletter widget--box" id="newsletter_widget-3">
<div class="newsletter__wrapper ">

	<div class="newsletter__signup-wrapper">
		<form novalidate="novalidate" action="http://thehuddle.com/wp-json/usat/v1/gems/subscribe/">

							<h3 class="newsletter__header">Sign up for our free newsletter and get great tips and updates.</h3>
			
			<input
				type="email"
				class="newsletter__input"
				placeholder="Enter your email address"
				name="email"
				required
			>
			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

							<p class="newsletter__text">Always fresh, no spam, guaranteed!</p>
			
			
		</form>

			</div>

	<div class="newsletter__state newsletter__state--success">

		<h3 class="newsletter__header">Success</h3>

		<p class="newsletter__text">
			Thanks for signing up.<br>
			You&#039;ll be waking up a little more awesome tomorrow.		</p>

	</div>

	<div class="newsletter__state newsletter__state--error">

		<h3 class="newsletter__header">Whoa!</h3>

		<p class="newsletter__text newsletter__text--error">
			Something went wrong.		</p>

		<button class="newsletter__button newsletter__button--reset">
			Try again?		</button>

	</div>

	</div>

</div><div class="widget widget_usat_sidebar_top_posts_widget" id="usat_sidebar_top_posts_widget-2">		<div class="col1 right" id="sticky-sidebar">
				<div class="heading-small">
		<h2>Popular <span>Now</span></h2>
	</div>
				
					<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498819-e1514595155745.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2017/12/31/game-day-inactives-injuries-and-weather-week-17/" title="Game day inactives, injuries and weather: Week 17" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498819-e1514595155745.jpg?w=100&#038;h=100&#038;crop=1" alt="Game day inactives, injuries and weather: Week 17" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				31 Dec 17			</div>
			<div class="text-block">	
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2017/12/31/game-day-inactives-injuries-and-weather-week-17/" title="Game day inactives, injuries and weather: Week 17" itemprop="url" >Game day inactives, injuries and weather: Week 17</a></p>
				<p class="widget-date">December 31, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498047-e1514504172179.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2017/12/29/daily-fantasy-domination-week-17-4/" title="Daily fantasy domination: Week 17" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498047-e1514504172179.jpg?w=100&#038;h=100&#038;crop=1" alt="Daily fantasy domination: Week 17" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				29 Dec 17			</div>
			<div class="text-block">	
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2017/12/29/daily-fantasy-domination-week-17-4/" title="Daily fantasy domination: Week 17" itemprop="url" >Daily fantasy domination: Week 17</a></p>
				<p class="widget-date">December 29, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10496145-e1514432080231.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2017/12/28/office-pool-pickem-week-17-5/" title="Office pool pick&#039;em: Week 17" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10496145-e1514432080231.jpg?w=100&#038;h=100&#038;crop=1" alt="Office pool pick&#039;em: Week 17" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				28 Dec 17			</div>
			<div class="text-block">	
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2017/12/28/office-pool-pickem-week-17-5/" title="Office pool pick&#039;em: Week 17" itemprop="url" >Office pool pick'em: Week 17</a></p>
				<p class="widget-date">December 28, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10498867-e1514503630103.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2017/12/28/daily-value-plays-and-bargain-basements-week-17/" title="Daily value plays and bargain basements: Week 17" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10498867-e1514503630103.jpg?w=100&#038;h=100&#038;crop=1" alt="Daily value plays and bargain basements: Week 17" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				28 Dec 17			</div>
			<div class="text-block">	
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2017/12/28/daily-value-plays-and-bargain-basements-week-17/" title="Daily value plays and bargain basements: Week 17" itemprop="url" >Daily value plays and bargain basements: Week 17</a></p>
				<p class="widget-date">December 28, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
					
		</div>
		</div><div class="widget widget--links widget--box" id="links_widget-8"><div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="http://www.thehuddle.com/2017/nfl/nfl-depth-charts.php">2017 Fantasy Depth Charts</a></li>
<li id="menu-item-427710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-427710"><a href="http://thehuddle.com/2017-top-nfl-free-agent-tracker/">2017 Top Free-agent Tracker</a></li>
<li id="menu-item-427509" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427509"><a href="http://thehuddle.com/2017-nfl-player-movement-tracker/">2017 Player Movement Tracker</a></li>
<li id="menu-item-427436" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427436"><a href="http://thehuddle.com/2017/01/18/2017-coaching-change-tracker/">2017 Coaching Change Tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7"><div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="http://www.thehuddle.com/2017/nfl/nfl-depth-charts.php">2017 Fantasy Depth Charts</a></li>
<li id="menu-item-424716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424716"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-grid.php">2017 NFL Schedule Grid</a></li>
<li id="menu-item-424717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424717"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-wk-grid.php">2017 NFL Schedule Weekly Grid</a></li>
<li id="menu-item-424718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424718"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-wk-txt.php">2017 NFL Full Weekly Schedule</a></li>
<li id="menu-item-428116" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428116"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-round/">2017 NFL Draft by round</a></li>
<li id="menu-item-428117" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428117"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-team/">2017 NFL Draft by team</a></li>
<li id="menu-item-428118" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428118"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-position/">2017 NFL Draft by position</a></li>
<li id="menu-item-427599" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-427599"><a href="http://thehuddle.com/2017/02/09/2017-nfl-important-dates/">2017 NFL Important Dates</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-4"><div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="http://www.thehuddle.com/stats/2017/plays_std.php">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="http://www.thehuddle.com/stats/2017/plays_weekly.php">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="http://www.thehuddle.com/stats/2017/gamescan.php">Weekly Fantasy Box Scores</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="http://www.thehuddle.com/stats/2017/tpr.php">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="http://www.thehuddle.com/stats/2017/tpm.php">Team Position Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="http://www.thehuddle.com/stats/2017/gsm.php">Game Stats Matchups</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="http://thehuddle.com/myHuddle/sos.php">Strength of Schedule Tool</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget--forum widget--box" id="forum_widget-3"><div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/" class="" rel="" target=""><img width="1000" height="1000" src="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg 1000w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=150&amp;h=150 150w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300&amp;h=300 300w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=768&amp;h=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="429990" data-permalink="http://thehuddle.com/blitz/" data-orig-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" data-orig-size="1000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Blitz" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=1000" /></a></div>
		<div class="widget sidebar-ad bottom">
			<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_bottom_300x250"] = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250").addService(googletag.pubads().setTargeting('kw',["Alex Collins","alex smith","Antonio Brown","Carson Wentz","Robby Anderson","Todd Gurley","David Dorey","General Fantasy Analysis"]).setTargeting('category',["General Fantasy Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_2a"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>		</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-424341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424341"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424340"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424342"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="The Huddle">
				<a class="mobile-nav__breadcrumb" href="http://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li class="mobile-nav__item mobile-nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li class="mobile-nav__item mobile-nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="/2017/nfl/nfl-depth-charts.php">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-424341" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>
<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Create an Account
		</a>
		<a href="http://thehuddle.com/login.php" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201801y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVy0EOQDAQheELqamEYCHOQk1otVVGcXwVGzYS2/+9D3bHxGRXtCsogg43KdAdsaIIHpPxzGnfS0ug5YgEs0ePQ2M7jcvHWUzGhMRupC7dAu3S4R/0CgHWpkoyXuRlxtNEnSMRR9o='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"0"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"","maxDistance":"250","medAdHeight":"0","maxDistanceMed":"0","largeAdHeight":"0","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var huddleUser = {"nameAPI":"http:\/\/thehuddle.com\/api\/get_user_name.php","cookie":"huddle-auth"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJydksFygzAMRH+owiVNpqdOv0XBmkRgbGrZUPr1FZmSHkgpyY0R3mftes3QQRV8Ip9MOlNLYnruTBZMweIIncsn9mIkcdWMwN6xJ+jZUhBT354XtTyZf7gOh0i+oonh+Gjqj0xxLKoQGqZ7AS2yv1eTCB3nFuhTjwsHv1i7zVf3O5g49QUH6NGNanvN5yx0+KXXBrTwXLxOgB+fEjzGol1d+0/GdbDF80wZUPDIkzwndpveaCn12PMJk6b1mF60H0c1/pAYo4buNpVjKd5akVmp/+CcrXWXsmyr5G1tFoqgwa3UC602ATQYXVMSRf2C0FOMGpf8zu4kpIhV8+hD0yCOkpJgYHuipJj39q08lLv9y6Hc7+tvtrCXHQ=='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-5','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-5','user_id':'0','post':'434500','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-5&user_id=0&post=434500&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6NHxqUCVoWXguQUddUl8zZD80SW5jeUIrP1U5dFFPQmgzW2Jtb1pwOU1YQTNxMkJVbkFRK2EsSmMzLyVlP11MSFU4SnMxK1FrWGlpWGkzUXMxPWJrRC1zeXpnYUt3T01YfGVYXVdfN2dxalsuZS5FTWdQV3pKbDFxc3pbVUw='}]);
_stq.push([ 'clickTrackerInit', '114275906', '434500' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated in 0.247 seconds
	111076 bytes batcached for 300 seconds
-->
