<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Complete tracking of all the fantasy football relevant 2018 NFL player movement from team to team." /><meta name="news_keywords" content="fantasy football,%tags%,%cats%" />
<meta name="keywords" content="fantasy football,2018 nfl free agents, free agents, nfl draft, nfl player movement, nfl trades,free agents, player movement" />
<title>2018 player movement tracker | The Huddle</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1520999694&amp;back=http%3A%2F%2Fthehuddle.com%2F2018%2F03%2F13%2F2018-player-movement-tracker%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Feed" href="http://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Comments Feed" href="http://thehuddle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; 2018 player movement tracker Comments Feed" href="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJylkN1SAyEMhV9IxJ9q9cLx1jfwOguRTTcQZmHb2beXLdNqtaIz3jA5cL6cEL2LykjIGLL2k4o8OQpJ76IRr5InxvmLujQpXejzGNOASW8wRzCD2quW3ciI5d5HyIvDoyVARl9sLczH+wO1lH3JasbU8bsujpiSKqenyavcl6BfxvPLKPUfuhhPbypKOkimQqdj8a1njdJbinpKkMXCfAxJhRlmRYEpoNqSRalZ5x7+1JlhN2IweHh8hQQd/QPVL5O1jM0Vk3WYy9BiCFjVfXwWLdihKBYDmSScCPXGQGMLHbFjcaV0+519yJ++26+0Y+mAF8Ozf7q+u7l6WD+u1rebd4uEJX0=?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFjt0KwjAMRl/IrhSdeiM+S9fGmbr+mLQb8+ntQC/EoRAIJCcnn5ySwGCGYoGlq3UvQPOrNY438hcgPPakMzQewxs2MWQIeWF97HAAURhI93VWRZe4wqXI2QNzhVa2n5EwjAjTX8xBTtrcBAHj48uar1D/yRGTLKxztHoWg54IgoHF1aG1QMLrUCNRvT77k2rVVqn98bBzT8Znczs='></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.4'></script>
<script type='text/javascript' async src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:thehuddle","priority_asset":"","blogname":"thehuddle","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"434791","headline":"2018 player movement tracker","byline":"Huddle Staff","taxonomykeywords":"2018 NFL free agents, free agents, nfl draft, NFL player movement, NFL trades"};
/* ]]> */
</script>
<script type='text/javascript'>
					utag_data.clickPage = sessionStorage.getItem( "clickPage" );
					sessionStorage.setItem( "clickPage", window.location.href );
					
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/thehuddle3/prod/utag.js?ver=4.9.4'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2ojccOw' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F03%2F13%2F2018-player-movement-tracker%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F03%2F13%2F2018-player-movement-tracker%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="2018 player movement tracker" />
<meta property="og:url" content="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/" />
<meta property="og:description" content="Updated: March 13, 2018 Quarterbacks Running Backs Wide Receivers Tight Ends ARI New: Sam Bradford Mike Glennon Gone: Adrian Peterson John Brown Ryan Grant ATL New: Gone: Taylor Gabriel BAL New: Jo…" />
<meta property="article:published_time" content="2018-03-13T09:03:59+00:00" />
<meta property="article:modified_time" content="2018-03-14T02:36:41+00:00" />
<meta property="og:site_name" content="The Huddle" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2018/03/usatsi_10529117-e1520976989315.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:text:title" content="2018 player movement tracker" />
<meta name="twitter:image:src" content="https://usathuddle.files.wordpress.com/2018/03/usatsi_10529117-e1520976989315.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="http://thehuddle.com/osd.xml" title="The Huddle" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Huddle" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Fantasy Football Cheat Sheets, Rankings, Sleepers &amp; Award Winning Draft Advice" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://thehuddle.com/feed/;icon-uri=http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["2018 NFL free agents","free agents","nfl draft","NFL player movement","NFL trades","Huddle Staff","Free Agents","Player Movement"],"category":"Free Agents","referrer":"","isMobile":"0"};
googletag_cmd_push(function() {
window.lawrence_dfp_desktop_skin = googletag.defineSlot("/7103/SMG_TheHuddle/skin/sports/fantasy/football.general", [1,1], "acm-ad-tag-lawrence_dfp_desktop_skin").addService(googletag.pubads().setTargeting('kw',["2018 NFL free agents","free agents","nfl draft","NFL player movement","NFL trades","Huddle Staff","Free Agents","Player Movement"]).setTargeting('category',["Free Agents","Player Movement"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["skin"]);window.lawrence_dfp_desktop_top = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.main", ['fluid',[728,90],[970,66],[970,250]], "acm-ad-tag-lawrence_dfp_desktop_top").addService(googletag.pubads().setTargeting('kw',["2018 NFL free agents","free agents","nfl draft","NFL player movement","NFL trades","Huddle Staff","Free Agents","Player Movement"]).setTargeting('category',["Free Agents","Player Movement"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);window.lawrence_dfp_desktop_top_300x250 = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_1a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_top_300x250").addService(googletag.pubads().setTargeting('kw',["2018 NFL free agents","free agents","nfl draft","NFL player movement","NFL trades","Huddle Staff","Free Agents","Player Movement"]).setTargeting('category',["Free Agents","Player Movement"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_1a"]);window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();

googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

bidManager.initialize();
});
</script>
<link rel="amphtml" href="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-434791 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_outstream", slotName: "/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", sizes : [4,1] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_outstream"] = googletag.defineSlot("/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", [4,1], "acm-ad-tag-lawrence_dfp_desktop_outstream").addService(googletag.pubads().setTargeting('kw',["2018 NFL free agents","free agents","nfl draft","NFL player movement","NFL trades","Huddle Staff","Free Agents","Player Movement"]).setTargeting('category',["Free Agents","Player Movement"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["outstream"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_outstream' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_outstream' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
	
<div id="wrapper">

	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="http://thehuddle.com"
				title="The Huddle"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="The Huddle"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Huddle" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-428297" class="nav__item nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li id="menu-item-428295" class="nav__item nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li id="menu-item-428296" class="nav__item nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-424408" class="nav__item nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li id="menu-item-429328" class="nav__item nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li id="menu-item-424410" class="nav__item nav__item--depth-charts"><a href="/2018-nfl-depth-charts.php">Depth Charts</a></li>
<li id="menu-item-424627" class="nav__item nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li id="menu-item-424411" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-424412" class="nav__item nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li id="menu-item-424413" class="nav__item nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li id="menu-item-424995" class="nav__item nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-434791" class="post-434791 post type-post status-publish format-standard has-post-thumbnail hentry category-free-agents category-player-movement tag-2018-nfl-free-agents tag-free-agents tag-nfl-draft tag-nfl-player-movement tag-nfl-trades article--no-image" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title article__title--no-image ">
	<h1 class="article__headline">2018 player movement tracker</h1>

	</div>
<h1 class="article__headline article__headline--mobile">2018 player movement tracker</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://thehuddle.com/category/player-movement/" class="" itemprop="articleSection">Player Movement</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">2018 player movement tracker</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a> 
		<span class="post-date updated">March 13, 2018</span>

	
	</p>
					</div>

					
				</header>

				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>		| March 13, 2018		<span class="article__author__widgets">
								</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p><em><strong>Updated:</strong> March 13, 2018</em></p>
<table class="table-responsive-inner">
<tbody>
<tr>
<th colspan="2"></th>
<th>Quarterbacks</th>
<th>Running Backs</th>
<th>Wide Receivers</th>
<th>Tight Ends</th>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>ARI</strong></td>
<td><strong>New: </strong></td>
<td>Sam Bradford<br />
Mike Glennon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Adrian Peterson</td>
<td style="border-bottom:2px solid #dddddd;">John Brown<br />
Ryan Grant</td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>ATL</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Taylor Gabriel</td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>BAL</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td>John Brown</td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"><span style="color:#000000;"><br />
</span></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>BUF</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td>Chris Ivory</td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;">Tyrod Taylor</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>CAR</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td>Torrey Smith</td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Jonathan Stewart</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>CHI</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td>Allen Robinson<br />
Taylor Gabriel</td>
<td>Trey Burton</td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;">Mike Glennon</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>CIN</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>CLE</strong></td>
<td><strong>New: </strong></td>
<td><a href="http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/" target="_blank" rel="noopener">Tyrod Taylor</a></td>
<td></td>
<td><a href="http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/" target="_blank" rel="noopener">Jarvis Landry</a></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;">DeShone Kizer</td>
<td style="border-bottom:2px solid #dddddd;">Isaiah Crowell</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>DAL</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>DEN</strong></td>
<td><strong>New: </strong></td>
<td>Case Keenum</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>DET</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>GB</strong></td>
<td><strong>New: </strong></td>
<td>DeShone Kizer</td>
<td></td>
<td></td>
<td><a href="http://thehuddle.com/2018/03/13/jimmy-graham-to-the-packers/">Jimmy Graham</a></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Jordy Nelson</td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>HOU</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>IND</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td>Donte Moncrief</td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><span style="color:#000000;"><strong>JAC</strong></span></td>
<td><span style="color:#000000;"><strong>New: </strong></span></td>
<td></td>
<td></td>
<td>Donte Moncrief</td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Chris Ivory</td>
<td style="border-bottom:2px solid #dddddd;">Allen Robinson</td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><span style="color:#000000;"><strong>KC</strong></span></td>
<td><span style="color:#000000;"><strong>New: </strong></span></td>
<td></td>
<td></td>
<td>Sammy Watkins</td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;">Alex Smith</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Albert Wilson</td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>LAC</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>LAR</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td>Sammy Watkins</td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>MIA</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td>Albert Wilson<br />
Danny Amendola</td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Jarvis Landry</td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>MIN</strong></td>
<td><strong>New: </strong></td>
<td><a href="http://thehuddle.com/2018/03/13/kirk-cousins-to-the-vikings/">Kirk Cousins</a></td>
<td class="t_std_left"></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;">Case Keenum<br />
Sam Bradford<br />
Teddy Bridgewater</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>NE</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"> Dion Lewis</td>
<td style="border-bottom:2px solid #dddddd;">Danny Amendola</td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>NO</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>NYG</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td>Jonathan Stewart</td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>NYJ</strong></td>
<td><strong>New: </strong></td>
<td>Teddy Bridgewater</td>
<td>Isaiah Crowell</td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Matt Forte (ret)</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>OAK</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>PHI</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Torrey Smith</td>
<td style="border-bottom:2px solid #dddddd;">Trey Burton<br />
Brent Celek</td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>PIT</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>SEA</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Paul Richardson</td>
<td style="border-bottom:2px solid #dddddd;">Jimmy Graham</td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>SF</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>TB</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Doug Martin</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>TEN</strong></td>
<td><strong>New: </strong></td>
<td></td>
<td>Dion Lewis</td>
<td></td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">DeMarco Murray</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;" rowspan="2"><strong>WAS</strong></td>
<td><strong>New: </strong></td>
<td>Alex Smith</td>
<td></td>
<td>Paul Richardson</td>
<td></td>
</tr>
<tr>
<td style="border-bottom:2px solid #dddddd;"><strong>Gone: </strong></td>
<td style="border-bottom:2px solid #dddddd;">Kirk Cousins</td>
<td style="border-bottom:2px solid #dddddd;"></td>
<td style="border-bottom:2px solid #dddddd;">Ryan Grant</td>
<td style="border-bottom:2px solid #dddddd;"></td>
</tr>
</tbody>
</table>
<p>arinyj</p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://thehuddle.com/tag/2018-nfl-free-agents/" rel="tag">2018 NFL free agents</a>, <a href="http://thehuddle.com/tag/free-agents/" rel="tag">free agents</a>, <a href="http://thehuddle.com/tag/nfl-draft/" rel="tag">nfl draft</a>, <a href="http://thehuddle.com/tag/nfl-player-movement/" rel="tag">NFL player movement</a>, <a href="http://thehuddle.com/tag/nfl-trades/" rel="tag">NFL trades</a>, <a href="http://thehuddle.com/category/free-agents/" rel="category tag">Free Agents</a>, <a href="http://thehuddle.com/category/player-movement/" rel="category tag">Player Movement</a></p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-1"
	   title="2018 top free agent tracker"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/02/usatsi_10510779-e1517847836696.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/02/usatsi_10510779-e1517847836696.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2018 top free agent tracker" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">22hr ago</span>
		<h2><a href="http://thehuddle.com/category/free-agents/" class="category" itemprop="articleSection">Free Agents</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/"
			   title="2018 top free agent tracker" itemprop="url">
				2018 top free agent tracker			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-2"
	   title="Free agency brings fantasy football hope to Cleveland"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_10395764-e1520892410380.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_10395764-e1520892410380.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Free agency brings fantasy football hope to Cleveland" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">17 shares</span><span class="block__time block__time--mobile">1d ago</span>
		<h2><a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/"
			   title="Free agency brings fantasy football hope to Cleveland" itemprop="url">
				Free agency brings fantasy football hope to Cleveland			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/02/15/2018-nfl-coaching-changes-buffalo-bills/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-3"
	   title="2018 NFL coaching changes: Buffalo Bills"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/02/usatsi_105256391.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/02/usatsi_105256391.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2018 NFL coaching changes: Buffalo Bills" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">13 shares</span><span class="block__time block__time--mobile">4w ago</span>
		<h2><a href="http://thehuddle.com/category/coaching-change/" class="category" itemprop="articleSection">Coaching Change</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="http://thehuddle.com/2018/02/15/2018-nfl-coaching-changes-buffalo-bills/"
			   title="2018 NFL coaching changes: Buffalo Bills" itemprop="url">
				2018 NFL coaching changes: Buffalo Bills			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_native", slotName: "/7103/SMG_TheHuddle/native/sports/fantasy/football.general", sizes : [[640,170],[3,1]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_native' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_native"] = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.general", [[640,170],[3,1]], "acm-ad-tag-lawrence_dfp_desktop_native").addService(googletag.pubads().setTargeting('kw',["2018 NFL free agents","free agents","nfl draft","NFL player movement","NFL trades","Huddle Staff","Free Agents","Player Movement"]).setTargeting('category',["Free Agents","Player Movement"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_native' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_native' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_native' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/13/jimmy-graham-to-the-packers/"
						title="Jimmy Graham to the Packers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_10417280-e1520994723682.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_10417280-e1520994723682.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Jimmy Graham to the Packers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/13/jimmy-graham-to-the-packers/"
								title="Jimmy Graham to the Packers"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/13/jimmy-graham-to-the-packers/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/13/jimmy-graham-to-the-packers/"
			title="Jimmy Graham to the Packers"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">1hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/13/jimmy-graham-to-the-packers/"
						title="Jimmy Graham to the Packers"
						itemprop="url" 						>
							Jimmy Graham to the Packers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 13, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>The Packers tried to acquire a receiving tight end in the last two years when they added Martellus Bennett and Jared Cook. Neither proved (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/13/kirk-cousins-to-the-vikings/"
						title="Kirk Cousins to the Vikings"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_10497922-e1520975753991.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_10497922-e1520975753991.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Kirk Cousins to the Vikings" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/13/kirk-cousins-to-the-vikings/"
								title="Kirk Cousins to the Vikings"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/13/kirk-cousins-to-the-vikings/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/13/kirk-cousins-to-the-vikings/"
			title="Kirk Cousins to the Vikings"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">6hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/13/kirk-cousins-to-the-vikings/"
						title="Kirk Cousins to the Vikings"
						itemprop="url" 						>
							Kirk Cousins to the Vikings					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 13, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>The belle of the free agent ball opted to become a Minnesota Viking in large part because of their potential to reach the Super Bowl. The (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/"
						title="2018 top free agent tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/02/usatsi_10510779-e1517847836696.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/02/usatsi_10510779-e1517847836696.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 top free agent tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/"
								title="2018 top free agent tracker"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/"
			title="2018 top free agent tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				22hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/free-agents/" class="category" itemprop="articleSection">Free Agents</a>						<span class="block__time block__time--mobile">22hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/"
						title="2018 top free agent tracker"
						itemprop="url" 						>
							2018 top free agent tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 13, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Below are the most fantasy-relevant 2018 NFL free agents who are most likely to turn in in relevant fantasy football production. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/"
						title="Free agency brings fantasy football hope to Cleveland"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_10395764-e1520892410380.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_10395764-e1520892410380.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Free agency brings fantasy football hope to Cleveland" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/"
								title="Free agency brings fantasy football hope to Cleveland"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/"
			title="Free agency brings fantasy football hope to Cleveland"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>17</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/12/fantasy-football-free-agency-cleveland-browns-tyrod-taylor-jarvis-landry/"
						title="Free agency brings fantasy football hope to Cleveland"
						itemprop="url" 						>
							Free agency brings fantasy football hope to Cleveland					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 12, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Cleveland retooled its offense enough to become competitive and offer fantasy gamers more options in 2018. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/05/nfl-combine-winner-and-losers-quarterbacks/"
						title="NFL combine winners and losers: Quarterbacks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_10671322-e1520273839618.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_10671322-e1520273839618.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NFL combine winners and losers: Quarterbacks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/05/nfl-combine-winner-and-losers-quarterbacks/"
								title="NFL combine winners and losers: Quarterbacks"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/05/nfl-combine-winner-and-losers-quarterbacks/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/05/nfl-combine-winner-and-losers-quarterbacks/"
			title="NFL combine winners and losers: Quarterbacks"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>36</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/05/nfl-combine-winner-and-losers-quarterbacks/"
						title="NFL combine winners and losers: Quarterbacks"
						itemprop="url" 						>
							NFL combine winners and losers: Quarterbacks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>This will be a QB-heavy draft with four quarterbacks expected to go in the first round if not the first ten picks. Measurables are important (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-running-backs/"
						title="NFL combine winners and losers: Running Backs"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106696841-e1520287959789.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106696841-e1520287959789.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NFL combine winners and losers: Running Backs" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-running-backs/"
								title="NFL combine winners and losers: Running Backs"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-running-backs/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-running-backs/"
			title="NFL combine winners and losers: Running Backs"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>28</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-running-backs/"
						title="NFL combine winners and losers: Running Backs"
						itemprop="url" 						>
							NFL combine winners and losers: Running Backs					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>The college ranks are providing better quality rookie running backs in recent years and 2018 should maintain that trend. Todd Gurley, Melvin (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-wide-receivers/"
						title="NFL combine winners and losers: Wide Receivers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106717641-e1520288323265.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106717641-e1520288323265.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NFL combine winners and losers: Wide Receivers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-wide-receivers/"
								title="NFL combine winners and losers: Wide Receivers"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-wide-receivers/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-wide-receivers/"
			title="NFL combine winners and losers: Wide Receivers"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>8</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-wide-receivers/"
						title="NFL combine winners and losers: Wide Receivers"
						itemprop="url" 						>
							NFL combine winners and losers: Wide Receivers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>The rookie wideouts have been mostly disappointing for the last several years and measurable characteristics can be overvalued. But (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-tight-ends/"
						title="NFL combine winners and losers: Tight Ends"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106689011.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106689011.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NFL combine winners and losers: Tight Ends" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-tight-ends/"
								title="NFL combine winners and losers: Tight Ends"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-tight-ends/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-tight-ends/"
			title="NFL combine winners and losers: Tight Ends"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/05/nfl-combine-winners-and-losers-tight-ends/"
						title="NFL combine winners and losers: Tight Ends"
						itemprop="url" 						>
							NFL combine winners and losers: Tight Ends					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2017 was a big year for tight ends with 17 drafted and a highly unusual three players made the first round &#8211; O.J. Howard (1.19), (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-quarterbacks/"
						title="2018 NFL combine results: Quarterbacks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106717621-e1520132046644.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106717621-e1520132046644.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 NFL combine results: Quarterbacks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-quarterbacks/"
								title="2018 NFL combine results: Quarterbacks"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/03/2018-nfl-combine-results-quarterbacks/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-quarterbacks/"
			title="2018 NFL combine results: Quarterbacks"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>6</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/nfl-combine/" class="category" itemprop="articleSection">NFL Combine</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-quarterbacks/"
						title="2018 NFL combine results: Quarterbacks"
						itemprop="url" 						>
							2018 NFL combine results: Quarterbacks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 3, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2018 NFL Combine results for the quarterbacks hoping to be on your fantasy football roster this season. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/"
						title="2018 NFL combine results: Wide Receivers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106733191-e1520132659339.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106733191-e1520132659339.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 NFL combine results: Wide Receivers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/"
								title="2018 NFL combine results: Wide Receivers"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/"
			title="2018 NFL combine results: Wide Receivers"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>4</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/nfl-combine/" class="category" itemprop="articleSection">NFL Combine</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/"
						title="2018 NFL combine results: Wide Receivers"
						itemprop="url" 						>
							2018 NFL combine results: Wide Receivers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 3, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2018 NFL Combine results for the wide receivers hoping to be on your fantasy football roster this season. </p>

				
				
			</div>
		</article>
	</div>
<a href="http://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
			<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>		</div>

		
		<div class="widget widget--login widget--box" id="login_widget-3"><div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget_usat_sidebar_top_posts_widget" id="usat_sidebar_top_posts_widget-2">		<div class="col1 right" id="sticky-sidebar">
				<div class="heading-small">
		<h2>Popular <span>Now</span></h2>
	</div>
	
					<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/03/usatsi_10529117-e1520976989315.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/" title="2018 player movement tracker" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_10529117-e1520976989315.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 player movement tracker" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				18hr			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/" title="2018 player movement tracker" itemprop="url" >2018 player movement tracker</a></p>
				<p class="widget-date">March 13, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/02/usatsi_10510779-e1517847836696.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/" title="2018 top free agent tracker" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/02/usatsi_10510779-e1517847836696.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 top free agent tracker" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				22hr			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/" title="2018 top free agent tracker" itemprop="url" >2018 top free agent tracker</a></p>
				<p class="widget-date">March 13, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106698301-e1520090706117.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/02/2018-nfl-combine-results-running-backs/" title="2018 NFL combine results: Running Backs" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106698301-e1520090706117.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 NFL combine results: Running Backs" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2w			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/02/2018-nfl-combine-results-running-backs/" title="2018 NFL combine results: Running Backs" itemprop="url" >2018 NFL combine results: Running Backs</a></p>
				<p class="widget-date">March 2, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106733191-e1520132659339.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/" title="2018 NFL combine results: Wide Receivers" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106733191-e1520132659339.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 NFL combine results: Wide Receivers" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2w			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/" title="2018 NFL combine results: Wide Receivers" itemprop="url" >2018 NFL combine results: Wide Receivers</a></p>
				<p class="widget-date">March 3, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
		
		</div>
		</div><div class="widget widget--links widget--box" id="links_widget-8"><div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="http://www.thehuddle.com/2018-nfl-depth-charts.php">2018 fantasy depth charts</a></li>
<li id="menu-item-434831" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434831"><a href="http://thehuddle.com/2018/03/13/2018-top-free-agent-tracker/">2018 top free agent tracker</a></li>
<li id="menu-item-434830" class="menu-item menu-item-type-post_type menu-item-object-post current-menu-item menu-item-434830"><a href="http://thehuddle.com/2018/03/13/2018-player-movement-tracker/">2018 player movement tracker</a></li>
<li id="menu-item-434533" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434533"><a href="http://thehuddle.com/2018/02/20/2018-coaching-change-tracker/">2018 coaching change tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7"><div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="http://www.thehuddle.com/2018-nfl-depth-charts.php">2018 fantasy depth charts</a></li>
<li id="menu-item-424716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424716"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-grid.php">2017 NFL Schedule Grid</a></li>
<li id="menu-item-424717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424717"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-wk-grid.php">2017 NFL Schedule Weekly Grid</a></li>
<li id="menu-item-424718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424718"><a href="http://www.thehuddle.com/2017/nfl/nfl-schedule-wk-txt.php">2017 NFL Full Weekly Schedule</a></li>
<li id="menu-item-428116" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428116"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-round/">2017 NFL Draft by round</a></li>
<li id="menu-item-428117" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428117"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-team/">2017 NFL Draft by team</a></li>
<li id="menu-item-428118" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428118"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-position/">2017 NFL Draft by position</a></li>
<li id="menu-item-434832" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434832"><a href="http://thehuddle.com/2018/02/06/2018-nfl-important-dates/">2018 NFL important dates</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-4"><div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="http://www.thehuddle.com/stats/2017/plays_std.php">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="http://www.thehuddle.com/stats/2017/plays_weekly.php">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="http://www.thehuddle.com/stats/2017/gamescan.php">Weekly Fantasy Box Scores</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="http://www.thehuddle.com/stats/2017/tpr.php">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="http://www.thehuddle.com/stats/2017/tpm.php">Team Position Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="http://www.thehuddle.com/stats/2017/gsm.php">Game Stats Matchups</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="http://thehuddle.com/myHuddle/sos.php">Strength of Schedule Tool</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget--forum widget--box" id="forum_widget-3"><div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/" class="" rel="" target=""><img width="1000" height="1000" src="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg 1000w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=150&amp;h=150 150w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300&amp;h=300 300w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=768&amp;h=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="429990" data-permalink="http://thehuddle.com/blitz/" data-orig-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" data-orig-size="1000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Blitz" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=1000" /></a></div>
		<div class="widget sidebar-ad bottom">
			<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250", slotName: "/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", sizes : [[300,250],[300,600]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_bottom_300x250"] = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250").addService(googletag.pubads().setTargeting('kw',["2018 NFL free agents","free agents","nfl draft","NFL player movement","NFL trades","Huddle Staff","Free Agents","Player Movement"]).setTargeting('category',["Free Agents","Player Movement"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_2a"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>		</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-424341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424341"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424340"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424342"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="The Huddle">
				<a class="mobile-nav__breadcrumb" href="http://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li class="mobile-nav__item mobile-nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li class="mobile-nav__item mobile-nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="/2018-nfl-depth-charts.php">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-424341" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>
<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Create an Account
		</a>
		<a href="http://thehuddle.com/login.php" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201811y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVy0EOQDAQheELqVGCWIizUBNabZVRHB+xYSOx/d/7YHNMjHZBu4AiaHGVAt0eKgrgMRnPnPadtARaDkgwefTY17bVOH+cxWjMmdiN1KUboE06/INe4YSVKXnKC57HSRapAyLtR9U='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"0"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"","maxDistance":"250","medAdHeight":"0","maxDistanceMed":"0","largeAdHeight":"0","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var huddleUser = {"nameAPI":"http:\/\/thehuddle.com\/api\/get_user_name.php","cookie":"huddle-auth"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJydks1ygzAMhF+oxkk6aXrp9FkE1iQC/1DLhtKnr8iU9EBKITdGeD9r16v7VlXBJ/RJpws6ZN1RqzNDCgYG1dp8Js+aE1XNoMhb8qg6MhhY1/fnRc1P+h+uhT6ir3BkWCp1/ZExDkUVQkO4FeCA/FZNQrCUncJPOc4U/Gxtl2/uD2rk1FecAg92ENtLPiehhS+5NoBRu+I0An58cvAQC7e49p+M22CN54nSA0NJozwnsqveaC710NEZkqT1mJ6lH6UYf0gMUUK3q8oxF6+tyKSUf+qSjbHXsqyr5H1tZoxKgluoFxhpgpJgZE1OGOVLhQ5jlLj4d7aRkCJUzfjQ7+5tfzzsjvuX19Nz/Q0B8nvW'></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-4','user_id':'0','post':'434791','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-4&user_id=0&post=434791&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6KzExUnBFTVRrRUw3dWtuUjd4VEZBLS9OSXhRcG1wM2suXUxDZVlLNkt5MXIwMGdQWytMbFR1aDN3SGRPazk2TC1aUkdHN1BMek0lP05OZmQxc1A9eXEzY3htWUssJkhxWCxvYWJMTGh6Yk9lUFM3OFpRRU5iUzddU1A9PURn'}]);
_stq.push([ 'clickTrackerInit', '114275906', '434791' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated in 0.221 seconds
	113479 bytes batcached for 300 seconds
-->
