<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="The third day of the 2018 #NFLDraft brings an array of intriguing rookies to #fantasyfootball." /><meta name="news_keywords" content="%tags%,%cats%" />
<meta name="keywords" content="2018 nfl draft, antonio callaway, chris herndon, ian thomas, keke coutee, kyle lauletta, nfl draft, nyheim hines,nfl draft, rookie analysis" />
<title>2018 NFL Draft: Notable Day 3 fantasy football picks | The Huddle</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1524958177&amp;back=http%3A%2F%2Fthehuddle.com%2F2018%2F04%2F28%2F2018-nfl-draft-day-3-fantasy-football%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Feed" href="http://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Comments Feed" href="http://thehuddle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; 2018 NFL Draft: Notable Day 3 fantasy football picks Comments Feed" href="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJylkNFSAyEMRX9IRDttHR8cX/0Dn7MQ2bSBMAvbnf172TKtVis64wuTC/fkhugpKiMhY8jajyry6CgkPUUjXiVPjPMXdWtSutHXMaY9Jr3DHMHs1VG17EYGLPc+Ql4cHi0BMvpia2E+bk/UUvYlqxlTx++6OGBKqpyeRq9yX4J+Gc8vo9R/6GK8vKko6SCZCp3OxbeeNUofKOoxQRYL8zkkFWY/KwpMAdWBLErNuvbwp84M04DB4OnxFRJ09A9Uv4zWMjZXTNZhLkOLIWBV9/FZtGCHolgMZJJwIdQbAw0tdMCOxZXSHXf2IX/6br/WjqUDXgzP/ul+s1o/bB/vVpvdO4t8JXg=?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFjt0KwjAMRl/IrptMmBfis2RtnKnrj027MZ/eDvRCHAqBQHJy8sk5CHJqzBpZmlL3jHF5tcrwTv4ChKUhQsLKknvDyruELq2s9T2NKDJjhKHMiujiN7jgOVlkLtDG9jMSuYlw/osZTAHUTURkenxZ0xXLPzlRkJkheQ2LGGGO6BSurp60xigsuBIpluuzPTWHfVt3x7przBPGh3M8'></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=4.9.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:thehuddle","priority_asset":"","blogname":"thehuddle","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"435559","headline":"2018 NFL Draft: Notable Day 3 fantasy football picks","byline":"Cory Bonini","taxonomykeywords":"2018 NFL Draft, Antonio Callaway, Chris Herndon, Ian Thomas, Keke Coutee, Kyle Lauletta, nfl draft, Nyheim Hines"};
/* ]]> */
</script>
<script type='text/javascript'>
					utag_data.clickPage = sessionStorage.getItem( "clickPage" );
					sessionStorage.setItem( "clickPage", window.location.href );
					
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/thehuddle3/prod/utag.js?ver=4.9.5'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2r9jaaf' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F04%2F28%2F2018-nfl-draft-day-3-fantasy-football%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F04%2F28%2F2018-nfl-draft-day-3-fantasy-football%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="2018 NFL Draft: Notable Day 3 fantasy football picks" />
<meta property="og:url" content="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/" />
<meta property="og:description" content="The third day of the 2018 #NFLDraft brings an array of intriguing rookies to #fantasyfootball." />
<meta property="article:published_time" content="2018-04-28T20:15:23+00:00" />
<meta property="article:modified_time" content="2018-04-28T20:17:35+00:00" />
<meta property="og:site_name" content="The Huddle" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:text:title" content="2018 NFL Draft: Notable Day 3 fantasy football picks" />
<meta name="twitter:image:src" content="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="http://thehuddle.com/osd.xml" title="The Huddle" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Huddle" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Fantasy Football Cheat Sheets, Rankings, Sleepers &amp; Award Winning Draft Advice" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://thehuddle.com/feed/;icon-uri=http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["2018 NFL Draft","Antonio Callaway","Chris Herndon","Ian Thomas","Keke Coutee","Kyle Lauletta","nfl draft","Nyheim Hines","Cory Bonini","NFL Draft","Rookie Analysis"],"category":"NFL Draft","referrer":"","isMobile":"0"};
googletag_cmd_push(function() {
window.lawrence_dfp_desktop_skin = googletag.defineSlot("/7103/SMG_TheHuddle/skin/sports/fantasy/football.general", [1,1], "acm-ad-tag-lawrence_dfp_desktop_skin").addService(googletag.pubads().setTargeting('kw',["2018 NFL Draft","Antonio Callaway","Chris Herndon","Ian Thomas","Keke Coutee","Kyle Lauletta","nfl draft","Nyheim Hines","Cory Bonini","NFL Draft","Rookie Analysis"]).setTargeting('category',["NFL Draft","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["skin"]);window.lawrence_dfp_desktop_top = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.main", ['fluid',[728,90],[970,66],[970,250]], "acm-ad-tag-lawrence_dfp_desktop_top").addService(googletag.pubads().setTargeting('kw',["2018 NFL Draft","Antonio Callaway","Chris Herndon","Ian Thomas","Keke Coutee","Kyle Lauletta","nfl draft","Nyheim Hines","Cory Bonini","NFL Draft","Rookie Analysis"]).setTargeting('category',["NFL Draft","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);window.lawrence_dfp_desktop_top_300x250 = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_1a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_top_300x250").addService(googletag.pubads().setTargeting('kw',["2018 NFL Draft","Antonio Callaway","Chris Herndon","Ian Thomas","Keke Coutee","Kyle Lauletta","nfl draft","Nyheim Hines","Cory Bonini","NFL Draft","Rookie Analysis"]).setTargeting('category',["NFL Draft","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_1a"]);window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();

googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

bidManager.initialize();
});
</script>
<link rel="amphtml" href="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-435559 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_outstream", slotName: "/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", sizes : [4,1] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_outstream"] = googletag.defineSlot("/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", [4,1], "acm-ad-tag-lawrence_dfp_desktop_outstream").addService(googletag.pubads().setTargeting('kw',["2018 NFL Draft","Antonio Callaway","Chris Herndon","Ian Thomas","Keke Coutee","Kyle Lauletta","nfl draft","Nyheim Hines","Cory Bonini","NFL Draft","Rookie Analysis"]).setTargeting('category',["NFL Draft","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["outstream"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_outstream' );
												bidManager.requestBid( 'lawrence_dfp_desktop_outstream' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_outstream' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
	
<div id="wrapper">

	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="http://thehuddle.com"
				title="The Huddle"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="The Huddle"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Huddle" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-428297" class="nav__item nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li id="menu-item-428295" class="nav__item nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li id="menu-item-428296" class="nav__item nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-424408" class="nav__item nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li id="menu-item-429328" class="nav__item nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li id="menu-item-424410" class="nav__item nav__item--depth-charts"><a href="/2018-nfl-depth-charts.php">Depth Charts</a></li>
<li id="menu-item-424627" class="nav__item nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li id="menu-item-424411" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-424412" class="nav__item nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li id="menu-item-424413" class="nav__item nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li id="menu-item-424995" class="nav__item nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-435559" class="post-435559 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl-draft category-rookie-analysis tag-2018-nfl-draft tag-antonio-callaway tag-chris-herndon tag-ian-thomas tag-keke-coutee tag-kyle-lauletta tag-nfl-draft tag-nyheim-hines article--no-image" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title article__title--no-image ">
	<h1 class="article__headline">2018 NFL Draft: Notable Day 3 fantasy football picks</h1>

	</div>
<h1 class="article__headline article__headline--mobile">2018 NFL Draft: Notable Day 3 fantasy football picks</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://thehuddle.com/category/rookie-analysis/" class="" itemprop="articleSection">Rookie Analysis</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">2018 NFL Draft: Notable Day 3 fantasy football picks</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a> 
		<span class="post-date updated">April 28, 2018</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
					Follow					@Cory_Bonini				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					
				</header>

				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">19</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>		| April 28, 2018		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
		Follow @Cory_Bonini	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p>The final day of the NFL draft will bring plenty of unfamiliar names to mix for casual fantasy gamers. We&#8217;ll provide insight on the guys worthy knowing.</p>
<h3>Round 4</h3>
<div id="attachment_435560" class="wp-caption aligncenter"><img data-attachment-id="435560" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-indiana-at-illinois/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&#038;h=370" data-orig-size="2977,1102" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;3.2&quot;,&quot;credit&quot;:&quot;Mike Granse-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark III&quot;,&quot;caption&quot;:&quot;Nov 11, 2017; Champaign, IL, USA; Illinois Fighting Illini defensive back Patrick Nelson (21) tackles Indiana Hoosiers tight end Ian Thomas (80) during the first quarter at Memorial Stadium. Mandatory Credit: Mike Granse-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1510398444&quot;,&quot;copyright&quot;:&quot;Mike Granse&quot;,&quot;focal_length&quot;:&quot;300&quot;,&quot;iso&quot;:&quot;500&quot;,&quot;shutter_speed&quot;:&quot;0.0004&quot;,&quot;title&quot;:&quot;NCAA Football: Indiana at Illinois&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Indiana at Illinois" data-image-description="&lt;p&gt;Nov 11, 2017; Champaign, IL, USA; Illinois Fighting Illini defensive back Patrick Nelson (21) tackles Indiana Hoosiers tight end Ian Thomas (80) during the first quarter at Memorial Stadium. Mandatory Credit: Mike Granse-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&#038;h=370?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&#038;h=370?w=1000" class="size-full wp-image-435560" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="370" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&#038;h=370"><noscript><img data-attachment-id="435560" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-indiana-at-illinois/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&#038;h=370" data-orig-size="2977,1102" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;3.2&quot;,&quot;credit&quot;:&quot;Mike Granse-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark III&quot;,&quot;caption&quot;:&quot;Nov 11, 2017; Champaign, IL, USA; Illinois Fighting Illini defensive back Patrick Nelson (21) tackles Indiana Hoosiers tight end Ian Thomas (80) during the first quarter at Memorial Stadium. Mandatory Credit: Mike Granse-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1510398444&quot;,&quot;copyright&quot;:&quot;Mike Granse&quot;,&quot;focal_length&quot;:&quot;300&quot;,&quot;iso&quot;:&quot;500&quot;,&quot;shutter_speed&quot;:&quot;0.0004&quot;,&quot;title&quot;:&quot;NCAA Football: Indiana at Illinois&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Indiana at Illinois" data-image-description="&lt;p&gt;Nov 11, 2017; Champaign, IL, USA; Illinois Fighting Illini defensive back Patrick Nelson (21) tackles Indiana Hoosiers tight end Ian Thomas (80) during the first quarter at Memorial Stadium. Mandatory Credit: Mike Granse-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&#038;h=370?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&#038;h=370?w=1000" class="size-full wp-image-435560" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&#038;h=370" alt="" width="1000" height="370" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1000&amp;h=370 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=2000&amp;h=740 2000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=150&amp;h=56 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=300&amp;h=111 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=768&amp;h=284 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10403661-e1524934210122.jpg?w=1024&amp;h=379 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Mike Granse, USA TODAY Sports)</p></div>
<p><strong>1) TE Ian Thomas, Carolina Panthers</strong></p>
<p>Gamers are unlikely to utilize Thomas without another major injury to Greg Olsen. Thomas is athletic and raw. His future is exciting, so tuck away the name for a few years from now.</p>
<p><strong><aside class="related shortcode shortcode--related">
				<h2 class="related__header">Related</h2><a
			class="block block--related"
			href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/"
			data-track="thehuddle-in-article-related-curated"
			
		><h2 class="block__title">2018 NFL Draft: Fantasy football recap of Round 1</h2></a></aside></strong></p>
<p><strong>3) WR Keke Coutee, Houston Texans</strong></p>
<p>It would be a surprise if Coutee &#8212; strictly a slot receiver &#8212; contributed in 2018. It would require Braxton Miller to falter, in conjunction with several other factors, to make Coutee a regular option in the passing game.</p>
<div id="attachment_435561" class="wp-caption aligncenter"><img data-attachment-id="435561" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-sun-bowl-arizona-state-vs-north-carolina-state/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&#038;h=442" data-orig-size="2518,1114" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;3.5&quot;,&quot;credit&quot;:&quot;Ivan Pierre Aguirre-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X&quot;,&quot;caption&quot;:&quot;Dec 29, 2017; El Paso, TX, United States; North Carolina State Wolfpack running back Nyheim Hines (7) runs the ball against the Arizona State Sun Devils defense in the 2017 Sun Bowl at Sun Bowl Stadium. Mandatory Credit: Ivan Pierre Aguirre-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1514574088&quot;,&quot;copyright&quot;:&quot;Ivan Pierre Aguirre&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;100&quot;,&quot;shutter_speed&quot;:&quot;0.0003125&quot;,&quot;title&quot;:&quot;NCAA Football: Sun Bowl-Arizona State vs North Carolina State&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Sun Bowl-Arizona State vs North Carolina State" data-image-description="&lt;p&gt;Dec 29, 2017; El Paso, TX, United States; North Carolina State Wolfpack running back Nyheim Hines (7) runs the ball against the Arizona State Sun Devils defense in the 2017 Sun Bowl at Sun Bowl Stadium. Mandatory Credit: Ivan Pierre Aguirre-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&#038;h=442?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&#038;h=442?w=1000" class="size-full wp-image-435561" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="442" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&#038;h=442"><noscript><img data-attachment-id="435561" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-sun-bowl-arizona-state-vs-north-carolina-state/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&#038;h=442" data-orig-size="2518,1114" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;3.5&quot;,&quot;credit&quot;:&quot;Ivan Pierre Aguirre-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X&quot;,&quot;caption&quot;:&quot;Dec 29, 2017; El Paso, TX, United States; North Carolina State Wolfpack running back Nyheim Hines (7) runs the ball against the Arizona State Sun Devils defense in the 2017 Sun Bowl at Sun Bowl Stadium. Mandatory Credit: Ivan Pierre Aguirre-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1514574088&quot;,&quot;copyright&quot;:&quot;Ivan Pierre Aguirre&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;100&quot;,&quot;shutter_speed&quot;:&quot;0.0003125&quot;,&quot;title&quot;:&quot;NCAA Football: Sun Bowl-Arizona State vs North Carolina State&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Sun Bowl-Arizona State vs North Carolina State" data-image-description="&lt;p&gt;Dec 29, 2017; El Paso, TX, United States; North Carolina State Wolfpack running back Nyheim Hines (7) runs the ball against the Arizona State Sun Devils defense in the 2017 Sun Bowl at Sun Bowl Stadium. Mandatory Credit: Ivan Pierre Aguirre-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&#038;h=442?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&#038;h=442?w=1000" class="size-full wp-image-435561" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&#038;h=442" alt="" width="1000" height="442" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1000&amp;h=442 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1998&amp;h=884 1998w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=150&amp;h=66 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=300&amp;h=133 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=768&amp;h=340 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10504446-e1524934308518.jpg?w=1024&amp;h=453 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Ivan Pierre Aguirre, USA TODAY Sports)</p></div>
<p><strong>4) RB Nyheim Hines, Indianapolis Colts</strong></p>
<p>Now this pick has some juice. Hines is a change-of-pace, out-in-space back. He nicely complements Marlon Mack and should provide an immediate spark to the offense. Fantasy owners will be all over Hines in the middle of 2018 drafts &#8212; and rightfully so.</p>
<p><strong>5) WR Antonio Callaway, Cleveland Browns</strong></p>
<p>General manager John Dorsey was not afraid of character concerns when he drafted Marcus Peters and Tyreek Hill in KC. Josh Gordon has remained on the roster through all of his trials and tribulations. Callaway didn&#8217;t play in 2017 and has been problematic dating back to high school. He admitted to failing a marijuana test at the scouting combine and will need to be closely managed in the pros. Extremely gifted, he is a worthwhile gamble for Cleveland&#8217;s future receiving corps, but he has little chance of finding playing time in 2018.</p>
<p><strong>7) TE Chris Herndon, New York Jets</strong></p>
<p>This is an intriguing pick. The Jets need help at the position, and Herndon is one of the most underrated players in the draft. He shared work with David Njoku prior to 2017 and can do so much more than the one-dimensional Brown. It may take a year or two before it shows on the field, but Herndon is the most talented tight end on this roster. Watch his summer performance to gauge if he&#8217;s worthy of a flier pick as a rookie.</p>
<div id="attachment_435562" class="wp-caption aligncenter"><img data-attachment-id="435562" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-richmond-at-james-madison/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&#038;h=666" data-orig-size="1106,737" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4.5&quot;,&quot;credit&quot;:&quot;Brad Mills-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D3S&quot;,&quot;caption&quot;:&quot;Oct 24, 2015; Harrisonburg, VA, USA; Richmond Spiders quarterback Kyle Lauletta (5) rolls out against the James Madison Dukes during the first half at Bridgeforth Stadium. Mandatory Credit: Brad Mills-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1445722457&quot;,&quot;copyright&quot;:&quot;Brad Mills&quot;,&quot;focal_length&quot;:&quot;240&quot;,&quot;iso&quot;:&quot;2000&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;NCAA Football: Richmond at James Madison&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Richmond at James Madison" data-image-description="&lt;p&gt;Oct 24, 2015; Harrisonburg, VA, USA; Richmond Spiders quarterback Kyle Lauletta (5) rolls out against the James Madison Dukes during the first half at Bridgeforth Stadium. Mandatory Credit: Brad Mills-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&#038;h=666?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&#038;h=666?w=1000" class="size-full wp-image-435562" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="666" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&#038;h=666"><noscript><img data-attachment-id="435562" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-richmond-at-james-madison/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&#038;h=666" data-orig-size="1106,737" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4.5&quot;,&quot;credit&quot;:&quot;Brad Mills-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D3S&quot;,&quot;caption&quot;:&quot;Oct 24, 2015; Harrisonburg, VA, USA; Richmond Spiders quarterback Kyle Lauletta (5) rolls out against the James Madison Dukes during the first half at Bridgeforth Stadium. Mandatory Credit: Brad Mills-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1445722457&quot;,&quot;copyright&quot;:&quot;Brad Mills&quot;,&quot;focal_length&quot;:&quot;240&quot;,&quot;iso&quot;:&quot;2000&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;NCAA Football: Richmond at James Madison&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Richmond at James Madison" data-image-description="&lt;p&gt;Oct 24, 2015; Harrisonburg, VA, USA; Richmond Spiders quarterback Kyle Lauletta (5) rolls out against the James Madison Dukes during the first half at Bridgeforth Stadium. Mandatory Credit: Brad Mills-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&#038;h=666?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&#038;h=666?w=1000" class="size-full wp-image-435562" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&#038;h=666" alt="" width="1000" height="666" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1000&amp;h=666 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=150&amp;h=100 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=300&amp;h=200 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=768&amp;h=512 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg?w=1024&amp;h=682 1024w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8881747-e1524934484491.jpg 1106w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Brad Mills, USA TODAY Sports)</p></div>
<p><strong>8) QB Kyle Lauletta, New York Giants</strong></p>
<p>The Richmond product will be groomed behind Eli Manning and probably starts his pro career on the scout team. He&#8217;s a highly accurate, quick-release passer whose needle points due north. Long term, Lauletta has a shot at being a fantasy star.</p>
<p><strong>12) RB Mark Walton, Cincinnati Bengals</strong></p>
<p>The former Miami Hurricane is a quick-twitch rusher and a change-of-pace option from the more powerful Joe Mixon. Injuries are a concern (missed seven games in 2017), and he&#8217;ll offer only limited contributions, but Walton can make a big boom with a little spark. He&#8217;s only useful in 2018 if an injury knocks out Mixon or Gio Bernard.</p>
<p><strong><aside class="related shortcode shortcode--related">
				<h2 class="related__header">Related</h2><a
			class="block block--related"
			href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/"
			data-track="thehuddle-in-article-related-curated"
			
		><h2 class="block__title">2018 NFL Draft: Fantasy football recap of Rounds 2-3</h2></a></aside></strong></p>
<div id="attachment_435566" class="wp-caption aligncenter"><img data-attachment-id="435566" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-rutgers-at-penn-state/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&#038;h=611" data-orig-size="1387,847" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Matthew O&#039;Haren-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark IV&quot;,&quot;caption&quot;:&quot;Nov 11, 2017; University Park, PA, USA; Penn State Nittany Lions wide receiver DaeSean Hamilton (5) catches the ball for a touchdown during the second quarter against the Rutgers Scarlet Knights at Beaver Stadium. Penn State defeated Rutgers 35-6. Mandatory Credit: Matthew O&#039;Haren-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1510405933&quot;,&quot;copyright&quot;:&quot;Matthew OHaren&quot;,&quot;focal_length&quot;:&quot;120&quot;,&quot;iso&quot;:&quot;500&quot;,&quot;shutter_speed&quot;:&quot;0.0003125&quot;,&quot;title&quot;:&quot;NCAA Football: Rutgers at Penn State&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="NCAA Football: Rutgers at Penn State" data-image-description="&lt;p&gt;Nov 11, 2017; University Park, PA, USA; Penn State Nittany Lions wide receiver DaeSean Hamilton (5) catches the ball for a touchdown during the second quarter against the Rutgers Scarlet Knights at Beaver Stadium. Penn State defeated Rutgers 35-6. Mandatory Credit: Matthew O&#8217;Haren-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&#038;h=611?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&#038;h=611?w=1000" class="size-full wp-image-435566" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="611" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&#038;h=611"><noscript><img data-attachment-id="435566" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-rutgers-at-penn-state/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&#038;h=611" data-orig-size="1387,847" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Matthew O&#039;Haren-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark IV&quot;,&quot;caption&quot;:&quot;Nov 11, 2017; University Park, PA, USA; Penn State Nittany Lions wide receiver DaeSean Hamilton (5) catches the ball for a touchdown during the second quarter against the Rutgers Scarlet Knights at Beaver Stadium. Penn State defeated Rutgers 35-6. Mandatory Credit: Matthew O&#039;Haren-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1510405933&quot;,&quot;copyright&quot;:&quot;Matthew OHaren&quot;,&quot;focal_length&quot;:&quot;120&quot;,&quot;iso&quot;:&quot;500&quot;,&quot;shutter_speed&quot;:&quot;0.0003125&quot;,&quot;title&quot;:&quot;NCAA Football: Rutgers at Penn State&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="NCAA Football: Rutgers at Penn State" data-image-description="&lt;p&gt;Nov 11, 2017; University Park, PA, USA; Penn State Nittany Lions wide receiver DaeSean Hamilton (5) catches the ball for a touchdown during the second quarter against the Rutgers Scarlet Knights at Beaver Stadium. Penn State defeated Rutgers 35-6. Mandatory Credit: Matthew O&#8217;Haren-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&#038;h=611?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&#038;h=611?w=1000" class="size-full wp-image-435566" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&#038;h=611" alt="" width="1000" height="611" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1000&amp;h=611 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=150&amp;h=92 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=300&amp;h=183 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=768&amp;h=469 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg?w=1024&amp;h=625 1024w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10418011-e1524936660380.jpg 1387w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Matthew O&#8217;Haren, USA TODAY Sports)</p></div>
<p><strong>13) WR DaeSean Hamilton, Denver Broncos</strong></p>
<p>This selection is forward-looking, particularly if the Broncos opt to move on from Emmanuel Sanders. The selection of Courtland Sutton makes Hamilton a complementary skill set and gives Case Keenum a chance to attack the field in multiple ways. Beyond this season, Hamilton is a high-upside option because of quick feet, precise routes, and sticky hands.</p>
<p><strong>20) TE Will Dissly, Seattle Seahawks</strong></p>
<p>The Washington product is a pure-play blocker first but also a capable receiver. He has no immediate fantasy football value without outright winning the starting job in the summer, and even then we&#8217;re talking a low-end TE2.</p>
<p><strong>23) TE Durham Smythe, Miami Dolphins</strong></p>
<p>Nothing to see here in fantasy &#8230; Smythe is the blocking counterpart to the Mike Gesicki selection.</p>
<p><strong>26) RB Ito Smith, Atlanta Falcons</strong></p>
<p>The 5-foot-9, 195-pounder from Southern Miss is a better receiver than runner and may be destined for a career on the special teams units. His slight build isn&#8217;t offset by blazing speed, and he is no better than a zone-blocking gadget player.</p>
<div id="attachment_435478" class="wp-caption aligncenter"><img data-attachment-id="435478" data-permalink="http://thehuddle.com/2018/04/24/nfl-draft-rb-kalen-ballage-arizona-state/ncaa-football-colorado-at-arizona-state/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&#038;h=525" data-orig-size="2621,1375" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Joe Camporeale-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D4&quot;,&quot;caption&quot;:&quot;Nov 4, 2017; Tempe, AZ, USA; Arizona State Sun Devils running back Kalen Ballage (7) runs with the ball against the Colorado Buffaloes during the second half at Sun Devil Stadium. Mandatory Credit: Joe Camporeale-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1509852616&quot;,&quot;copyright&quot;:&quot;Joe Camporeale&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;2500&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;NCAA Football: Colorado at Arizona State&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Colorado at Arizona State" data-image-description="&lt;p&gt;Nov 4, 2017; Tempe, AZ, USA; Arizona State Sun Devils running back Kalen Ballage (7) runs with the ball against the Colorado Buffaloes during the second half at Sun Devil Stadium. Mandatory Credit: Joe Camporeale-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&#038;h=525?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&#038;h=525?w=1000" class="size-full wp-image-435478" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="525" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&#038;h=525"><noscript><img data-attachment-id="435478" data-permalink="http://thehuddle.com/2018/04/24/nfl-draft-rb-kalen-ballage-arizona-state/ncaa-football-colorado-at-arizona-state/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&#038;h=525" data-orig-size="2621,1375" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Joe Camporeale-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D4&quot;,&quot;caption&quot;:&quot;Nov 4, 2017; Tempe, AZ, USA; Arizona State Sun Devils running back Kalen Ballage (7) runs with the ball against the Colorado Buffaloes during the second half at Sun Devil Stadium. Mandatory Credit: Joe Camporeale-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1509852616&quot;,&quot;copyright&quot;:&quot;Joe Camporeale&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;2500&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;NCAA Football: Colorado at Arizona State&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Colorado at Arizona State" data-image-description="&lt;p&gt;Nov 4, 2017; Tempe, AZ, USA; Arizona State Sun Devils running back Kalen Ballage (7) runs with the ball against the Colorado Buffaloes during the second half at Sun Devil Stadium. Mandatory Credit: Joe Camporeale-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&#038;h=525?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&#038;h=525?w=1000" class="size-full wp-image-435478" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&#038;h=525" alt="" width="1000" height="525" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1000&amp;h=525 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=2000&amp;h=1050 2000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=150&amp;h=79 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=300&amp;h=157 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=768&amp;h=403 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=1024&amp;h=537 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Joe Camporeale, USA TODAY Sports)</p></div>
<p><strong>31) RB Kalen Ballage, Miami Dolphins</strong></p>
<p>Ballage most directly threatens Frank Gore&#8217;s touches. If the elder statesman falters, Ballage will be waiting for his chance to shine. Kenyan Drake wasn&#8217;t a full-time player in college and will get a helping hand from Gore. Ballage and Drake will make for a fine one-two punch in the future, but gamers should treat this situation with a hint of caution in 2018 drafts.</p>
<p><strong>32) WR Jaleel Scott, Baltimore Ravens</strong></p>
<p>Standing 6-foot-5, 218 pounds, Scott brings great size to the revamped Ravens. He could snag a TD or three in 2018, but playing him will be a pure guessing game. Make a mental note of his name for the future and avoid Scott in 2018 drafts.</p>
<p><strong>33) WR J&#8217;Mon Moore, Green Bay Packers</strong></p>
<p>If used properly, Moore could develop into a steal in Round 4. He&#8217;s never going to be the guy catching a ton of balls over the middle of the field, nor will he be a WR1. Moore struggles with securing the ball in traffic, but he shows little issue hauling in tracked balls on the outside. All told, he has value in 2019 and beyond when Randall Cobb is gone and more targets open up, but they are nothing like each other on the field.</p>
<div id="attachment_435568" class="wp-caption aligncenter"><img data-attachment-id="435568" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-fordham-at-army/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&#038;h=454" data-orig-size="3056,1386" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Danny Wild-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark IV&quot;,&quot;caption&quot;:&quot;Sep 4, 2015; West Point, NY, USA; Fordham Rams running back Chase Edmonds (22) runs after catching a pass against the Army Black Knights during the first half at Michie Stadium. Mandatory Credit: Danny Wild-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1441413300&quot;,&quot;copyright&quot;:&quot;Danny Wild&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;2500&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;NCAA Football: Fordham at Army&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Fordham at Army" data-image-description="&lt;p&gt;Sep 4, 2015; West Point, NY, USA; Fordham Rams running back Chase Edmonds (22) runs after catching a pass against the Army Black Knights during the first half at Michie Stadium. Mandatory Credit: Danny Wild-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&#038;h=454?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&#038;h=454?w=1000" class="size-full wp-image-435568" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="454" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&#038;h=454"><noscript><img data-attachment-id="435568" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-fordham-at-army/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&#038;h=454" data-orig-size="3056,1386" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Danny Wild-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark IV&quot;,&quot;caption&quot;:&quot;Sep 4, 2015; West Point, NY, USA; Fordham Rams running back Chase Edmonds (22) runs after catching a pass against the Army Black Knights during the first half at Michie Stadium. Mandatory Credit: Danny Wild-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1441413300&quot;,&quot;copyright&quot;:&quot;Danny Wild&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;2500&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;NCAA Football: Fordham at Army&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Fordham at Army" data-image-description="&lt;p&gt;Sep 4, 2015; West Point, NY, USA; Fordham Rams running back Chase Edmonds (22) runs after catching a pass against the Army Black Knights during the first half at Michie Stadium. Mandatory Credit: Danny Wild-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&#038;h=454?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&#038;h=454?w=1000" class="size-full wp-image-435568" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&#038;h=454" alt="" width="1000" height="454" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1000&amp;h=454 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=2000&amp;h=908 2000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=150&amp;h=68 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=300&amp;h=136 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=768&amp;h=348 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_8781207-e1524937832508.jpg?w=1024&amp;h=464 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Danny Wild, USA TODAY Sports)</p></div>
<p><strong>34) RB Chase Edmonds, Arizona Cardinals</strong></p>
<p>The Fordham back is shifty and has good hands. If Arizona is looking to reduce David Johnson&#8217;s touches, Edmonds could be a fine change-of-pace and/or third-downer, as well as a totally different style than backup Elijhaa Penny. Remember Edmonds&#8217; name as training camp progresses.</p>
<p><strong>37) TE Dalton Schultz, Dallas Cowboys</strong></p>
<p>There it is &#8230; the news of Jason Witten&#8217;s expected retirement, in part, led to this selection. Schultz wasn&#8217;t used as much as he could have been at Stanford, due to a wealth of talent at the position, but he still caught 55 balls and five scores in 2017. Rookie tight ends tend to struggle in fantasy, and Dallas has an intriguing guy in Rico Gathers to step in during the summer to prove he belongs. Schultz is no better than a late-round flier if the job is his entering Week 1.</p>
<h3>Round 5</h3>
<p><strong>20) TE Tyler Conklin, Minnesota Vikings</strong></p>
<p>Ignore him in single-year formats, but Conklin will have time to develop behind one of football&#8217;s better tight ends. Kyle Rudolph is entering the penultimate year of his contract and could be cut before 2019 at no cost to the cap. Stash the Central Michigan talent&#8217;s name in the old memory bank for another day.</p>
<div id="attachment_435576" class="wp-caption aligncenter"><img data-attachment-id="435576" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-northern-iowa-at-iowa-state/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&#038;h=640" data-orig-size="1584,1013" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Reese Strickland-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Sep 2, 2017; Ames, IA, USA; Northern Iowa Panthers wide receiver Daurice Fountain (10) makes a catch in front of Iowa State Cyclones defensive back D&#039;Andre Payne (1) at Jack Trice Stadium. Mandatory Credit: Reese Strickland-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1504400049&quot;,&quot;copyright&quot;:&quot;Reese Strickland&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;NCAA Football: Northern Iowa at Iowa State&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Northern Iowa at Iowa State" data-image-description="&lt;p&gt;Sep 2, 2017; Ames, IA, USA; Northern Iowa Panthers wide receiver Daurice Fountain (10) makes a catch in front of Iowa State Cyclones defensive back D&#8217;Andre Payne (1) at Jack Trice Stadium. Mandatory Credit: Reese Strickland-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&#038;h=640?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&#038;h=640?w=1000" class="size-full wp-image-435576" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="640" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&#038;h=640"><noscript><img data-attachment-id="435576" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-northern-iowa-at-iowa-state/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&#038;h=640" data-orig-size="1584,1013" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Reese Strickland-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Sep 2, 2017; Ames, IA, USA; Northern Iowa Panthers wide receiver Daurice Fountain (10) makes a catch in front of Iowa State Cyclones defensive back D&#039;Andre Payne (1) at Jack Trice Stadium. Mandatory Credit: Reese Strickland-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1504400049&quot;,&quot;copyright&quot;:&quot;Reese Strickland&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;NCAA Football: Northern Iowa at Iowa State&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Northern Iowa at Iowa State" data-image-description="&lt;p&gt;Sep 2, 2017; Ames, IA, USA; Northern Iowa Panthers wide receiver Daurice Fountain (10) makes a catch in front of Iowa State Cyclones defensive back D&#8217;Andre Payne (1) at Jack Trice Stadium. Mandatory Credit: Reese Strickland-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&#038;h=640?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&#038;h=640?w=1000" class="size-full wp-image-435576" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&#038;h=640" alt="" width="1000" height="640" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1000&amp;h=640 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=150&amp;h=96 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=300&amp;h=192 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=768&amp;h=491 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg?w=1024&amp;h=655 1024w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10256447-e1524943035678.jpg 1584w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Reese Strickland, USA TODAY Sports)</p></div>
<p><strong>22) WR Daurice Fountain, Indianapolis Colts</strong></p>
<p>Simply by virtue of necessity, Fountain could be a fantasy option in 2018. Indy has basically nothing at receiver after T.Y. Hilton and Ryan Grant, and that is assuming Grant can be anything decent in a new offense after a one-year flash in Washington. Fountain offers adequate size (6-foot-1, 210 pounds) and a one-year wonder in his own right at Northern Iowa. He was a prep star in Wisconsin and, while raw, could be a Year 1 contributor. Watch for his name in the summer months.</p>
<p><strong>28) RB/TE Jaylen Samuels, Pittsburgh Steelers</strong></p>
<p>A Swiss army knife, Samuels can line up all over the field &#8212; tailback, H-back, tight end and in the slot. The Steelers have obvious question marks at running back with Le&#8217;Veon Bell&#8217;s future in doubt, but Samuels won&#8217;t be anything more than a part of the puzzle if he needs to be replaced in &#8217;19. Despite being an intriguing prospect, Samuels has practically no immediate fantasy value.</p>
<h3>Round 6</h3>
<div id="attachment_435578" class="wp-caption aligncenter"><img data-attachment-id="435578" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-sugar-bowl-alabama-vs-clemson/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&#038;h=632" data-orig-size="1891,1195" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;Kevin Jairaj-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;Jan 1, 2018; New Orleans, LA, USA; Clemson Tigers wide receiver Deon Cain (8) runs the ball during the second quarter against the Alabama Crimson Tide in the 2018 Sugar Bowl college football playoff semifinal game at Mercedes-Benz Superdome. Mandatory Credit: Kevin Jairaj-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1514857528&quot;,&quot;copyright&quot;:&quot;Kevin Jairaj&quot;,&quot;focal_length&quot;:&quot;560&quot;,&quot;iso&quot;:&quot;6400&quot;,&quot;shutter_speed&quot;:&quot;0.00125&quot;,&quot;title&quot;:&quot;NCAA Football: Sugar Bowl-Alabama vs Clemson&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Sugar Bowl-Alabama vs Clemson" data-image-description="&lt;p&gt;Jan 1, 2018; New Orleans, LA, USA; Clemson Tigers wide receiver Deon Cain (8) runs the ball during the second quarter against the Alabama Crimson Tide in the 2018 Sugar Bowl college football playoff semifinal game at Mercedes-Benz Superdome. Mandatory Credit: Kevin Jairaj-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&#038;h=632?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&#038;h=632?w=1000" class="size-full wp-image-435578" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="632" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&#038;h=632"><noscript><img data-attachment-id="435578" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/ncaa-football-sugar-bowl-alabama-vs-clemson/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&#038;h=632" data-orig-size="1891,1195" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;Kevin Jairaj-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;Jan 1, 2018; New Orleans, LA, USA; Clemson Tigers wide receiver Deon Cain (8) runs the ball during the second quarter against the Alabama Crimson Tide in the 2018 Sugar Bowl college football playoff semifinal game at Mercedes-Benz Superdome. Mandatory Credit: Kevin Jairaj-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1514857528&quot;,&quot;copyright&quot;:&quot;Kevin Jairaj&quot;,&quot;focal_length&quot;:&quot;560&quot;,&quot;iso&quot;:&quot;6400&quot;,&quot;shutter_speed&quot;:&quot;0.00125&quot;,&quot;title&quot;:&quot;NCAA Football: Sugar Bowl-Alabama vs Clemson&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Sugar Bowl-Alabama vs Clemson" data-image-description="&lt;p&gt;Jan 1, 2018; New Orleans, LA, USA; Clemson Tigers wide receiver Deon Cain (8) runs the ball during the second quarter against the Alabama Crimson Tide in the 2018 Sugar Bowl college football playoff semifinal game at Mercedes-Benz Superdome. Mandatory Credit: Kevin Jairaj-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&#038;h=632?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&#038;h=632?w=1000" class="size-full wp-image-435578" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&#038;h=632" alt="" width="1000" height="632" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1000&amp;h=632 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=150&amp;h=95 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=300&amp;h=190 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=768&amp;h=485 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg?w=1024&amp;h=647 1024w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10512737-e1524946495584.jpg 1891w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Kevin Jairaj, USA TODAY Sports)</p></div>
<p><strong>12) WR Deon Cain, Indianapolis Colts</strong></p>
<p>Cain (6-foot-2, 202) is a size-speed (4.43-second 40) combo talent with an ability to stretch the field. He regressed in most imaginable ways after Mike Williams left Clemson for the NFL in 2017&#8217;s draft, suggesting Cain is a better WR2 in the NFL than a go-to guy. Indianapolis could turn this sixth-round pick into a Year 1 starter, especially if the previous selection of Daurice Fountain doesn&#8217;t pan out. Drops and concentration lapses are a major issue here. Play close attention to Cain&#8217;s role in the late summer.</p>
<h3>Day 3 draft trades</h3>
<div id="attachment_435571" class="wp-caption aligncenter"><img data-attachment-id="435571" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/nfl-los-angeles-rams-at-arizona-cardinals-2/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&#038;h=308" data-orig-size="3020,931" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Matt Kartozian-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D4&quot;,&quot;caption&quot;:&quot;Dec 3, 2017; Glendale, AZ, USA; Los Angeles Rams wide receiver Tavon Austin (11) runs the ball as Arizona Cardinals linebacker Chandler Jones (55) defends during the second half at University of Phoenix Stadium. Mandatory Credit: Matt Kartozian-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1512345684&quot;,&quot;copyright&quot;:&quot;Matt Kartozian&quot;,&quot;focal_length&quot;:&quot;380&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;NFL: Los Angeles Rams at Arizona Cardinals&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NFL: Los Angeles Rams at Arizona Cardinals" data-image-description="&lt;p&gt;Dec 3, 2017; Glendale, AZ, USA; Los Angeles Rams wide receiver Tavon Austin (11) runs the ball as Arizona Cardinals linebacker Chandler Jones (55) defends during the second half at University of Phoenix Stadium. Mandatory Credit: Matt Kartozian-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&#038;h=308?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&#038;h=308?w=1000" class="size-full wp-image-435571" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="308" data-lazy-src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&#038;h=308"><noscript><img data-attachment-id="435571" data-permalink="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/nfl-los-angeles-rams-at-arizona-cardinals-2/" data-orig-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&#038;h=308" data-orig-size="3020,931" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Matt Kartozian-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D4&quot;,&quot;caption&quot;:&quot;Dec 3, 2017; Glendale, AZ, USA; Los Angeles Rams wide receiver Tavon Austin (11) runs the ball as Arizona Cardinals linebacker Chandler Jones (55) defends during the second half at University of Phoenix Stadium. Mandatory Credit: Matt Kartozian-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1512345684&quot;,&quot;copyright&quot;:&quot;Matt Kartozian&quot;,&quot;focal_length&quot;:&quot;380&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;NFL: Los Angeles Rams at Arizona Cardinals&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NFL: Los Angeles Rams at Arizona Cardinals" data-image-description="&lt;p&gt;Dec 3, 2017; Glendale, AZ, USA; Los Angeles Rams wide receiver Tavon Austin (11) runs the ball as Arizona Cardinals linebacker Chandler Jones (55) defends during the second half at University of Phoenix Stadium. Mandatory Credit: Matt Kartozian-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&#038;h=308?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&#038;h=308?w=1000" class="size-full wp-image-435571" src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&#038;h=308" alt="" width="1000" height="308" srcset="https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1000&amp;h=308 1000w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1998&amp;h=616 1998w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=150&amp;h=46 150w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=300&amp;h=92 300w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=768&amp;h=237 768w, https://usathuddle.files.wordpress.com/2018/04/usatsi_10459048-e1524941407406.jpg?w=1024&amp;h=316 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Matt Kartozian, USA TODAY Sports)</p></div>
<p><strong>Dallas acquires WR Tavon Austin</strong></p>
<p>It is easy to write off Austin at this point, and no one really could be blamed. Sometimes a fresh start is what it takes for a once-promising player to get back on track, but Austin has proven to be one-dimensional. He struggles to create yardage after the catch &#8212; a necessary trait for diminuative players. WR Cole Beasley is firmly locked into the slot, so Austin will be moved to running back as a change-up for Scott Linehan&#8217;s offense. Gamers can take a shot on him in drafts as a late-round flier.</p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://thehuddle.com/tag/2018-nfl-draft/" rel="tag">2018 NFL Draft</a>, <a href="http://thehuddle.com/tag/antonio-callaway/" rel="tag">Antonio Callaway</a>, <a href="http://thehuddle.com/tag/chris-herndon/" rel="tag">Chris Herndon</a>, <a href="http://thehuddle.com/tag/ian-thomas/" rel="tag">Ian Thomas</a>, <a href="http://thehuddle.com/tag/keke-coutee/" rel="tag">Keke Coutee</a>, <a href="http://thehuddle.com/tag/kyle-lauletta/" rel="tag">Kyle Lauletta</a>, <a href="http://thehuddle.com/tag/nfl-draft/" rel="tag">nfl draft</a>, <a href="http://thehuddle.com/tag/nyheim-hines/" rel="tag">Nyheim Hines</a>, <a href="http://thehuddle.com/category/nfl-draft/" rel="category tag">NFL Draft</a>, <a href="http://thehuddle.com/category/rookie-analysis/" rel="category tag">Rookie Analysis</a></p>
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">19</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/04/28/2018-nfl-draft-day-3-fantasy-football/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-1"
	   title="2018 NFL Draft: Fantasy football recap of Rounds 2-3"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10512093-e1524871988338.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512093-e1524871988338.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2018 NFL Draft: Fantasy football recap of Rounds 2-3" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">33 shares</span><span class="block__time block__time--mobile">21hr ago</span>
		<h2><a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/"
			   title="2018 NFL Draft: Fantasy football recap of Rounds 2-3" itemprop="url">
				2018 NFL Draft: Fantasy football recap of Rounds 2-3			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/03/21/rookie-rundown-rb-saquon-barkley-penn-state/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-2"
	   title="Rookie Rundown: RB Saquon Barkley, Penn State"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_105072262-e1521646377892.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_105072262-e1521646377892.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Rookie Rundown: RB Saquon Barkley, Penn State" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">3 shares</span><span class="block__time block__time--mobile">21 Mar</span>
		<h2><a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="http://thehuddle.com/2018/03/21/rookie-rundown-rb-saquon-barkley-penn-state/"
			   title="Rookie Rundown: RB Saquon Barkley, Penn State" itemprop="url">
				Rookie Rundown: RB Saquon Barkley, Penn State			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-3"
	   title="2018 NFL Draft: Fantasy football recap of Round 1"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10805871-e1524789044907.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10805871-e1524789044907.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2018 NFL Draft: Fantasy football recap of Round 1" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">57 shares</span><span class="block__time block__time--mobile">2d ago</span>
		<h2><a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/"
			   title="2018 NFL Draft: Fantasy football recap of Round 1" itemprop="url">
				2018 NFL Draft: Fantasy football recap of Round 1			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_native", slotName: "/7103/SMG_TheHuddle/native/sports/fantasy/football.general", sizes : [[640,170],[3,1]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_native' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_native"] = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.general", [[640,170],[3,1]], "acm-ad-tag-lawrence_dfp_desktop_native").addService(googletag.pubads().setTargeting('kw',["2018 NFL Draft","Antonio Callaway","Chris Herndon","Ian Thomas","Keke Coutee","Kyle Lauletta","nfl draft","Nyheim Hines","Cory Bonini","NFL Draft","Rookie Analysis"]).setTargeting('category',["NFL Draft","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_native' );
												bidManager.requestBid( 'lawrence_dfp_desktop_native' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_native' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_native' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/28/2018-player-movement-tracker/"
						title="2018 player movement tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_10407651-e1521158473863.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_10407651-e1521158473863.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 player movement tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/28/2018-player-movement-tracker/"
								title="2018 player movement tracker"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/28/2018-player-movement-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/28/2018-player-movement-tracker/"
			title="2018 player movement tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>2</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				18hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">18hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/28/2018-player-movement-tracker/"
						title="2018 player movement tracker"
						itemprop="url" 						>
							2018 player movement tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 28, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>&nbsp;  &nbsp; </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/"
						title="2018 NFL Draft: Fantasy football recap of Rounds 2-3"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10512093-e1524871988338.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512093-e1524871988338.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 NFL Draft: Fantasy football recap of Rounds 2-3" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/"
								title="2018 NFL Draft: Fantasy football recap of Rounds 2-3"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/"
			title="2018 NFL Draft: Fantasy football recap of Rounds 2-3"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>33</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				21hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">21hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/"
						title="2018 NFL Draft: Fantasy football recap of Rounds 2-3"
						itemprop="url" 						>
							2018 NFL Draft: Fantasy football recap of Rounds 2-3					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 27, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Day 2 of the NFL draft brings plenty of excitement to the fantasy football landscape. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/"
						title="2018 NFL Draft: Fantasy football recap of Round 1"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10805871-e1524789044907.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10805871-e1524789044907.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 NFL Draft: Fantasy football recap of Round 1" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/"
								title="2018 NFL Draft: Fantasy football recap of Round 1"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/"
			title="2018 NFL Draft: Fantasy football recap of Round 1"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>57</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/"
						title="2018 NFL Draft: Fantasy football recap of Round 1"
						itemprop="url" 						>
							2018 NFL Draft: Fantasy football recap of Round 1					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 26, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>We will have months to further evaluate the depths of what these players mean for fantasy purposes, but you&#8217;ve come to the right (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/24/nfl-draft-rb-kalen-ballage-arizona-state/"
						title="Rookie Rundown: RB Kalen Ballage, Arizona State"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10392995-e1524596384817.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Rookie Rundown: RB Kalen Ballage, Arizona State" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/24/nfl-draft-rb-kalen-ballage-arizona-state/"
								title="Rookie Rundown: RB Kalen Ballage, Arizona State"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/24/nfl-draft-rb-kalen-ballage-arizona-state/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/24/nfl-draft-rb-kalen-ballage-arizona-state/"
			title="Rookie Rundown: RB Kalen Ballage, Arizona State"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>10</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/24/nfl-draft-rb-kalen-ballage-arizona-state/"
						title="Rookie Rundown: RB Kalen Ballage, Arizona State"
						itemprop="url" 						>
							Rookie Rundown: RB Kalen Ballage, Arizona State					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 24, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>A do-all running back, ASU&#8217;s Kalen Ballage won&#8217;t have trouble finding a home in the NFL. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/23/2018-nfl-mock-draft/"
						title="2018 NFL Mock Draft: Rounds 1-2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10435199-e1524506672554.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10435199-e1524506672554.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 NFL Mock Draft: Rounds 1-2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/23/2018-nfl-mock-draft/"
								title="2018 NFL Mock Draft: Rounds 1-2"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/23/2018-nfl-mock-draft/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/23/2018-nfl-mock-draft/"
			title="2018 NFL Mock Draft: Rounds 1-2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>160</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/nfl-draft/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/23/2018-nfl-mock-draft/"
						title="2018 NFL Mock Draft: Rounds 1-2"
						itemprop="url" 						>
							2018 NFL Mock Draft: Rounds 1-2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 23, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>We&#8217;ve updated our two-round NFL mock draft. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/22/nfl-draft-wr-equanimeous-st-brown-notre-dame/"
						title="Rookie Rundown: WR Equanimeous St. Brown, Notre Dame"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_9561931-e1524413957388.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_9561931-e1524413957388.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Rookie Rundown: WR Equanimeous St. Brown, Notre Dame" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/22/nfl-draft-wr-equanimeous-st-brown-notre-dame/"
								title="Rookie Rundown: WR Equanimeous St. Brown, Notre Dame"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/22/nfl-draft-wr-equanimeous-st-brown-notre-dame/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/22/nfl-draft-wr-equanimeous-st-brown-notre-dame/"
			title="Rookie Rundown: WR Equanimeous St. Brown, Notre Dame"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>13</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/22/nfl-draft-wr-equanimeous-st-brown-notre-dame/"
						title="Rookie Rundown: WR Equanimeous St. Brown, Notre Dame"
						itemprop="url" 						>
							Rookie Rundown: WR Equanimeous St. Brown, Notre Dame					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 22, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Notre Dame wide receiver Equanimeous St. Brown enters the NFL draft with impressive size and more than enough speed to threaten down the (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/21/rookie-rundown-rb-royce-freeman-oregon/"
						title="Rookie Rundown: RB Royce Freeman, Oregon"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/10301857-e1524366416493.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/10301857-e1524366416493.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Rookie Rundown: RB Royce Freeman, Oregon" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/21/rookie-rundown-rb-royce-freeman-oregon/"
								title="Rookie Rundown: RB Royce Freeman, Oregon"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/21/rookie-rundown-rb-royce-freeman-oregon/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/21/rookie-rundown-rb-royce-freeman-oregon/"
			title="Rookie Rundown: RB Royce Freeman, Oregon"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>13</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/21/rookie-rundown-rb-royce-freeman-oregon/"
						title="Rookie Rundown: RB Royce Freeman, Oregon"
						itemprop="url" 						>
							Rookie Rundown: RB Royce Freeman, Oregon					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 21, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Royce Freeman ended his stellar career at Oregon with 6,435 total yards and 64 touchdowns.  He owns the Pac-12 all-time record for (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/20/nfl-draft-wr-simmie-cobbs-indiana/"
						title="Rookie Rundown: WR Simmie Cobbs Jr., Indiana"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10390572-e1524278252321.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10390572-e1524278252321.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Rookie Rundown: WR Simmie Cobbs Jr., Indiana" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/20/nfl-draft-wr-simmie-cobbs-indiana/"
								title="Rookie Rundown: WR Simmie Cobbs Jr., Indiana"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/20/nfl-draft-wr-simmie-cobbs-indiana/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/20/nfl-draft-wr-simmie-cobbs-indiana/"
			title="Rookie Rundown: WR Simmie Cobbs Jr., Indiana"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>6</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/20/nfl-draft-wr-simmie-cobbs-indiana/"
						title="Rookie Rundown: WR Simmie Cobbs Jr., Indiana"
						itemprop="url" 						>
							Rookie Rundown: WR Simmie Cobbs Jr., Indiana					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 20, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Indiana WR Simmie Cobbs Jr. will gain attention for his size, but this prospect has a long way to go yet. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-team-by-week-grid/"
						title="2018 NFL Schedule - Team by Week Grid"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/01/usatsi_10509027-e1515449165146.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/01/usatsi_10509027-e1515449165146.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 NFL Schedule - Team by Week Grid" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-team-by-week-grid/"
								title="2018 NFL Schedule - Team by Week Grid"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/19/2018-nfl-schedule-team-by-week-grid/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-team-by-week-grid/"
			title="2018 NFL Schedule - Team by Week Grid"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>11</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/nfl-schedule/" class="category" itemprop="articleSection">NFL Schedule</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-team-by-week-grid/"
						title="2018 NFL Schedule - Team by Week Grid"
						itemprop="url" 						>
							2018 NFL Schedule - Team by Week Grid					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>The 2018 NFL Schedule presented in an easy to view and print grid format. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-weekly-grid/"
						title="2018 NFL Schedule - Weekly Grid"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/12/usatsi_10478825-e1514478321774.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/12/usatsi_10478825-e1514478321774.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 NFL Schedule - Weekly Grid" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-weekly-grid/"
								title="2018 NFL Schedule - Weekly Grid"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/19/2018-nfl-schedule-weekly-grid/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-weekly-grid/"
			title="2018 NFL Schedule - Weekly Grid"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>5</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/nfl-schedule/" class="category" itemprop="articleSection">NFL Schedule</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-weekly-grid/"
						title="2018 NFL Schedule - Weekly Grid"
						itemprop="url" 						>
							2018 NFL Schedule - Weekly Grid					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>  &nbsp; </p>

				
				
			</div>
		</article>
	</div>
<a href="http://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
			<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>		</div>

		
		<div class="widget widget--login widget--box" id="login_widget-3"><div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget_usat_sidebar_top_posts_widget" id="usat_sidebar_top_posts_widget-2">		<div class="col1 right" id="sticky-sidebar">
				<div class="heading-small">
		<h2>Popular <span>Now</span></h2>
	</div>
	
					<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10805871-e1524789044907.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/" title="2018 NFL Draft: Fantasy football recap of Round 1" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10805871-e1524789044907.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 NFL Draft: Fantasy football recap of Round 1" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/04/26/2018-nfl-draft-round-1-fantasy-football/" title="2018 NFL Draft: Fantasy football recap of Round 1" itemprop="url" >2018 NFL Draft: Fantasy football recap of Round 1</a></p>
				<p class="widget-date">April 26, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106698301-e1520090706117.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/02/2018-nfl-combine-results-running-backs/" title="2018 NFL combine results: Running Backs" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106698301-e1520090706117.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 NFL combine results: Running Backs" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				02 Mar			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/02/2018-nfl-combine-results-running-backs/" title="2018 NFL combine results: Running Backs" itemprop="url" >2018 NFL combine results: Running Backs</a></p>
				<p class="widget-date">March 2, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/03/usatsi_106733191-e1520132659339.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/" title="2018 NFL combine results: Wide Receivers" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_106733191-e1520132659339.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 NFL combine results: Wide Receivers" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				03 Mar			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/03/03/2018-nfl-combine-results-wide-receivers/" title="2018 NFL combine results: Wide Receivers" itemprop="url" >2018 NFL combine results: Wide Receivers</a></p>
				<p class="widget-date">March 3, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10512093-e1524871988338.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/" title="2018 NFL Draft: Fantasy football recap of Rounds 2-3" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10512093-e1524871988338.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 NFL Draft: Fantasy football recap of Rounds 2-3" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				21hr			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/04/27/2018-nfl-draft-day-2-fantasy-football-recap/" title="2018 NFL Draft: Fantasy football recap of Rounds 2-3" itemprop="url" >2018 NFL Draft: Fantasy football recap of Rounds 2-3</a></p>
				<p class="widget-date">April 27, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
		
		</div>
		</div><div class="widget widget--links widget--box" id="links_widget-8"><div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="http://www.thehuddle.com/2018-nfl-depth-charts.php">2018 fantasy depth charts</a></li>
<li id="menu-item-434831" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434831"><a href="http://thehuddle.com/2018/04/19/2018-top-free-agent-tracker/">2018 top free agent tracker</a></li>
<li id="menu-item-434830" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434830"><a href="http://thehuddle.com/2018/04/28/2018-player-movement-tracker/">2018 player movement tracker</a></li>
<li id="menu-item-434533" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434533"><a href="http://thehuddle.com/2018/02/20/2018-coaching-change-tracker/">2018 coaching change tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7"><div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="http://www.thehuddle.com/2018-nfl-depth-charts.php">2018 fantasy depth charts</a></li>
<li id="menu-item-435449" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435449"><a href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-team-by-week-grid/">2018 NFL Schedule - Team by Week Grid</a></li>
<li id="menu-item-435450" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435450"><a href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-weekly-grid/">2018 NFL Schedule - Weekly Grid</a></li>
<li id="menu-item-428116" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428116"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-round/">2017 NFL Draft by round</a></li>
<li id="menu-item-428117" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428117"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-team/">2017 NFL Draft by team</a></li>
<li id="menu-item-428118" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-428118"><a href="http://thehuddle.com/2017/04/30/2017-nfl-draft-by-position/">2017 NFL Draft by position</a></li>
<li id="menu-item-434832" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434832"><a href="http://thehuddle.com/2018/02/06/2018-nfl-important-dates/">2018 NFL important dates</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-4"><div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="http://www.thehuddle.com/stats/2017/plays_std.php">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="http://www.thehuddle.com/stats/2017/plays_weekly.php">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="http://www.thehuddle.com/stats/2017/gamescan.php">Weekly Fantasy Box Scores</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="http://www.thehuddle.com/stats/2017/tpr.php">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="http://www.thehuddle.com/stats/2017/tpm.php">Team Position Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="http://www.thehuddle.com/stats/2017/gsm.php">Game Stats Matchups</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="http://thehuddle.com/myHuddle/sos.php">Strength of Schedule Tool</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget--forum widget--box" id="forum_widget-3"><div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/" class="" rel="" target=""><img width="1000" height="1000" src="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg 1000w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=150&amp;h=150 150w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300&amp;h=300 300w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=768&amp;h=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="429990" data-permalink="http://thehuddle.com/blitz/" data-orig-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" data-orig-size="1000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Blitz" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=1000" /></a></div>
		<div class="widget sidebar-ad bottom">
			<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250", slotName: "/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", sizes : [[300,250],[300,600]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_bottom_300x250"] = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250").addService(googletag.pubads().setTargeting('kw',["2018 NFL Draft","Antonio Callaway","Chris Herndon","Ian Thomas","Keke Coutee","Kyle Lauletta","nfl draft","Nyheim Hines","Cory Bonini","NFL Draft","Rookie Analysis"]).setTargeting('category',["NFL Draft","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_2a"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' );
												bidManager.requestBid( 'lawrence_dfp_desktop_bottom_300x250' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>		</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-424341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424341"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424340"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424342"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="The Huddle">
				<a class="mobile-nav__breadcrumb" href="http://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li class="mobile-nav__item mobile-nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li class="mobile-nav__item mobile-nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="/2018-nfl-depth-charts.php">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-424341" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://thehuddle.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-424340" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://thehuddle.com/privacy-notice-your-california-privacy-rights/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-424342" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="/privacy-notice-your-california-privacy-rights#adchoices">Ad Choices</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>
<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="http://thehuddle.com/login.php" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201817y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="114275906" />
				<input type="hidden" id="carousel-reblog-blog-url" value="http://thehuddle.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Huddle" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="2ad37ff1ce" /><input type="hidden" name="_wp_http_referer" value="/2018/04/28/2018-nfl-draft-day-3-fantasy-football/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVy0EOQDAQheELqVGCWIizUBNabZVRHB+xYSOx/d/7YHNMjHZBu4AiaHGVAt0eKgrgMRnPnPadtARaDkgwefTY17bVOH+cxWjMmdiN1KUboE06/INe4YSVKXnKC57HSRapAyLtR9U='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"0"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"","maxDistance":"250","medAdHeight":"0","maxDistanceMed":"0","largeAdHeight":"0","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var huddleUser = {"nameAPI":"http:\/\/thehuddle.com\/api\/get_user_name.php","cookie":"huddle-auth"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/thehuddle.com\/wp-admin\/admin-ajax.php","nonce":"b0229ae573","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathuddle.wordpress.com\/wp-login.php?redirect_to=http%3A%2F%2Fthehuddle.com%2F2018%2F04%2F28%2F2018-nfl-draft-day-3-fantasy-football%2F","blog_id":"114275906","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=114275906&v=wpcom&tz=-4&user_id=0&subd=usathuddle","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJydUtFSwjAQ/CGvUQQdHhy/5Uhv4Eqa1FxSrF/vFW1hpoiFt842u3e7t+bQgA0+kU8m7agmMS03JgumUGIHjctb9mIksd13wN6xJ2i5pCCmuowXlTyYf3QdHiJ5S72G442pPjLFrrAh7JluFaiR/a2cROg410Cf+lw4+MnadR7dL6DXqY5ygB5dp7av+RyIDr90bMASHovXXuDXpwSPsaivrv2nxgjM8TyoHFBwwz09J3azbjSlemx5i0nTuo8v2o+NGr+LjFFDd7PKMSXPrcjA1H+wy2XpjmWZV8nL3CwUQYO7Ui8stQmgweiakijqF4SWYtS45ITdqJAi2v14aPbW5V6uP0NzCuMc/ynn2NFmGtnZSIsxqDdnKkqNToIBUM57/fa0Wixf1uvV87L6BoiUpuc='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-4','user_id':'0','post':'435559','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-4&user_id=0&post=435559&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6MUpUUG5uL0RoSjRTVzNFP0R3XU9oTURLTkwvSE1XODNPaXhSSldxQWxsWEF3eDVZa0IwWFNnckFMY3EuJU09OFRtXyZ8LUU9SW13MXlLPTF8TVcwVWRocD0rZzEwbFd6bDJpRj93JTJxJm5PSHZpM2ktYVJHb0hUQlBveUF4'}]);
_stq.push([ 'clickTrackerInit', '114275906', '435559' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated 100 seconds ago
	generated in 0.245 seconds
	served from batcache in 0.002 seconds
	expires in 200 seconds
-->
