<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Top IDP rookies entering the 2018 fantasy football season." /><meta name="news_keywords" content="fantasy football,%tags%,%cats%" />
<meta name="keywords" content="fantasy football,2018 fantasy rookies, idp, rookie idp,idp analysis, rookie analysis" />
<title>Top 2018 Rookie Linebackers – IDP Value | The Huddle</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1525796755&amp;back=http%3A%2F%2Fthehuddle.com%2F2018%2F05%2F02%2Ftop-2018-rookie-linebackers-idp-value%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Feed" href="http://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Comments Feed" href="http://thehuddle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Top 2018 Rookie Linebackers – IDP Value Comments Feed" href="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.6-beta1-43176"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJylkNFOwzAMRX+IkIG6viFe+QOe3cSkXp04atJV/XvSVRsMRkDiJfJN7vF1rOeojISMIWs/qciTo5D0HI14lTwxLl/UvUnpTt/GmAZM+oA5ghnUSdXsRkYs9z5CXh0eLQEy+mKrYT62Z2ot+5JVjdnG77o4YkqqnJ4mr3Jfgn4Zz6+jbP/QxXh9s6Gkg2QqdLoU33puUfpIUU8JslhYLiGpMMOiKDAFVEeyKFvWrYc/dWaYRwwGz4+vkKCjf6D6ZbKWsbpisg5zGVoMAattH59FDXYoisVAJglXQr0x0FhDR+xYXCndaWcf8qfv9o12LB3wanj2Tw/7x33T7nZtc3gHi0wlcA==?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFjt0KwjAMRl/IrptMmBfis2RtnKnrj027MZ/eDvRCHAqBQHJy8sk5CHJqzBpZmlL3jHF5tcrwTv4ChKUhQsLKknvDyruELq2s9T2NKDJjhKHMiujiN7jgOVlkLtDG9jMSuYlw/osZTAHUTURkenxZ0xXLPzlRkJkheQ2LGGGO6BSurp60xigsuBIpluuzPTWHfVt3x7przBPGh3M8'></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.6-beta1-43176'></script>
<script type='text/javascript' src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=4.9.6-beta1-43176'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:thehuddle","priority_asset":"","blogname":"thehuddle","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"435553","headline":"Top 2018 Rookie Linebackers \u2013 IDP Value","byline":"T.J. Ford","taxonomykeywords":"2018 fantasy rookies, idp, rookie IDP"};
/* ]]> */
</script>
<script type='text/javascript'>
					utag_data.clickPage = sessionStorage.getItem( "clickPage" );
					sessionStorage.setItem( "clickPage", window.location.href );
					
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/thehuddle3/prod/utag.js?ver=4.9.6-beta1-43176'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2r61kVv' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F05%2F02%2Ftop-2018-rookie-linebackers-idp-value%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F05%2F02%2Ftop-2018-rookie-linebackers-idp-value%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Top 2018 Rookie Linebackers – IDP Value" />
<meta property="og:url" content="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/" />
<meta property="og:description" content="Top IDP rookies entering the 2018 fantasy football season." />
<meta property="article:published_time" content="2018-05-02T13:18:00+00:00" />
<meta property="article:modified_time" content="2018-05-07T13:24:11+00:00" />
<meta property="og:site_name" content="The Huddle" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:text:title" content="Top 2018 Rookie Linebackers – IDP Value" />
<meta name="twitter:image:src" content="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="http://thehuddle.com/osd.xml" title="The Huddle" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Huddle" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Fantasy Football Cheat Sheets, Rankings, Sleepers &amp; Award Winning Draft Advice" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://thehuddle.com/feed/;icon-uri=http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["2018 fantasy rookies","idp","rookie IDP","T.J. Ford","IDP Analysis","Rookie Analysis"],"category":"IDP Analysis","referrer":"","isMobile":"0"};
googletag_cmd_push(function() {
window.lawrence_dfp_desktop_skin = googletag.defineSlot("/7103/SMG_TheHuddle/skin/sports/fantasy/football.general", [1,1], "acm-ad-tag-lawrence_dfp_desktop_skin").addService(googletag.pubads().setTargeting('kw',["2018 fantasy rookies","idp","rookie IDP","T.J. Ford","IDP Analysis","Rookie Analysis"]).setTargeting('category',["IDP Analysis","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["skin"]);window.lawrence_dfp_desktop_top = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.main", ['fluid',[728,90],[970,66],[970,250]], "acm-ad-tag-lawrence_dfp_desktop_top").addService(googletag.pubads().setTargeting('kw',["2018 fantasy rookies","idp","rookie IDP","T.J. Ford","IDP Analysis","Rookie Analysis"]).setTargeting('category',["IDP Analysis","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);window.lawrence_dfp_desktop_top_300x250 = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_1a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_top_300x250").addService(googletag.pubads().setTargeting('kw',["2018 fantasy rookies","idp","rookie IDP","T.J. Ford","IDP Analysis","Rookie Analysis"]).setTargeting('category',["IDP Analysis","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_1a"]);window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();

googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

bidManager.initialize();
});
</script>
<link rel="amphtml" href="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-435553 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_outstream", slotName: "/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", sizes : [4,1] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_outstream"] = googletag.defineSlot("/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", [4,1], "acm-ad-tag-lawrence_dfp_desktop_outstream").addService(googletag.pubads().setTargeting('kw',["2018 fantasy rookies","idp","rookie IDP","T.J. Ford","IDP Analysis","Rookie Analysis"]).setTargeting('category',["IDP Analysis","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["outstream"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_outstream' );
												bidManager.requestBid( 'lawrence_dfp_desktop_outstream' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_outstream' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
	
<div id="wrapper">

	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="http://thehuddle.com"
				title="The Huddle"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="The Huddle"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Huddle" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-428297" class="nav__item nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li id="menu-item-428295" class="nav__item nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li id="menu-item-428296" class="nav__item nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-424408" class="nav__item nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li id="menu-item-429328" class="nav__item nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li id="menu-item-424410" class="nav__item nav__item--depth-charts"><a href="/2018-nfl-depth-charts.php">Depth Charts</a></li>
<li id="menu-item-424627" class="nav__item nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li id="menu-item-424411" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-424412" class="nav__item nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li id="menu-item-424413" class="nav__item nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li id="menu-item-424995" class="nav__item nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-435553" class="post-435553 post type-post status-publish format-standard has-post-thumbnail hentry category-idp-analysis category-rookie-analysis tag-2018-fantasy-rookies tag-idp tag-rookie-idp article--no-image" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title article__title--no-image ">
	<h1 class="article__headline">Top 2018 Rookie Linebackers – IDP Value</h1>

	</div>
<h1 class="article__headline article__headline--mobile">Top 2018 Rookie Linebackers – IDP Value</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://thehuddle.com/category/rookie-analysis/" class="" itemprop="articleSection">Rookie Analysis</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Top 2018 Rookie Linebackers – IDP Value</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://thehuddle.com/author/t-j-ford/" title="Posts by T.J. Ford" class="author url fn" rel="author">T.J. Ford</a> 
		<span class="post-date updated">May 2, 2018</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/TJFordCDN" class="twitter-follow-button" data-show-count="false">
					Follow					@TJFordCDN				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					
				</header>

				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://thehuddle.com/author/t-j-ford/" title="Posts by T.J. Ford" class="author url fn" rel="author">T.J. Ford</a>		| May 2, 2018		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/TJFordCDN" class="twitter-follow-button" data-show-count="false">
		Follow @TJFordCDN	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><div id="attachment_435721" class="wp-caption aligncenter"><img data-attachment-id="435721" data-permalink="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/ncaa-football-cfp-national-championship-game-alabama-vs-georgia-6/" data-orig-file="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&#038;h=603" data-orig-size="2785,1678" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Matthew Emmons-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;Jan 8, 2018; Atlanta, GA, USA; Georgia Bulldogs linebacker Roquan Smith (3) in action against the Alabama Crimson Tide during the second half against the  in the 2018 CFP national championship college football game at Mercedes-Benz Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1515477293&quot;,&quot;copyright&quot;:&quot;Matthew Emmons&quot;,&quot;focal_length&quot;:&quot;600&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;NCAA Football: CFP National Championship Game-Alabama vs Georgia&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: CFP National Championship Game-Alabama vs Georgia" data-image-description="&lt;p&gt;Jan 8, 2018; Atlanta, GA, USA; Georgia Bulldogs linebacker Roquan Smith (3) in action against the Alabama Crimson Tide during the second half against the  in the 2018 CFP national championship college football game at Mercedes-Benz Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&#038;h=603?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&#038;h=603?w=1000" class="size-full wp-image-435721 image--no-bleed" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="603" data-lazy-src="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&#038;h=603"><noscript><img data-attachment-id="435721" data-permalink="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/ncaa-football-cfp-national-championship-game-alabama-vs-georgia-6/" data-orig-file="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&#038;h=603" data-orig-size="2785,1678" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Matthew Emmons-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;Jan 8, 2018; Atlanta, GA, USA; Georgia Bulldogs linebacker Roquan Smith (3) in action against the Alabama Crimson Tide during the second half against the  in the 2018 CFP national championship college football game at Mercedes-Benz Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1515477293&quot;,&quot;copyright&quot;:&quot;Matthew Emmons&quot;,&quot;focal_length&quot;:&quot;600&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;NCAA Football: CFP National Championship Game-Alabama vs Georgia&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: CFP National Championship Game-Alabama vs Georgia" data-image-description="&lt;p&gt;Jan 8, 2018; Atlanta, GA, USA; Georgia Bulldogs linebacker Roquan Smith (3) in action against the Alabama Crimson Tide during the second half against the  in the 2018 CFP national championship college football game at Mercedes-Benz Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&#038;h=603?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&#038;h=603?w=1000" class="size-full wp-image-435721 image--no-bleed" src="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&#038;h=603" alt="" width="1000" height="603" srcset="https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1000&amp;h=603 1000w, https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=2000&amp;h=1206 2000w, https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=150&amp;h=90 150w, https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=300&amp;h=181 300w, https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=768&amp;h=463 768w, https://usathuddle.files.wordpress.com/2018/05/10683161-e1525699347505.jpg?w=1024&amp;h=617 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p class="wp-caption-text">(Matthew Emmons-USA TODAY Sports)</p></div>
<p><strong>Roquan Smith &#8211; 3-4 ILB</strong><br />
6’1” 236 lbs Georgia<br />
Pick 8, Round 1 (8) Bears<br />
Twitter: <span class="username u-dir" dir="ltr">@<b class="u-linkComplex-target">RoquanSmith1</b></span></p>
<p>Not many expected Roquan Smith to last out there very long before someone snapped at the chance to grab the former Georgia stand-out. Smith is one of the few linebacker prospects that check every box for me. Great leader and consistently looking for ways to make himself better in that respect? Check. Elite speed and sideline-to-sideline capability? Check. Coverage skills that allow him to hang with tight ends and running backs in space? Check. Surefire instincts and quality tackling technique? Check. Quickness to beat backs to the edge as well as the toughness to get into the hole to make plays for a loss? Check. Elusiveness that allows him to shake blocks? Check. My one criticism is that he is a slightly small for what the Bears are going to ask of him playing inside. Being a little smaller means that he can get swallowed up by the bigs and doesn&#8217;t have the strength or handfighting skills to shed a blocker. That said, Smith doesn&#8217;t really find himself in that situation as often as you think. With the Bears cutting Jerrell Freeman loose after another violation of the PED policy and Christian Jones landing with the Lions, the Bears needed more help for oft-injured ILBs Danny Trevathan and Nick Kwiatkoski. The path to significant playing time has little in the way for Smith and he may already be the best linebacker on his team. Expect three down work for Smith early.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft:</strong> I expect Smith to be a viable fantasy starter in all leagues especially balanced and tackle-heavy leagues. I put him firmly in high-upside LB2 territory for 2018 with the only thing standing between him and LB1 territory is the presence of Danny Trevathan who will vacuum up a fair amount of tackles in his own right if he stays healthy.</p>
<p><strong>Dynasty:</strong> I have Smith as a very close LB2 in this draft for dynasty purposes. I think he is the best linebacker in the draft but his position could put a slight a cap of high-end production. That said, he&#8217;s a great silver medal to get.</p>
<p><strong>Tremaine Edmunds &#8211; 4-3 MLB</strong><br />
6’5” 253 lbs Virginia Tech<br />
Pick 16, Round 1 (16) Bills<br />
Twitter: <span class="username u-dir" dir="ltr">@<b class="u-linkComplex-target">maine_savage23</b></span></p>
<p>Elite athleticism meets dire roster need. This pick was a match made in fantasy heaven. The son of a former NFL tight end, Edmunds combines the size and strength of a defensive end to the speed and coverage ability of a linebacker. It&#8217;s rare to see NFL caliber linebackers that big that can still run with elite speed and cover but Edmunds does it well. Looking at his frame, playing in the 260 lb range wouldn&#8217;t be that unreasonable as long as his speed wasn&#8217;t affected. The obvious benefits of a player like Edmunds are easy to spot. His speed allows him the ability to chase down the play and his strength allows him to sift through the mess to get to and bring down the ballcarrier. He can make plays that smaller linebackers can&#8217;t get away with because his arms are so long and he has the strength to pull it off. His versatility is something that NFL defensive coordinators salivate over. You could place Edmunds anywhere on the field and I bet he could hang. His pass rush chops are battle tested as the former Hokie has 10 sacks to his name from 2016 onward. The downside of Edmunds is like many elite athletes, he relies on being faster and stronger than his opponents to make plays and as such, his instincts and gap discipline are below average. He is getting credit for being a great cover guy but I think he still looks stiff at times when guarding against a real route run on him. However, we have seen in recent years that elite athleticism and opportunity can yield great fantasy results with a guy like Zach Brown even if the NFL-caliber instincts aren&#8217;t there. What excites me most about Edmunds is the fact that he is expected to be replacing Preston Brown in the Bills defense. Brown logged 140 total tackles playing MLB for the Bills last year. With Brown gone to Cincinnati and the Bills not possessing much behind him, Edmunds has arguably the best opportunity of the incoming rookies this year.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft: </strong>Edmunds&#8217; versatility hurts him a bit here as there is risk that the Bills play him outside and kick Matt Milano/Ramon Humber inside. That wouldn&#8217;t be a deathknell to Edmunds&#8217; value but I like him better inside. Edmunds playing MLB places him squarely into LB1 territory in most league scoring types.</p>
<p><strong>Dynasty:</strong> Pairing elite upside and top-tier opportunity gives Edmunds the edge over Smith despite being much farther from a finished product. I&#8217;m taking Edmunds as my dynasty LB1 as long as he remains inside, otherwise I&#8217;m taking Smith.</p>
<p><strong>Leighton Vander Esch &#8211; 4-3 MLB</strong><br />
6’4” 256 lbs Boise State<br />
Pick 19, Round 1 (19) Cowboys<br />
Twitter: <span class="username u-dir" dir="ltr">@</span><span class="username u-dir" dir="ltr"><b class="u-linkComplex-target">VanderEsch38</b></span></p>
<p>With the departure of Anthony Hitchens to Kansas City and some weak roster depth behind him, the Cowboys had a need to fill at linebacker going into the draft. Leighton Vander Esch is a bigger linebacker that can still run and cover. Maybe my favorite attribute of Vander Esch is how smooth he is in everything he does. Economical is a word that sometimes can be associated with lesser athletes that maximize what they have. I would call Vander Esch economical because everything he does is simple and smooth; nothing is robotic. However, that does not say that Vander Esch is a below average athlete as he is very much the opposite. The former Boise State stand out showed his ability running sideline to sideline and solid wrap-up tackling technique while piling up over 10 total tackles a game in his junior year. His coverage ability is surprisingly adept for a bigger guy and he can match elite tight end speed and strength. I like how he manages to shake blockers with speed but needs to work of shedding blocks with power and technique as well. Critics will make mention of the lack of starting experience given that he only had significant snaps last year. That tends lead to over-pursuit and other positioning problems and Vander Esch is no different. Dallas currently has Sean Lee and Jaylon Smith starting at weakside and middle linebacker respectively which likely leaves Vander Esch at strong side. That said, Lee is 31 years old with a storied injury history and while Smith is much younger, his injury history is well-documented also. Lee is signed through the 2019 season but could be a cap casualty at the end of the 2018 season. I expect to see Vander Esch playing part-time snaps in his rookie year in a two-down role but is unlikely to make a fantasy impact this year barring injury to Smith or Lee.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft: </strong>Vander Esch has potential to make a fantasy splash but is unlikely to realize that value in redraft leagues unless Smith or Lee gets hurt. He is bench fodder for deeper leagues at best otherwise as I don&#8217;t see the Cowboys moving away from Smith and Lee otherwise.</p>
<p><strong>Dynasty: </strong>However, I do like Vander Esch as a dynasty pickup that you can wait a year or two on. While you might need to wait, the upside is high as I can see him easily playing three downs and leading the Cowboys&#8217; defense when his time comes to step into that role. I have him as the dynasty LB5 of the draft.</p>
<p><strong>Rashaan Evans &#8211; 3-4 ILB</strong><br />
6’3” 232 lbs Alabama<br />
Pick 22, Round 1 (22) Titans<br />
Twitter: <span class="username u-dir" dir="ltr">@</span><span class="username u-dir" dir="ltr"><b class="u-linkComplex-target">616evans4</b></span></p>
<p>The latest in the seemingly endless supply of quality Alabama linebackers to come to the NFL, Rashaan Evans finds himself in a decent situation in Tennessee. After losing Avery Williamson to the Jets, the Titans were left with Wesley Woodyard (signed through 2019), 2017 5th round pick Jayon Brown and UFA signees Will Compton and Nate Palmer. Williamson played over 650 snaps last year and those plays need to be filled. Evans is a rangy athlete that fits the new mold of what an NFL linebacker needs to be; run sideline to sideline, have above average coverage ability, can chase down edge runners but still be able to shake a block or two from a 300 lb lineman. As has been typical with most Alabama linebackers coming into the NFL, Evans has experience at multiple positions across multiple fronts. His pass rushing ability in both burst and timing might be the best out of any ILB propsect this year because of his experience elsewhere in Nick Saban&#8217;s defense. Evans is a well-trained, well-disciplined linebacker who rarely is caught out of position. He manages his gap well and is able to shake would-be blockers and stay in the play longer than other linebackers would. That said, his leverage and ability to shed blocks once engaged is challenged at times and facing NFL linemen will only exacerbate the problem. I also see him as a touch slow in diagnosing plays. He rarely over-commits but also doesn&#8217;t make plays in the hole as much as he could.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft: </strong>I think that Evans has an easier path to playing time given his competition. However, the Titans have committed to only having one fulltime linebacker in years past and I&#8217;d be hard-pressed to say that it will be anyone other than Woodyard, barring injury. Evans&#8217; ceiling is likely where Avery Williamson finished last year, around LB3/flex range. His big play ability might be a touch better than others if the Titans choose to turn him loose on the pass rush.</p>
<p><strong>Dynasty: </strong>With Woodyard at 31 years old and little else by way of legitimate competition, the path is clear for Evans to assume full command of this defense next year or the year after. In a division that features Andrew Luck and Deshaun Watson, his speed and coverage ability will be critical to the Titans&#8217; success. For that reason, I like him as the dynasty LB4 of the draft.</p>
<p><strong>Darius Leonard &#8211; 3-4 ILB</strong><br />
6’2” 234 lbs South Carolina State<br />
Pick 4, Round 2 (36) Titans<br />
Twitter: <span class="username u-dir" dir="ltr">@<b class="u-linkComplex-target">dsleon45</b></span> ‏</p>
<p>The Colts haven&#8217;t had much fantasy value at the ILB since D&#8217;Qwell Jackson and haven&#8217;t invested a pick higher than a 3rd rounder into the position since Pat Angerer in 2010. Darius Leonard is twitchy kind of linebacker that has very good close range speed and agility to both get himself in position to make a play as well as get himself out of situations where he is washed out of the play by blockers or other bodies. His closing speed to make tackles is elite-caliber and has a plenty of great tape showing him closing out plays with great breakdown and wrap-up. His coverage ability to decent but isn&#8217;t of the quality of the linebackers taken before him in the draft. That said, he might be better than the talent that the Colts currently have. While he plays squarely and seems to be see the field well, he doesn&#8217;t take the best angles every play. Instead, he relies on his athleticism to run around to make a play. He is on the smaller side and doesn&#8217;t look like he is going to get much bigger at the NFL level. At the college level, he struggled with hand-fighting and might lack the pure strength to shed an NFL blocker. The Colts currently feature 2016 4th round pick Antonio Morrison, 2017 5th round pick Anthony Walker and four other rookies in their inside linebacker positions. A good camp might see Leonard take control of the defense. He has four years of starting experience at South Carolina State and the Colts need a leader on that side of the ball.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft: </strong>Leonard has a chance to win a job out of camp given the lack of talent in front of him, this is a camp battle to watch. A fulltime Colts ILB has a ceiling of LB1 as shown by D&#8217;Qwell Jackson whereas it has been a LB2/LB3 position as of late. My guess is that he starts but doesn&#8217;t take 100% of the snaps this year, giving him LB3 value in redraft.</p>
<p><strong>Dynasty: </strong>I think the Colts are looking for Leonard to lead their defense and will give him every opportunity to do so once he is ready. History says that even below average abilities yield LB1-LB2 results for a fulltime Colts ILB. Leonard carries some risk but the upside is high. I&#8217;m taking him as my dynasty LB3 this year.</p>
<p><strong>Fred Warner &#8211; 4-3 OLB</strong><br />
6’3” 236 lbs BYU<br />
Pick 6, Round 3 (70) 49ers<br />
Twitter: <span class="username u-dir" dir="ltr">@<b class="u-linkComplex-target">fred_</b></span><span class="username u-dir" dir="ltr"><b class="u-linkComplex-target">warner</b></span>‏</p>
<p>A two-year starter for the Cougars, Warner is built closely to what I think the 49ers envisioned when they moved Eric Reid down to linebacker but with a touch more size. Warner&#8217;s strengths come in running with pass catchers, quick and smooth changes of direction, above average instincts and great reactionary ability. He is a leader and someone who can positively impact your team on the field with his demeanor. What he needs to get better at is pure tackling ability. He is far from a devastating hitter and frequently attempts arm tackles either due to poor technique or poor angle. He also struggles once engaged by a blocker and his involvement in the play is usually over if his initial attempt doesn&#8217;t shake them. His role might be that of a nickel LB rather than full time. The 49ers currently feature Reuben Foster, Malcolm Smith and Eli Harold as their starters at linebacker. Foster&#8217;s legal troubles currently have him in hot water with the 49ers front office and Smith is returning from a pectoral injury that ended his season last year. It&#8217;s not out of the realm of possibility that Warner plays significant snaps for the 49ers this year but he needs some opportunity and a scheme that is better tailored to his abilities.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft: </strong>Warner needs either Foster or Smith out of his way to make any kind of meaningful fantasy contribution in 2017. I&#8217;m passing in redraft.</p>
<p><strong>Dynasty: </strong>It&#8217;s a steep dropoff after the top 5 guys to the next tier. Warner is one of a handful of guys who have some ability but really don&#8217;t have the path opened up to make an impact. Those guys can be quality fantasy with some luck but you don&#8217;t invest significant draft capital on them. I have Warner as my LB7 of the draft simply due to Foster&#8217;s legal trouble potentially opening a door for him sooner than others in his tier.</p>
<p><strong>Jerome Baker &#8211; 4-3 OLB</strong><br />
6’1” 229 lbs Ohio State<br />
Pick 9, Round 3 (73) Dolphins<br />
Twitter: ‏<span class="username u-dir" dir="ltr">@<b class="u-linkComplex-target">Lastname_Baker</b></span></p>
<p>The Dolphins released Lawrence Timmons this offseason after a tumultuous 2017 campaign which should leave an opening in their linebacking corps but it remains to be seen how the Dolphins juggle their linebackers. Timmons played strongside last year with Mike Hull in the middle and Kiko Alonso on the weakside. Raekwon McMillan is set to return from a knee injury suffered in the preseason last year. Baker is too small to play anywhere but weak side in my opinion. So if McMillan returns to play strongside, Kiko slides to the middle and Baker plays weakside, he has a shot at starting. However, Stephone Anthony is projected to start at strongside. As mentioned before is certainly on the smaller side compared to other at his position. He cannot get engaged by blocks or the play is over for him. He has the poor tackling technique of a big hitter looking for the highlight heel hit without any of the power to back it up. He needs to diagnose the play sooner and wrap up better once he gets there. What I do like about his game is his speed and agility. He can go sideline to sideline and change directions very quickly. He plays faster than his 4.53 forty time would tell you as well. You trust him in coverage against the opposing team&#8217;s gamechangers. From what I&#8217;ve seen of him, I wonder if his NFL future is that of a safety or at least a safety/linebacker hybrid.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft: </strong>It&#8217;s unlikely that Baker starts this year unless injury or a shakeup of positions occurs. Watch training camp reports to confirm but I&#8217;m passing altogether unless it&#8217;s clear that Baker is starting.</p>
<p><strong>Dynasty: </strong>There is a lot of youth in the Dolphins&#8217; linebacking corps right now. Baker might emerge but the Dolphins are high on Alonso (27 years old, signed through 2020) and McMillan (21 years old). I&#8217;m not holding my breath for him unless there&#8217;s a position change in his future. He&#8217;s my LB9 of this draft.</p>
<p><strong>Malik Jefferson &#8211; 4-3 OLB/MLB</strong><br />
6’2” 236 lbs Texas<br />
Pick 14, Round 3 (78) Bengals<br />
Twitter: ‏<span class="username u-dir" dir="ltr">@</span><span class="username u-dir" dir="ltr"><b class="u-linkComplex-target">malikjefferson</b></span></p>
<p>Malik Jefferson is a curious case in that on paper and in shorts, he checks all of the boxes. Height, weight, speed, strength, he even looks like a guy you&#8217;d peg for being an NFL linebacker. And yet despite that, he never seems to equate those attributes into production on gameday. My thoughts are that for all of Jefferson&#8217;s gifts, he doesn&#8217;t have the instincts to play the position. He needs to be in a scheme that lets him have very simple reads, attack one gap or man cover one guy. When he played in more complicated schemes or positions with increased responsibility, he seemed a step or two slower and process time led to missed plays. It will be interesting to see how Cincinnati plays him and those interested should tune into the Bengals preseason games to see where he is slotted in. At the worst, he can play special teams and likely excel. At best, you have an attacking weakside linebacker. The downside of Jefferson&#8217;s opportunity is that Cincinnati is very deep at linebacker. He likely doesn&#8217;t see the field this year much even though Vontaze Burfict is suspended for the first four games of the season.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft: </strong>Lots of things need to happen to see Jefferson make an impact this year in redraft. I doubt he gets 100 snaps.</p>
<p><strong>Dynasty: </strong>Upside is limited here due to depth and what I perceive as limited options in where he can play on the field but the physical gifts are there. I&#8217;m stashing him and waiting a year or two to see what happens to both Jefferson and the guys in front of him. He&#8217;s my LB8 of the draft.</p>
<p><strong>Oren Burks &#8211; 3-4 ILB</strong><br />
6’3” 233 lbs Vanderbilt<br />
Pick 24, Round 3 (88) Packers<br />
Twitter: ‏<span class="username u-dir" dir="ltr">@<b class="u-linkComplex-target">BangTimeBurks</b></span></p>
<p>Similar to many ILBs you&#8217;ve seen on this list, Oren Burks is a smaller ILB who excels in coverage versus many predecessors at the position. In fact, Burks has a season and half of experience at safety playing at Vanderbilt. His hips are very good which allows him the ability to change directions and run with tight ends and runningbacks. He has above average athleticism and impressive quickness where necessary to make plays. Like many other tweener-type players, he struggles to make plays at the line of scrimmage. HE doesn&#8217;t do a great job separating himself from blockers and doesn&#8217;t play with the strength he needs to at times. The Packers currently have Blake Martinez taking virtually all of their snaps but the other ILB starter, Jake Ryan, is on the last year of his contract. The Packers have little else behind them to challenge Burks for playing time if Ryan leaves or either starter is hurt.</p>
<p><strong>Fantasy impact/value</strong></p>
<p><strong>Redraft: </strong>I wouldn&#8217;t be surprised to see Burks sprinkle in for his rookie season but he is not going to be a fantasy impact unless Martinez or Ryan is hurt.</p>
<p><strong>Dynasty: </strong>The Packers are famous for getting their home-grown talent into the lineup at the linebacker positions. Burks should be no different especially if Ryan leaves for a payday elsewhere. He&#8217;s a massive upgrade in coverage ability over Ryan. He&#8217;s my dynasty LB6 of the draft.</p>
<p><b>Best of the Rest</b></p>
<p><strong>Dorian O&#8217;Daniel KCC ILB (3rd round, Clemson)</strong> &#8211; This guy gets my vote of the all-name team for sure. O&#8217;Daniel is currently behind Anthony Hitchens and Reggie Ragland for ILB snaps in Kansas City. He&#8217;s one injury away from relevance.</p>
<p><strong>Josey Jewell DEN ILB (4th round, Iowa)</strong> &#8211; Todd Davis is a below average starter in Denver and Brandon Marshall is far from the picture of health. Little else in the way for the former Hawkeye.</p>
<p><strong>Micah Kiser LAR ILB (5th round, Virginia)</strong> &#8211; The Rams traded away their best linebacker in the offseason in Alec Ogletree and outside of Mark Barron, a converted safety, the Rams have a whole bunch of replacement talent at linebacker. A good camp might earn him some snaps.</p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://thehuddle.com/tag/2018-fantasy-rookies/" rel="tag">2018 fantasy rookies</a>, <a href="http://thehuddle.com/tag/idp/" rel="tag">idp</a>, <a href="http://thehuddle.com/tag/rookie-idp/" rel="tag">rookie IDP</a>, <a href="http://thehuddle.com/category/idp-analysis/" rel="category tag">IDP Analysis</a>, <a href="http://thehuddle.com/category/rookie-analysis/" rel="category tag">Rookie Analysis</a></p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/05/02/top-2018-rookie-linebackers-idp-value/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-backs-idp-value/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-1"
	   title="Top 2018 Rookie Defensive Backs – IDP Value"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/05/10264184-e1525700482850.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/05/10264184-e1525700482850.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Top 2018 Rookie Defensive Backs – IDP Value" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">8 shares</span><span class="block__time block__time--mobile">6d ago</span>
		<h2><a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-backs-idp-value/"
			   title="Top 2018 Rookie Defensive Backs – IDP Value" itemprop="url">
				Top 2018 Rookie Defensive Backs – IDP Value			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-linemen-idp-value/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-2"
	   title="Top 2018 Rookie Defensive Linemen – IDP Value"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/05/104294641-e1525700017197.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/05/104294641-e1525700017197.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Top 2018 Rookie Defensive Linemen – IDP Value" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">6d ago</span>
		<h2><a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-linemen-idp-value/"
			   title="Top 2018 Rookie Defensive Linemen – IDP Value" itemprop="url">
				Top 2018 Rookie Defensive Linemen – IDP Value			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/"
	   data-track="thehuddlefeaturedstories thehuddlemore-related-3"
	   title="2018 Top 12 fantasy rookies"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/10450773-e1525097463796.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/04/10450773-e1525097463796.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2018 Top 12 fantasy rookies" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">78 shares</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/"
			   title="2018 Top 12 fantasy rookies" itemprop="url">
				2018 Top 12 fantasy rookies			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_native", slotName: "/7103/SMG_TheHuddle/native/sports/fantasy/football.general", sizes : [[640,170],[3,1]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_native' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_native"] = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.general", [[640,170],[3,1]], "acm-ad-tag-lawrence_dfp_desktop_native").addService(googletag.pubads().setTargeting('kw',["2018 fantasy rookies","idp","rookie IDP","T.J. Ford","IDP Analysis","Rookie Analysis"]).setTargeting('category',["IDP Analysis","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_native' );
												bidManager.requestBid( 'lawrence_dfp_desktop_native' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_native' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_native' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/07/2018-player-movement-tracker/"
						title="2018 player movement tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/03/usatsi_10407651-e1521158473863.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/03/usatsi_10407651-e1521158473863.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 player movement tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/05/07/2018-player-movement-tracker/"
								title="2018 player movement tracker"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/05/07/2018-player-movement-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/05/07/2018-player-movement-tracker/"
			title="2018 player movement tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/07/2018-player-movement-tracker/"
						title="2018 player movement tracker"
						itemprop="url" 						>
							2018 player movement tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 7, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p> &nbsp; </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/05/fantasy-football-rookie-preview-tight-ends/"
						title="Fantasy football rookie preview: Tight ends"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/05/usatsi_10668727-e1525536248302.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/05/usatsi_10668727-e1525536248302.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Tight ends" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/05/05/fantasy-football-rookie-preview-tight-ends/"
								title="Fantasy football rookie preview: Tight ends"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/05/05/fantasy-football-rookie-preview-tight-ends/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/05/05/fantasy-football-rookie-preview-tight-ends/"
			title="Fantasy football rookie preview: Tight ends"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>16</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/05/fantasy-football-rookie-preview-tight-ends/"
						title="Fantasy football rookie preview: Tight ends"
						itemprop="url" 						>
							Fantasy football rookie preview: Tight ends					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Which rookie tight ends should #fantasyfootball owners target? </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/04/fantasy-football-rookie-preview-wide-receivers/"
						title="Fantasy football rookie preview: Wide receivers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/05/usatsi_10819406-e1525478482396.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/05/usatsi_10819406-e1525478482396.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Wide receivers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/05/04/fantasy-football-rookie-preview-wide-receivers/"
								title="Fantasy football rookie preview: Wide receivers"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/05/04/fantasy-football-rookie-preview-wide-receivers/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/05/04/fantasy-football-rookie-preview-wide-receivers/"
			title="Fantasy football rookie preview: Wide receivers"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>57</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/04/fantasy-football-rookie-preview-wide-receivers/"
						title="Fantasy football rookie preview: Wide receivers"
						itemprop="url" 						>
							Fantasy football rookie preview: Wide receivers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 4, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Making #fantasyfootball sense of the rookie WRs selected in the NFL draft. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/03/fantasy-football-rookie-preview-running-backs/"
						title="Fantasy football rookie preview: Running backs"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/05/usatsi_10684620-e1525387604465.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/05/usatsi_10684620-e1525387604465.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Running backs" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/05/03/fantasy-football-rookie-preview-running-backs/"
								title="Fantasy football rookie preview: Running backs"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/05/03/fantasy-football-rookie-preview-running-backs/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/05/03/fantasy-football-rookie-preview-running-backs/"
			title="Fantasy football rookie preview: Running backs"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>49</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/03/fantasy-football-rookie-preview-running-backs/"
						title="Fantasy football rookie preview: Running backs"
						itemprop="url" 						>
							Fantasy football rookie preview: Running backs					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 3, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Analyzing the #fantasyfootball prospects for all running backs chosen in the NFL draft. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/02/fantasy-football-rookie-preview-quarterbacks/"
						title="Fantasy football rookie preview: Quarterbacks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/05/usatsi_10807886-e1525289762691.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/05/usatsi_10807886-e1525289762691.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Quarterbacks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/05/02/fantasy-football-rookie-preview-quarterbacks/"
								title="Fantasy football rookie preview: Quarterbacks"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/05/02/fantasy-football-rookie-preview-quarterbacks/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/05/02/fantasy-football-rookie-preview-quarterbacks/"
			title="Fantasy football rookie preview: Quarterbacks"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>13</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/02/fantasy-football-rookie-preview-quarterbacks/"
						title="Fantasy football rookie preview: Quarterbacks"
						itemprop="url" 						>
							Fantasy football rookie preview: Quarterbacks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Breaking down the value of every rookie quarterback drafted and how they fit into #fantasyfootball plans.  </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-backs-idp-value/"
						title="Top 2018 Rookie Defensive Backs – IDP Value"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/05/10264184-e1525700482850.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/05/10264184-e1525700482850.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Top 2018 Rookie Defensive Backs – IDP Value" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-backs-idp-value/"
								title="Top 2018 Rookie Defensive Backs – IDP Value"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-backs-idp-value/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-backs-idp-value/"
			title="Top 2018 Rookie Defensive Backs – IDP Value"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>8</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-backs-idp-value/"
						title="Top 2018 Rookie Defensive Backs – IDP Value"
						itemprop="url" 						>
							Top 2018 Rookie Defensive Backs – IDP Value					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/jayarr47/" title="Posts by Joe Redemann" class="author url fn" rel="author">Joe Redemann</a>													</span>
					</p>
				</footer>

				<p>Top rookie IDP defensive backs entering the 2018 fantasy football season. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-linemen-idp-value/"
						title="Top 2018 Rookie Defensive Linemen – IDP Value"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/05/104294641-e1525700017197.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/05/104294641-e1525700017197.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Top 2018 Rookie Defensive Linemen – IDP Value" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-linemen-idp-value/"
								title="Top 2018 Rookie Defensive Linemen – IDP Value"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-linemen-idp-value/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-linemen-idp-value/"
			title="Top 2018 Rookie Defensive Linemen – IDP Value"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/02/top-2018-rookie-defensive-linemen-idp-value/"
						title="Top 2018 Rookie Defensive Linemen – IDP Value"
						itemprop="url" 						>
							Top 2018 Rookie Defensive Linemen – IDP Value					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/stevegallonfl/" title="Posts by Steve Gallo" class="author url fn" rel="author">Steve Gallo</a>													</span>
					</p>
				</footer>

				<p>Top IDP rookie defensive linemen entering the 2018 fantasy football season. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/01/2018-fantasy-football-rookie-rankings/"
						title="2018 fantasy football rookie dynasty rankings"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10511607-e1522712387738.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10511607-e1522712387738.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 fantasy football rookie dynasty rankings" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/05/01/2018-fantasy-football-rookie-rankings/"
								title="2018 fantasy football rookie dynasty rankings"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/05/01/2018-fantasy-football-rookie-rankings/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/05/01/2018-fantasy-football-rookie-rankings/"
			title="2018 fantasy football rookie dynasty rankings"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>123</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/05/01/2018-fantasy-football-rookie-rankings/"
						title="2018 fantasy football rookie dynasty rankings"
						itemprop="url" 						>
							2018 fantasy football rookie dynasty rankings					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 1, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Positional fantasy football rankings for skill players chosen in the 2018 #NFLDraft  </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/"
						title="2018 Top 12 fantasy rookies"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/10450773-e1525097463796.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/10450773-e1525097463796.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 Top 12 fantasy rookies" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/"
								title="2018 Top 12 fantasy rookies"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/"
			title="2018 Top 12 fantasy rookies"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>78</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/"
						title="2018 Top 12 fantasy rookies"
						itemprop="url" 						>
							2018 Top 12 fantasy rookies					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 30, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>After months of speculation and analysis, the NFL Draft is over. Now we have one of the most critical pieces of information &#8211; where (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-round/"
						title="2018 NFL Draft by Round"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10805882-e1524969524383.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10805882-e1524969524383.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2018 NFL Draft by Round" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-round/"
								title="2018 NFL Draft by Round"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/04/28/2018-nfl-draft-by-round/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-round/"
			title="2018 NFL Draft by Round"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/nfl-draft/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-round/"
						title="2018 NFL Draft by Round"
						itemprop="url" 						>
							2018 NFL Draft by Round					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 28, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Complete 2018 NFL Draft listed by round. </p>

				
				
			</div>
		</article>
	</div>
<a href="http://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
			<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>		</div>

		
		<div class="widget widget--login widget--box" id="login_widget-3"><div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget_usat_sidebar_top_posts_widget" id="usat_sidebar_top_posts_widget-2">		<div class="col1 right" id="sticky-sidebar">
				<div class="heading-small">
		<h2>Popular <span>Now</span></h2>
	</div>
	
					<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/04/usatsi_10511607-e1522712387738.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/05/01/2018-fantasy-football-rookie-rankings/?utm_source=thehuddle&#038;utm_medium=recirc&#038;utm_campaign=rail-most-popular" title="2018 fantasy football rookie dynasty rankings" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/04/usatsi_10511607-e1522712387738.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 fantasy football rookie dynasty rankings" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				1w			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/05/01/2018-fantasy-football-rookie-rankings/?utm_source=thehuddle&#038;utm_medium=recirc&#038;utm_campaign=rail-most-popular" title="2018 fantasy football rookie dynasty rankings" itemprop="url" >2018 fantasy football rookie dynasty rankings</a></p>
				<p class="widget-date">May 1, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/05/usatsi_10684620-e1525387604465.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/05/03/fantasy-football-rookie-preview-running-backs/?utm_source=thehuddle&#038;utm_medium=recirc&#038;utm_campaign=rail-most-popular" title="Fantasy football rookie preview: Running backs" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/05/usatsi_10684620-e1525387604465.jpg?w=100&#038;h=100&#038;crop=1" alt="Fantasy football rookie preview: Running backs" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				5d			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/05/03/fantasy-football-rookie-preview-running-backs/?utm_source=thehuddle&#038;utm_medium=recirc&#038;utm_campaign=rail-most-popular" title="Fantasy football rookie preview: Running backs" itemprop="url" >Fantasy football rookie preview: Running backs</a></p>
				<p class="widget-date">May 3, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/05/usatsi_10668727-e1525536248302.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/05/05/fantasy-football-rookie-preview-tight-ends/?utm_source=thehuddle&#038;utm_medium=recirc&#038;utm_campaign=rail-most-popular" title="Fantasy football rookie preview: Tight ends" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/05/usatsi_10668727-e1525536248302.jpg?w=100&#038;h=100&#038;crop=1" alt="Fantasy football rookie preview: Tight ends" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				3d			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/05/05/fantasy-football-rookie-preview-tight-ends/?utm_source=thehuddle&#038;utm_medium=recirc&#038;utm_campaign=rail-most-popular" title="Fantasy football rookie preview: Tight ends" itemprop="url" >Fantasy football rookie preview: Tight ends</a></p>
				<p class="widget-date">May 5, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathuddle.files.wordpress.com/2018/04/10450773-e1525097463796.jpg?w=480');" data-track="thehuddlemostshared" href="http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/?utm_source=thehuddle&#038;utm_medium=recirc&#038;utm_campaign=rail-most-popular" title="2018 Top 12 fantasy rookies" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathuddle.files.wordpress.com/2018/04/10450773-e1525097463796.jpg?w=100&#038;h=100&#038;crop=1" alt="2018 Top 12 fantasy rookies" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2w			</div>
			<div class="text-block">
												<p><a data-track="thehuddlemostshared" href="http://thehuddle.com/2018/04/30/2018-top-12-fantasy-rookies/?utm_source=thehuddle&#038;utm_medium=recirc&#038;utm_campaign=rail-most-popular" title="2018 Top 12 fantasy rookies" itemprop="url" >2018 Top 12 fantasy rookies</a></p>
				<p class="widget-date">April 30, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
		
		</div>
		</div><div class="widget widget--links widget--box" id="links_widget-8"><div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="http://www.thehuddle.com/2018-nfl-depth-charts.php">2018 fantasy depth charts</a></li>
<li id="menu-item-434831" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434831"><a href="http://thehuddle.com/2018/04/19/2018-top-free-agent-tracker/">2018 top free agent tracker</a></li>
<li id="menu-item-434830" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434830"><a href="http://thehuddle.com/2018/05/07/2018-player-movement-tracker/">2018 player movement tracker</a></li>
<li id="menu-item-434533" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434533"><a href="http://thehuddle.com/2018/02/20/2018-coaching-change-tracker/">2018 coaching change tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7"><div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="http://www.thehuddle.com/2018-nfl-depth-charts.php">2018 fantasy depth charts</a></li>
<li id="menu-item-435449" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435449"><a href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-team-by-week-grid/">2018 NFL Schedule - Team by Week Grid</a></li>
<li id="menu-item-435450" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435450"><a href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-weekly-grid/">2018 NFL Schedule - Weekly Grid</a></li>
<li id="menu-item-435612" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435612"><a href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-round/">2018 NFL Draft by Round</a></li>
<li id="menu-item-435613" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435613"><a href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-team/">2018 NFL Draft by Team</a></li>
<li id="menu-item-435614" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435614"><a href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-position/">2018 NFL Draft by Position</a></li>
<li id="menu-item-434832" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434832"><a href="http://thehuddle.com/2018/02/06/2018-nfl-important-dates/">2018 NFL important dates</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-4"><div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="http://www.thehuddle.com/stats/2017/plays_std.php">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="http://www.thehuddle.com/stats/2017/plays_weekly.php">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="http://www.thehuddle.com/stats/2017/gamescan.php">Weekly Fantasy Box Scores</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="http://www.thehuddle.com/stats/2017/tpr.php">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="http://www.thehuddle.com/stats/2017/tpm.php">Team Position Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="http://www.thehuddle.com/stats/2017/gsm.php">Game Stats Matchups</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="http://thehuddle.com/myHuddle/sos.php">Strength of Schedule Tool</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget--forum widget--box" id="forum_widget-3"><div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/" class="" rel="" target=""><img width="1000" height="1000" src="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg 1000w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=150&amp;h=150 150w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300&amp;h=300 300w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=768&amp;h=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="429990" data-permalink="http://thehuddle.com/blitz/" data-orig-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" data-orig-size="1000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Blitz" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=1000" /></a></div>
		<div class="widget sidebar-ad bottom">
			<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250", slotName: "/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", sizes : [[300,250],[300,600]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_bottom_300x250"] = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250").addService(googletag.pubads().setTargeting('kw',["2018 fantasy rookies","idp","rookie IDP","T.J. Ford","IDP Analysis","Rookie Analysis"]).setTargeting('category',["IDP Analysis","Rookie Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_2a"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' );
												bidManager.requestBid( 'lawrence_dfp_desktop_bottom_300x250' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>		</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="http://static.usatoday.com/privacy/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="http://static.usatoday.com/terms/">Terms of Service</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="http://static.usatoday.com/privacy/#adchoices">Ad Choices</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="The Huddle">
				<a class="mobile-nav__breadcrumb" href="http://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-kit"><a href="http://thehuddle.com/2017-draft-kit/">Draft Kit</a></li>
<li class="mobile-nav__item mobile-nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li class="mobile-nav__item mobile-nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="/2018-nfl-depth-charts.php">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://static.usatoday.com/privacy/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://static.usatoday.com/terms/">Terms of Service</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="http://static.usatoday.com/privacy/#adchoices">Ad Choices</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>
<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="http://thehuddle.com/login.php" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201819y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="114275906" />
				<input type="hidden" id="carousel-reblog-blog-url" value="http://thehuddle.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Huddle" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="86fd20b94c" /><input type="hidden" name="_wp_http_referer" value="/2018/05/02/top-2018-rookie-linebackers-idp-value/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVy0EOQDAQheELqVGCWIizUBNabZVRHB+xYSOx/d/7YHNMjHZBu4AiaHGVAt0eKgrgMRnPnPadtARaDkgwefTY17bVOH+cxWjMmdiN1KUboE06/INe4YSVKXnKC57HSRapAyLtR9U='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"0"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"","maxDistance":"250","medAdHeight":"0","maxDistanceMed":"0","largeAdHeight":"0","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var huddleUser = {"nameAPI":"http:\/\/thehuddle.com\/api\/get_user_name.php","cookie":"huddle-auth"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/thehuddle.com\/wp-admin\/admin-ajax.php","nonce":"5cd1228b1e","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathuddle.wordpress.com\/wp-login.php?redirect_to=http%3A%2F%2Fthehuddle.com%2F2018%2F05%2F02%2Ftop-2018-rookie-linebackers-idp-value%2F","blog_id":"114275906","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=114275906&v=wpcom&tz=-4&user_id=0&subd=usathuddle","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJydUtFuwjAM/KG52ZAq2MO0bzGpBS5p0sVJWff1c9lakMpY4a265s6+85ljCzb4RD6ZtKeGxHTcmiyYQoU9tC7v2IuRxPbQA3vHnqDjioKY+jpe1PJk/tF1eIzkLQ0ajrem/sgU+8KGcGC6V6BB9vdyEqHj3AB96nPh4GdrN3lyv4JBpz7JAXp0vdq+5XMkOvzSsQEreC7Wg8CvTwkeY9HcXPtPjQlY4nlUOaLglgd6TuwW3WhO9djxDpOm9RhftB9bNf4QGaOG7haVY05eWpGRqf9gn6vKncqyrJLXuVkoggZ3o15YaRNAg9E1JVHULwgdxahxyRm7UyFFtIfp0Oyty4PccIb2HMYl/lPOqaPtPLKLkRZjUG/O1JRanQQjoJz35u2lXJXr13KzKetviKym7g=='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-4','user_id':'0','post':'435553','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-4&user_id=0&post=435553&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6MXJIUnBFTVRrRUw3dWtuUjd4VEZBLS9OSXhRcG1wM2suXUxDZVlLNkt5MXIwMGdQWytMbFR1aDN3SGRPazk2TC1aUkdHN1BMek0lP05OZmQxc1A9eXEzY3htWUssJkhxWCxvYWJMTGh6WkI3P2R6bzdEbll3aGQsUWR5VWd8aGhR'}]);
_stq.push([ 'clickTrackerInit', '114275906', '435553' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated 271 seconds ago
	generated in 0.246 seconds
	served from batcache in 0.003 seconds
	expires in 29 seconds
-->
