<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="A game-by-game breakdown of the fantasy football impact of Sunday’s action." /><meta name="news_keywords" content="fantasy football,%tags%,%cats%" />
<meta name="keywords" content="fantasy football,fantasy game recaps, fantasy impact,game analysis" />
<title>Fantasy impact of Week 6</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1539599011&amp;back=http%3A%2F%2Fthehuddle.com%2F2018%2F10%2F15%2Ffantasy-impact-of-week-6-5%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Feed" href="http://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Comments Feed" href="http://thehuddle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Fantasy impact of Week 6 Comments Feed" href="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1532082729h&ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJylkNFOwzAMRX+IEFWwTTwgXvkDnt3EpF6dOGrSVf37pYs2GIyCxEvkm9zj61hPURkJGUPWflSRR0ch6Ska8Sp5Ypy/qHuT0p2+jTH1mPQecwTTq5NasxsZsNz7CHlxeLQEyOiLbQ3zcXumlrIrWasxdfy2jQOmpMrpafQqdyXol/H8Mkr9hy7G65uKkg6SqdDpUnzrWaP0gaIeE2SxMF9CUmH6WVFgCqgOZFFq1q2HP3VmmAYMBs+Pb5CgpX+g+nW0lnF1xWQd5jK0GAJWdR+fxRrsUBSLgUwSroR6Z6BhDR2wZXGldKedfcifvts9asfSAi+GF//cbB6emma32W33R4uAJXw=?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFjt0KwjAMRl/Irm7DCy/EZ8naOFPXH5t2ZT69HeiFOBQCgeTk5JMlCHJqyhpZmlr3jHF5tcbwTv4ChKUxQsLGknvDyruELq2s9QNNKDJjhLHOqujiN7jgOVlkrtDG9jMSuZmw/MUMpgDqJiIyPb6s6Yr1n5wpyMyQvIZFTFAiOoWrayCtMQoLrkaK9fpsT+2h79p91x578wTGP3Mx'></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=4.9.8'></script>
<script type='text/javascript'>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:thehuddle","priority_asset":"","blogname":"thehuddle","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"438166","headline":"Fantasy impact of Week 6","byline":"Thomas Casale","taxonomykeywords":"fantasy game recaps, fantasy impact"};
/* ]]> */
</script>
<script type='text/javascript'>
			utag_data.clickPage = sessionStorage.getItem( "clickPage" );
			sessionStorage.setItem( "clickPage", window.location.href );
			
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/thehuddle3/prod/utag.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script type='text/javascript' src='//s3.amazonaws.com/smg-gdpr/geo-check-1.js?ver=4.9.8'></script>
<script type='text/javascript' src='//s3.amazonaws.com/smg-gdpr/geo-check-2.js?ver=4.9.8'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p7JunM-1PZc' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F10%2F15%2Ffantasy-impact-of-week-6-5%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fthehuddle.com%2F2018%2F10%2F15%2Ffantasy-impact-of-week-6-5%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Fantasy impact of Week 6" />
<meta property="og:url" content="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/" />
<meta property="og:description" content="A game-by-game breakdown of the fantasy football impact of Sunday’s action." />
<meta property="article:published_time" content="2018-10-15T04:19:48+00:00" />
<meta property="article:modified_time" content="2018-10-15T04:19:48+00:00" />
<meta property="og:site_name" content="The Huddle" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2018/10/11443426-e1539577168438.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:text:title" content="Fantasy impact of Week 6" />
<meta name="twitter:image" content="https://usathuddle.files.wordpress.com/2018/10/11443426-e1539577168438.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="http://thehuddle.com/osd.xml" title="The Huddle" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

<meta name="gdpr" content="false" />
	<script>
	/* Wrapper for USA TODAY Sports Media Group, generated on 2018-09-06T18:02:09-04:00 */
	(function() {
		var w = window;
		var h = 'clarium.global.ssl.fastly.net';
		w._clrm = w._clrm || {};
		w._clrm.gpt = {
			propertyId: 'FvW3szAY_s729BZEa4_yfA6omyQ',
			confiantCdn: h,
			mapping: 'W3siaSI6MiwidCI6Int7b319Ont7d319eHt7aH19IiwicCI6MCwiRCI6MSwiciI6W119LHsiaSI6NiwidCI6Int7Y299fTp7e3d9fXh7e2h9fSIsInAiOjUwLCJEIjowLCJyIjpbeyJ0IjoiZXgiLCJzIjpudWxsLCJ2IjoiY28ifV19XQ==',
			activation: '|co|ex|MQ==,|||MjE1MzMyMjYzOA==,|||MjE3MDkwMDc5Mg==,|||MjE3MDkwNDg3NQ==,|||MjE3MDkxMzQyOA==,|||MjE3MDkxOTQzMQ==,|||MjE3MDk5ODkyNw==,|||MjE3MTAwMjIzNQ==,|||MjE3MTAxMDYyMQ==,|||MjE3MTAxODI4OQ==,|||MjE3MTAyNzQ0MQ==,|||MjI1MTA0MzcyOQ==,|||MjI1MTA1NDc2OQ==,|||MjI1MTA2MDI2OA==,|||MjI1MTIxMzY0OA==,|||MjI1MTQ2MTExNA==,|||MjI1MTQ3NDk1Ng==,|||MjI1MTQ3NTY0Ng==,|||MjI1MTQ4MTI1Ng==,|||MjI1MTQ5Mjk2OA==,|||MjI3NDkzNjIwOQ==,|||MjI3NTA0NzM0MA==,|||MjI3NTA1MjU5Mw==,|||MjI3NTA1NTkxNA==,|||MjI3NTA1OTU2OA==,|||MjI3NTA2NjIxMw==,|||MjI3NTM2MDI5OQ==,|||MjI3NTM2MzEzMQ==,|||MjI3NTM2NTc3Nw==,|||MjM0ODM1MTY0Mg==,|||MjM0ODcwODI4Nw==,|||MjM0ODcxMTQ0OQ==,|||MjM0ODg5Mzg4Ng==,|||MjM0ODkxMzExMw==,|||MjM0ODkxNDQ0Mg==,|||MjM0OTA4ODAyMw==,|||MjM0OTYyMjI5OQ==,|||MjM1ODc3MDExMg==,|||MjMyMzk1OTAwMg==,|||MjMyMzk2MDczOQ==,|||MjMyMzk2NjMxMw==,|||MjMyMzk3MTI3Mg==,|||MjMyNDE4MjUyOA==,|||MjMyNDE5OTc1NA==,|||MjMyNDIwMzQzNQ==,|||MjMyNDU3NjgyOQ==,|||MjMyNDU4MzQ4OQ==,|||MjE1MzE2NTcxMw==,|||MjE1MzkwODk2NQ==,|||MjE1MzkwNzAwNg==,|||MjE1MjY4OTA0NA==,|||MjE1MjU3NDYyNQ==,|||MjE1MjU1NDkyMw==',
			callback: function(blockingType, blockingId, isBlocked, wrapperId, tagId, impressionData) {
				console.log("w00t one more bad ad nixed.", arguments);
			}
		};
		var e = document.createElement('script');
		e.async = true;
		e.src = '//' + h + '/gpt/a/wrap.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(e, s);
	})();
	</script>
	<meta property="categoryId" content="2048" /><style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.newsletter-modal {
	border-top: solid 8px #dd9933;
}

.article__back {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#dd9933, #dd9933)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

.smg-event__ctabutton {
	background-color: #dd9933;
	box-shadow: 0 2px 0 0 #dd9933;
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Huddle" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Fantasy Football Cheat Sheets, Rankings, Sleepers &amp; Award Winning Draft Advice" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://thehuddle.com/feed/;icon-uri=http://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["fantasy game recaps","fantasy impact","Thomas Casale","Game Analysis"],"category":"Game Analysis","referrer":"","isMobile":"0"};
	dfpTargetingObject.level2adunit = "SMG_TheHuddle";
	googletag_cmd_push(function() {
window.lawrence_dfp_desktop_skin = googletag.defineSlot("/7103/SMG_TheHuddle/skin/sports/fantasy/football.general", [1,1], "acm-ad-tag-lawrence_dfp_desktop_skin").addService(googletag.pubads().setTargeting('kw',["fantasy game recaps","fantasy impact","Thomas Casale","Game Analysis"]).setTargeting('category',["Game Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["skin"]);window.lawrence_dfp_desktop_top = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.main", ['fluid',[728,90],[970,66],[970,250]], "acm-ad-tag-lawrence_dfp_desktop_top").addService(googletag.pubads().setTargeting('kw',["fantasy game recaps","fantasy impact","Thomas Casale","Game Analysis"]).setTargeting('category',["Game Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);window.lawrence_dfp_desktop_top_300x250 = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_1a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_top_300x250").addService(googletag.pubads().setTargeting('kw',["fantasy game recaps","fantasy impact","Thomas Casale","Game Analysis"]).setTargeting('category',["Game Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_1a"]);window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();

googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

bidManager.initialize();
});
</script>
<link rel="amphtml" href="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-438166 single-format-aside mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_outstream", slotName: "/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", sizes : [4,1] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_outstream"] = googletag.defineSlot("/7103/SMG_TheHuddle/outstream/sports/fantasy/football.general", [4,1], "acm-ad-tag-lawrence_dfp_desktop_outstream").addService(googletag.pubads().setTargeting('kw',["fantasy game recaps","fantasy impact","Thomas Casale","Game Analysis"]).setTargeting('category',["Game Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["outstream"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_outstream' );
												bidManager.requestBid( 'lawrence_dfp_desktop_outstream' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_outstream' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_outstream' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="http://thehuddle.com"
				title="The Huddle"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="The Huddle"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Huddle" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-435881" class="nav__item nav__item--draft-kit"><a href="http://thehuddle.com/2018-fantasy-football-draft-kit/">Draft Kit</a></li>
<li id="menu-item-428295" class="nav__item nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li id="menu-item-428296" class="nav__item nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-424408" class="nav__item nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li id="menu-item-429328" class="nav__item nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li id="menu-item-424410" class="nav__item nav__item--depth-charts"><a href="/2018-nfl-depth-charts.php">Depth Charts</a></li>
<li id="menu-item-424627" class="nav__item nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li id="menu-item-424411" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-424412" class="nav__item nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li id="menu-item-424413" class="nav__item nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li id="menu-item-424995" class="nav__item nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-438166" class="post-438166 post type-post status-publish format-aside has-post-thumbnail hentry category-game-analysis tag-fantasy-game-recaps tag-fantasy-impact post_format-post-format-aside article--no-image" itemscope
				itemtype="http://schema.org/NewsArticle">

				<div class="article__title article__title--no-image ">
	<h1 class="article__headline">Fantasy impact of Week 6</h1>

	</div>
<h1 class="article__headline article__headline--mobile">Fantasy impact of Week 6</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://thehuddle.com/category/game-analysis/" class="" itemprop="articleSection">Game Analysis</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Fantasy impact of Week 6</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a> 
		<span class="post-date updated">October 15, 2018</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/ThePigskinGuy" class="twitter-follow-button" data-show-count="false">
					Follow					@ThePigskinGuy				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					
				</header>

				
				
									<div class="fullwidth-article-format">
				
				
				<div id="content-container">
					<div class="entry-content ">

						
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a>		| October 15, 2018		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/ThePigskinGuy" class="twitter-follow-button" data-show-count="false">
		Follow @ThePigskinGuy	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p><strong>Falcons 34 Buccaneers 29</strong></p>
<p>This was expected to be a high-scoring game and it didn&#8217;t disappoint. Both quarterbacks had big days with Matt Ryan throwing for 354 yards and three touchdowns, while Jameis Winston threw for 395 yards with four scores and two interceptions.</p>
<p><strong>Extra Points: </strong>O.J. Howard was expected to miss 2-4 weeks with a sprained MCL but returned Sunday to post four catches, 62 yards and a touchdown. Howard has now gained at least 50 yards receiving in every game this season other than the one he left early with the knee injury…Julio Jones exploded for 10 receptions and 143 yards but he still hasn&#8217;t scored a touchdown this season. Ito Smith scored a touchdown for the third-straight week. The world doesn&#8217;t even make sense anymore.</p>
<p><strong>Texans 20 Bills 13</strong></p>
<p>The Texans&#8217; defense was a popular play this week and they delivered with two sacks and two interceptions, including a pick six of Nathan Peterman to break a 13-13 tie late in the fourth quarter and give Houston the win.</p>
<p><strong>Extra Points: </strong>Deshaun Watson&#8217;s streak of three straight games with at least 375 yards passing came to an end. The Bills&#8217; defense harassed Watson all game long and held him to 177 yards, one touchdown and two interceptions…Buffalo has been tough on receivers this year and that continued on Sunday. However, DeAndre Hopkins (6/63) did manage to catch a touchdown to save his fantasy day…LeSean McCoy racked up 94 total yards. That&#8217;s about as good as it gets for McCoy owners in the Bills&#8217; struggling offense.</p>
<p><strong>Steelers 28 Bengals 21</strong></p>
<p>No Le&#8217;Veon Bell, no problem for the Steelers&#8217; offense. James Conner continues to impress with 111 yards and two touchdowns on 19 carries. Conner added four receptions in what turned out to be another big fantasy day for him while Bell sits out.</p>
<p><strong>Extra Points: </strong>It&#8217;s hard to argue against the Steelers not having the best receiving tandem in the NFL with Antonio Brown and JuJu Smith-Schuster. The duo continued to dominate on Sunday. Smith-Schuster caught seven balls for 111 yards, while Brown added five receptions for 105 yards and a touchdown…Like the Steelers, the Bengals have two stud receivers in A.J. Green and Tyler Boyd. It was Boyd who had the big game on Sunday with seven receptions for 62 yards and two touchdowns.</p>
<p><strong>Chargers 38 Browns 14</strong></p>
<p>The Chargers ran the ball down Cleveland&#8217;s throat Sunday. Melvin Gordon was the star with 132 yards and three touchdowns on 18 carries. Backup Austin Ekeler added 60 yards as the Chargers rushed for 246 yards on the day.</p>
<p><strong>Extra Points: </strong>With the running game rolling, Philip Rivers didn&#8217;t have to do much. River threw for a workmanlike 207 yards, two touchdowns and an interception…Tyrell Williams only caught three passes against the Browns but they went for 118 yards and two touchdowns…Baker Mayfield struggled versus the Chargers&#8217; defense. The rookie completed just 22 of 46 passes for 238 yards, one touchdown and two interceptions. Mayfield was also sacked five times.</p>
<p><strong>Jets 42 Colts 34</strong></p>
<p>In what turned out to be a wild shootout, Andrew Luck threw for 301 yards and four touchdowns, although Luck was also picked off three times. Rookie Sam Darnold continues to play better. Darnold threw for 280 yards, two touchdowns and an interception.</p>
<p><strong>Extra Points: </strong>Marlon Mack is finally healthy and that&#8217;s bad news for Nyheim Hines owners. Mack got 13 touches and recorded 93 total yards, while Hines gained just 35 yards on five touches…Eric Ebron&#8217;s resurgence with the Colts has been of the fantasy surprises this season. Ebron caught four passes for 71 yards and a score. He now has six touchdowns on the season…After being questionable all week. Isaiah Crowell was a non-factor, rushing 13 times for 40 yards.</p>
<p><strong>Seahawks 27 Raiders 3</strong></p>
<p>The Raiders&#8217; tough start to the season didn&#8217;t get any better on Sunday. Russell Wilson threw for 222 yards, three touchdowns and an interception in Seattle&#8217;s blowout win in London.</p>
<p><strong>Extra Points: </strong>Doug Baldwin had a nice bounce back week after catching just one ball for one yard against the Rams. Baldwin hauled in 6 of 8 targets for 91 yards…Marshawn Lynch was hoping for a big game against his former team but after falling behind early, Lynch got just 13 carries and was held to 45 yards…Amari Cooper (head) left the game early and didn&#8217;t return.  Cooper and Jordy Nelson combined for only two receptions for six yards on four targets.</p>
<p><strong>Redskins 23 Panthers 17</strong></p>
<p>This wasn&#8217;t a great game for fantasy performances unless you&#8217;re a Cam Newton owner. Despite coming up short on the scoreboard, Newton threw for 275 yards, two touchdowns and an interception. Newton also ran for 43 yards.</p>
<p><strong>Extra Points: </strong>Newton ended up being the Panthers&#8217; leading rusher because Christian McCaffrey was completely shut down. McCaffrey was held to 20 yards on just eight carries. He did catch seven balls for 46 yards but it was a quiet day overall for McCaffrey…Devin Funchess was the Panthers&#8217; leading receiver with five receptions, 74 yards and a touchdown…Adrian Peterson had another solid fantasy day, rushing for 97 yards on 17 carries.</p>
<p><strong>Vikings 27 Cardinals 17</strong></p>
<p>The Vikings came into this game last in the NFL in rushing offense. The Cardinals came in second to last in rushing defense. Something had to give and it was Arizona&#8217;s defense. With Dalvin Cook inactive, Latavius Murray exploded for 155 yards and a touchdown on 24 carries.</p>
<p><strong>Extra Points: </strong>With Murray running over the Cardinals&#8217; defense, Kirk Cousins and the Vikings&#8217; passing game had a rare slow day. Cousins threw for only 233 yards and a touchdown. However, one player that didn&#8217;t stay quiet was Adam Thielen. Thielen caught 11 passes for 123 yards and a touchdown. It&#8217;s Thielen&#8217;s sixth straight 100-yard game to start the season…One bright spot for the Cardinals is rookie receiver Christian Kirk. Kirk caught six passes for 77 yards and he&#8217;s shown a strong connection with rookie quarterback Josh Rosen. Kirk has 162 yards in his last two games.</p>
<p><strong>Dolphins 31 Bears 28</strong></p>
<p>In the second biggest surprise of the day, the Dolphins scored 31 points on the Bears&#8217; defense. The biggest surprise was the performance of Brock Osweiler. Starting for the injured Ryan Tannehill, Osweiler threw for 380 yards, three touchdowns and two interceptions in leading Miami to the upset win.</p>
<p><strong>Extra Points: </strong>Not to be outdone, Frank Gore came out of nowhere to rush for 101 yards on 15 carries in his best game of the year…Albert Wilson was another player many fantasy owners didn&#8217;t start but he came through with six receptions for 155 yards and two touchdowns. Wilson now has four touchdowns on the season…Mitchell Trubisky followed up his six-touchdown day with 316 yards, three scores and an interception…Tarik Cohen is becoming a fantasy stud. For the second straight game, Cohen went over 100 total yards (121) and scored.</p>
<p><strong>Rams 23 Broncos 20</strong></p>
<p>This just in: Todd Gurley is good. Gurley rewarded owners once again who took him with the No. 1 overall pick. Gurley ran the ball 28 times for 208 yards and two more touchdowns. He has 11 touchdowns through the first six games.</p>
<p><strong>Extra Points: </strong>With Cooper Kupp hurting, Robert Woods was the Rams&#8217; receiver who stepped up against Denver. Woods caught 7 of 10 targets for 109 yards…The Broncos&#8217; passing game has been inconsistent this season but both Emmanuel Sanders and Demaryius Thomas found the end zone on Sunday. Sanders caught seven passes for 115 yards and a score, while Thomas hauled in three balls for 57 yards and a touchdown.</p>
<p><strong>Cowboys 40 Jaguars 7</strong></p>
<p>There are surprising performances and then there&#8217;s the struggling Cowboys&#8217; offense hanging 40 points on Jacksonville&#8217;s No. 1 ranked defense. Dak Prescott had his best game of the season throwing for 183 yards and two touchdowns. Prescott also rushed for a career-high 82 yards and added a touchdown on the ground.</p>
<p><strong>Extra Points: </strong>Ezekiel Elliott ran for 106 tough yards and a touchdown on 24 carries. With Prescott making some plays down the field, Elliott found more room to run…Cole Beasley had by far his best game of the season catching nine balls for 101 yards and two touchdowns. Beasley&#8217;s previous high in yardage before Sunday was 73 yards in the opener…The Jaguars&#8217; offense was shut down all day with their lone touchdown being scored by Dede Westbrook. Westbrook finished with three receptions for 38 yards and the score.</p>
<p><strong> </strong><strong>Ravens 21 Titans 0</strong></p>
<p>If you started anyone on the Titans&#8217; offense, it was a long day. The Ravens put up the most impressive defensive outing of the season, sacking Marcus Mariota 11 times. Baltimore had more sacks than Mariota had completions (10).</p>
<p><strong>Extra Points: </strong>The Ravens&#8217; offense didn&#8217;t need to do much on Sunday, as three points would have been good enough to win the game. Alex Collins had a strong game with 54 yards and two touchdowns…One other player who made an impact was Michael Crabtree. Crabtree had his strongest performance of the season with six receptions for 93 yards and a touchdown.</p>
<p><strong>Patriots 43 Chiefs 40</strong></p>
<p>As you can probably guess in a game where the two teams combined to score 83 points, there were a lot of fantasy stars. Patrick Mahomes kept delivering for fantasy owners with 352 yards, four touchdowns and two interceptions. Tom Brady also put up big numbers with 340 yards and a touchdown. Brady also scored a rare rushing touchdown.</p>
<p><strong>Extra Points: </strong>Tyreek Hill ripped the Patriots&#8217; defense for seven catches, 142 yards and three touchdowns, including a 75-yard score to tie the game at 40&#8230;Kareem Hunt loves playing the Patriots. Just like he did last season, Hunt gave New England&#8217;s defense fits, finishing with five receptions, 185 total yards and a touchdown&#8230;Sony Michel is clearly the Patriots lead back now. Michel rushed for 106 yards and two touchdowns on 24 carries. Michel now has at least 98 yards rushing in three straight games and four touchdowns over that span.</p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://thehuddle.com/tag/fantasy-game-recaps/" rel="tag">fantasy game recaps</a>, <a href="http://thehuddle.com/tag/fantasy-impact/" rel="tag">fantasy impact</a>, <a href="http://thehuddle.com/category/game-analysis/" rel="category tag">Game Analysis</a></p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://thehuddle.com/2018/10/15/fantasy-impact-of-week-6-5/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

									</div>
				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/10/01/figures-flukes-and-feelings-week-5/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-1"
		title="Figures, Flukes and Feelings: Week 5"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/usatsi_11354538.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/10/usatsi_11354538.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Figures, Flukes and Feelings: Week 5" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">84 shares</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="http://thehuddle.com/category/statistical-analysis/" class="category" itemprop="articleSection">Statistical Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="http://thehuddle.com/2018/10/01/figures-flukes-and-feelings-week-5/"
				title="Figures, Flukes and Feelings: Week 5" itemprop="url">
				Figures, Flukes and Feelings: Week 5			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/09/17/figures-flukes-and-feelings-week-3/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-2"
		title="Figures, Flukes and Feelings: Week 3"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/09/usatsi_11263978-e1537205087770.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/09/usatsi_11263978-e1537205087770.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Figures, Flukes and Feelings: Week 3" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">77 shares</span><span class="block__time block__time--mobile">4w ago</span>
		<h2><a href="http://thehuddle.com/category/statistical-analysis/" class="category" itemprop="articleSection">Statistical Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="http://thehuddle.com/2018/09/17/figures-flukes-and-feelings-week-3/"
				title="Figures, Flukes and Feelings: Week 3" itemprop="url">
				Figures, Flukes and Feelings: Week 3			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://thehuddle.com/2018/09/11/figures-flukes-and-feelings-week-2/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-3"
		title="Figures, Flukes and Feelings: Week 2"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/09/usatsi_11216918-e1536621484190.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/09/usatsi_11216918-e1536621484190.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Figures, Flukes and Feelings: Week 2" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">104 shares</span><span class="block__time block__time--mobile">11 Sep</span>
		<h2><a href="http://thehuddle.com/category/player-analysis/" class="category" itemprop="articleSection">Player Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="http://thehuddle.com/2018/09/11/figures-flukes-and-feelings-week-2/"
				title="Figures, Flukes and Feelings: Week 2" itemprop="url">
				Figures, Flukes and Feelings: Week 2			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_native", slotName: "/7103/SMG_TheHuddle/native/sports/fantasy/football.general", sizes : [[640,170],[3,1]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_native' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_native"] = googletag.defineSlot("/7103/SMG_TheHuddle/native/sports/fantasy/football.general", [[640,170],[3,1]], "acm-ad-tag-lawrence_dfp_desktop_native").addService(googletag.pubads().setTargeting('kw',["fantasy game recaps","fantasy impact","Thomas Casale","Game Analysis"]).setTargeting('category',["Game Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_native' );
												bidManager.requestBid( 'lawrence_dfp_desktop_native' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_native' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_native' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/14/game-day-inactives-injuries-and-weather-week-6-2/"
						title="Game day inactives, injuries and weather: Week 6"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11324806-e1539385750784.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/10/11324806-e1539385750784.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Game day inactives, injuries and weather: Week 6" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/10/14/game-day-inactives-injuries-and-weather-week-6-2/"
								title="Game day inactives, injuries and weather: Week 6"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/10/14/game-day-inactives-injuries-and-weather-week-6-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/10/14/game-day-inactives-injuries-and-weather-week-6-2/"
			title="Game day inactives, injuries and weather: Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>12</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/game-day/" class="category" itemprop="articleSection">Game Day</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/14/game-day-inactives-injuries-and-weather-week-6-2/"
						title="Game day inactives, injuries and weather: Week 6"
						itemprop="url" 						>
							Game day inactives, injuries and weather: Week 6					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 14, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/wwalters/" title="Posts by Whit Walters" class="author url fn" rel="author">Whit Walters</a>													</span>
					</p>
				</footer>

				<p>List of inactive or injured players. Real-time updates from the NFL right up until kickoff each Sunday morning. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/12/friday-walkthrough-week-6-2/"
						title="Friday walkthrough: Week 6"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11397665-e1539385088573.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/10/11397665-e1539385088573.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Friday walkthrough: Week 6" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/10/12/friday-walkthrough-week-6-2/"
								title="Friday walkthrough: Week 6"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/10/12/friday-walkthrough-week-6-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/10/12/friday-walkthrough-week-6-2/"
			title="Friday walkthrough: Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/injury-analysis/" class="category" itemprop="articleSection">Injury Analysis</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/12/friday-walkthrough-week-6-2/"
						title="Friday walkthrough: Week 6"
						itemprop="url" 						>
							Friday walkthrough: Week 6					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 12, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/wwalters/" title="Posts by Whit Walters" class="author url fn" rel="author">Whit Walters</a>													</span>
					</p>
				</footer>

				<p>Final late afternoon practice and playing status report for all key fantasy football players. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/12/daily-fantasy-domination-week-6-5/"
						title="Daily fantasy domination: Week 6"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11313607-e1539301452249.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/10/11313607-e1539301452249.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Daily fantasy domination: Week 6" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/10/12/daily-fantasy-domination-week-6-5/"
								title="Daily fantasy domination: Week 6"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/10/12/daily-fantasy-domination-week-6-5/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/10/12/daily-fantasy-domination-week-6-5/"
			title="Daily fantasy domination: Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>35</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/dfs/" class="category" itemprop="articleSection">DFS</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/12/daily-fantasy-domination-week-6-5/"
						title="Daily fantasy domination: Week 6"
						itemprop="url" 						>
							Daily fantasy domination: Week 6					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 12, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/newclearharley/" title="Posts by Harley Schultz" class="author url fn" rel="author">Harley Schultz</a>													</span>
					</p>
				</footer>

				<p>Last week was pretty solid, with the rare exception being a bit too much exposure to Alex Smith on MNF. I thought for sure when Marshon (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/12/six-points-with-david-dorey-week-6-3/"
						title="Six points with David Dorey: Week 6"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/10/usatsi_10320747-e1506990421142.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/10/usatsi_10320747-e1506990421142.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Six points with David Dorey: Week 6" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/10/12/six-points-with-david-dorey-week-6-3/"
								title="Six points with David Dorey: Week 6"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/10/12/six-points-with-david-dorey-week-6-3/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/10/12/six-points-with-david-dorey-week-6-3/"
			title="Six points with David Dorey: Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>4</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/game-analysis/" class="category" itemprop="articleSection">Game Analysis</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/12/six-points-with-david-dorey-week-6-3/"
						title="Six points with David Dorey: Week 6"
						itemprop="url" 						>
							Six points with David Dorey: Week 6					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 12, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Coming into Week 6 and that&#8217;s almost halfway to the fantasy playoffs. Last Week every Jay Ajayi owner said, &#8220;I&#8217;m (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/11/the-huddle-up-podcast-week-6/"
						title="The Huddle Up! Podcast: Week 6"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="The Huddle Up! Podcast: Week 6" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/10/11/the-huddle-up-podcast-week-6/"
								title="The Huddle Up! Podcast: Week 6"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/10/11/the-huddle-up-podcast-week-6/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/10/11/the-huddle-up-podcast-week-6/"
			title="The Huddle Up! Podcast: Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>8</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/11/the-huddle-up-podcast-week-6/"
						title="The Huddle Up! Podcast: Week 6"
						itemprop="url" 						>
							The Huddle Up! Podcast: Week 6					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 11, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>LeSean McCoy, Aaron Rodgers, Seattle&#8217;s backfield, Adrian Peterson&#8217;s injury, Eric Ebron&#8217;s situation and plenty of (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=6"
						title="Week 6 start bench tool"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11400797-e1539231878382.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/10/11400797-e1539231878382.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Week 6 start bench tool" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=6"
								title="Week 6 start bench tool"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=6';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=6"
			title="Week 6 start bench tool"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>8</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/lineup-management/" class="category" itemprop="articleSection">Lineup Management</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://www.thehuddle.com/myHuddle/start-bench-tool.php?week=6"
						title="Week 6 start bench tool"
						itemprop="url" 						>
							Week 6 start bench tool					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 11, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-tools/" title="Posts by Huddle Tools" class="author url fn" rel="author">Huddle Tools</a>													</span>
					</p>
				</footer>

				<p>Weekly player advice, analysis and projected stats displayed using your custom myHuddle leagues. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/11/dfs-value-plays-and-bargain-basements-for-week-6/"
						title="DFS value plays and bargain basements for Week 6"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11396115-e1539222476881.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/10/11396115-e1539222476881.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="DFS value plays and bargain basements for Week 6" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/10/11/dfs-value-plays-and-bargain-basements-for-week-6/"
								title="DFS value plays and bargain basements for Week 6"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/10/11/dfs-value-plays-and-bargain-basements-for-week-6/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/10/11/dfs-value-plays-and-bargain-basements-for-week-6/"
			title="DFS value plays and bargain basements for Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/dfs/" class="category" itemprop="articleSection">DFS</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/11/dfs-value-plays-and-bargain-basements-for-week-6/"
						title="DFS value plays and bargain basements for Week 6"
						itemprop="url" 						>
							DFS value plays and bargain basements for Week 6					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 11, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/thomas-casale/" title="Posts by Thomas Casale" class="author url fn" rel="author">Thomas Casale</a>													</span>
					</p>
				</footer>

				<p>Everyone knows to start Patrick Mahomes and Todd Gurley most weeks in DFS. What can bring home the money in is finding players who will (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://www.thehuddle.com/2018/season/06/start-bench-list.php"
						title="Start bench list: Week 6"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11397235-e1539231596251.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/10/11397235-e1539231596251.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Start bench list: Week 6" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://www.thehuddle.com/2018/season/06/start-bench-list.php"
								title="Start bench list: Week 6"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://www.thehuddle.com/2018/season/06/start-bench-list.php';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://www.thehuddle.com/2018/season/06/start-bench-list.php"
			title="Start bench list: Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>14</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/lineup-management/" class="category" itemprop="articleSection">Lineup Management</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="http://www.thehuddle.com/2018/season/06/start-bench-list.php"
						title="Start bench list: Week 6"
						itemprop="url" 						>
							Start bench list: Week 6					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 11, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Old school static list of players tiered by their start/bench viability. </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/11/office-pool-pickem-week-6-6/"
						title="Office pool pick&#039;em: Week 6"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11396411-e1539232573965.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/10/11396411-e1539232573965.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Office pool pick&#039;em: Week 6" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thehuddlemostrecent"
								href="http://thehuddle.com/2018/10/11/office-pool-pickem-week-6-6/"
								title="Office pool pick&#039;em: Week 6"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='http://thehuddle.com/2018/10/11/office-pool-pickem-week-6-6/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://thehuddle.com/2018/10/11/office-pool-pickem-week-6-6/"
			title="Office pool pick&#039;em: Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>4</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thehuddle.com/category/game-picks/" class="category" itemprop="articleSection">Game Picks</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="http://thehuddle.com/2018/10/11/office-pool-pickem-week-6-6/"
						title="Office pool pick&#039;em: Week 6"
						itemprop="url" 						>
							Office pool pick&#039;em: Week 6					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">October 11, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Our staff makes weekly picks for both straight up and against the spread. </p>

				
				
			</div>
		</article>
	<article class="block block--hero">
	<a
		data-track="thehuddlemostrecent"
		href="http://www.thehuddle.com/2018/season/06/game-prediction-LAC-CLE.php"
		title="Game predictions and player projections: Week 6"
		rel=""
		itemprop="url"
		class="block__link"
			>
		<img
			src="https://usathuddle.files.wordpress.com/2018/10/11397057-e1539012756339.jpg?w=680&#038;h=420&#038;crop=1"
			width="680"
			height="420"
			alt="Game predictions and player projections: Week 6"
			itemprop="image"
			class="block__image"
		>
			</a>
	<div class="block__content">
		<h4 class="block__category">
			<a href="http://thehuddle.com/category/game-predictions/" class="block__category__link" itemprop="articleSection">Game Predictions</a>		</h4>
		<h2 class="block__title">
			<a
				data-track="thehuddlemostrecent"
				href="http://www.thehuddle.com/2018/season/06/game-prediction-LAC-CLE.php"
				title="Game predictions and player projections: Week 6"
				itemprop="url"
				rel=""
				class="block__title__link"
							>
					Game predictions and player projections: Week 6			</a>
		</h2>
							
<div class="meta" onclick="location.href='http://www.thehuddle.com/2018/season/06/game-prediction-LAC-CLE.php';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="http://www.thehuddle.com/2018/season/06/game-prediction-LAC-CLE.php"
			title="Game predictions and player projections: Week 6"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>106</span>
		shares	</span>
</span>
			</div>
</div>
			</div>
</article>
</div>
<a href="http://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget widget--login widget--box" id="login_widget-3">
<div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget_media_image" id="media_image-3"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/"><img width="1000" height="1000" src="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg 1000w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=150&amp;h=150 150w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300&amp;h=300 300w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=768&amp;h=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="429990" data-permalink="http://thehuddle.com/blitz/" data-orig-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" data-orig-size="1000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Blitz" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=1000" /></a></div><div class="widget widget--forum widget--box" id="forum_widget-4">
<div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="http://www.thehuddle.com/stats/2018/plays_std.php">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="http://www.thehuddle.com/stats/2018/plays_weekly.php">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="http://www.thehuddle.com/stats/2018/gamescan.php">Weekly Fantasy Box Scores</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="http://www.thehuddle.com/stats/2018/tpr.php">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="http://www.thehuddle.com/stats/2018/tpm.php">Team Position Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="http://www.thehuddle.com/stats/2018/gsm.php">Game Stats Matchups</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="http://thehuddle.com/myHuddle/sos.php">Strength of Schedule Tool</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-4"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/"><img width="1266" height="858" src="https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=1266" class="image wp-image-437270  attachment-1396x1025 size-1396x1025" alt="" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png 1266w, https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=150 150w, https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=300 300w, https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=768 768w, https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=1024 1024w" sizes="(max-width: 1266px) 100vw, 1266px" data-attachment-id="437270" data-permalink="http://thehuddle.com/2018/09/14/the-huddle-up-podcast-week-2/huddleup-audioboom-cropped-avatar/" data-orig-file="https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png" data-orig-size="1266,858" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="huddleup-audioboom-cropped-avatar" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=300" data-large-file="https://usathuddle.files.wordpress.com/2018/09/huddleup-audioboom-cropped-avatar-e1538750993232.png?w=1000" /></a></div><div class="widget widget--links widget--box" id="links_widget-7">
<div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="http://www.thehuddle.com/2018-nfl-depth-charts.php">2018 fantasy depth charts</a></li>
<li id="menu-item-435449" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435449"><a href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-team-by-week-grid/">2018 NFL Schedule - Team by Week Grid</a></li>
<li id="menu-item-435450" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435450"><a href="http://thehuddle.com/2018/04/19/2018-nfl-schedule-weekly-grid/">2018 NFL Schedule - Weekly Grid</a></li>
<li id="menu-item-435612" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435612"><a href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-round/">2018 NFL Draft by Round</a></li>
<li id="menu-item-435613" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435613"><a href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-team/">2018 NFL Draft by Team</a></li>
<li id="menu-item-435614" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-435614"><a href="http://thehuddle.com/2018/04/28/2018-nfl-draft-by-position/">2018 NFL Draft by Position</a></li>
<li id="menu-item-434832" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434832"><a href="http://thehuddle.com/2018/02/06/2018-nfl-important-dates/">2018 NFL important dates</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-8">
<div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="http://www.thehuddle.com/2018-nfl-depth-charts.php">2018 fantasy depth charts</a></li>
<li id="menu-item-434831" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434831"><a href="http://thehuddle.com/2018/04/19/2018-top-free-agent-tracker/">2018 top free agent tracker</a></li>
<li id="menu-item-434830" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434830"><a href="http://thehuddle.com/2018/05/29/2018-player-movement-tracker/">2018 player movement tracker</a></li>
<li id="menu-item-434533" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-434533"><a href="http://thehuddle.com/2018/02/20/2018-coaching-change-tracker/">2018 coaching change tracker</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-3">
<div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div>
		
			<div class="widget sidebar-ad bottom">
				<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250", slotName: "/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", sizes : [[300,250],[300,600]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_bottom_300x250"] = googletag.defineSlot("/7103/SMG_TheHuddle/300x250_2a/sports/fantasy/football.general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250").addService(googletag.pubads().setTargeting('kw',["fantasy game recaps","fantasy impact","Thomas Casale","Game Analysis"]).setTargeting('category',["Game Analysis"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_2a"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' );
												bidManager.requestBid( 'lawrence_dfp_desktop_bottom_300x250' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="http://static.usatoday.com/privacy/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="http://static.usatoday.com/terms/">Terms of Service</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="http://static.usatoday.com/privacy/#adchoices">Ad Choices</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="The Huddle">
				<a class="mobile-nav__breadcrumb" href="http://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-kit"><a href="http://thehuddle.com/2018-fantasy-football-draft-kit/">Draft Kit</a></li>
<li class="mobile-nav__item mobile-nav__item--in-season"><a href="http://thehuddle.com/in-season-fantasy-football/">In Season</a></li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="http://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news"><a href="/fantasy_football_news.php">News</a></li>
<li class="mobile-nav__item mobile-nav__item--stats"><a href="http://thehuddle.com/fantasy-football-statistics/">Stats</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="/2018-nfl-depth-charts.php">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--myhuddle"><a href="/myHuddle">myHUDDLE</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--teams"><a href="/fantasy_football_nfl_teams.php">Teams</a></li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="/fantasy_football_nfl_players.php">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="http://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="http://thehuddle.com/about-2/">About The Huddle</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://static.usatoday.com/privacy/">Privacy Notice / Your California Privacy Rights</a></li>
<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://static.usatoday.com/terms/">Terms of Service</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="http://static.usatoday.com/privacy/#adchoices">Ad Choices</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>

<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="http://www.thehuddle.com/login.php" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201842y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVy0EOQDAQheELqVGCWIizUBNabZVRHB+xYSOx/d/7YHNMjHZBu4AiaHGVAt0eKgrgMRnPnPadtARaDkgwefTY17bVOH+cxWjMmdiN1KUboE06/INe4YSVKXnKC57HSRapAyLtR9U='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_ADS_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"0"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVzsEOgjAMBuAXclRiiOFgfJaxNdKxtUg3kLcXLp48wLHt3y8/LKNxwhk5Q+4xocJMIxS1WbxdTbTLhOwQgkJGG6kkg58triSsVdALHBWS+BK3azdZdr0h2c3fcIQaY3kRK2gmN6yGOBKjmcmj6I7925+quBmROgjvgtNaOZGB8CyQLPHZH+v3ns/0qJtbe63vTdOGL5Lomhs='></script>
<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"","maxDistance":"250","medAdHeight":"0","maxDistanceMed":"0","largeAdHeight":"0","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var huddleUser = {"nameAPI":"http:\/\/thehuddle.com\/api\/get_user_name.php","cookie":"huddle-auth"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJydkt1OwzAMhV8IN2xobDeIZ/Eaa3PJT4mdTuXpcZEYA6RI61UiJ9/J8YndZYQ+J6WkLlYYQz1xEreFiUc3iLMFMGGYlXvpBnlwN4CeKdLXHfcNBvyYIWT08NjtF4HhvVKZO8kJSxc5rdG4FhpwFdTscb62cEHBIy94VQ4t7w004cQnVM4t3w1e2NPRGl8FY7HQA62DIzaz/kfaGZyr94EWmu969TdbhQpYcH8VbsYLvU0CWDBmU5SK7SBPVIrFJT+1OxW0YP+2fPRrfNnstofN0353eB4+AR3PFGE='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-4','user_id':'0','post':'438166','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-4&user_id=0&post=438166&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6MS4mczF1bW9bcGhaSGhXSVMyK1csdlFkUkFabkJjLGh1VncxdXBfMENxcThyZmouM204VTlXMmh+dXo1MFRBMjlvYlVxdlklUlprSWxkeHxDUU80ej8wLjZvbk5yP0ZHfDBtY1gzcmZsP2M1ZXMta3Y3LkNxLS5sVlh8PVUx'}]);
_stq.push([ 'clickTrackerInit', '114275906', '438166' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated in 0.222 seconds
	106905 bytes batcached for 300 seconds
-->
