<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Examining the situations of every drafted running back in the 2020 class." />
<meta name="keywords" content="rookie analysis, 2020 fantasy football, 2020 fantasy football rookies, 2020 nfl draft, 2020 nfl rookies, fantasy football, nfl draft" />
<title>Fantasy football rookie preview: Running backs</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1588824108&amp;back=https%3A%2F%2Fthehuddle.com%2F2020%2F05%2F06%2Ffantasy-football-rookie-preview-running-backs-2%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Feed" href="https://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Comments Feed" href="https://thehuddle.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1582709031h&ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJylUstOxDAM/CGyXsRDvSCu/AHnPEzXrJNUcbJV/x6XQtHCUiFxieyxxzNxAuNgfE4VU4XYzMCtpyQwDj5HI5EYp2/ZzotcKWQoeW4BBRSAQFLBcfZHw+SKLRNInRh3kdLKuCDkc0HF42Dr3BExkEXGqG1btMWRc0NBEaNnpBZNPShRtuXiPFo9Hj+MnyELlSDlSsqWNfgxc5GCEw3QxNYc7LSKiHKOk+6HKaE5UcC8aF0q/Gky27Fg8vhZfLZiHf2DCk8tBH2djVX1mI2+p62U01liXthS2aIW1J/Qa9i/X/sr/c3x4RZ6zs7y3PAYH67vuu7mft91+9c3ZTr9vQ==?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script>
var amznAcctId = ["3090"];
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJx9jdEKwjAMRX/Irkzm9EX8lqyNs6VNa5Nu7O/tQF9EhMB9uOee6DUrRyZUi6x9u2fFsr2j83zQ/wAV3VxAsIuOPrBJJEiyszmxRGSGGX+0MU0uoKqMpQEk7c09fXPywGbQi8u6MkiysKkAa0EyuEsmZy0WFYGao7T1LV770+U89OM4HP0L2K5SdQ=='></script>
<script src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=5.4.1'></script>
<script src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=5.4.1'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.4.1'></script>
<script>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","page-blogname":"thehuddle","page-has-video":"","page-use-canonical":"1","content-ssts-section":"sports","content-ssts-subsection":"sports:thehuddle","content-ssts-topic":"sports:thehuddle","content-ssts-subtopic":"sports:thehuddle","page-experience-type":"desktop","content-type":"story pages","content-id":"450218","content-headline":"Fantasy football rookie preview: Running backs","content-date-published":"2020-05-06T17:32:39Z","content-byline":"Cory Bonini","content-contributor-names":"Cory Bonini","content-keywords":"2020 fantasy football,2020 fantasy football rookies,2020 nfl draft,2020 NFL rookies,Fantasy Football,nfl draft","content-title":"Fantasy football rookie preview: Running backs |  | "};
</script>
<script>
			window.gciAnalyticsUAID = "SMG-TEALIUM-THEHUDDLE";
			gciDataLayer["page-full-url"] = window.location.href;
			gciDataLayer["content-name"] = window.location.pathname;
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1'></script>
<script>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0'></script>
<script>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-1.js?ver=5.4.1'></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-2.js?ver=5.4.1'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p7JunM-1T7A' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fthehuddle.com%2F2020%2F05%2F06%2Ffantasy-football-rookie-preview-running-backs-2%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fthehuddle.com%2F2020%2F05%2F06%2Ffantasy-football-rookie-preview-running-backs-2%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Fantasy football rookie preview: Running backs" />
<meta property="og:url" content="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/" />
<meta property="og:description" content="Examining the situations of every drafted running back in the 2020 class." />
<meta property="article:published_time" content="2020-05-06T21:32:39+00:00" />
<meta property="article:modified_time" content="2020-05-06T21:33:49+00:00" />
<meta property="og:site_name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:text:title" content="Fantasy football rookie preview: Running backs" />
<meta name="twitter:image" content="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon" href="https://secure.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="https://thehuddle.com/osd.xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

<meta name="gdpr" content="false" />

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle",
		"url": "https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/",
		"headline": "Fantasy football rookie preview: Running backs",
		"thumbnailUrl": "https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=192&#038;h=150&#038;crop=1",
		"datePublished": "2020-05-06T17:32:39Z",
		"articleSection": "Rookie Analysis",
		"creator": ["Cory Bonini"],
		"keywords": ["2020 fantasy football","2020 fantasy football rookies","2020 nfl draft","2020 NFL rookies","Fantasy Football","nfl draft"],
	}
</script>
<style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.newsletter-modal {
	border-top: solid 8px #dd9933;
}

.article__back {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#dd9933, #dd9933)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

.smg-event__ctabutton {
	background-color: #dd9933;
	box-shadow: 0 2px 0 0 #dd9933;
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Win your fantasy football league with The Huddle&#039;s award-winning fantasy football cheat sheets, rankings, sleepers and insider tools." /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://thehuddle.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/amp/">
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-450218 single-format-standard customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://thehuddle.com"
				title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-442845" class="nav__item nav__item--draft-kit nav__item--parent"><a title="Fantasy football draft guide: Player rankings, cheat sheets and sleepers" href="https://thehuddle.com/2019-fantasy-football-draft-kit/">Draft Kit</a>
<ul class="sub-menu">
	<li id="menu-item-442874" class="nav__item nav__item--cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets?year=2019&#038;week=0">Cheat Sheets</a></li>
	<li id="menu-item-442875" class="nav__item nav__item--rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections?year=2019&#038;week=0">Rankings/Projections</a></li>
	<li id="menu-item-442876" class="nav__item nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/top-200-standard">Top 200 Overall</a></li>
	<li id="menu-item-442877" class="nav__item nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/top-200-ppr">Top 200 PPR</a></li>
	<li id="menu-item-442878" class="nav__item nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li id="menu-item-442879" class="nav__item nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442880" class="nav__item nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442881" class="nav__item nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
	<li id="menu-item-442882" class="nav__item nav__item--sleepers"><a href="https://thehuddle.com/category/sleepers/">Sleepers</a></li>
	<li id="menu-item-442883" class="nav__item nav__item--strength-of-schedule"><a href="https://thehuddle.com/category/strength-of-schedule/">Strength of Schedule</a></li>
	<li id="menu-item-442884" class="nav__item nav__item--player-movement"><a href="https://thehuddle.com/category/player-movement/">Player Movement</a></li>
</ul>
</li>
<li id="menu-item-442847" class="nav__item nav__item--in-season nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">In Season</a>
<ul class="sub-menu">
	<li id="menu-item-442894" class="nav__item nav__item--game-predictions"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">Game Predictions</a></li>
	<li id="menu-item-442895" class="nav__item nav__item--start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Start Bench Tool</a></li>
	<li id="menu-item-442896" class="nav__item nav__item--player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Player Rankings/Projections</a></li>
	<li id="menu-item-442897" class="nav__item nav__item--cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Cheat Sheets</a></li>
	<li id="menu-item-442898" class="nav__item nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li id="menu-item-442848" class="nav__item nav__item--dfs"><a href="https://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-442849" class="nav__item nav__item--news nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li id="menu-item-450179" class="nav__item nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li id="menu-item-450180" class="nav__item nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li id="menu-item-450181" class="nav__item nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li id="menu-item-450182" class="nav__item nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li id="menu-item-450183" class="nav__item nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li id="menu-item-442850" class="nav__item nav__item--stats nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li id="menu-item-442899" class="nav__item nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li id="menu-item-442900" class="nav__item nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li id="menu-item-442901" class="nav__item nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li id="menu-item-442902" class="nav__item nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li id="menu-item-442903" class="nav__item nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li id="menu-item-442904" class="nav__item nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li id="menu-item-442906" class="nav__item nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li id="menu-item-442851" class="nav__item nav__item--teams nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li id="menu-item-442917" class="nav__item nav__item--afc-east"><a href="#">AFC East</a></li>
	<li id="menu-item-442918" class="nav__item nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li id="menu-item-442919" class="nav__item nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li id="menu-item-442920" class="nav__item nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li id="menu-item-442921" class="nav__item nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li id="menu-item-442922" class="nav__item nav__item--afc-north"><a href="#">AFC North</a></li>
	<li id="menu-item-442923" class="nav__item nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li id="menu-item-442924" class="nav__item nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li id="menu-item-442925" class="nav__item nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li id="menu-item-442926" class="nav__item nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li id="menu-item-442927" class="nav__item nav__item--afc-south"><a href="#">AFC South</a></li>
	<li id="menu-item-442928" class="nav__item nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li id="menu-item-442929" class="nav__item nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li id="menu-item-442930" class="nav__item nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li id="menu-item-442931" class="nav__item nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li id="menu-item-442932" class="nav__item nav__item--afc-west"><a href="#">AFC West</a></li>
	<li id="menu-item-442933" class="nav__item nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li id="menu-item-442934" class="nav__item nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li id="menu-item-442935" class="nav__item nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li id="menu-item-442936" class="nav__item nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/oakland-raiders">Las Vegas Raiders</a></li>
	<li id="menu-item-442937" class="nav__item nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li id="menu-item-442938" class="nav__item nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li id="menu-item-442939" class="nav__item nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li id="menu-item-442940" class="nav__item nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li id="menu-item-442941" class="nav__item nav__item--washington-redskins"><a title="Washington Redskins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-redskins">Washington Redskins</a></li>
	<li id="menu-item-442942" class="nav__item nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li id="menu-item-442943" class="nav__item nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li id="menu-item-442944" class="nav__item nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li id="menu-item-442945" class="nav__item nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li id="menu-item-442946" class="nav__item nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li id="menu-item-442947" class="nav__item nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li id="menu-item-442948" class="nav__item nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li id="menu-item-442949" class="nav__item nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li id="menu-item-442950" class="nav__item nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li id="menu-item-442951" class="nav__item nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li id="menu-item-442952" class="nav__item nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li id="menu-item-442953" class="nav__item nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li id="menu-item-442954" class="nav__item nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li id="menu-item-442955" class="nav__item nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li id="menu-item-442956" class="nav__item nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li id="menu-item-442852" class="nav__item nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li id="menu-item-442853" class="nav__item nav__item--resources nav__item--parent"><a href="#">Resources</a>
<ul class="sub-menu">
	<li id="menu-item-442911" class="nav__item nav__item--depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Depth Charts</a></li>
	<li id="menu-item-442914" class="nav__item nav__item--nfl-draft"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">NFL Draft</a></li>
</ul>
</li>
<li id="menu-item-442854" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-442855" class="nav__item nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-450218" class="post-450218 post type-post status-publish format-standard has-post-thumbnail hentry category-rookie-analysis tag-2020-fantasy-football tag-2020-fantasy-football-rookies tag-2020-nfl-draft tag-2020-nfl-rookies tag-fantasy-football tag-nfl-draft" itemscope
				itemtype="http://schema.org/NewsArticle">

				<link itemprop="mainEntityofPage" href="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"/>
		<meta itemprop="url" content="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png">
	</div>
	<meta itemprop="name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com">
</div>
<div class="article__title ">
	<h1 class="article__headline">Fantasy football rookie preview: Running backs</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
			<img width="1000" height="600" src="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=100&amp;h=600&amp;crop=1&amp;h=60" class="article__image wp-post-image lazy-load" alt data-attachment-id="450241" data-permalink="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/ncaa-football-college-football-playoff-national-championship-clemson-vs-louisiana-state-5/" data-orig-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg" data-orig-size="4113,2565" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Mark J. Rebilas-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;Jan 13, 2020; New Orleans, Louisiana, USA; LSU Tigers running back Clyde Edwards-Helaire (22) against the Clemson Tigers in the College Football Playoff national championship game at Mercedes-Benz Superdome. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1578974238&quot;,&quot;copyright&quot;:&quot;Mark J. Rebilas&quot;,&quot;focal_length&quot;:&quot;600&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;NCAA Football: College Football Playoff National Championship-Clemson vs Louisiana State&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: College Football Playoff National Championship-Clemson vs Louisiana State" data-image-description="&lt;p&gt;Jan 13, 2020; New Orleans, Louisiana, USA; LSU Tigers running back Clyde Edwards-Helaire (22) against the Clemson Tigers in the College Football Playoff national championship game at Mercedes-Benz Superdome. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1000" data-lazy-src="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1000&amp;h=600&amp;crop=1" data-lazy-srcset="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=2000&amp;h=1200&amp;crop=1 2000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=150&amp;h=90&amp;crop=1 150w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1024&amp;h=614&amp;crop=1 1024w" data-lazy-sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img width="1000" height="600" src="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" srcset="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=2000&amp;h=1200&amp;crop=1 2000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=150&amp;h=90&amp;crop=1 150w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1024&amp;h=614&amp;crop=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="450241" data-permalink="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/ncaa-football-college-football-playoff-national-championship-clemson-vs-louisiana-state-5/" data-orig-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg" data-orig-size="4113,2565" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Mark J. Rebilas-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;Jan 13, 2020; New Orleans, Louisiana, USA; LSU Tigers running back Clyde Edwards-Helaire (22) against the Clemson Tigers in the College Football Playoff national championship game at Mercedes-Benz Superdome. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1578974238&quot;,&quot;copyright&quot;:&quot;Mark J. Rebilas&quot;,&quot;focal_length&quot;:&quot;600&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;NCAA Football: College Football Playoff National Championship-Clemson vs Louisiana State&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: College Football Playoff National Championship-Clemson vs Louisiana State" data-image-description="&lt;p&gt;Jan 13, 2020; New Orleans, Louisiana, USA; LSU Tigers running back Clyde Edwards-Helaire (22) against the Clemson Tigers in the College Football Playoff national championship game at Mercedes-Benz Superdome. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg?w=1000" /></noscript>			<meta itemprop="url" content="https://usathuddle.files.wordpress.com/2020/05/usatsi_14259951.jpg">
		</span>
		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Fantasy football rookie preview: Running backs</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="https://thehuddle.com/category/rookie-analysis/" class="" itemprop="articleSection">Rookie Analysis</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Fantasy football rookie preview: Running backs</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p>

	By <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a></span></span> 
		<span class="post-date updated">May 6, 2020</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
					Follow					@Cory_Bonini				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-'); });</script></div>
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">9</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a></span></span> |
		<span itemprop="datePublished" content="2020-05-06T17:32:39-04:00">
			May 6, 2020		</span>
		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
		Follow @Cory_Bonini	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p>Now that we have had some time to digest the NFL draft and its aftermath, us fantasy footballers are excitedly waiting to add some of the rookies to our fake teams. Deciding which players have fantasy worth in 2020 comes down to assessing the likelihood of meaningful playing time. The following players are ranked in order of anticipated opportunity and corresponding value.</p>
<aside class="related shortcode shortcode--related">
				<h2 class="related__header">Related</h2><a
			class="block block--related"
			href="https://thehuddle.com/2020/05/05/fantasy-football-rookie-preview-quarterbacks-2/"
			data-track="thehuddle-in-article-related-curated"
			
		><h2 class="block__title">Fantasy football rookie preview: Quarterbacks</h2></a></aside>
<div id="attachment_450249" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-450249" data-attachment-id="450249" data-permalink="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/syndication-tallahassee-3/" data-orig-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg" data-orig-size="4233,1789" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Alicia Devine\/Tallahassee Democrat, Tallahassee Democrat via Imagn Content Services, LLC&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Florida State Seminoles quarterback James Blackman (1) hands off the ball to Florida State Seminoles running back Cam Akers (3) to run into the end zone. The Florida State Seminoles beat the Louisiana Monroe Warhawks 45-44 in overtime.\n\nFsu V Ulm2182&quot;,&quot;created_timestamp&quot;:&quot;1567906373&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Syndication: Tallahassee&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Syndication: Tallahassee" data-image-description="&lt;p&gt;Florida State Seminoles quarterback James Blackman (1) hands off the ball to Florida State Seminoles running back Cam Akers (3) to run into the end zone. The Florida State Seminoles beat the Louisiana Monroe Warhawks 45-44 in overtime.&lt;/p&gt;
&lt;p&gt;Fsu V Ulm2182&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=1000" class="size-full wp-image-450249 lazy-load" src="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=100&amp;h=42#038;h=423" alt width="1000" height="423" data-lazy-src="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=1000&#038;h=423" srcset="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=1000&amp;h=423 1000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=2000&amp;h=846 2000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=150&amp;h=63 150w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=300&amp;h=127 300w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=768&amp;h=325 768w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=1024&amp;h=433 1024w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-450249" data-attachment-id="450249" data-permalink="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/syndication-tallahassee-3/" data-orig-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg" data-orig-size="4233,1789" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Alicia Devine\/Tallahassee Democrat, Tallahassee Democrat via Imagn Content Services, LLC&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Florida State Seminoles quarterback James Blackman (1) hands off the ball to Florida State Seminoles running back Cam Akers (3) to run into the end zone. The Florida State Seminoles beat the Louisiana Monroe Warhawks 45-44 in overtime.\n\nFsu V Ulm2182&quot;,&quot;created_timestamp&quot;:&quot;1567906373&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Syndication: Tallahassee&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Syndication: Tallahassee" data-image-description="&lt;p&gt;Florida State Seminoles quarterback James Blackman (1) hands off the ball to Florida State Seminoles running back Cam Akers (3) to run into the end zone. The Florida State Seminoles beat the Louisiana Monroe Warhawks 45-44 in overtime.&lt;/p&gt;
&lt;p&gt;Fsu V Ulm2182&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=1000" class="size-full wp-image-450249" src="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=1000&#038;h=423" alt="" width="1000" height="423" srcset="https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=1000&amp;h=423 1000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=2000&amp;h=846 2000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=150&amp;h=63 150w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=300&amp;h=127 300w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=768&amp;h=325 768w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13325944.jpg?w=1024&amp;h=433 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-450249" class="wp-caption-text">(Alicia Devine, Tallahassee Democrat)</p></div>
<h2>Most immediate impact</h2>
<p><strong><a href="https://thehuddle.com/2020/03/25/rookie-rundown-rb-cam-akers-florida-state/">Cam Akers</a> | Los Angeles Rams | 5-10, 217 | Florida State</strong></p>
<table border="1">
<tbody>
<tr>
<td>
<div align="center"><b>Year</b></div>
</td>
<td>
<div align="left"><b>Team</b></div>
</td>
<td>
<div align="center"><b>Att</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
<td>
<div align="center"><b>Long</b></div>
</td>
<td>
<div align="center"><b>Rec</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
</tr>
<tr>
<td>
<div align="center">2017</div>
</td>
<td>
<div align="left">FSU</div>
</td>
<td>
<div align="center">194</div>
</td>
<td>
<div align="center">1,024</div>
</td>
<td>
<div align="center">5.3</div>
</td>
<td>
<div align="center">7</div>
</td>
<td>
<div align="center">63</div>
</td>
<td>
<div align="center">16</div>
</td>
<td>
<div align="center">116</div>
</td>
<td>
<div align="center">7.3</div>
</td>
<td>
<div align="center">1</div>
</td>
</tr>
<tr>
<td>
<div align="center">2018</div>
</td>
<td>
<div align="left">FSU</div>
</td>
<td>
<div align="center">161</div>
</td>
<td>
<div align="center">706</div>
</td>
<td>
<div align="center">4.4</div>
</td>
<td>
<div align="center">6</div>
</td>
<td>
<div align="center">85</div>
</td>
<td>
<div align="center">23</div>
</td>
<td>
<div align="center">145</div>
</td>
<td>
<div align="center">6.3</div>
</td>
<td>
<div align="center">2</div>
</td>
</tr>
<tr>
<td>
<div align="center">2019</div>
</td>
<td>
<div align="left">FSU</div>
</td>
<td>
<div align="center">231</div>
</td>
<td>
<div align="center">1,144</div>
</td>
<td>
<div align="center">5.0</div>
</td>
<td>
<div align="center">14</div>
</td>
<td>
<div align="center">50</div>
</td>
<td>
<div align="center">30</div>
</td>
<td>
<div align="center">225</div>
</td>
<td>
<div align="center">7.5</div>
</td>
<td>
<div align="center">4</div>
</td>
</tr>
</tbody>
</table>
<p>Akers is a do-all weapon out of the backfield and has been highly productive when given the chance. He&#8217;s tasked with taking charge of a faceless backfield. While Todd Gurley remained lethal around the stripe, he ran for a career-low 857 yards on 223 carries (3.8 per attempt). The entire offense lagged in comparison to the prior year.</p>
<p>Part of Akers&#8217; assignment will be to share the workload with some combination of veteran grinder Malcolm Brown and 2019 third-rounder Darrell Henderson, whose rookie season was a thorough disappointment. Sometimes it takes a year or two for everything to click, even at running back, but it&#8217;s not like Gurley was entirely on point, either.</p>
<p>This one is all about the opportunity to steal as many backfield handles as Akers can get his mitts on &#8230; and make no mistake about it, the Rams will roll with the hot hand as much as possible. Akers has the makings of a dual-threat asset for PPR gamers, somewhere in the RB2 or flex range for most league formats.</p>
<p><strong><a href="https://thehuddle.com/2020/04/08/nfl-draft-rb-clyde-edwards-helaire-lsu/">Clyde Edwards-Helaire</a> | Kansas City Chiefs | 5-7, 208 | LSU</strong></p>
<table border="1">
<tbody>
<tr>
<td>
<div align="center"><b>Year</b></div>
</td>
<td>
<div align="left"><b>Team</b></div>
</td>
<td>
<div align="center"><b>Att</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
<td>
<div align="center"><b>Long</b></div>
</td>
<td>
<div align="center"><b>Rec</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
</tr>
<tr>
<td>
<div align="center">2017</div>
</td>
<td>
<div align="left">LSU</div>
</td>
<td>
<div align="center">9</div>
</td>
<td>
<div align="center">31</div>
</td>
<td>
<div align="center">3.4</div>
</td>
<td>
<div align="center">0</div>
</td>
<td>
<div align="center">10</div>
</td>
<td>
<div align="center">3</div>
</td>
<td>
<div align="center">46</div>
</td>
<td>
<div align="center">15.3</div>
</td>
<td>
<div align="center">0</div>
</td>
</tr>
<tr>
<td>
<div align="center">2018</div>
</td>
<td>
<div align="left">LSU</div>
</td>
<td>
<div align="center">146</div>
</td>
<td>
<div align="center">658</div>
</td>
<td>
<div align="center">4.5</div>
</td>
<td>
<div align="center">7</div>
</td>
<td>
<div align="center">47</div>
</td>
<td>
<div align="center">11</div>
</td>
<td>
<div align="center">96</div>
</td>
<td>
<div align="center">8.7</div>
</td>
<td>
<div align="center">0</div>
</td>
</tr>
<tr>
<td>
<div align="center">2019</div>
</td>
<td>
<div align="left">LSU</div>
</td>
<td>
<div align="center">215</div>
</td>
<td>
<div align="center">1,414</div>
</td>
<td>
<div align="center">6.6</div>
</td>
<td>
<div align="center">16</div>
</td>
<td>
<div align="center">89</div>
</td>
<td>
<div align="center">55</div>
</td>
<td>
<div align="center">453</div>
</td>
<td>
<div align="center">8.2</div>
</td>
<td>
<div align="center">1</div>
</td>
</tr>
</tbody>
</table>
<p>Some see Maurice Jones-Drew, but Devonta Freeman is probably the better NFL comp. Edwards-Helaire is one determined fella, and his skills in the passing game give the creative KC offensive brain trust so many possibilities. There are other backs in the mix &#8212; as there should be in today&#8217;s NFL &#8212; looking to challenge the rookie. When healthy, Damien Williams has performed about as well as anyone could expect in the past two years. He&#8217;s also not an every-down performer, despite having the skills to play all three downs. Edwards-Helaire provides a better option for the Chiefs inside of the 5-yard line.</p>
<p>The former Tiger also has to deal with Darwin Thompson and DeAndre Washington. Both have traits that could earn them a few touches per contest. It shouldn&#8217;t be taken for granted that a rookie automatically is the top guy in the backfield, regardless of draft placement, and especially in a pandemic shutdown. Talent typically wins out. Translation: Washington would have signed elsewhere as a starter, and Thompson would have flashed more last year. Give CEH the benefit of the doubt as an RB2-lite &#8230; he will have games of studly contributions but also may get lost in the shuffle of an offense that is about as lethal as they come through the vertical game. It&#8217;s hard to rack up fantasy points when you&#8217;re watching the offense score on abbreviated drives due to Tyreek Hill and Co.</p>
<p><strong><a href="https://thehuddle.com/2020/03/15/rookie-rundown-rb-dandre-swift-georgia/">D&#8217;Andre Swift</a> | Detroit Lions | 5-8, 212 | Georgia</strong></p>
<table border="1">
<tbody>
<tr>
<td>
<div align="center"><b>Year</b></div>
</td>
<td>
<div align="left"><b>Team</b></div>
</td>
<td>
<div align="center"><b>Att</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
<td>
<div align="center"><b>Long</b></div>
</td>
<td>
<div align="center"><b>Rec</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
</tr>
<tr>
<td>
<div align="center">2017</div>
</td>
<td>
<div align="left">UGA</div>
</td>
<td>
<div align="center">81</div>
</td>
<td>
<div align="center">618</div>
</td>
<td>
<div align="center">7.6</div>
</td>
<td>
<div align="center">3</div>
</td>
<td>
<div align="center">71</div>
</td>
<td>
<div align="center">17</div>
</td>
<td>
<div align="center">153</div>
</td>
<td>
<div align="center">9.0</div>
</td>
<td>
<div align="center">1</div>
</td>
</tr>
<tr>
<td>
<div align="center">2018</div>
</td>
<td>
<div align="left">UGA</div>
</td>
<td>
<div align="center">163</div>
</td>
<td>
<div align="center">1,049</div>
</td>
<td>
<div align="center">6.4</div>
</td>
<td>
<div align="center">10</div>
</td>
<td>
<div align="center">83</div>
</td>
<td>
<div align="center">32</div>
</td>
<td>
<div align="center">297</div>
</td>
<td>
<div align="center">9.3</div>
</td>
<td>
<div align="center">3</div>
</td>
</tr>
<tr>
<td>
<div align="center">2019</div>
</td>
<td>
<div align="left">UGA</div>
</td>
<td>
<div align="center">196</div>
</td>
<td>
<div align="center">1,218</div>
</td>
<td>
<div align="center">6.2</div>
</td>
<td>
<div align="center">7</div>
</td>
<td>
<div align="center">47</div>
</td>
<td>
<div align="center">24</div>
</td>
<td>
<div align="center">216</div>
</td>
<td>
<div align="center">9.0</div>
</td>
<td>
<div align="center">1</div>
</td>
</tr>
</tbody>
</table>
<p>One could argue Swift is the best overall back in the 2020 class without facing much contention. The better discussion is whether Detroit needed him, but we&#8217;ll save that for another day. The Lions clearly want to run the ball and take shots when required or strategic. Kerryon Johnson has the flimsiest of grasps on the starting job entering the summer &#8212; no offseason program works in his favor. Durability issues do not, and that&#8217;s the ticket for Swift, even if he doesn&#8217;t see a single snap of on-field work prior to Week 1.</p>
<p>Both backs undoubtedly acquit themselves in the passing game, and neither is truly built for an every-down pounding. The offensive system has generated a few studly campaigns through the years (Adrian Peterson, Marshawn Lynch say hello). The major doubt should come from whether the defense will allow the offense to remain committed to the ground game. Swift&#8217;s pass-catching talents will come into play in this area. In PPR, the former Bulldog is a safer option as a borderline No. 2 fantasy back. He easily approaches RB1 status with a long-term Johnson injury.</p>
<p><strong><a href="https://thehuddle.com/2020/03/19/rookie-rundown-rb-jonathan-taylor-wisconsin/">Jonathan Taylor</a> | Indianapolis Colts | 5-10, 226 | Wisconsin</strong></p>
<table border="1">
<tbody>
<tr>
<td>
<div align="center"><b>Year</b></div>
</td>
<td>
<div align="left"><b>Team</b></div>
</td>
<td>
<div align="center"><b>Att</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
<td>
<div align="center"><b>Long</b></div>
</td>
<td>
<div align="center"><b>Rec</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
</tr>
<tr>
<td>
<div align="center">2017</div>
</td>
<td>
<div align="left">WIS</div>
</td>
<td>
<div align="center">299</div>
</td>
<td>
<div align="center">1,977</div>
</td>
<td>
<div align="center">6.6</div>
</td>
<td>
<div align="center">13</div>
</td>
<td>
<div align="center">75</div>
</td>
<td>
<div align="center">8</div>
</td>
<td>
<div align="center">95</div>
</td>
<td>
<div align="center">11.9</div>
</td>
<td>
<div align="center">0</div>
</td>
</tr>
<tr>
<td>
<div align="center">2018</div>
</td>
<td>
<div align="left">WIS</div>
</td>
<td>
<div align="center">307</div>
</td>
<td>
<div align="center">2,194</div>
</td>
<td>
<div align="center">7.1</div>
</td>
<td>
<div align="center">16</div>
</td>
<td>
<div align="center">88</div>
</td>
<td>
<div align="center">8</div>
</td>
<td>
<div align="center">60</div>
</td>
<td>
<div align="center">7.5</div>
</td>
<td>
<div align="center">0</div>
</td>
</tr>
<tr>
<td>
<div align="center">2019</div>
</td>
<td>
<div align="left">WIS</div>
</td>
<td>
<div align="center">320</div>
</td>
<td>
<div align="center">2,003</div>
</td>
<td>
<div align="center">6.3</div>
</td>
<td>
<div align="center">21</div>
</td>
<td>
<div align="center">72</div>
</td>
<td>
<div align="center">26</div>
</td>
<td>
<div align="center">252</div>
</td>
<td>
<div align="center">9.7</div>
</td>
<td>
<div align="center">5</div>
</td>
</tr>
</tbody>
</table>
<p>How many backs can say they averaged more than 2,000 yards for three straight years? You&#8217;re looking at him. Taylor is, in fact, the second back (Troy Davis 1995-96) to consecutively break the 2,000-yard barrier. No one with any experience evaluating college and professional football will tell you with a straight face that it translates to the NFL in any apple-to-apple sense. The one true correlation is mileage &#8230; a human body can take only so much, especially at running back, before it says no mas.</p>
<p>Only dynasty leaguers care if he plays beyond 2020. In single-year formats, the Year 1 utility of Taylor remains in question. The most talented back in Indy, he&#8217;s still a rookie entering an offseason without an on-field program. The Colts also have Nyheim Hines in the aerial game, an area in which Taylor&#8217;s game needs refinement anyway. One has to believe Taylor will outright steal the No. 1a work from Marlon Mack, which is dubious, or that Mack will once again lose time to injuries, which is seemingly inevitable. It also makes valuating Taylor beyond frustrating. If Mack were to get hurt in Week 1, we could be talking about a Rookie of the Year candidate. Conversely, how much utility do gamers get from drafting Taylor as, say, an RB3 and he only shares touches evenly with Mack all year? But at least that offensive line is elite!</p>
<p><strong><a href="https://thehuddle.com/2020/04/13/rookie-rundown-rb-keshawn-vaughn-vanderbilt/">Ke&#8217;Shawn Vaughn</a> | Tampa Bay Buccaneers | 5-10, 214 | Vanderbilt</strong></p>
<table border="1">
<tbody>
<tr>
<td>
<div align="center"><b>Year</b></div>
</td>
<td>
<div align="left"><b>Team</b></div>
</td>
<td>
<div align="center"><b>Att</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
<td>
<div align="center"><b>Long</b></div>
</td>
<td>
<div align="center"><b>Rec</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
</tr>
<tr>
<td>
<div align="center">2015</div>
</td>
<td>
<div align="left">ILL</div>
</td>
<td>
<div align="center">157</div>
</td>
<td>
<div align="center">723</div>
</td>
<td>
<div align="center">4.6</div>
</td>
<td>
<div align="center">6</div>
</td>
<td>
<div align="center">78</div>
</td>
<td>
<div align="center">16</div>
</td>
<td>
<div align="center">119</div>
</td>
<td>
<div align="center">7.4</div>
</td>
<td>
<div align="center">0</div>
</td>
</tr>
<tr>
<td>
<div align="center">2016</div>
</td>
<td>
<div align="left">ILL</div>
</td>
<td>
<div align="center">60</div>
</td>
<td>
<div align="center">301</div>
</td>
<td>
<div align="center">5.0</div>
</td>
<td>
<div align="center">3</div>
</td>
<td>
<div align="center">65</div>
</td>
<td>
<div align="center">9</div>
</td>
<td>
<div align="center">89</div>
</td>
<td>
<div align="center">9.9</div>
</td>
<td>
<div align="center">0</div>
</td>
</tr>
<tr>
<td>
<div align="center">2018</div>
</td>
<td>
<div align="left">VAN</div>
</td>
<td>
<div align="center">157</div>
</td>
<td>
<div align="center">1,244</div>
</td>
<td>
<div align="center">7.9</div>
</td>
<td>
<div align="center">12</div>
</td>
<td>
<div align="center">78</div>
</td>
<td>
<div align="center">13</div>
</td>
<td>
<div align="center">170</div>
</td>
<td>
<div align="center">13.1</div>
</td>
<td>
<div align="center">2</div>
</td>
</tr>
<tr>
<td>
<div align="center">2019</div>
</td>
<td>
<div align="left">VAN</div>
</td>
<td>
<div align="center">198</div>
</td>
<td>
<div align="center">1,028</div>
</td>
<td>
<div align="center">5.2</div>
</td>
<td>
<div align="center">9</div>
</td>
<td>
<div align="center">75</div>
</td>
<td>
<div align="center">29</div>
</td>
<td>
<div align="center">286</div>
</td>
<td>
<div align="center">9.9</div>
</td>
<td>
<div align="center">1</div>
</td>
</tr>
</tbody>
</table>
<p>Opportunity often overshadows talent. That is exactly what is going on in this case. Vaughn is a talented back but has limitations (athleticism and fluidity). There also is the huge issue of being a starter, or even the largest portion of a touch share, still isn&#8217;t all that large in comparison to other primary backs. The Bucs didn&#8217;t sign Tom Brady and trade for Rob Gronkowski to hand it off to a mediocre rookie back all day. Then there&#8217;s Ronald Jones and rookie Raymond Calais in the mix.</p>
<p>Vaughn still could manage to generate low-tier RB2 work, if he can average something like 4.5 yards per carry and find the end zone at least eight total times. Jones will be the more likely weapon in the passing game for Bruce Arians&#8217; group, and it will take at least a brief time early on for Vaughn to get up to speed with the pace of the NFL coming out of Illinois and Vanderbilt&#8217;s programs. Draft the rookie as a third back with modest expectations, believing it probably won&#8217;t get much better than flex territory.</p>
<p><strong><a href="https://thehuddle.com/2020/04/04/nfl-draft-rb-jk-dobbins-ohio-state/">J.K. Dobbins</a> | Baltimore Ravens | 5-10, 209 | Ohio State</strong></p>
<table border="1">
<tbody>
<tr>
<td>
<div align="center"><b>Year</b></div>
</td>
<td>
<div align="left"><b>Team</b></div>
</td>
<td>
<div align="center"><b>Att</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
<td>
<div align="center"><b>Long</b></div>
</td>
<td>
<div align="center"><b>Rec</b></div>
</td>
<td>
<div align="center"><b>Yds</b></div>
</td>
<td>
<div align="center"><b>Avg</b></div>
</td>
<td>
<div align="center"><b>TD</b></div>
</td>
</tr>
<tr>
<td>
<div align="center">2017</div>
</td>
<td>
<div align="left">OSU</div>
</td>
<td>
<div align="center">194</div>
</td>
<td>
<div align="center">1,403</div>
</td>
<td>
<div align="center">7.2</div>
</td>
<td>
<div align="center">7</div>
</td>
<td>
<div align="center">77</div>
</td>
<td>
<div align="center">22</div>
</td>
<td>
<div align="center">135</div>
</td>
<td>
<div align="center">6.1</div>
</td>
<td>
<div align="center">1</div>
</td>
</tr>
<tr>
<td>
<div align="center">2018</div>
</td>
<td>
<div align="left">OSU</div>
</td>
<td>
<div align="center">230</div>
</td>
<td>
<div align="center">1,053</div>
</td>
<td>
<div align="center">4.6</div>
</td>
<td>
<div align="center">10</div>
</td>
<td>
<div align="center">42</div>
</td>
<td>
<div align="center">26</div>
</td>
<td>
<div align="center">263</div>
</td>
<td>
<div align="center">10.1</div>
</td>
<td>
<div align="center">2</div>
</td>
</tr>
<tr>
<td>
<div align="center">2019</div>
</td>
<td>
<div align="left">OSU</div>
</td>
<td>
<div align="center">301</div>
</td>
<td>
<div align="center">2,003</div>
</td>
<td>
<div align="center">6.7</div>
</td>
<td>
<div align="center">21</div>
</td>
<td>
<div align="center">68</div>
</td>
<td>
<div align="center">23</div>
</td>
<td>
<div align="center">247</div>
</td>
<td>
<div align="center">10.7</div>
</td>
<td>
<div align="center">2</div>
</td>
</tr>
</tbody>
</table>
<p>Mark Ingram isn&#8217;t getting any younger, and Justice Hill figuratively incarcerated himself via paltry play in 2019. Gus Edwards is just a dude. In other words, Dobbins has a clear sight of being the top dog in this backfield. While it&#8217;s not automatic, and he&#8217;ll need some breaks (physically or figuratively), the Ohio State star is positioned nicely for a <em>chance</em> at a huge role in 2020. Draft him as a No. 4 and a handcuff to Ingram, but don&#8217;t be totally shocked if we see something much closer to an even split than an Ingram-dominated share of the touches. All of that aside, Lamar Jackson&#8217;s legs have Dobbins operating in a hamstrung manner no matter the touch count.</p>
<div id="attachment_450243" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-450243" data-attachment-id="450243" data-permalink="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/ncaa-football-ucla-at-stanford/" data-orig-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg" data-orig-size="5061,3017" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;Kirby Lee-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;ILCE-9&quot;,&quot;caption&quot;:&quot;Oct 17, 2019; Stanford, CA, USA; UCLA Bruins running back Joshua Kelley (27) scores on a 54-yard touchdown run in the fourth quarter against the Stanford Cardinal at Stanford Stadium. UCLA defeated Stanford 34-16. Mandatory Credit: Kirby Lee-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1571371254&quot;,&quot;copyright&quot;:&quot;Kirby Lee&quot;,&quot;focal_length&quot;:&quot;288&quot;,&quot;iso&quot;:&quot;10000&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;NCAA Football: UCLA at Stanford&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: UCLA at Stanford" data-image-description="&lt;p&gt;Oct 17, 2019; Stanford, CA, USA; UCLA Bruins running back Joshua Kelley (27) scores on a 54-yard touchdown run in the fourth quarter against the Stanford Cardinal at Stanford Stadium. UCLA defeated Stanford 34-16. Mandatory Credit: Kirby Lee-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=1000" class="size-full wp-image-450243 lazy-load" src="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=100&amp;h=59#038;h=596" alt width="1000" height="596" data-lazy-src="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=1000&#038;h=596" srcset="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=1000&amp;h=596 1000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=2000&amp;h=1192 2000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=150&amp;h=89 150w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=300&amp;h=179 300w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=768&amp;h=458 768w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=1024&amp;h=610 1024w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-450243" data-attachment-id="450243" data-permalink="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/ncaa-football-ucla-at-stanford/" data-orig-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg" data-orig-size="5061,3017" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;Kirby Lee-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;ILCE-9&quot;,&quot;caption&quot;:&quot;Oct 17, 2019; Stanford, CA, USA; UCLA Bruins running back Joshua Kelley (27) scores on a 54-yard touchdown run in the fourth quarter against the Stanford Cardinal at Stanford Stadium. UCLA defeated Stanford 34-16. Mandatory Credit: Kirby Lee-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1571371254&quot;,&quot;copyright&quot;:&quot;Kirby Lee&quot;,&quot;focal_length&quot;:&quot;288&quot;,&quot;iso&quot;:&quot;10000&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;NCAA Football: UCLA at Stanford&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: UCLA at Stanford" data-image-description="&lt;p&gt;Oct 17, 2019; Stanford, CA, USA; UCLA Bruins running back Joshua Kelley (27) scores on a 54-yard touchdown run in the fourth quarter against the Stanford Cardinal at Stanford Stadium. UCLA defeated Stanford 34-16. Mandatory Credit: Kirby Lee-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=1000" class="size-full wp-image-450243" src="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=1000&#038;h=596" alt="" width="1000" height="596" srcset="https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=1000&amp;h=596 1000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=2000&amp;h=1192 2000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=150&amp;h=89 150w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=300&amp;h=179 300w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=768&amp;h=458 768w, https://usathuddle.files.wordpress.com/2020/05/usatsi_13530667.jpg?w=1024&amp;h=610 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-450243" class="wp-caption-text">(Kirby Lee, USA TODAY Sports)</p></div>
<h3>So you&#8217;re telling me there&#8217;s a chance?</h3>
<p><strong>Darrynton Evans | Tennessee Titans | 5-10, 203 | Appalachian State</strong></p>
<p>By virtue of no one to speak of around him, Evans goes from small-school standout to backing up the NFL&#8217;s leading rusher in the blink of an eye. He&#8217;s thoroughly a change-of-pace contrast to Derrick Henry&#8217;s damaging rushing style. The Titans hardly have turned away from Henry, however. Last year&#8217;s top backup, Dion Lewis, touched the rock just only 79 times in 16 games after 214 handles the prior year. Evans is a handcuff to Henry and a standalone No. 4 with flex potential in PPR.</p>
<p><strong><a href="https://thehuddle.com/2020/03/29/rookie-rundown-rb-zack-moss-utah/">Zack Moss</a> | Buffalo Bills | 5-9, 223 | Utah</strong></p>
<p>Moss landed in a pretty good spot as far as opportunity goes, yet the downside of it all cannot be overlooked. A rookie in 2019, Devin Singletary is the explosive option of this likely pairing, making Moss more of a grinding complement. The Bills absolutely needed someone like Moss, which suggests he&#8217;ll be involved early and often. That said, the former Ute faces touch uncertainty and has a the looming issue of QB Josh Allen stealing scoring chances in the red zone. Moss belongs on all 2020 rosters as an RB3 with weekly flex consideration, but consistent production may be tough to come by as a rook.</p>
<p><strong>Joshua Kelley | Los Angeles Chargers | 5-11, 212 | UCLA</strong></p>
<p>Austin Ekeler has been a fantastic find for the Bolts and was extended in the offseason. Kelley enters a backfield to compete with Justin Jackson for No. 2, which is a role that probably winds up touching the ball, at the very least, 100 times. Kelley, a fourth-round pick, is a punishing, downhill runner whose game contributes to an early expiration date. No one much cares for 2020, though, if the UCLA product doesn&#8217;t last in the NFL until the ripe old age of 30. In the upcoming season, Kelley has a legitimate chance of entering RB2 territory a few times, although the safe view of his situation is somewhere around being a No. 4 with tremendous upside. Few players at his position stand to benefit more from a full training camp to show off his abilities. Stay tuned&#8230;</p>
<p><strong>AJ Dillon | Green Bay Packers | 6-0, 247 | Boston College</strong></p>
<p>Green Bay&#8217;s second curious draft choice in as many picks, Dillon is a battering ram with a nose for paydirt. Aaron Jones is coming off of one of the finest fantasy seasons in recent memory, and Jamaal Williams has proven quite capable off in reserve. In 2021, both players are set to become unrestricted free agents. It stands to reason we&#8217;ll see an extension for Jones, but Williams is likely to walk. In that context, Dillon&#8217;s addition makes a little more sense, even if the idea of sitting on a highly drafted running back for a year is foolish. All of that out of the way, Dillon might be able to overtake Williams as the changeup &#8212; so long as he gets a shot with a full-ish training camp. Wait before making any serious investment in Dillon; he&#8217;s an RB5 at the moment but could vault closer to an RB3.</p>
<div id="attachment_450245" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-450245" data-attachment-id="450245" data-permalink="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/ncaa-football-florida-state-at-miami/" data-orig-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg" data-orig-size="1377,993" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Steve Mitchell-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D4S&quot;,&quot;caption&quot;:&quot;Oct 6, 2018; Miami Gardens, FL, USA; Miami Hurricanes running back DeeJay Dallas (13) carries the ball past Florida State Seminoles defensive back Calvin Brewton (10) during the second half at Hard Rock Stadium. Mandatory Credit: Steve Mitchell-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1538853525&quot;,&quot;copyright&quot;:&quot;Steve Mitchell&quot;,&quot;focal_length&quot;:&quot;200&quot;,&quot;iso&quot;:&quot;4000&quot;,&quot;shutter_speed&quot;:&quot;0.0008&quot;,&quot;title&quot;:&quot;NCAA Football: Florida State at Miami&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Florida State at Miami" data-image-description="&lt;p&gt;Oct 6, 2018; Miami Gardens, FL, USA; Miami Hurricanes running back DeeJay Dallas (13) carries the ball past Florida State Seminoles defensive back Calvin Brewton (10) during the second half at Hard Rock Stadium. Mandatory Credit: Steve Mitchell-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=1000" class="size-full wp-image-450245 lazy-load" src="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=100&amp;h=72#038;h=721" alt width="1000" height="721" data-lazy-src="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=1000&#038;h=721" srcset="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=1000&amp;h=721 1000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=150&amp;h=108 150w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=300&amp;h=216 300w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=768&amp;h=554 768w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=1024&amp;h=738 1024w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg 1377w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-450245" data-attachment-id="450245" data-permalink="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/ncaa-football-florida-state-at-miami/" data-orig-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg" data-orig-size="1377,993" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Steve Mitchell-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D4S&quot;,&quot;caption&quot;:&quot;Oct 6, 2018; Miami Gardens, FL, USA; Miami Hurricanes running back DeeJay Dallas (13) carries the ball past Florida State Seminoles defensive back Calvin Brewton (10) during the second half at Hard Rock Stadium. Mandatory Credit: Steve Mitchell-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1538853525&quot;,&quot;copyright&quot;:&quot;Steve Mitchell&quot;,&quot;focal_length&quot;:&quot;200&quot;,&quot;iso&quot;:&quot;4000&quot;,&quot;shutter_speed&quot;:&quot;0.0008&quot;,&quot;title&quot;:&quot;NCAA Football: Florida State at Miami&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NCAA Football: Florida State at Miami" data-image-description="&lt;p&gt;Oct 6, 2018; Miami Gardens, FL, USA; Miami Hurricanes running back DeeJay Dallas (13) carries the ball past Florida State Seminoles defensive back Calvin Brewton (10) during the second half at Hard Rock Stadium. Mandatory Credit: Steve Mitchell-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=1000" class="size-full wp-image-450245" src="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=1000&#038;h=721" alt="" width="1000" height="721" srcset="https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=1000&amp;h=721 1000w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=150&amp;h=108 150w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=300&amp;h=216 300w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=768&amp;h=554 768w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg?w=1024&amp;h=738 1024w, https://usathuddle.files.wordpress.com/2020/05/usatsi_11390852.jpg 1377w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-450245" class="wp-caption-text">(Steve Mitchell, USA TODAY Sports)</p></div>
<h4>Roster fodder?</h4>
<p><strong>Antonio Gibson | Washington Redskins | 6-0, 228 pounds | Memphis</strong></p>
<p>Gibson is expected to move from wide receiver to running back, but he wasn&#8217;t too much of a true receiver in the first place. Curtis Samuel comes to mind, and not just for the obvious connection to the Redskins&#8217; new coaching staff. It gets complicated when looking for a clear path to enough touches to matter in fantasy. Adrian Peterson, Derrius Guice, Bryce Love, Peyton Barber &#8230; where exactly will Gibson fit in? He&#8217;s a better receiver than all of them, so that&#8217;s a plus, as is Peterson&#8217;s age (35) and substantial injury history for Guice and Love. Go go gadget Gibson.</p>
<p><strong>Eno Benjamin | Arizona Cardinals | 5-9, 207 | Arizona State</strong></p>
<p>This one comes down to whether we should trust Kenyan Drake over a full season to play like he did down the stretch (or even close to it) last year. It also forces one to prematurely question whether Chase Edmonds is an injury liability. Benjamin can do a little bit of it all, offering three-down worth and a willingness in pass protection. Tuck away his name for whatever comes of the training camp situation for this year.</p>
<p><strong>DeeJay Dallas | Seattle Seahawks | 5-10, 217 | Miami (Fla.)</strong></p>
<p>The former wide receiver turned running back enters a Seattle backfield looking for a sure-handed weapon out of the backfield. Dallas joins Seattle to find former first-rounder Rashaad Penny and Chris Carson pretty well entrenched in the top two, although we&#8217;ve seen a few times from Pete Carroll that rookies can win prominent roles. The problem here for Dallas is he probably won&#8217;t have an offseason to showcase his ability. Travis Homer also likely enters whatever would be a form of training camp ahead of the rookie. Barring another injury to Carson and/or Penny, it&#8217;s tough to find regular touches for Dallas.</p>
<p><strong>Anthony McFarland Jr. | Pittsburgh Steelers | 5-8, 208 | Maryland</strong></p>
<p>The Steelers drafted midround backs in consecutive years, but McFarland and Benny Snell Jr. really couldn&#8217;t be that much different from one another. James Conner is teetering on the edge of being an injury liability, and Jaylen Samuels thus far has proven mostly ineffective as a the utility back of this lot. Despite so many bodies ahead of him, McFarland has a puncher&#8217;s chance of seeing meaningful action throughout 2020 and is a late-round gamble for PPR types.</p>
<p><strong>Lamical Perine | New York Jets | 5-10, 216 | Florida</strong></p>
<p>Perine&#8217;s 2020 fantasy football stock had an enticing outlook of New York aiming to ease Le&#8217;Veon Bell&#8217;s workload and not having much of anything between the rookie and the star back. That was until Frank Gore&#8217;s 37-year-old legs were added to the mix. He has a good relationship with head coach Adam Gase from their year together in Miami, and it seems no better than a long shot now that Perine will be in the shadows.</p>
<p><strong>Jason Huntley | Detroit Lions | 5-8, 190 | New Mexico State</strong></p>
<p>Detroit drafted Swift in Round 2 and has Johnson as a versatile backfield complement. Huntley may have a hard time finding work if both of those backs remain healthy &#8212; a huge question mark for Johnson. Huntley is a slight figure whose best role will be as a pass-grabbing outlet for Matthew Stafford. There could be a role to seize with a little help from that pesky injury bug.</p>
<p><strong>Lynn Bowden Jr. | Las Vegas Raiders | 6-1, 199 | Kentucky</strong></p>
<p>Bowden played quarterback, wide receiver and running back in college and offers an intriguing skill set for Jon Gruden. The current belief is the rookie will see the majority of his snaps as a running back, possibly as a change of pace from Josh Jacobs. With no idea of how much Bowden will be on the field, let alone where he&#8217;ll line up any given play, recommending him as anything more than deep-league roster filler is quite risky.</p>
<p><strong>Raymond Calais | Tampa Bay Buccaneers | 5-8, 188 | Louisiana</strong></p>
<p>This one intrigues me to a great degree &#8230; Calais is a quick-burst, inside-outside back whose ability as a change-up offers the Bucs a fallback if the Ronald Jones experiment continues to disappoint. Calais could struggle to see action, however, if pass protection of TB12 is an obvious issue &#8212; and it very well could be at his size. Furthermore, just how many footballs are there to go around in this star-studded offense?</p>
</div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
						
						
						
						<p class="post-tags post-tags--hide"><a href="https://thehuddle.com/tag/2020-fantasy-football/" rel="tag">2020 fantasy football</a>, <a href="https://thehuddle.com/tag/2020-fantasy-football-rookies/" rel="tag">2020 fantasy football rookies</a>, <a href="https://thehuddle.com/tag/2020-nfl-draft/" rel="tag">2020 nfl draft</a>, <a href="https://thehuddle.com/tag/2020-nfl-rookies/" rel="tag">2020 NFL rookies</a>, <a href="https://thehuddle.com/tag/fantasy-football/" rel="tag">Fantasy Football</a>, <a href="https://thehuddle.com/tag/nfl-draft/" rel="tag">nfl draft</a>, <a href="https://thehuddle.com/category/rookie-analysis/" rel="category tag">Rookie Analysis</a></p>
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">9</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2020/05/06/fantasy-football-rookie-preview-running-backs-2/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/05/05/fantasy-football-rookie-preview-quarterbacks-2/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-1"
		title="Fantasy football rookie preview: Quarterbacks"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2020/05/usatsi_14107435.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2020/05/usatsi_14107435.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Fantasy football rookie preview: Quarterbacks" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">3 shares</span><span class="block__time block__time--mobile">2d ago</span>
		<h2><a href="https://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="https://thehuddle.com/2020/05/05/fantasy-football-rookie-preview-quarterbacks-2/"
				title="Fantasy football rookie preview: Quarterbacks" itemprop="url">
				Fantasy football rookie preview: Quarterbacks			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/04/07/nfl-draft-rb-lamical-perine-florida/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-2"
		title="Rookie Rundown: RB Lamical Perine, Florida"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_13855715.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_13855715.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Rookie Rundown: RB Lamical Perine, Florida" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">8 shares</span><span class="block__time block__time--mobile">5w ago</span>
		<h2><a href="https://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="https://thehuddle.com/2020/04/07/nfl-draft-rb-lamical-perine-florida/"
				title="Rookie Rundown: RB Lamical Perine, Florida" itemprop="url">
				Rookie Rundown: RB Lamical Perine, Florida			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/04/08/nfl-draft-rb-clyde-edwards-helaire-lsu/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-3"
		title="Rookie Rundown: RB Clyde Edwards-Helaire, LSU"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_13920213.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_13920213.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Rookie Rundown: RB Clyde Edwards-Helaire, LSU" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">7 shares</span><span class="block__time block__time--mobile">5w ago</span>
		<h2><a href="https://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="https://thehuddle.com/2020/04/08/nfl-draft-rb-clyde-edwards-helaire-lsu/"
				title="Rookie Rundown: RB Clyde Edwards-Helaire, LSU" itemprop="url">
				Rookie Rundown: RB Clyde Edwards-Helaire, LSU			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/05/05/fantasy-football-rookie-preview-quarterbacks-2/"
						title="Fantasy football rookie preview: Quarterbacks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/05/usatsi_14107435.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/05/usatsi_14107435.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football rookie preview: Quarterbacks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/05/05/fantasy-football-rookie-preview-quarterbacks-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/05/05/fantasy-football-rookie-preview-quarterbacks-2/"
			title="Fantasy football rookie preview: Quarterbacks"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>3</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/05/05/fantasy-football-rookie-preview-quarterbacks-2/"
						title="Fantasy football rookie preview: Quarterbacks"
						itemprop="url" 						>
							Fantasy football rookie preview: Quarterbacks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 5, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Breaking down the top fantasy football rookie quarterbacks in 2020. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/05/03/2020-player-movement-tracker/"
						title="2020 player movement tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2017/11/usatsi_10394017-e1509995270628.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2017/11/usatsi_10394017-e1509995270628.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 player movement tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/05/03/2020-player-movement-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/05/03/2020-player-movement-tracker/"
			title="2020 player movement tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Player Movement</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/05/03/2020-player-movement-tracker/"
						title="2020 player movement tracker"
						itemprop="url" 						>
							2020 player movement tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 3, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2020 NFL off-season player movement tracker. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://tools.thehuddle.com/nfl-depth-charts"
						title="Updated fantasy football depth charts"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2019/08/usatsi_11893690.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2019/08/usatsi_11893690.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Updated fantasy football depth charts" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://tools.thehuddle.com/nfl-depth-charts';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://tools.thehuddle.com/nfl-depth-charts"
			title="Updated fantasy football depth charts"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-depth-charts/" class="category" itemprop="articleSection">NFL Depth Charts</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://tools.thehuddle.com/nfl-depth-charts"
						title="Updated fantasy football depth charts"
						itemprop="url" 						>
							Updated fantasy football depth charts					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 30, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Our fantasy football depth charts have been updated following the 2020 NFL Draft.  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/28/2020-dynasty-keeper-player-rankings/"
						title="2020 fantasy football dynasty/keeper player rankings"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_136109461.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_136109461.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 fantasy football dynasty/keeper player rankings" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/04/28/2020-dynasty-keeper-player-rankings/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/04/28/2020-dynasty-keeper-player-rankings/"
			title="2020 fantasy football dynasty/keeper player rankings"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>4</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-rankings/" class="category" itemprop="articleSection">Player Rankings</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/28/2020-dynasty-keeper-player-rankings/"
						title="2020 fantasy football dynasty/keeper player rankings"
						itemprop="url" 						>
							2020 fantasy football dynasty/keeper player rankings					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 28, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Which fantasy football rookie players have the most long-term value after the 2020 NFL Draft? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/28/2020-coaching-change-tracker/"
						title="2020 coaching change tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2019/12/13708179-e1577980665938.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2019/12/13708179-e1577980665938.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 coaching change tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/04/28/2020-coaching-change-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/04/28/2020-coaching-change-tracker/"
			title="2020 coaching change tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/coaching-change/" class="category" itemprop="articleSection">Coaching Change</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/28/2020-coaching-change-tracker/"
						title="2020 coaching change tracker"
						itemprop="url" 						>
							2020 coaching change tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 28, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Tracking the coaching changes across the NFL for the upcoming 2019 season. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/27/top-12-fantasy-rookies/"
						title="Top 12 fantasy football rookies"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_13762322-1.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_13762322-1.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Top 12 fantasy football rookies" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/04/27/top-12-fantasy-rookies/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/04/27/top-12-fantasy-rookies/"
			title="Top 12 fantasy football rookies"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>103</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-draft/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/27/top-12-fantasy-rookies/"
						title="Top 12 fantasy football rookies"
						itemprop="url" 						>
							Top 12 fantasy football rookies					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 27, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Which rookies are most likely to offer fantasy value for 2020? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-team/"
						title="2020 NFL Draft results: by team"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_13507777.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_13507777.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 NFL Draft results: by team" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-team/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-team/"
			title="2020 NFL Draft results: by team"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>23</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-draft/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-team/"
						title="2020 NFL Draft results: by team"
						itemprop="url" 						>
							2020 NFL Draft results: by team					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 25, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Tracking all of the 2020 NFL Draft picks by the their selecting teams. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-position/"
						title="2020 NFL Draft results: by position"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_13540698.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_13540698.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 NFL Draft results: by position" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-position/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-position/"
			title="2020 NFL Draft results: by position"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>14</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-draft/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-position/"
						title="2020 NFL Draft results: by position"
						itemprop="url" 						>
							2020 NFL Draft results: by position					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 25, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Tracking all of the 2020 NFL Draft picks sorted by position </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/"
						title="2020 NFL Draft results: by round"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_13610946.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_13610946.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 NFL Draft results: by round" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/"
			title="2020 NFL Draft results: by round"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>2</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-draft/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/"
						title="2020 NFL Draft results: by round"
						itemprop="url" 						>
							2020 NFL Draft results: by round					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 25, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Tracking all of the 2020 NFL Draft picks by round selected </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/25/2020-nfl-draft-fantasy-football-day-3-recap/"
						title="2020 NFL Draft: Fantasy football Day 3 recap"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_13940464.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_13940464.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 NFL Draft: Fantasy football Day 3 recap" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/04/25/2020-nfl-draft-fantasy-football-day-3-recap/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/04/25/2020-nfl-draft-fantasy-football-day-3-recap/"
			title="2020 NFL Draft: Fantasy football Day 3 recap"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-draft/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/04/25/2020-nfl-draft-fantasy-football-day-3-recap/"
						title="2020 NFL Draft: Fantasy football Day 3 recap"
						itemprop="url" 						>
							2020 NFL Draft: Fantasy football Day 3 recap					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 25, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Keeping tabs on which skill position guys will make an impact in 2020 fantasy football. </p>

				
				
			</div>
		</article>
	</div>
<a href="https://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget widget--login widget--box" id="login_widget-3">
<div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="https://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget--forum widget--box" id="forum_widget-4">
<div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="https://tools.thehuddle.com/season">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="https://tools.thehuddle.com/weekly">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Stats Matchups</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/"><img width="1000" height="1000" src="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg 1000w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=150&amp;h=150 150w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300&amp;h=300 300w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=768&amp;h=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="429990" data-permalink="https://thehuddle.com/blitz/" data-orig-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" data-orig-size="1000,1000" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Blitz" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=1000" /></a></div><div class="widget widget--links widget--box" id="links_widget-8">
<div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="https://tools.thehuddle.com/nfl-depth-charts">2020 fantasy depth charts</a></li>
<li id="menu-item-449190" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449190"><a href="https://thehuddle.com/2020/04/19/2020-top-free-agent-tracker/">2020 top free-agent tracker</a></li>
<li id="menu-item-449189" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449189"><a href="https://thehuddle.com/2020/05/03/2020-player-movement-tracker/">2020 player movement tracker</a></li>
<li id="menu-item-449191" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449191"><a href="https://thehuddle.com/2020/04/28/2020-coaching-change-tracker/">2020 coaching change tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7">
<div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="https://tools.thehuddle.com/nfl-depth-charts">2020 fantasy depth charts</a></li>
<li id="menu-item-450161" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450161"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">2020 NFL Draft results: by round</a></li>
<li id="menu-item-450159" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450159"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-team/">2020 NFL Draft results: by team</a></li>
<li id="menu-item-450160" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450160"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-position/">2020 NFL Draft results: by position</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-3">
<div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448091"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-'); });</script></div>
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com">
				<a class="mobile-nav__breadcrumb" href="https://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-kit mobile-nav__item--parent"><a title="Fantasy football draft guide: Player rankings, cheat sheets and sleepers" href="https://thehuddle.com/2019-fantasy-football-draft-kit/">Draft Kit</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets?year=2019&#038;week=0">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections?year=2019&#038;week=0">Rankings/Projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/top-200-standard">Top 200 Overall</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/top-200-ppr">Top 200 PPR</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li class="mobile-nav__item mobile-nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2019/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--sleepers"><a href="https://thehuddle.com/category/sleepers/">Sleepers</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule"><a href="https://thehuddle.com/category/strength-of-schedule/">Strength of Schedule</a></li>
	<li class="mobile-nav__item mobile-nav__item--player-movement"><a href="https://thehuddle.com/category/player-movement/">Player Movement</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--in-season mobile-nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">In Season</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--game-predictions"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">Game Predictions</a></li>
	<li class="mobile-nav__item mobile-nav__item--start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Start Bench Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Player Rankings/Projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="https://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news mobile-nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li class="mobile-nav__item mobile-nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--stats mobile-nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li class="mobile-nav__item mobile-nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--teams mobile-nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--afc-east"><a href="#">AFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-north"><a href="#">AFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li class="mobile-nav__item mobile-nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li class="mobile-nav__item mobile-nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-south"><a href="#">AFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li class="mobile-nav__item mobile-nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li class="mobile-nav__item mobile-nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li class="mobile-nav__item mobile-nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-west"><a href="#">AFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li class="mobile-nav__item mobile-nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li class="mobile-nav__item mobile-nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/oakland-raiders">Las Vegas Raiders</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-redskins"><a title="Washington Redskins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-redskins">Washington Redskins</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li class="mobile-nav__item mobile-nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li class="mobile-nav__item mobile-nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li class="mobile-nav__item mobile-nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--resources mobile-nav__item--parent"><a href="#">Resources</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Depth Charts</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfl-draft"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">NFL Draft</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>

<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="https://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="https://tools.thehuddle.com/login" class="user-nav__item">
			Sign In
		</a>
		<a href="https://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script src='//0.gravatar.com/js/gprofiles.js?ver=202019y'></script>
<script>
var WPGroHo = {"my_hash":""};
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="114275906" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://thehuddle.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="cffe400c0b" /><input type="hidden" name="_wp_http_referer" value="/2020/05/06/fantasy-football-rookie-preview-running-backs-2/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1563361695h&cssminify=yes' type='text/css' media='all' />
<script>
var comment_like_text = {"loading":"Loading..."};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVy00KgCAQQOELZUOQmIvoLtkQY/7BaHb8bFfLtu/xQU3CxJAxZLAMG55kMF295Q5eyxeRXNkpMJjofUvC0YH8GEcrcKWEf9AnNLj4eZBq1GqSUtsbk082wA=='></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script>
var stickyInlineVideosOptions = {"side":"right","hide":"Hide video"};
</script>
<script>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"30","refresh_type":"all","distance":"2000","active":"1"}};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVzsEOwiAQBNAfEjdaG+PB+C0rbHQpLMhCm/691YMnE+11JvMyMGVjk1SSCvVOkRRGztAUa3I4m4BTIbEEMbkWlhadUVs4VwWvkLFgTE3q1usGflg5tBuLgla2w2xYAguZkR2lN/Yt/8f9fFyMwFfwj0Zl3tqUBqa1QESWtRt0r5+XeN71x+5w6vp95580foGb'></script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0'></script>
<script>
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
</script>
<script>
var wasabiFacebookReferral = "0";
</script>
<script>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script>
var huddleUser = {"name":"Huddle User","cookie":"session","logoutAPI":"https:\/\/api.thehuddle.com\/User\/Logout"};
</script>
<script>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/thehuddle.com\/wp-admin\/admin-ajax.php","nonce":"a535a5346f","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathuddle.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fthehuddle.com%2F2020%2F05%2F06%2Ffantasy-football-rookie-preview-running-backs-2%2F","blog_id":"114275906","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=114275906&v=wpcom&tz=-4&user_id=0&subd=usathuddle","is_public":"1","reblog_enabled":""};
</script>
<script>
var huddleLoginDebugData = {"is_member":"","user_data":[]};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJytUstOxDAM/CHciJXK9oL4Fm9jdR3SJOTRpXw97gragrik4uRo4hnbY6tbgN67TC6rsUCwZWCX1AkmDsokJQHQoZ0z96kx6UHtCPlKI91zVEmYvcZ5VbD4MYP1qIHeJVmTXuRWtBnZ/adchdQNE154oZfMtmqojepw4gEz+6opNn5iTReMx8gYZRuWjpFHrHNe/uBatLa0sLmq6k9uSRRBjPutsLs71HIXIMZImylTlBf4iWIUu9KGVSrkiP3rumh2vS2L3LKGsJmxx81boTh/hWaf9UfJHqOX2awylINUgm/guFXWCwhyImUQkZfx+bHtutO5e2pb8wnYCWS+'></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?61" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-4','user_id':'0','post':'450218','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-4&user_id=0&post=450218&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6KzFUVmxZcy1+TzIrTzh0S3Y2czV3RCtsSzNtajdZcjhnVDRONW5OaEc/eTI9ck9PTC9BYi9weD0sT19KeC94flZNJktVUVd3WGk0Tnxsa1hOVGdrQ0kydGZRLnl+UnVVQ2tRSF9oM35kVUZuRlE5JS1WdSZLNUNQS2orel1n'}]);
_stq.push([ 'clickTrackerInit', '114275906', '450218' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
