<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Explaining the rationale behind some of my picks in the industry championship league." />
<meta name="keywords" content="draft strategy, expert league, fantasy football, fantasy football draft review, fantasy football experts league review, fantasy football trade draft, fsga" />
<title>Recapping FSGA fantasy football experts draft</title>
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thehuddle.com&amp;id=114275906&amp;t=1593057805&amp;back=https%3A%2F%2Fthehuddle.com%2F2020%2F06%2F23%2Frecapping-fsga-fantasy-football-experts-draft%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//usathuddle.wordpress.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Feed" href="https://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Comments Feed" href="https://thehuddle.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1582709031h&ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJylUstOxDAM/CGyXiRePSCu/MGe8zBd07wUJ1v173EpFC0sFRKXyB57PBMnMGZlU6wYK4Smsm89RYYx2xQUB/I4fct2lvlKIEXR+uaQQQBwxBWMT3ZQnkzRZQKuk8ddoLgyLgjZVFDwkHWdOwI60ugxSNsWbXFkTC7IrOQM1IKqRyHytlyYR4vH4cP4GbJQCWKqJGxegx8zFyk4UYbGuianp1WEhTNMsh9PEdWJHKZF61LhT5O9HgtGi5/Fg2Zt6B9UeG7OyetsrKrHpOQ9daUUzxL14jWVLWpB+Qm9hP37tb/S3xwfb6D3yWg/NzyFx+vbbn/X3T/su9c3ZUf9xA==?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script>
var amznAcctId = ["3090"];
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId[0], adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJx9jdEKwjAMRX/IrhOZuAfxW7I2zpY2rU26sb+3A30REQL34Z57otesHJlQLbL27Z4Vy/aOzvNB/wNUdHMBwS46+sAmkSDJzubEEpEZZvzRxjS5gKoylgaQtDf39M3JA5tBLy7ryiDJwqYCrAXJ4C6ZnLVYVARqjtLWt3g9DmN/7i/DafQv2JhSdw=='></script>
<script src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=5.4.2'></script>
<script src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=5.4.2'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.4.2'></script>
<script>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","page-blogname":"thehuddle","page-has-video":"","page-use-canonical":"1","content-ssts-section":"sports","content-ssts-subsection":"sports:thehuddle","content-ssts-topic":"sports:thehuddle","content-ssts-subtopic":"sports:thehuddle","page-experience-type":"desktop","content-type":"story pages","content-id":"452433","content-headline":"Recapping FSGA fantasy football experts draft","content-date-published":"2020-06-23T21:07:24Z","content-byline":"Cory Bonini","content-contributor-names":"Cory Bonini","content-keywords":"Fantasy Football,fantasy football draft review,fantasy football experts league review,fantasy football trade draft,FSGA","content-title":"Recapping FSGA fantasy football experts draft |  | "};
</script>
<script>
			window.gciAnalyticsUAID = "SMG-TEALIUM-THEHUDDLE";
			gciDataLayer["page-full-url"] = window.location.href;
			gciDataLayer["content-name"] = window.location.pathname;
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1'></script>
<script>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0'></script>
<script>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-1.js?ver=5.4.2'></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-2.js?ver=5.4.2'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathuddle.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p7JunM-1THj' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fthehuddle.com%2F2020%2F06%2F23%2Frecapping-fsga-fantasy-football-experts-draft%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fthehuddle.com%2F2020%2F06%2F23%2Frecapping-fsga-fantasy-football-experts-draft%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Recapping FSGA fantasy football experts draft" />
<meta property="og:url" content="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/" />
<meta property="og:description" content="Explaining the rationale behind some of my picks in the industry championship league." />
<meta property="article:published_time" content="2020-06-24T01:07:24+00:00" />
<meta property="article:modified_time" content="2020-06-24T01:07:24+00:00" />
<meta property="og:site_name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
<meta property="og:image" content="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@TheHuddle" />
<meta name="twitter:site" content="@thehuddle" />
<meta name="twitter:text:title" content="Recapping FSGA fantasy football experts draft" />
<meta name="twitter:image" content="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32" sizes="16x16" />
<link rel="apple-touch-icon" href="https://secure.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114" />
<link rel="search" type="application/opensearchdescription+xml" href="https://thehuddle.com/osd.xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

<meta name="gdpr" content="false" />

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle",
		"url": "https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/",
		"headline": "Recapping FSGA fantasy football experts draft",
		"thumbnailUrl": "https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=192&#038;h=150&#038;crop=1",
		"datePublished": "2020-06-23T21:07:24Z",
		"articleSection": "Draft Strategy",
		"creator": ["Cory Bonini"],
		"keywords": ["Fantasy Football","fantasy football draft review","fantasy football experts league review","fantasy football trade draft","FSGA"],
	}
</script>
<style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.newsletter-modal {
	border-top: solid 8px #dd9933;
}

.article__back {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#dd9933, #dd9933)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

.smg-event__ctabutton {
	background-color: #dd9933;
	box-shadow: 0 2px 0 0 #dd9933;
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Win your fantasy football league with The Huddle&#039;s award-winning fantasy football cheat sheets, rankings, sleepers and insider tools." /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://thehuddle.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/amp/">
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-452433 single-format-standard customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://thehuddle.com"
				title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
				class="branding__logo-link "
			>
				<img
					src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"
					alt="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-450451" class="nav__item nav__item--draft-guide nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2020-fantasy-football-league-draft-preview-rankings-cheatsheets-sleepers/">Draft Guide</a>
<ul class="sub-menu">
	<li id="menu-item-442874" class="nav__item nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2020&#038;week=0">Cheat Sheets</a></li>
	<li id="menu-item-442875" class="nav__item nav__item--fantasy-football-projections-rankings"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2020&#038;week=0">Fantasy football projections/rankings</a></li>
	<li id="menu-item-442876" class="nav__item nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-standard">Top 200 Overall</a></li>
	<li id="menu-item-442877" class="nav__item nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-ppr">Top 200 PPR</a></li>
	<li id="menu-item-442878" class="nav__item nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li id="menu-item-442879" class="nav__item nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442880" class="nav__item nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442881" class="nav__item nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
	<li id="menu-item-442882" class="nav__item nav__item--sleepers"><a href="https://thehuddle.com/category/sleepers/">Sleepers</a></li>
	<li id="menu-item-442883" class="nav__item nav__item--strength-of-schedule"><a href="https://thehuddle.com/category/strength-of-schedule/">Strength of Schedule</a></li>
	<li id="menu-item-442884" class="nav__item nav__item--player-movement"><a href="https://thehuddle.com/category/player-movement/">Player Movement</a></li>
</ul>
</li>
<li id="menu-item-442847" class="nav__item nav__item--in-season nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">In Season</a>
<ul class="sub-menu">
	<li id="menu-item-442894" class="nav__item nav__item--game-predictions"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">Game Predictions</a></li>
	<li id="menu-item-442895" class="nav__item nav__item--start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Start Bench Tool</a></li>
	<li id="menu-item-442896" class="nav__item nav__item--player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Player Rankings/Projections</a></li>
	<li id="menu-item-442897" class="nav__item nav__item--cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Cheat Sheets</a></li>
	<li id="menu-item-442898" class="nav__item nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li id="menu-item-442848" class="nav__item nav__item--dfs"><a href="https://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-442849" class="nav__item nav__item--news nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li id="menu-item-450179" class="nav__item nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li id="menu-item-450180" class="nav__item nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li id="menu-item-450181" class="nav__item nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li id="menu-item-450182" class="nav__item nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li id="menu-item-450183" class="nav__item nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li id="menu-item-442850" class="nav__item nav__item--stats nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li id="menu-item-442899" class="nav__item nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li id="menu-item-442900" class="nav__item nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li id="menu-item-442901" class="nav__item nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li id="menu-item-442902" class="nav__item nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li id="menu-item-442903" class="nav__item nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li id="menu-item-442904" class="nav__item nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li id="menu-item-442906" class="nav__item nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li id="menu-item-442851" class="nav__item nav__item--teams nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li id="menu-item-442917" class="nav__item nav__item--afc-east"><a href="#">AFC East</a></li>
	<li id="menu-item-442918" class="nav__item nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li id="menu-item-442919" class="nav__item nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li id="menu-item-442920" class="nav__item nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li id="menu-item-442921" class="nav__item nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li id="menu-item-442922" class="nav__item nav__item--afc-north"><a href="#">AFC North</a></li>
	<li id="menu-item-442923" class="nav__item nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li id="menu-item-442924" class="nav__item nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li id="menu-item-442925" class="nav__item nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li id="menu-item-442926" class="nav__item nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li id="menu-item-442927" class="nav__item nav__item--afc-south"><a href="#">AFC South</a></li>
	<li id="menu-item-442928" class="nav__item nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li id="menu-item-442929" class="nav__item nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li id="menu-item-442930" class="nav__item nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li id="menu-item-442931" class="nav__item nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li id="menu-item-442932" class="nav__item nav__item--afc-west"><a href="#">AFC West</a></li>
	<li id="menu-item-442933" class="nav__item nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li id="menu-item-442934" class="nav__item nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li id="menu-item-442936" class="nav__item nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li id="menu-item-442935" class="nav__item nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li id="menu-item-442937" class="nav__item nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li id="menu-item-442938" class="nav__item nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li id="menu-item-442939" class="nav__item nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li id="menu-item-442940" class="nav__item nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li id="menu-item-442941" class="nav__item nav__item--washington-redskins"><a title="Washington Redskins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-redskins">Washington Redskins</a></li>
	<li id="menu-item-442942" class="nav__item nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li id="menu-item-442943" class="nav__item nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li id="menu-item-442944" class="nav__item nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li id="menu-item-442945" class="nav__item nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li id="menu-item-442946" class="nav__item nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li id="menu-item-442947" class="nav__item nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li id="menu-item-442948" class="nav__item nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li id="menu-item-442949" class="nav__item nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li id="menu-item-442950" class="nav__item nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li id="menu-item-442951" class="nav__item nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li id="menu-item-442952" class="nav__item nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li id="menu-item-442953" class="nav__item nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li id="menu-item-442954" class="nav__item nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li id="menu-item-442955" class="nav__item nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li id="menu-item-442956" class="nav__item nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li id="menu-item-442852" class="nav__item nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li id="menu-item-442911" class="nav__item nav__item--depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Depth Charts</a></li>
<li id="menu-item-442914" class="nav__item nav__item--nfl-draft"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">NFL Draft</a></li>
<li id="menu-item-442854" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-450426" class="nav__item nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener noreferrer" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li id="menu-item-450427" class="nav__item nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener noreferrer" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li id="menu-item-442855" class="nav__item nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-452433" class="post-452433 post type-post status-publish format-standard has-post-thumbnail hentry category-draft-strategy category-expert-league tag-fantasy-football tag-fantasy-football-draft-review tag-fantasy-football-experts-league-review tag-fantasy-football-trade-draft tag-fsga" itemscope
				itemtype="http://schema.org/NewsArticle">

				<link itemprop="mainEntityofPage" href="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png"/>
		<meta itemprop="url" content="https://usathuddle.files.wordpress.com/2016/08/logo-huddle-header.png">
	</div>
	<meta itemprop="name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com">
</div>
<div class="article__title ">
	<h1 class="article__headline">Recapping FSGA fantasy football experts draft</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
			<img width="1000" height="600" src="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=100&amp;h=600&amp;crop=1&amp;h=60" class="article__image wp-post-image lazy-load" alt data-attachment-id="452453" data-permalink="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/nfl-afc-wild-card-buffalo-bills-at-houston-texans/" data-orig-file="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg" data-orig-size="1769,1349" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;Kirby Lee-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D5&quot;,&quot;caption&quot;:&quot;Jan 4, 2020; Houston, Texas, USA; Houston Texans outside linebacker Brennan Scarlett (57) tackles Buffalo Bills running back Devin Singletary (26) during the second quarter in the AFC Wild Card NFL Playoff game at NRG Stadium. Mandatory Credit: Kirby Lee-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1578152762&quot;,&quot;copyright&quot;:&quot;Kirby Lee&quot;,&quot;focal_length&quot;:&quot;500&quot;,&quot;iso&quot;:&quot;6400&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;NFL: AFC Wild Card-Buffalo Bills at Houston Texans&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NFL: AFC Wild Card-Buffalo Bills at Houston Texans" data-image-description="&lt;p&gt;Jan 4, 2020; Houston, Texas, USA; Houston Texans outside linebacker Brennan Scarlett (57) tackles Buffalo Bills running back Devin Singletary (26) during the second quarter in the AFC Wild Card NFL Playoff game at NRG Stadium. Mandatory Credit: Kirby Lee-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1000" data-lazy-src="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1000&amp;h=600&amp;crop=1" data-lazy-srcset="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=150&amp;h=90&amp;crop=1 150w, https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1024&amp;h=614&amp;crop=1 1024w" data-lazy-sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img width="1000" height="600" src="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" srcset="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=150&amp;h=90&amp;crop=1 150w, https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1024&amp;h=614&amp;crop=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="452453" data-permalink="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/nfl-afc-wild-card-buffalo-bills-at-houston-texans/" data-orig-file="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg" data-orig-size="1769,1349" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;Kirby Lee-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D5&quot;,&quot;caption&quot;:&quot;Jan 4, 2020; Houston, Texas, USA; Houston Texans outside linebacker Brennan Scarlett (57) tackles Buffalo Bills running back Devin Singletary (26) during the second quarter in the AFC Wild Card NFL Playoff game at NRG Stadium. Mandatory Credit: Kirby Lee-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1578152762&quot;,&quot;copyright&quot;:&quot;Kirby Lee&quot;,&quot;focal_length&quot;:&quot;500&quot;,&quot;iso&quot;:&quot;6400&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;NFL: AFC Wild Card-Buffalo Bills at Houston Texans&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NFL: AFC Wild Card-Buffalo Bills at Houston Texans" data-image-description="&lt;p&gt;Jan 4, 2020; Houston, Texas, USA; Houston Texans outside linebacker Brennan Scarlett (57) tackles Buffalo Bills running back Devin Singletary (26) during the second quarter in the AFC Wild Card NFL Playoff game at NRG Stadium. Mandatory Credit: Kirby Lee-USA TODAY Sports&lt;/p&gt;
" data-medium-file="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg?w=1000" /></noscript>			<meta itemprop="url" content="https://usathuddle.files.wordpress.com/2020/06/usatsi_13871963.jpg">
		</span>
		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Recapping FSGA fantasy football experts draft</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="https://thehuddle.com/category/draft-strategy/" class="" itemprop="articleSection">Draft Strategy</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Recapping FSGA fantasy football experts draft</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p>

	By <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a></span></span> 
		<span class="post-date updated">June 23, 2020 9:07 pm</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
					Follow					@Cory_Bonini				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">27</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a></span></span> |
		<span itemprop="datePublished" content="2020-06-23T21:07:24-04:00">
			June 23, 2020 9:07 pm		</span>
		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
		Follow @Cory_Bonini	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p>Haters gonna hate.</p>
<p>Two things should be abundantly clear to every fantasy sports professional: You&#8217;re wrong almost as much you&#8217;re right in reality, and you&#8217;re wrong <em>all of the time</em> in the eyes of social media pundits. It&#8217;s fine. Having thick skin is a prerequisite for survival in this industry. A long-running rule of thumb is that being right 60 percent of the time is considered good. In other words, we&#8217;re in the same boat as meteorologists.</p>
<p>While being wrong roughly four out of 10 times isn&#8217;t ideal, it also illustrates the disparity in accuracy from the general public to people doing prognostication for a living. That&#8217;s not a brag but a fact of life in this business. That&#8217;s also not to say brilliant fantasy minds and competitors don&#8217;t exist outside of the sphere of people fortunate enough to do this for a living. But it&#8217;s super common to hear &#8212; especially when drafting in the middle of June &#8212; how wrong our picks are and what we should have done instead. Par for the course &#8230; Yet, every so often, someone&#8217;s critiques open our eyes to reevaluating a situation &#8212; or at least they should if we&#8217;re being open-minded.</p>
<p>That&#8217;s a long-winded way of saying, &#8220;Keep the hate coming!&#8221; I won&#8217;t pretend to speak for everyone, but it&#8217;s motivating, since millions of people would happily trade in their day jobs for mine, and I&#8217;m never going to let myself lose sight of it.</p>
<aside class="related shortcode shortcode--related">
				<h2 class="related__header">Related</h2><a
			class="block block--related"
			href="https://thehuddle.com/2020/06/16/fantasy-football-preseason-preview-receivers-4/"
			data-track="thehuddle-in-article-related-curated"
			
		><h2 class="block__title">Fantasy football preseason preview: Receivers</h2></a></aside>
<p>Where does that miniature rant come from? The feedback to my Fantasy Sports and Gaming Association (FSGA) draft results.</p>
<p>Monday, June 22, witnessed 14 of the industry&#8217;s most prominent companies represented in an online draft. We normally congregate in person. I&#8217;ve been in this league for roughly a decade now, and one of the first things I learned was the need to take calculated risks at a level unprecedented in any other professional draft. In addition to this being a 14-teamer, comprised by some of the brightest minds in fantasy, the loser goes home. This year, the bottom three teams get the boot.</p>
<p>In short, I much rather take a chance reaching for some players I expect to break out and then fail miserably instead of finishing in the middle of the pack with an uninspired effort.</p>
<p>In 2019, I hated my draft and was roundly panned for it. I had no business being in the playoffs if we were grading on an immediate post-draft reaction. That team finished as the second-highest scorer and landed in second place, earning a first-round bye week. While it was bounced in the second round after a flat showing, that lineup scored the most points of all teams during the bye and would have beaten all teams over the rest of the playoffs. Again, that&#8217;s also not a brag. It&#8217;s an illustration that the season is so much more than the aesthetics of a draft result in June. Or July. Or August and September.</p>
<p>It&#8217;s easy (and fun) to get caught up in the immediate reactionary takes about a roster. However, luck avoiding devastating injuries, astute inseason waiver manipulation (no trading in this league), and &#8212; arguably most important of all &#8212; optimal lineup decisions matter so much more. Sometimes we all draft a team that is so dang good we get to skate through the regular season, but anyone who has played this game long enough knows how rare that tends to be when playing against 13 other professionals.</p>
<p>May team out of the eighth spot:</p>
<table width="334">
<tbody>
<tr>
<td width="61"><strong>Overall</strong></td>
<td style="text-align:center;" width="43"><strong>Pick</strong></td>
<td width="146"><strong>Player</strong></td>
<td style="text-align:center;" width="37"><strong>Team</strong></td>
<td style="text-align:center;" width="47"><strong>Pos</strong></td>
</tr>
<tr>
<td style="text-align:center;">8</td>
<td style="text-align:center;">1.8</td>
<td>Derrick Henry</td>
<td style="text-align:center;">TEN</td>
<td style="text-align:center;">RB</td>
</tr>
<tr>
<td style="text-align:center;">21</td>
<td style="text-align:center;">2.7</td>
<td style="text-align:left;">Devin Singletary</td>
<td style="text-align:center;">BUF</td>
<td style="text-align:center;">RB</td>
</tr>
<tr>
<td style="text-align:center;">36</td>
<td style="text-align:center;">3.8</td>
<td style="text-align:left;">Raheem Mostert</td>
<td style="text-align:center;">SFO</td>
<td style="text-align:center;">RB</td>
</tr>
<tr>
<td style="text-align:center;">49</td>
<td style="text-align:center;">4.7</td>
<td style="text-align:left;">D.K. Metcalf</td>
<td style="text-align:center;">SEA</td>
<td style="text-align:center;">WR</td>
</tr>
<tr>
<td style="text-align:center;">64</td>
<td style="text-align:center;">5.8</td>
<td style="text-align:left;">Diontae Johnson</td>
<td style="text-align:center;">PIT</td>
<td style="text-align:center;">WR</td>
</tr>
<tr>
<td style="text-align:center;">77</td>
<td style="text-align:center;">6.7</td>
<td style="text-align:left;">Russell Wilson</td>
<td style="text-align:center;">SEA</td>
<td style="text-align:center;">QB</td>
</tr>
<tr>
<td style="text-align:center;">92</td>
<td style="text-align:center;">7.8</td>
<td style="text-align:left;">Rob Gronkowski</td>
<td style="text-align:center;">TAM</td>
<td style="text-align:center;">TE</td>
</tr>
<tr>
<td style="text-align:center;">105</td>
<td style="text-align:center;">8.7</td>
<td style="text-align:left;">Jamison Crowder</td>
<td style="text-align:center;">NYJ</td>
<td style="text-align:center;">WR</td>
</tr>
<tr>
<td style="text-align:center;">120</td>
<td style="text-align:center;">9.8</td>
<td style="text-align:left;">Zack Moss</td>
<td style="text-align:center;">BUF</td>
<td style="text-align:center;">RB</td>
</tr>
<tr>
<td style="text-align:center;">133</td>
<td style="text-align:center;">10.7</td>
<td style="text-align:left;">Hunter Renfrow</td>
<td style="text-align:center;">LV</td>
<td style="text-align:center;">WR</td>
</tr>
<tr>
<td style="text-align:center;">148</td>
<td style="text-align:center;">11.8</td>
<td style="text-align:left;">Jace Sternberger</td>
<td style="text-align:center;">GNB</td>
<td style="text-align:center;">TE</td>
</tr>
<tr>
<td style="text-align:center;">161</td>
<td>12.7</td>
<td style="text-align:left;">Chris Thompson</td>
<td>JAC</td>
<td>RB</td>
</tr>
<tr>
<td style="text-align:center;">176</td>
<td style="text-align:center;">13.8</td>
<td style="text-align:center;">Drew Lock</td>
<td style="text-align:center;">DEN</td>
<td style="text-align:center;">QB</td>
</tr>
<tr>
<td style="text-align:center;">189</td>
<td style="text-align:center;">14.7</td>
<td style="text-align:left;">Larry Fitzgerald</td>
<td style="text-align:center;">ARI</td>
<td style="text-align:center;">WR</td>
</tr>
<tr>
<td style="text-align:center;">204</td>
<td style="text-align:center;">15.8</td>
<td style="text-align:center;">Tampa Bay Buccaneers</td>
<td style="text-align:center;">TAM</td>
<td style="text-align:center;">Def/ST</td>
</tr>
<tr>
<td style="text-align:center;">217</td>
<td style="text-align:center;">16.7</td>
<td style="text-align:left;">Ka&#8217;imi Fairbairn</td>
<td style="text-align:center;">HOU</td>
<td style="text-align:center;">K</td>
</tr>
</tbody>
</table>
<p>I&#8217;ll address the controversial picks rather than going line-item for 16 rounds worth of selections.</p>
<ul>
<li style="text-align:left;"><strong>Devin Singletary</strong> drew a bunch of criticism for his lack of scoring prowess, Josh Allen&#8217;s role around the end zone, and the drafting of running back <strong>Zack Moss</strong>. I handcuffed Moss to Singletary to be safe, even though I really don&#8217;t like the idea of rookies in 2020 due to the abbreviated offseason. At least this is the one position where the transition may not be as daunting. If Allen is supposed to become a better quarterback in Year 3, coinciding with the addition of Stefon Diggs, Singletary stands to benefit. If the Bills are expected to be the favorite in the AFC East, the second-year back is going to be an integral part of it. I&#8217;ll take may chances reaching slightly that he&#8217;s closer to a strong RB2 in PPR than not. I wasn&#8217;t keen on a receiver, and none of the other RBs made more sense from an upside perspective.</li>
<li>Some criticism was levied for the <strong>D.K. Metcalf</strong> selection, and while I can see merit in the concerns, this, in part,, is the result of going three straight running backs to open the draft. I felt strongly enough in <strong>Raheem Mostert</strong> being a weekly lineup fixture as a flex, meaning wideouts could be thinner and less important. We saw elite-level flashes from Metcalf last year, and I&#8217;m confident he&#8217;s the real deal. I briefly considered Adam Thielen, but his lack of talent around him leaves me nervous, and his best play is behind him. Keenan Allen may look more respectable as a WR1 than Metcalf in a PPR, yet I have no confidence in the LA quarterback situation delivering weekly results. I then took a gamble that one of Robert Woods, D.J. Chark, Terry McLaurin or T.Y Hilton would be available in Round 5. I was wrong, which led me to the next (and most) controversial pick:</li>
<li><strong>Diontae Johnson</strong> has soared up draft boards in recent weeks. While some gamers may not be comfortable with him as either a WR2 or as a fifth-round choice, I&#8217;m perfectly fine with both in a 14-teamer. I was determined to not miss out. Johnson will outscore JuJu Smith-Schuster and is going to be the No. 1 receiver in Pittsburgh. Not only that, he&#8217;ll emerge as a leading candidate for the top fantasy breakout player in 2020. Had I landed one of those aforementioned receivers, I then would have aimed for Johnson in Round 6. I reached for Chris Godwin last year and was rewarded. I don&#8217;t mind reaching for a guy I strongly feel will finish in the top 25 at his position.</li>
<li>The selection of <strong>Rob Gronkowski</strong> was questioned as being too early by many of the people providing feedback. I truly get the risk factor in drafting him, but there&#8217;s also considerable upside. I wrote for this very site that Gronk has bust factor written all over him, and much of it is due to injury history. Here&#8217;s to hoping the year away helped get his body right. It&#8217;s hard to ignore the chemistry with Tom Brady when looking around a talent-laden Tampa offense. We objectively have <em>no idea</em> if TB12 has any connection with Mike Evans and Godwin, regardless of how talented those guys are in their own right. The tight ends who immediately came off the board in the next round or so following my Gronk choice: Hayden Hurst, Tyler Higbee and Jared Cook. Those three guys are not less risky than the goofball I drafted. The final thought: I drafted Green Bay&#8217;s <strong>Jace Sternberger</strong> as Gronk&#8217;s backup, and the young tight end is another one of my favorite sleeper targets.</li>
<li><strong>Chris Thompson</strong> is the only pick I&#8217;m not all that crazy about. He&#8217;s a boo-boo away from IR at all times, and the Jaguars have plenty of weapons around him to lessen the chance the former Washington Redskins pass-catching back is heavily involved. He is reunited with Jay Gruden, and there&#8217;s zero chance the coaching staff wants Leonard Fournette catching 76 passes again. The idea here is hopefully I don&#8217;t have to use Thompson, but if I do, I am comfortable with the situation.</li>
</ul>
</div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
						
						
						
						<p class="post-tags post-tags--hide"><a href="https://thehuddle.com/tag/fantasy-football/" rel="tag">Fantasy Football</a>, <a href="https://thehuddle.com/tag/fantasy-football-draft-review/" rel="tag">fantasy football draft review</a>, <a href="https://thehuddle.com/tag/fantasy-football-experts-league-review/" rel="tag">fantasy football experts league review</a>, <a href="https://thehuddle.com/tag/fantasy-football-trade-draft/" rel="tag">fantasy football trade draft</a>, <a href="https://thehuddle.com/tag/fsga/" rel="tag">FSGA</a>, <a href="https://thehuddle.com/category/draft-strategy/" rel="category tag">Draft Strategy</a>, <a href="https://thehuddle.com/category/expert-league/" rel="category tag">Expert League</a></p>
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">27</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2020/06/23/recapping-fsga-fantasy-football-experts-draft/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/06/11/fantasy-football-draft-prep-12-common-mistakes-to-avoid/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-1"
		title="Fantasy football draft prep: 12 common mistakes to avoid"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11355667-e1538396065406.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2018/10/11355667-e1538396065406.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Fantasy football draft prep: 12 common mistakes to avoid" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="https://thehuddle.com/category/draft-strategy/" class="category" itemprop="articleSection">Draft Strategy</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="https://thehuddle.com/2020/06/11/fantasy-football-draft-prep-12-common-mistakes-to-avoid/"
				title="Fantasy football draft prep: 12 common mistakes to avoid" itemprop="url">
				Fantasy football draft prep: 12 common mistakes to avoid			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/05/08/fantasy-football-rookie-preview-wide-receivers-3/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-2"
		title="Fantasy football rookie preview: Wide receivers"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2020/05/usatsi_13641599.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2020/05/usatsi_13641599.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Fantasy football rookie preview: Wide receivers" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">20 shares</span><span class="block__time block__time--mobile">08 May</span>
		<h2><a href="https://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="https://thehuddle.com/2020/05/08/fantasy-football-rookie-preview-wide-receivers-3/"
				title="Fantasy football rookie preview: Wide receivers" itemprop="url">
				Fantasy football rookie preview: Wide receivers			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/05/09/fantasy-football-rookie-preview-tight-ends-3/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-3"
		title="Fantasy football rookie preview: Tight ends"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathuddle.files.wordpress.com/2020/04/usatsi_13507777.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathuddle.files.wordpress.com/2020/04/usatsi_13507777.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Fantasy football rookie preview: Tight ends" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">10 shares</span><span class="block__time block__time--mobile">09 May</span>
		<h2><a href="https://thehuddle.com/category/rookie-analysis/" class="category" itemprop="articleSection">Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="https://thehuddle.com/2020/05/09/fantasy-football-rookie-preview-tight-ends-3/"
				title="Fantasy football rookie preview: Tight ends" itemprop="url">
				Fantasy football rookie preview: Tight ends			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/20/sound-off-which-te-do-you-plan-to-draft-first-in-2020-2/"
						title="Sound Off: Which TE do you plan to draft first in 2020?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/11/11595439-e1541433990813.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/11/11595439-e1541433990813.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sound Off: Which TE do you plan to draft first in 2020?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/20/sound-off-which-te-do-you-plan-to-draft-first-in-2020-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/20/sound-off-which-te-do-you-plan-to-draft-first-in-2020-2/"
			title="Sound Off: Which TE do you plan to draft first in 2020?"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>9</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/poll/" class="category" itemprop="articleSection">Poll</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/20/sound-off-which-te-do-you-plan-to-draft-first-in-2020-2/"
						title="Sound Off: Which TE do you plan to draft first in 2020?"
						itemprop="url" 						>
							Sound Off: Which TE do you plan to draft first in 2020?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 20, 2020 12:33 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>The ADP data shows a clear TE1. Do you agree? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/18/49ers-wr-deebo-samuel-breaks-foot-and-hearts-in-the-process/"
						title="49ers WR Deebo Samuel breaks foot and hearts in the process"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/01/13852476-e1579145356740.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/01/13852476-e1579145356740.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="49ers WR Deebo Samuel breaks foot and hearts in the process" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/18/49ers-wr-deebo-samuel-breaks-foot-and-hearts-in-the-process/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/18/49ers-wr-deebo-samuel-breaks-foot-and-hearts-in-the-process/"
			title="49ers WR Deebo Samuel breaks foot and hearts in the process"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>35</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/injury-analysis/" class="category" itemprop="articleSection">Injury Analysis</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/18/49ers-wr-deebo-samuel-breaks-foot-and-hearts-in-the-process/"
						title="49ers WR Deebo Samuel breaks foot and hearts in the process"
						itemprop="url" 						>
							49ers WR Deebo Samuel breaks foot and hearts in the process					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 18, 2020 3:43 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Can Samuel salvage a fantasy-worthy season after the injury? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/18/sound-off-which-wr-do-you-plan-to-draft-second-in-2020/"
						title="Sound Off: Which WR do you plan to draft second in 2020?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/11/11693968-e1542647155909.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/11/11693968-e1542647155909.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sound Off: Which WR do you plan to draft second in 2020?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/18/sound-off-which-wr-do-you-plan-to-draft-second-in-2020/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/18/sound-off-which-wr-do-you-plan-to-draft-second-in-2020/"
			title="Sound Off: Which WR do you plan to draft second in 2020?"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/poll/" class="category" itemprop="articleSection">Poll</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/18/sound-off-which-wr-do-you-plan-to-draft-second-in-2020/"
						title="Sound Off: Which WR do you plan to draft second in 2020?"
						itemprop="url" 						>
							Sound Off: Which WR do you plan to draft second in 2020?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 18, 2020 1:53 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>After Michael Thomas, which WR do you prefer to go next in PPR? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/17/sound-off-which-rb-do-you-plan-to-draft-first-in-2020/"
						title="Sound Off: Which RB do you plan to draft first in 2020?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2019/11/13615429-e1573699072231.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2019/11/13615429-e1573699072231.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sound Off: Which RB do you plan to draft first in 2020?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/17/sound-off-which-rb-do-you-plan-to-draft-first-in-2020/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/17/sound-off-which-rb-do-you-plan-to-draft-first-in-2020/"
			title="Sound Off: Which RB do you plan to draft first in 2020?"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>36</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/poll/" class="category" itemprop="articleSection">Poll</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/17/sound-off-which-rb-do-you-plan-to-draft-first-in-2020/"
						title="Sound Off: Which RB do you plan to draft first in 2020?"
						itemprop="url" 						>
							Sound Off: Which RB do you plan to draft first in 2020?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 17, 2020 1:32 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>While it may seem like there&#8217;s an obvious choice, it never hurts to consider all options. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/16/fantasy-football-which-qb-do-you-plan-to-draft-first-in-2020/"
						title="Sound Off: Which QB do you plan to draft first in 2020?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2019/09/13328648-e1568169574202.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2019/09/13328648-e1568169574202.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sound Off: Which QB do you plan to draft first in 2020?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/16/fantasy-football-which-qb-do-you-plan-to-draft-first-in-2020/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/16/fantasy-football-which-qb-do-you-plan-to-draft-first-in-2020/"
			title="Sound Off: Which QB do you plan to draft first in 2020?"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>19</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/poll/" class="category" itemprop="articleSection">Poll</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/16/fantasy-football-which-qb-do-you-plan-to-draft-first-in-2020/"
						title="Sound Off: Which QB do you plan to draft first in 2020?"
						itemprop="url" 						>
							Sound Off: Which QB do you plan to draft first in 2020?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 16, 2020 1:42 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Will our readers agree with the ADP data for the first QB to be chosen? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/16/fantasy-football-preseason-preview-receivers-4/"
						title="Fantasy football preseason preview: Receivers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2019/12/13827577-e1577418594765.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2019/12/13827577-e1577418594765.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football preseason preview: Receivers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/16/fantasy-football-preseason-preview-receivers-4/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/16/fantasy-football-preseason-preview-receivers-4/"
			title="Fantasy football preseason preview: Receivers"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>36</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/positional-analysis/" class="category" itemprop="articleSection">Positional Analysis</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/16/fantasy-football-preseason-preview-receivers-4/"
						title="Fantasy football preseason preview: Receivers"
						itemprop="url" 						>
							Fantasy football preseason preview: Receivers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 16, 2020 11:31 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Reviewing team receivers before the preseason </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/15/fantasy-footballs-top-point-per-reception-specialists/"
						title="Fantasy football&#039;s most interesting PPR specialists"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/06/usatsi_13828981.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/06/usatsi_13828981.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football&#039;s most interesting PPR specialists" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/15/fantasy-footballs-top-point-per-reception-specialists/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/15/fantasy-footballs-top-point-per-reception-specialists/"
			title="Fantasy football&#039;s most interesting PPR specialists"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/draft-strategy/" class="category" itemprop="articleSection">Draft Strategy</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/15/fantasy-footballs-top-point-per-reception-specialists/"
						title="Fantasy football&#039;s most interesting PPR specialists"
						itemprop="url" 						>
							Fantasy football&#039;s most interesting PPR specialists					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 15, 2020 5:28 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Look at these players for cheap help in PPR scoring formats. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/13/poll-will-the-2020-nfl-season-begin-on-time/"
						title="Sound Off: Will the 2020 NFL season begin on time?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/02/usatsi_10587585.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/02/usatsi_10587585.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sound Off: Will the 2020 NFL season begin on time?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/13/poll-will-the-2020-nfl-season-begin-on-time/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/13/poll-will-the-2020-nfl-season-begin-on-time/"
			title="Sound Off: Will the 2020 NFL season begin on time?"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>15</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/poll/" class="category" itemprop="articleSection">Poll</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/13/poll-will-the-2020-nfl-season-begin-on-time/"
						title="Sound Off: Will the 2020 NFL season begin on time?"
						itemprop="url" 						>
							Sound Off: Will the 2020 NFL season begin on time?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 13, 2020 1:15 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Poll: Do you feel the 2020 NFL season will begin as scheduled? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/12/2020-fantasy-football-busts-and-overvalued-players/"
						title="2020 fantasy football busts and overvalued players"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2020/05/usatsi_13800365.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2020/05/usatsi_13800365.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 fantasy football busts and overvalued players" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/12/2020-fantasy-football-busts-and-overvalued-players/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/12/2020-fantasy-football-busts-and-overvalued-players/"
			title="2020 fantasy football busts and overvalued players"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/busts/" class="category" itemprop="articleSection">Busts</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/12/2020-fantasy-football-busts-and-overvalued-players/"
						title="2020 fantasy football busts and overvalued players"
						itemprop="url" 						>
							2020 fantasy football busts and overvalued players					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 12, 2020 5:00 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Make sure you know which player pitfalls to avoid in 2020 fantasy football drafts.  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/11/fantasy-football-draft-prep-12-common-mistakes-to-avoid/"
						title="Fantasy football draft prep: 12 common mistakes to avoid"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathuddle.files.wordpress.com/2018/10/11355667-e1538396065406.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathuddle.files.wordpress.com/2018/10/11355667-e1538396065406.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football draft prep: 12 common mistakes to avoid" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/06/11/fantasy-football-draft-prep-12-common-mistakes-to-avoid/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/06/11/fantasy-football-draft-prep-12-common-mistakes-to-avoid/"
			title="Fantasy football draft prep: 12 common mistakes to avoid"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/draft-strategy/" class="category" itemprop="articleSection">Draft Strategy</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/06/11/fantasy-football-draft-prep-12-common-mistakes-to-avoid/"
						title="Fantasy football draft prep: 12 common mistakes to avoid"
						itemprop="url" 						>
							Fantasy football draft prep: 12 common mistakes to avoid					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">June 11, 2020 3:36 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>A dozen rules fantasy footballers must follow for consistent success. </p>

				
				
			</div>
		</article>
	</div>
<a href="https://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget widget--login widget--box" id="login_widget-3">
<div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="https://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget--forum widget--box" id="forum_widget-4">
<div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="https://tools.thehuddle.com/season">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="https://tools.thehuddle.com/weekly">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Stats Matchups</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.thehuddle.com/podcast/"><img width="1000" height="1000" src="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg 1000w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=150&amp;h=150 150w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300&amp;h=300 300w, https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=768&amp;h=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="429990" data-permalink="https://thehuddle.com/blitz/" data-orig-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg" data-orig-size="1000,1000" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Blitz" data-image-description="" data-medium-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=300" data-large-file="https://usathuddle.files.wordpress.com/2017/09/blitz.jpg?w=1000" /></a></div><div class="widget widget--links widget--box" id="links_widget-8">
<div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="https://tools.thehuddle.com/nfl-depth-charts">2020 fantasy depth charts</a></li>
<li id="menu-item-449190" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449190"><a href="https://thehuddle.com/2020/04/19/2020-top-free-agent-tracker/">2020 top free-agent tracker</a></li>
<li id="menu-item-449189" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449189"><a href="https://thehuddle.com/2020/05/23/2020-player-movement-tracker/">2020 player movement tracker</a></li>
<li id="menu-item-449191" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449191"><a href="https://thehuddle.com/2020/04/28/2020-coaching-change-tracker/">2020 coaching change tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7">
<div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="https://tools.thehuddle.com/nfl-depth-charts">2020 fantasy depth charts</a></li>
<li id="menu-item-450161" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450161"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">2020 NFL Draft results: by round</a></li>
<li id="menu-item-450159" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450159"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-team/">2020 NFL Draft results: by team</a></li>
<li id="menu-item-450160" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450160"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-position/">2020 NFL Draft results: by position</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-3">
<div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathuddle.files.wordpress.com/2016/08/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448091"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathuddle.files.wordpress.com/2016/08/icon-huddle.png" alt="Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com">
				<a class="mobile-nav__breadcrumb" href="https://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-guide mobile-nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2020-fantasy-football-league-draft-preview-rankings-cheatsheets-sleepers/">Draft Guide</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2020&#038;week=0">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-projections-rankings"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2020&#038;week=0">Fantasy football projections/rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-standard">Top 200 Overall</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-ppr">Top 200 PPR</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li class="mobile-nav__item mobile-nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--sleepers"><a href="https://thehuddle.com/category/sleepers/">Sleepers</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule"><a href="https://thehuddle.com/category/strength-of-schedule/">Strength of Schedule</a></li>
	<li class="mobile-nav__item mobile-nav__item--player-movement"><a href="https://thehuddle.com/category/player-movement/">Player Movement</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--in-season mobile-nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">In Season</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--game-predictions"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">Game Predictions</a></li>
	<li class="mobile-nav__item mobile-nav__item--start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Start Bench Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Player Rankings/Projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="https://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news mobile-nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li class="mobile-nav__item mobile-nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--stats mobile-nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li class="mobile-nav__item mobile-nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--teams mobile-nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--afc-east"><a href="#">AFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-north"><a href="#">AFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li class="mobile-nav__item mobile-nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li class="mobile-nav__item mobile-nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-south"><a href="#">AFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li class="mobile-nav__item mobile-nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li class="mobile-nav__item mobile-nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li class="mobile-nav__item mobile-nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-west"><a href="#">AFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li class="mobile-nav__item mobile-nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li class="mobile-nav__item mobile-nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-redskins"><a title="Washington Redskins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-redskins">Washington Redskins</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li class="mobile-nav__item mobile-nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li class="mobile-nav__item mobile-nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li class="mobile-nav__item mobile-nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-draft"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">NFL Draft</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener noreferrer" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li class="mobile-nav__item mobile-nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener noreferrer" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathuddle.files.wordpress.com/2016/08/usat-logo-mobile-off-canvas.png">
		</a>
	</div>

<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="https://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="https://tools.thehuddle.com/login" class="user-nav__item">
			Sign In
		</a>
		<a href="https://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script src='//0.gravatar.com/js/gprofiles.js?ver=202026y'></script>
<script>
var WPGroHo = {"my_hash":""};
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script>
var comment_like_text = {"loading":"Loading..."};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVy00KgCAQQOELZUOQmIvoLtkQY/7BaHb8bFfLtu/xQU3CxJAxZLAMG55kMF295Q5eyxeRXNkpMJjofUvC0YH8GEcrcKWEf9AnNLj4eZBq1GqSUtsbk082wA=='></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script>
var stickyInlineVideosOptions = {"side":"right","hide":"Hide video"};
</script>
<script>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"60","refresh_type":"all","distance":"2000","active":"1"}};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVzsEOwiAQBNAfEjdaG+PB+C0rbHQpLMhCm/691YMnE+11JvMyMGVjk1SSCvVOkRRGztAUa3I4m4BTIbEEMbkWlhadUVs4VwWvkLFgTE3q1usGflg5tBuLgla2w2xYAguZkR2lN/Yt/8f9fFyMwFfwj0Zl3tqUBqa1QESWtRt0r5+XeN71x+5w6vp95580foGb'></script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0'></script>
<script>
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
</script>
<script>
var wasabiFacebookReferral = "0";
</script>
<script>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script>
var huddleUser = {"name":"Huddle User","cookie":"session","logoutAPI":"https:\/\/api.thehuddle.com\/User\/Logout"};
</script>
<script>
var huddleLoginDebugData = {"is_member":"","user_data":[]};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJytkt1uwzAIhV9o1Nu0SO3FtGehMUrJ/BMZnC57+pFeNG3vXO3KFuY7hgPuPEGfk1JSFytMoQ6cxL3DzJMbxdkBmDAsyr3sRnlxN4CeKNIlx1VBzR6Xq0LA3wVCRg/0Y8me/Cp3je4ip/+Ua5A6o+CRV7wqh6amNjThzAMq56YuNl7Y0xHLczAWm0ag5+CIbc7bG5yq94FWmpt+vWerUAEz7lHhZu/Q216AGWNlilKxG+SZSjG7ZIs1KmjB/rtp0PeFh2xBsIHVwUS+4udbt98fuu718DH+AczVObY='></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?61" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'114275906','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'114275906','v':'wpcom','tz':'-4','user_id':'0','post':'452433','subd':'usathuddle'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=114275906&v=wpcomvt&tz=-4&user_id=0&post=452433&subd=usathuddle&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6MSt+Mz9jVlo0YXJWRSw1X20lbWdMK1RDZCwtY3ZGMCxlbWZsWUhDLDFkQyVMaEZjJV13JithMFswcFhXW21yM1pCS3lSXWUwQzksVSZDJXFiVjVMMTFmSH5WdEdbWGUmejgvUENBOCU/UTc5Tl8mU3NWLmFBNjEldlV2P3xOOEk5'}]);
_stq.push([ 'clickTrackerInit', '114275906', '452433' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
		<script defer src="data:text/javascript,%21function%28%29%7B%22use%20strict%22%3Bvar%20e%3D%5B%5D%2Ct%3D%22wpcom.simple.ttfb.batcache.%22%3Btry%7Bfor%28var%20n%3Dperformance.getEntriesByType%28%22navigation%22%29%5B0%5D%7C%7C%7B%7D%2Co%3D0%2Cs%3Ddocument.body.childNodes%2Cc%3Ds.length-1%3Bc%3E%3D0%3Bc--%29s%5Bc%5D.nodeType%3D%3D%3DNode.COMMENT_NODE%26%26s%5Bc%5D.textContent.indexOf%28%22served%20from%20batcache%22%29%3E0%26%26%28o%3D1%29%3Bvar%20r%3DMath.round%28n.responseStart%7C%7C0%29%3Bif%28r%3E0%26%26%28o%3Fe.push%28t%2B%22hit%3A%22%2Br%2B%22%7Cms%22%29%3Ae.push%28t%2B%22miss%3A%22%2Br%2B%22%7Cms%22%29%29%2Ce.length%29document.createElement%28%22img%22%29.src%3D%22https%3A%2F%2Fpixel.wp.com%2Fboom.gif%3Fjson%3D%22%2BencodeURIComponent%28JSON.stringify%28%7Bbeacons%3Ae%7D%29%29%7Dcatch%28e%29%7B%7D%7D%28%29%3B"></script>
		<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
