<!DOCTYPE html>
<!--[if IE 8]> <html lang="en-US" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en-US" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Sleepers and busts for fantasy football wide receivers" /><meta name="news_keywords" content="fantasy football,%tags%,%cats%" />
<meta name="keywords" content="fantasy football,2020 fantasy football sleepers, adam thielen, allen robinson, brandin cooks, calvin ridley, chris godwin, courtland sutton, d.j. clark, devante parker, juju smith-schuster, julian edelman, kenny golladay, marvin jones, stefon diggs, t.y. hilton, terry mclaurin, tyler boyd, tyler lockett, will fuller,fantasy football sleepers and undervalued picks" />
<title>Sleepers and Value Plays: Wide Receivers Update</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Feed" href="https://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Comments Feed" href="https://thehuddle.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thehuddle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??-eJydj0sOwjAMRC9EaoGooAvElhuwThMLTPOpaqdVbk/4FCFgxc7yzDzNwNQrCsYliwyGGSyxQOui6ZSjdtBDBpbssPIUqmJYQEmYGASDQO/SiQJDYi3R6qzmBwuZLheyo4BqJIvxgf8lfGHljB7fqE5PAwaDs3DUrFv6MwaHZG3Z85n26dX+gtJr090LP++bfe93y7rZrjeruqmvN0R1Tw==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script id='amazon-adsystem-js-extra'>
var amznAcctId = ["3090"];
</script>
<script id='amazon-adsystem-js-before'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId[0], adServer: "googletag"});
</script>
<script src='https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/bidder-manager.js?ver=5.5' id='amazon-adsystem-js'></script>
<script src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=5.5' id='sonobi-adsystem-js'></script>
<script src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=5.5' id='lawrence-header-bidding-js'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.5' id='lawrence-ads-ias-js'></script>
<script id='lawrence-ads-ias-js-after'>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script type='text/javascript' src='https://thehuddle.com/wp-includes/js/jquery/jquery.js?m=1597173190g'></script>
<script id='lawrence-tealium-js-extra'>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","page-blogname":"thehuddle","page-has-video":"","page-use-canonical":"1","content-ssts-section":"sports","content-ssts-subsection":"sports:thehuddle","content-ssts-topic":"sports:thehuddle","content-ssts-subtopic":"sports:thehuddle","page-experience-type":"desktop","content-type":"story pages","content-id":"453328","content-headline":"Sleepers and Value Plays: Wide Receivers Update","content-date-published":"2020-08-28T10:10:14Z","content-byline":"David Dorey","content-contributor-names":"David Dorey","content-keywords":"2020 fantasy football sleepers,Adam Thielen,Allen Robinson,Brandin Cooks,Calvin Ridley,Chris Godwin,Courtland Sutton,D.J. Clark,Devante Parker,JuJu Smith-Schuster,Julian Edelman,Kenny Golladay,marvin jones,Stefon Diggs,T.Y. Hilton,Terry McLaurin,Tyler Boyd,Tyler Lockett,Will Fuller","content-title":"Sleepers and Value Plays: Wide Receivers Update |  | "};
</script>
<script id='lawrence-tealium-js-before'>
			window.gciAnalyticsUAID = "SMG-TEALIUM-THEHUDDLE";
			gciDataLayer["page-full-url"] = window.location.href;
			gciDataLayer["content-name"] = window.location.pathname;
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1' id='lawrence-tealium-js'></script>
<script id='lawrence-tealium-js-after'>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0' id='lawrence-confiant-js'></script>
<script id='usatoday-gallery-js-extra'>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-4086578-2","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-4086578-2","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJylkOEKwjAMhF/Irp0w0B/is9Qum+nSri7t5t7eDpyIgjD8l9zxHbnIKQjT+wg+ykCpRc8ysY59rWexCjqgaDURDAh5Y4bI0rKMoAmTe3pzYXkn/8lLXIesT9kSY1nsPwPjFRy85ZGeBvAGFpY7DILQd6LpTWLR4H0Lbm9paeA0+i0Y4WVFOaLpvn7w82Sshxed58ye3amsjgelKlUq+wBf+Jtb'></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-1.js?ver=5.5' id='the-huddle-eu-redirect-1-js'></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-2.js?ver=5.5' id='the-huddle-eu-redirect-2-js'></script>
<link rel="https://api.w.org/" href="https://thehuddle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thehuddle.com/wp-json/wp/v2/posts/453328" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thehuddle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thehuddle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5" />
<link rel='shortlink' href='https://thehuddle.com/?p=453328' />
<link rel="alternate" type="application/json+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2020%2F08%2F28%2Fsleepers-and-value-plays-wide-receivers-update%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2020%2F08%2F28%2Fsleepers-and-value-plays-wide-receivers-update%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="gdpr" content="false" />

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle",
		"mainEntityOfPage": {
			"@type": "WebPage",
			"@id": "https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		},
		"url": "https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/",
		"headline": "Sleepers and Value Plays: Wide Receivers Update",
		"thumbnailUrl": "https://thehuddle.com/wp-content/uploads/sites/74/2017/08/usatsi_10110128-e1502725630950.jpg?w=192&#038;h=150&#038;crop=1",
		"image": "https://thehuddle.com/wp-content/uploads/sites/74/2017/08/usatsi_10110128-e1502725630950.jpg?w=192&#038;h=150&#038;crop=1",
		"datePublished": "2020-08-28T10:10:14Z",
		"dateModified": "2020-08-28T10:28:53Z",
		"articleSection": "Fantasy Football Sleepers and Undervalued Picks",
		"creator": ["David Dorey"],
		"author": {
			"@type": "Person",
			"name": "David Dorey"
		},
		"keywords": ["2020 fantasy football sleepers","Adam Thielen","Allen Robinson","Brandin Cooks","Calvin Ridley","Chris Godwin","Courtland Sutton","D.J. Clark","Devante Parker","JuJu Smith-Schuster","Julian Edelman","Kenny Golladay","marvin jones","Stefon Diggs","T.Y. Hilton","Terry McLaurin","Tyler Boyd","Tyler Lockett","Will Fuller"],
	"publisher": {
		"@type": "Organization",
		"name": "Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com",
		"logo": {
			"@type": "ImageObject",
			"url": "https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
		}
	}
}
</script>
<style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.newsletter-modal {
	border-top: solid 8px #dd9933;
}

.article__back {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#dd9933, #dd9933)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

.smg-event__ctabutton {
	background-color: #dd9933;
	box-shadow: 0 2px 0 0 #dd9933;
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/" />

<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Sleepers and Value Plays: Wide Receivers Update" />
<meta property="og:url" content="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/" />
<meta property="og:description" content="2020 Sleeper and Value Play Wide Receivers" />
<meta property="article:published_time" content="2020-08-28T14:10:14+00:00" />
<meta property="article:modified_time" content="2020-08-28T14:28:53+00:00" />
<meta property="og:site_name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
<meta property="og:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2017/08/usatsi_10110128-e1502725630950.jpg?w=968&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="968" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Sleepers and Value Plays: Wide Receivers Update" />
<meta name="twitter:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2017/08/usatsi_10110128-e1502725630950.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=180" />
<meta name="msapplication-TileImage" content="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=270" />

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-453328 single-format-aside">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://thehuddle.com"
				title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
				class="branding__logo-link "
			>
				<img
					src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
					alt="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/logo-usat-bar-1.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-450451" class="nav__item nav__item--draft-guide nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2020-fantasy-football-league-draft-preview-rankings-cheatsheets-sleepers/">Draft Guide</a>
<ul class="sub-menu">
	<li id="menu-item-442874" class="nav__item nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2020&#038;week=0">Cheat Sheets</a></li>
	<li id="menu-item-442875" class="nav__item nav__item--fantasy-football-projections-rankings"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2020&#038;week=0">Fantasy football projections/rankings</a></li>
	<li id="menu-item-442876" class="nav__item nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-standard">Top 200 Overall</a></li>
	<li id="menu-item-442877" class="nav__item nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-ppr">Top 200 PPR</a></li>
	<li id="menu-item-442878" class="nav__item nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li id="menu-item-442879" class="nav__item nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442880" class="nav__item nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442881" class="nav__item nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li id="menu-item-442847" class="nav__item nav__item--in-season nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">In Season</a>
<ul class="sub-menu">
	<li id="menu-item-442894" class="nav__item nav__item--game-predictions"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">Game Predictions</a></li>
	<li id="menu-item-442895" class="nav__item nav__item--start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Start Bench Tool</a></li>
	<li id="menu-item-442896" class="nav__item nav__item--player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Player Rankings/Projections</a></li>
	<li id="menu-item-442897" class="nav__item nav__item--cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Cheat Sheets</a></li>
	<li id="menu-item-442898" class="nav__item nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li id="menu-item-442848" class="nav__item nav__item--dfs"><a href="https://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li id="menu-item-442849" class="nav__item nav__item--news nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li id="menu-item-450179" class="nav__item nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li id="menu-item-450180" class="nav__item nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li id="menu-item-450181" class="nav__item nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li id="menu-item-450182" class="nav__item nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li id="menu-item-450183" class="nav__item nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li id="menu-item-442850" class="nav__item nav__item--stats nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li id="menu-item-442899" class="nav__item nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li id="menu-item-442900" class="nav__item nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li id="menu-item-442901" class="nav__item nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li id="menu-item-442902" class="nav__item nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li id="menu-item-442903" class="nav__item nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li id="menu-item-442904" class="nav__item nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li id="menu-item-442906" class="nav__item nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li id="menu-item-442851" class="nav__item nav__item--teams nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li id="menu-item-442917" class="nav__item nav__item--afc-east"><a href="#">AFC East</a></li>
	<li id="menu-item-442918" class="nav__item nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li id="menu-item-442919" class="nav__item nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li id="menu-item-442920" class="nav__item nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li id="menu-item-442921" class="nav__item nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li id="menu-item-442922" class="nav__item nav__item--afc-north"><a href="#">AFC North</a></li>
	<li id="menu-item-442923" class="nav__item nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li id="menu-item-442924" class="nav__item nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li id="menu-item-442925" class="nav__item nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li id="menu-item-442926" class="nav__item nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li id="menu-item-442927" class="nav__item nav__item--afc-south"><a href="#">AFC South</a></li>
	<li id="menu-item-442928" class="nav__item nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li id="menu-item-442929" class="nav__item nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li id="menu-item-442930" class="nav__item nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li id="menu-item-442931" class="nav__item nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li id="menu-item-442932" class="nav__item nav__item--afc-west"><a href="#">AFC West</a></li>
	<li id="menu-item-442933" class="nav__item nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li id="menu-item-442934" class="nav__item nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li id="menu-item-442936" class="nav__item nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li id="menu-item-442935" class="nav__item nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li id="menu-item-442937" class="nav__item nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li id="menu-item-442938" class="nav__item nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li id="menu-item-442939" class="nav__item nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li id="menu-item-442940" class="nav__item nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li id="menu-item-442941" class="nav__item nav__item--washington-ft"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-football-team">Washington FT</a></li>
	<li id="menu-item-442942" class="nav__item nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li id="menu-item-442943" class="nav__item nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li id="menu-item-442944" class="nav__item nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li id="menu-item-442945" class="nav__item nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li id="menu-item-442946" class="nav__item nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li id="menu-item-442947" class="nav__item nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li id="menu-item-442948" class="nav__item nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li id="menu-item-442949" class="nav__item nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li id="menu-item-442950" class="nav__item nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li id="menu-item-442951" class="nav__item nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li id="menu-item-442952" class="nav__item nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li id="menu-item-442953" class="nav__item nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li id="menu-item-442954" class="nav__item nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li id="menu-item-442955" class="nav__item nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li id="menu-item-442956" class="nav__item nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li id="menu-item-442852" class="nav__item nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li id="menu-item-442911" class="nav__item nav__item--depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Depth Charts</a></li>
<li id="menu-item-442914" class="nav__item nav__item--nfl-draft"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">NFL Draft</a></li>
<li id="menu-item-442854" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-450426" class="nav__item nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener noreferrer" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li id="menu-item-450427" class="nav__item nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener noreferrer" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li id="menu-item-442855" class="nav__item nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-453328" class="post-453328 post type-post status-publish format-aside has-post-thumbnail hentry category-fantasy-football-sleepers-undervalued-draft-picks tag-2020-fantasy-football-sleepers tag-adam-thielen tag-allen-robinson tag-brandin-cooks tag-calvin-ridley tag-chris-godwin tag-courtland-sutton tag-d-j-clark tag-devante-parker tag-juju-smith-schuster tag-julian-edelman tag-kenny-golladay tag-marvin-jones tag-stefon-diggs tag-t-y-hilton tag-terry-mclaurin tag-tyler-boyd tag-tyler-lockett tag-will-fuller post_format-post-format-aside article--no-image" itemscope
				itemtype="http://schema.org/NewsArticle">

				<link itemprop="mainEntityofPage" href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"/>
		<meta itemprop="url" content="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png">
	</div>
	<meta itemprop="name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com">
</div>
<div class="article__title article__title--no-image ">
	<h1 class="article__headline">Sleepers and Value Plays: Wide Receivers Update</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject" href="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg" data-image-src="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg">
			<link itemprop="url" href="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg" />
		</span>
	</div>
<h1 class="article__headline article__headline--mobile">Sleepers and Value Plays: Wide Receivers Update</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Sleepers and Value Plays: Wide Receivers Update</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p>

	By <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a></span></span> 
		<span class="post-date updated">August 28, 2020 10:10 am</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
					Follow					@DMDorey				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
				</header>

				
				
									<div class="fullwidth-article-format">
				
				
				<div id="content-container">
					<div class="entry-content ">

						
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a></span></span> |
		<span itemprop="datePublished" content="2020-08-28T10:10:14-04:00">
			August 28, 2020 10:10 am		</span>
		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
		Follow @DMDorey	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p><span style="font-size: 18px">A sleeper wide receiver is </span>a player taken as a backup who ends up worthy of being a starter or at least far outplays the draft slot where you selected him.  <strong>Average Draft Positions (ADP) are taken from <a href="https://api.myfantasyleague.com/2020/reports?R=ADP" target="_blank" rel="nofollow noopener noreferrer">MyFantasyLeague.com</a>  using only recent drafts.</strong></p>
<p><strong>See also:<br />
</strong><strong><a href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-quarterbacks-update/">Sleepers and Value Plays: Quarterbacks Update</a></strong><br />
<strong><a href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-tight-ends-update/">Sleepers and Value Plays: Tight Ends Update</a><br />
<a href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-running-backs-update/">Sleepers and Value Plays: Running Backs Update</a></strong></p>
<p>The Average Draft order shows a general picture of how your draft will unfold and where values/sleepers and bad values/busts likely exist. Any green highlight means the player is a good value that could be taken earlier. A red highlight signifies an overvalued player that is a bad value or just too high of a risk for that spot.</p>
<h4>Average Draft order – Value plays</h4>
<p><img loading="lazy" class="aligncenter size-full wp-image-453385 lazy-load" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg?w=68&amp;h=95" alt width="681" height="951" data-lazy-src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg" data-lazy-srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg 681w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg?resize=215,300 215w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg?resize=243,340 243w" data-lazy-sizes="(max-width: 681px) 100vw, 681px"><noscript><img loading="lazy" class="aligncenter size-full wp-image-453385" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg" alt="" width="681" height="951" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg 681w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg?resize=215,300 215w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-1-U.jpg?resize=243,340 243w" sizes="(max-width: 681px) 100vw, 681px" /></noscript> <img loading="lazy" class="aligncenter size-full wp-image-453386 lazy-load" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg?w=68&amp;h=102" alt width="682" height="1028" data-lazy-src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg" data-lazy-srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg 682w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg?resize=199,300 199w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg?resize=679,1024 679w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg?resize=226,340 226w" data-lazy-sizes="(max-width: 682px) 100vw, 682px"><noscript><img loading="lazy" class="aligncenter size-full wp-image-453386" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg" alt="" width="682" height="1028" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg 682w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg?resize=199,300 199w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg?resize=679,1024 679w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-2-U.jpg?resize=226,340 226w" sizes="(max-width: 682px) 100vw, 682px" /></noscript> <img loading="lazy" class="aligncenter size-full wp-image-453387 lazy-load" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg?w=68&amp;h=103" alt width="680" height="1036" data-lazy-src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg" data-lazy-srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg 680w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg?resize=197,300 197w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg?resize=672,1024 672w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg?resize=223,340 223w" data-lazy-sizes="(max-width: 680px) 100vw, 680px"><noscript><img loading="lazy" class="aligncenter size-full wp-image-453387" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg" alt="" width="680" height="1036" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg 680w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg?resize=197,300 197w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg?resize=672,1024 672w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-3-U.jpg?resize=223,340 223w" sizes="(max-width: 680px) 100vw, 680px" /></noscript></p>
<h4>Sleepers and over-valued players</h4>
<p><img loading="lazy" class="aligncenter size-full wp-image-453389 lazy-load" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg?w=68&amp;h=102" alt width="683" height="1029" data-lazy-src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg" data-lazy-srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg 683w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg?resize=199,300 199w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg?resize=680,1024 680w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg?resize=226,340 226w" data-lazy-sizes="(max-width: 683px) 100vw, 683px"><noscript><img loading="lazy" class="aligncenter size-full wp-image-453389" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg" alt="" width="683" height="1029" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg 683w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg?resize=199,300 199w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg?resize=680,1024 680w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-4-U.jpg?resize=226,340 226w" sizes="(max-width: 683px) 100vw, 683px" /></noscript><img loading="lazy" class="aligncenter size-full wp-image-453388 lazy-load" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg?w=68&amp;h=97" alt width="680" height="976" data-lazy-src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg" data-lazy-srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg 680w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg?resize=209,300 209w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg?resize=237,340 237w" data-lazy-sizes="(max-width: 680px) 100vw, 680px"><noscript><img loading="lazy" class="aligncenter size-full wp-image-453388" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg" alt="" width="680" height="976" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg 680w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg?resize=209,300 209w, https://thehuddle.com/wp-content/uploads/sites/74/2020/08/WR-5-U.jpg?resize=237,340 237w" sizes="(max-width: 680px) 100vw, 680px" /></noscript></p>
<h4>Best of the Rest</h4>
<p><strong>Robby Anderson (CAR)</strong> &#8211; Worth up to 63-941-7 while with the Jets, Anderson comes over to pair with DJ Moore in what promises to be a pass-heavy new offense under new HC Matt Rhule. He&#8217;s overlooked in drafts because he left a bad offense for what should be an innovative one.</p>
<p><strong>Dede Westbrook (JAC)</strong> &#8211; Maybe Laviska Shenault is newer and shinier, but Westbrook is a speedy slot receiver with 66 catches for around 700 yards and four scores for the last two years. A more experienced Gardner Minshew should help trend up those stats if only incrementally.</p>
<p><strong>Mohamed Sanu (NE)</strong> &#8211; He is 30 years old and didn&#8217;t add much in his first season with the Patriots. But managed 838 yards in his last year with the Falcons and was hampered by an ankle injury last year that required off-season surgery. The Pats need a receiver to step up and Sanu will be a starter. He&#8217;s worth keeping an eye on at the least.</p>
<p><strong>James Washington (PIT)</strong> &#8211; Second-rounder from 2018 was an after-thought as a rookie when Antonio Brown and Juju Smith-Schuster dominated. Rose to 44-735-3 last year playing with &#8220;not Roethlisberger&#8221;. He&#8217;s just one of three or four receivers, but it is far too early to write him off.</p>
<p><strong>Michael Pittman (IND)</strong> &#8211; The 6-4, 223-pounder from USC is expected to win the No. 2 job across from T.Y. Hilton. The Colts upgraded with Philip Rivers and face one of the easiest passing schedules in the NFL.</p>
<p>&nbsp;</p>
</div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
						
						
						
						<p class="post-tags post-tags--hide"><a href="https://thehuddle.com/tag/2020-fantasy-football-sleepers/" rel="tag">2020 fantasy football sleepers</a>, <a href="https://thehuddle.com/tag/adam-thielen/" rel="tag">Adam Thielen</a>, <a href="https://thehuddle.com/tag/allen-robinson/" rel="tag">Allen Robinson</a>, <a href="https://thehuddle.com/tag/brandin-cooks/" rel="tag">Brandin Cooks</a>, <a href="https://thehuddle.com/tag/calvin-ridley/" rel="tag">Calvin Ridley</a>, <a href="https://thehuddle.com/tag/chris-godwin/" rel="tag">Chris Godwin</a>, <a href="https://thehuddle.com/tag/courtland-sutton/" rel="tag">Courtland Sutton</a>, <a href="https://thehuddle.com/tag/d-j-clark/" rel="tag">D.J. Clark</a>, <a href="https://thehuddle.com/tag/devante-parker/" rel="tag">Devante Parker</a>, <a href="https://thehuddle.com/tag/juju-smith-schuster/" rel="tag">JuJu Smith-Schuster</a>, <a href="https://thehuddle.com/tag/julian-edelman/" rel="tag">Julian Edelman</a>, <a href="https://thehuddle.com/tag/kenny-golladay/" rel="tag">Kenny Golladay</a>, <a href="https://thehuddle.com/tag/marvin-jones/" rel="tag">marvin jones</a>, <a href="https://thehuddle.com/tag/stefon-diggs/" rel="tag">Stefon Diggs</a>, <a href="https://thehuddle.com/tag/t-y-hilton/" rel="tag">T.Y. Hilton</a>, <a href="https://thehuddle.com/tag/terry-mclaurin/" rel="tag">Terry McLaurin</a>, <a href="https://thehuddle.com/tag/tyler-boyd/" rel="tag">Tyler Boyd</a>, <a href="https://thehuddle.com/tag/tyler-lockett/" rel="tag">Tyler Lockett</a>, <a href="https://thehuddle.com/tag/will-fuller/" rel="tag">Will Fuller</a>, <a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" rel="category tag">Fantasy Football Sleepers and Undervalued Picks</a></p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-wide-receivers-update/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

									</div>
				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-running-backs-update/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-1"
		title="Sleepers and Value Plays: Running Backs Update"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/06/usatsi_12707311.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/06/usatsi_12707311.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Sleepers and Value Plays: Running Backs Update" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">2hr ago</span>
		<h2><a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="category" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-running-backs-update/"
				title="Sleepers and Value Plays: Running Backs Update" itemprop="url">
				Sleepers and Value Plays: Running Backs Update			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-tight-ends-update/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-2"
		title="Sleepers and  Value Plays: Tight Ends Update"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/09/13329841-e1568344617849.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/09/13329841-e1568344617849.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Sleepers and  Value Plays: Tight Ends Update" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">2hr ago</span>
		<h2><a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="category" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-tight-ends-update/"
				title="Sleepers and  Value Plays: Tight Ends Update" itemprop="url">
				Sleepers and  Value Plays: Tight Ends Update			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-quarterbacks-update/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-3"
		title="Sleepers and Value Plays: Quarterbacks Update"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2018/10/11356175-e1538782386400.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2018/10/11356175-e1538782386400.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Sleepers and Value Plays: Quarterbacks Update" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">2hr ago</span>
		<h2><a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="category" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-quarterbacks-update/"
				title="Sleepers and Value Plays: Quarterbacks Update" itemprop="url">
				Sleepers and Value Plays: Quarterbacks Update			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-running-backs-update/"
						title="Sleepers and Value Plays: Running Backs Update"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/06/usatsi_12707311.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/06/usatsi_12707311.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sleepers and Value Plays: Running Backs Update" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/28/sleepers-and-value-plays-running-backs-update/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-running-backs-update/"
			title="Sleepers and Value Plays: Running Backs Update"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="category" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a>						<span class="block__time block__time--mobile">2hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-running-backs-update/"
						title="Sleepers and Value Plays: Running Backs Update"
						itemprop="url" 						>
							Sleepers and Value Plays: Running Backs Update					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 28, 2020 10:11 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2020 Fantasy Sleepers &#8211; Running Backs </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-tight-ends-update/"
						title="Sleepers and  Value Plays: Tight Ends Update"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/09/13329841-e1568344617849.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/09/13329841-e1568344617849.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sleepers and  Value Plays: Tight Ends Update" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/28/sleepers-and-value-plays-tight-ends-update/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-tight-ends-update/"
			title="Sleepers and  Value Plays: Tight Ends Update"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="category" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a>						<span class="block__time block__time--mobile">2hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-tight-ends-update/"
						title="Sleepers and  Value Plays: Tight Ends Update"
						itemprop="url" 						>
							Sleepers and  Value Plays: Tight Ends Update					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 28, 2020 10:10 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2020 Sleeper and Value Plays at Tight End </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-quarterbacks-update/"
						title="Sleepers and Value Plays: Quarterbacks Update"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2018/10/11356175-e1538782386400.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2018/10/11356175-e1538782386400.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sleepers and Value Plays: Quarterbacks Update" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/28/sleepers-and-value-plays-quarterbacks-update/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-quarterbacks-update/"
			title="Sleepers and Value Plays: Quarterbacks Update"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="category" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a>						<span class="block__time block__time--mobile">2hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/28/sleepers-and-value-plays-quarterbacks-update/"
						title="Sleepers and Value Plays: Quarterbacks Update"
						itemprop="url" 						>
							Sleepers and Value Plays: Quarterbacks Update					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 28, 2020 10:09 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2020 Quarterback Sleepers and Value Plays </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/last-minute-tips-for-your-fantasy-football-draft/"
						title="Last-minute tips for your fantasy football draft"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/08/12237803.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/08/12237803.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Last-minute tips for your fantasy football draft" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/27/last-minute-tips-for-your-fantasy-football-draft/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/27/last-minute-tips-for-your-fantasy-football-draft/"
			title="Last-minute tips for your fantasy football draft"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>11</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				19hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-draft-strategy-tips-advice/" class="category" itemprop="articleSection">Fantasy football draft strategy tips and advice</a>						<span class="block__time block__time--mobile">19hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/last-minute-tips-for-your-fantasy-football-draft/"
						title="Last-minute tips for your fantasy football draft"
						itemprop="url" 						>
							Last-minute tips for your fantasy football draft					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 27, 2020 5:23 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Get ready for your fantasy football draft </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/2020-fantasy-football-top-sleepers-and-flier-picks/"
						title="Cory Bonini&#039;s 2020 fantasy football sleepers and flier picks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/08/usatsi_13277743.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/usatsi_13277743.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Cory Bonini&#039;s 2020 fantasy football sleepers and flier picks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/27/2020-fantasy-football-top-sleepers-and-flier-picks/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/27/2020-fantasy-football-top-sleepers-and-flier-picks/"
			title="Cory Bonini&#039;s 2020 fantasy football sleepers and flier picks"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				23hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="category" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a>						<span class="block__time block__time--mobile">23hr ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/2020-fantasy-football-top-sleepers-and-flier-picks/"
						title="Cory Bonini&#039;s 2020 fantasy football sleepers and flier picks"
						itemprop="url" 						>
							Cory Bonini&#039;s 2020 fantasy football sleepers and flier picks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 27, 2020 1:33 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Every fantasy football gamers needs to know the top sleeper candidates for 2020. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/2020-fantasy-football-best-value-buys/"
						title="2020 Fantasy Football: best value buys"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2018/06/usatsi_10520926.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2018/06/usatsi_10520926.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2020 Fantasy Football: best value buys" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/27/2020-fantasy-football-best-value-buys/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/27/2020-fantasy-football-best-value-buys/"
			title="2020 Fantasy Football: best value buys"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				23hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-sleepers-undervalued-draft-picks/" class="category" itemprop="articleSection">Fantasy Football Sleepers and Undervalued Picks</a>						<span class="block__time block__time--mobile">23hr ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/2020-fantasy-football-best-value-buys/"
						title="2020 Fantasy Football: best value buys"
						itemprop="url" 						>
							2020 Fantasy Football: best value buys					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 27, 2020 1:24 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Examining the best value buys in fantasy football average draft placement trends. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/fantasy-football-idp-sleepers-target-these-individual-defensive-players-on-draft-day/"
						title="Fantasy football IDP sleepers: Target these individual defensive players on draft day"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/08/USATSI_13555742.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/USATSI_13555742.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football IDP sleepers: Target these individual defensive players on draft day" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/27/fantasy-football-idp-sleepers-target-these-individual-defensive-players-on-draft-day/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/27/fantasy-football-idp-sleepers-target-these-individual-defensive-players-on-draft-day/"
			title="Fantasy football IDP sleepers: Target these individual defensive players on draft day"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-idp-analysis/" class="category" itemprop="articleSection">Fantasy Football IDP Analysis</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/fantasy-football-idp-sleepers-target-these-individual-defensive-players-on-draft-day/"
						title="Fantasy football IDP sleepers: Target these individual defensive players on draft day"
						itemprop="url" 						>
							Fantasy football IDP sleepers: Target these individual defensive players on draft day					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 27, 2020 12:31 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>The top IDP sleepers to target for 2020 fantasy football defensive player drafts. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/downloadable-fantasy-football-rankings-offense-and-defensive-teams/"
						title="Downloadable fantasy football rankings: QB-RB-WR-TE-PK-DT"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2018/10/11353658-e1538450497406.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2018/10/11353658-e1538450497406.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Downloadable fantasy football rankings: QB-RB-WR-TE-PK-DT" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/27/downloadable-fantasy-football-rankings-offense-and-defensive-teams/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/27/downloadable-fantasy-football-rankings-offense-and-defensive-teams/"
			title="Downloadable fantasy football rankings: QB-RB-WR-TE-PK-DT"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-projections/" class="category" itemprop="articleSection">Player Projections</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/27/downloadable-fantasy-football-rankings-offense-and-defensive-teams/"
						title="Downloadable fantasy football rankings: QB-RB-WR-TE-PK-DT"
						itemprop="url" 						>
							Downloadable fantasy football rankings: QB-RB-WR-TE-PK-DT					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 27, 2020 1:43 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/26/downloadable-idp-rankings/"
						title="Downloadable IDP rankings"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/05/usatsi_11942962.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						 target="_blank" >

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/05/usatsi_11942962.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Downloadable IDP rankings" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/26/downloadable-idp-rankings/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/26/downloadable-idp-rankings/"
			title="Downloadable IDP rankings"
			class="reply" rel="nofollow"
			 target="_blank" >reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-projections/" class="category" itemprop="articleSection">Player Projections</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/26/downloadable-idp-rankings/"
						title="Downloadable IDP rankings"
						itemprop="url" 						 target="_blank" >
							Downloadable IDP rankings					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 26, 2020 12:40 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/25/second-year-wideouts-ready-to-breakout/"
						title="Second-year wideouts ready to breakout"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/09/usatsi_13328786.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/09/usatsi_13328786.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Second-year wideouts ready to breakout" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2020/08/25/second-year-wideouts-ready-to-breakout/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2020/08/25/second-year-wideouts-ready-to-breakout/"
			title="Second-year wideouts ready to breakout"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/" class="category" itemprop="articleSection">Fantasy football player analysis tips and advice</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2020/08/25/second-year-wideouts-ready-to-breakout/"
						title="Second-year wideouts ready to breakout"
						itemprop="url" 						>
							Second-year wideouts ready to breakout					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">August 25, 2020 9:58 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Wideouts from the 2019 draft class are ready to step into starting roles after a year of learning the NFL. </p>

				
				
			</div>
		</article>
	</div>
<a href="https://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget widget--login widget--box" id="login_widget-3">
<div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget_media_image" id="media_image-4"><a href="https://rotolab.com/ordering.htm"><img width="300" height="200" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/banner-draftlab-300x200_UPDATED.png?w=300" class="image wp-image-453201  attachment-300x200 size-300x200" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div><div class="widget widget--forum widget--box" id="forum_widget-4">
<div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="https://tools.thehuddle.com/season">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="https://tools.thehuddle.com/weekly">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Stats Matchups</a></li>
</ul><a href="/fantasy_football_statistics.php" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><a href="http://www.thehuddle.com/podcast/"><img width="1000" height="1000" src="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg 1000w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=150,150 150w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=300,300 300w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=768,768 768w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=600,600 600w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=100,100 100w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=340,340 340w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=32,32 32w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=50,50 50w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=64,64 64w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=96,96 96w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=128,128 128w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></div><div class="widget widget--links widget--box" id="links_widget-8">
<div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="https://tools.thehuddle.com/nfl-depth-charts">2020 fantasy depth charts</a></li>
<li id="menu-item-449190" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449190"><a href="https://thehuddle.com/2020/04/19/2020-top-free-agent-tracker/">2020 top free-agent tracker</a></li>
<li id="menu-item-449189" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449189"><a href="https://thehuddle.com/2020/05/23/2020-player-movement-tracker/">2020 player movement tracker</a></li>
<li id="menu-item-449191" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-449191"><a href="https://thehuddle.com/2020/04/28/2020-coaching-change-tracker/">2020 coaching change tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7">
<div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="https://tools.thehuddle.com/nfl-depth-charts">2020 fantasy depth charts</a></li>
<li id="menu-item-450161" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450161"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">2020 NFL Draft results: by round</a></li>
<li id="menu-item-450159" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450159"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-team/">2020 NFL Draft results: by team</a></li>
<li id="menu-item-450160" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-450160"><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-position/">2020 NFL Draft results: by position</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-3">
<div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/logo-usat-footer-1.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448091"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
	<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/icon-huddle.png" alt="Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com">
				<a class="mobile-nav__breadcrumb" href="https://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-guide mobile-nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2020-fantasy-football-league-draft-preview-rankings-cheatsheets-sleepers/">Draft Guide</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2020&#038;week=0">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-projections-rankings"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2020&#038;week=0">Fantasy football projections/rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-standard">Top 200 Overall</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-ppr">Top 200 PPR</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li class="mobile-nav__item mobile-nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--in-season mobile-nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">In Season</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--game-predictions"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">Game Predictions</a></li>
	<li class="mobile-nav__item mobile-nav__item--start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Start Bench Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Player Rankings/Projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--dfs"><a href="https://thehuddle.com/daily-fantasy-football/">DFS</a></li>
<li class="mobile-nav__item mobile-nav__item--news mobile-nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li class="mobile-nav__item mobile-nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--stats mobile-nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li class="mobile-nav__item mobile-nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--teams mobile-nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--afc-east"><a href="#">AFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-north"><a href="#">AFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li class="mobile-nav__item mobile-nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li class="mobile-nav__item mobile-nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-south"><a href="#">AFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li class="mobile-nav__item mobile-nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li class="mobile-nav__item mobile-nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li class="mobile-nav__item mobile-nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-west"><a href="#">AFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li class="mobile-nav__item mobile-nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li class="mobile-nav__item mobile-nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-ft"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-football-team">Washington FT</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li class="mobile-nav__item mobile-nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li class="mobile-nav__item mobile-nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li class="mobile-nav__item mobile-nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-draft"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">NFL Draft</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener noreferrer" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li class="mobile-nav__item mobile-nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener noreferrer" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/usat-logo-mobile-off-canvas-1.png">
		</a>
	</div>

<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="https://tools.thehuddle.com/login" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script src='https://native.sharethrough.com/assets/sfp.js?ver=1' id='sharethrough-native-responsive-js'></script>
<script id='usatoday-sticky-inline-videos-script-js-extra'>
var stickyInlineVideosOptions = {"side":"right","hide":"Hide video"};
</script>
<script id='lawrence-ads-js-js-extra'>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"60","refresh_type":"all","distance":"2000","active":"1"}};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJydjsEKwjAQRH/IGBSL9iB+iqzJUjdNNjXZtOTvrYIg4sF6nZn3GD0NykQWZNFyxYBZlwwSLVTlYUrIBnWItvi5AauySTRI1i7rARKEWFjWLq/0/x4GoRHPXYKRpH7KBl864jfbK8hCpq+K2BOjGslifOq+5T8/nHlPF+1uBVNdmxh7wiVwAOIle7CPb6dw3DTtYbffNm3j7jltmGc='></script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0' id='lawrence-confiant-js-js'></script>
<script id='wasabi-article-js-extra'>
var wasabiFacebookReferral = "0";
</script>
<script id='wasabi-main-js-extra'>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script id='huddle-user-nav-js-extra'>
var huddleUser = {"name":"Huddle User","cookie":"session","logoutAPI":"https:\/\/api.thehuddle.com\/User\/Logout"};
</script>
<script id='huddle-login-debug-js-extra'>
var huddleLoginDebugData = {"is_member":"","user_data":[]};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJytkUsOgzAMRC/UkLBAahdVz2KwBUb5IJyU0tM3LFDLDlCXHvuNrbGeBtUEH8lHPdjUshedBGJAmNUqWHjPygZARa88iYS6/1ELx77o5aL/4bXXZwKBmhc2RbZygvPw5BYih/3Hf2FhpBrGEySMkRtLJ0gHB3KOHakuIVpaUN6/bwsmoVHlpFacfWMTkiy9XJKr6dj/t/Y2ZFHlKFObHR7uXla3qzGVKU3/AV4x+9U='></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin' id='sop-script-js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202035.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8.2',blog:'175784887',post:'453328',tz:'-4',srv:'thehuddle.com'} ]);
	_stq.push([ 'clickTrackerInit', '175784887', '453328' ]);
</script>
</body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
