<!DOCTYPE html>
<!--[if IE 8]> <html lang="en-US" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en-US" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Jets bring in new coaching staff" /><meta name="news_keywords" content="fantasy football,%tags%,%cats%" />
<meta name="keywords" content="fantasy football,fantasy football, jeff ulbrich, mike lafleur, new york jets, nfl coaching changes, robert saleh, sam darnold,nfl coaching change with fantasy football impact" />
<title>2021 NFL coaching changes: New York Jets</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//ads.rubiconproject.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Feed" href="https://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Comments Feed" href="https://thehuddle.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thehuddle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??-eJydkEsOwjAMRC9EapAAwQKx5Qas3cQCQ5pEsUPV2xM+FUggFiz9mefxQJ8MB+uLIwErAo5FofXRno3nNmMeQHTw1HQcmrowgaqwMSgFha6Y5MuBg4AQZnsE8ijKNmUaWTdorm0lZ1IUFfOg36nyFTsyi6BGh8PrSEWfh2rYcyBzYUfx4frb4AOrR+rojeqxzxQsjYM9Crb8pwx2xbka04+ITqQJ6+frZn43/axvkm23mS1n8+l0vVosr+WAl1s=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script id='amazon-adsystem-js-extra'>
var amznAcctId = ["3090"];
</script>
<script id='amazon-adsystem-js-before'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId[0], adServer: "googletag"});
</script>
<script src='https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/bidder-manager.js?ver=5.6.2' id='amazon-adsystem-js'></script>
<script src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=5.6.2' id='sonobi-adsystem-js'></script>
<script src='//ads.rubiconproject.com/prebid/10968_USAToday_Sports.js?ver=5.6.2' id='lawrence_magnite_header_bidder_script-js'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.6.2' id='lawrence-ads-ias-js'></script>
<script id='lawrence-ads-ias-js-after'>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZoYmBgaWFqVkWAK9RIiA='></script>
<script id='lawrence-tealium-js-extra'>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","content-market-name":"thehuddle","page-has-video":"no","page-has-gallery":"0","page-canonical-url":"https:\/\/thehuddle.com\/2021\/02\/23\/2021-nfl-coaching-changes-new-york-jets\/","content-ssts-section":"sports","content-ssts-subsection":"sports:thehuddle","content-ssts-topic":"sports:thehuddle","content-ssts-subtopic":"sports:thehuddle","page-experience-type":"desktop","content-type":"story pages","content-id":"457401","content-headline":"2021 NFL coaching changes: New York Jets","content-date-published":"2021-02-23T02:42:49Z","content-byline":"David Dorey","content-contributor-names":"David Dorey","content-article-length":"1598","content-keywords":"Fantasy Football,Jeff Ulbrich,Mike LaFleur,New York Jets,NFL Coaching Changes,Robert Saleh,Sam Darnold","content-title":"2021 NFL coaching changes: New York Jets |  | "};
</script>
<script id='lawrence-tealium-js-before'>
			window.gciAnalyticsUAID = "SMG-TEALIUM-THEHUDDLE";
			gciDataLayer["page-full-url"]    = window.location.href;
			gciDataLayer["content-name"]     = window.location.pathname;
			gciDataLayer["page-referer"]     = document.referrer;
			gciDataLayer["page-has-gallery"] = Boolean(parseInt(gciDataLayer["page-has-gallery"], 10));
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1' id='lawrence-tealium-js'></script>
<script id='lawrence-tealium-js-after'>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0' id='lawrence-confiant-js'></script>
<script id='usatoday-gallery-js-extra'>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-166840762-5","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-166840762-5","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJylkNEKwjAMRX/IrLQPAx/Eb6ldNtO1XV3azf29HTgRBWH4ltzLueRGzBHMEBKGJKLLHQUWmXUaGr3AJuhI0GnncCQsGzMmFpZFQu0o+6e3VJYP4p+8zE0s+lwsmGSlPgPTFT2+5Tk9jxgMriz3FMFR6KEdTGZo6b4Ht7e8NvCawh7M0WVDOZHpv37w82Rqxhdd5sKe/UnWUtXyqJSyD1/dm14='></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-1.js?ver=5.6.2' id='the-huddle-eu-redirect-1-js'></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-2.js?ver=5.6.2' id='the-huddle-eu-redirect-2-js'></script>
<link rel="https://api.w.org/" href="https://thehuddle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thehuddle.com/wp-json/wp/v2/posts/457401" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thehuddle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thehuddle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://thehuddle.com/?p=457401' />
<link rel="alternate" type="application/json+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2021%2F02%2F23%2F2021-nfl-coaching-changes-new-york-jets%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2021%2F02%2F23%2F2021-nfl-coaching-changes-new-york-jets%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="gdpr" content="false" />

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle",
		"mainEntityOfPage": {
			"@type": "WebPage",
			"@id": "https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		},
		"url": "https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/",
		"headline": "2021 NFL coaching changes: New York Jets",
		"thumbnailUrl": "https://thehuddle.com/wp-content/uploads/sites/74/2021/02/e1d54139-ba0f-45b2-b817-a0a69d5a236d-USATSI_14022567.jpg?w=192&#038;h=150&#038;crop=1",
		"image": "https://thehuddle.com/wp-content/uploads/sites/74/2021/02/e1d54139-ba0f-45b2-b817-a0a69d5a236d-USATSI_14022567.jpg?w=192&#038;h=150&#038;crop=1",
		"datePublished": "2021-02-23T02:42:49Z",
		"dateModified": "2021-02-23T02:53:42Z",
		"articleSection": "NFL Coaching Change with fantasy football impact",
		"creator": ["David Dorey"],
		"author": {
			"@type": "Person",
			"name": "David Dorey"
		},
		"keywords": ["Fantasy Football","Jeff Ulbrich","Mike LaFleur","New York Jets","NFL Coaching Changes","Robert Saleh","Sam Darnold"],
	"publisher": {
		"@type": "Organization",
		"name": "Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com",
		"logo": {
			"@type": "ImageObject",
			"url": "https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
		}
	}
}
</script>
<style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.newsletter-modal {
	border-top: solid 8px #dd9933;
}

.article__back {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.listicle__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#dd9933, #dd9933)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

.smg-event__ctabutton {
	background-color: #dd9933;
	box-shadow: 0 2px 0 0 #dd9933;
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/" />

<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.addBidder( 'magnite' );
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video', 'ignoreRefresh' : true } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="2021 NFL coaching changes: New York Jets" />
<meta property="og:url" content="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/" />
<meta property="og:description" content="The Jets move ojto head coach Robert Saleh" />
<meta property="article:published_time" content="2021-02-23T07:42:49+00:00" />
<meta property="article:modified_time" content="2021-02-23T07:53:42+00:00" />
<meta property="og:site_name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
<meta property="og:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/e1d54139-ba0f-45b2-b817-a0a69d5a236d-USATSI_14022567.jpg?w=660&amp;h=393&amp;crop=1" />
<meta property="og:image:width" content="660" />
<meta property="og:image:height" content="393" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="2021 NFL coaching changes: New York Jets" />
<meta name="twitter:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/e1d54139-ba0f-45b2-b817-a0a69d5a236d-USATSI_14022567.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=180" />
<meta name="msapplication-TileImage" content="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=270" />

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-457401 single-format-standard">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://thehuddle.com"
				title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
				class="branding__logo-link "
			>
				<img
					src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
					alt="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/logo-usat-bar-1.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-450451" class="nav__item nav__item--draft-guide nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2020-fantasy-football-league-draft-preview-rankings-cheatsheets-sleepers/">Draft Guide</a>
<ul class="sub-menu">
	<li id="menu-item-442874" class="nav__item nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2020&#038;week=0">Cheat Sheets</a></li>
	<li id="menu-item-442875" class="nav__item nav__item--fantasy-football-projections"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2020&#038;week=0">Fantasy football projections</a></li>
	<li id="menu-item-442876" class="nav__item nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-standard">Top 200 Overall</a></li>
	<li id="menu-item-442877" class="nav__item nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-ppr">Top 200 PPR</a></li>
	<li id="menu-item-442878" class="nav__item nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li id="menu-item-442879" class="nav__item nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442880" class="nav__item nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442881" class="nav__item nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li id="menu-item-442847" class="nav__item nav__item--inseason nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">Inseason</a>
<ul class="sub-menu">
	<li id="menu-item-442896" class="nav__item nav__item--fantasy-football-player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy Football Player Rankings / Projections</a></li>
	<li id="menu-item-442897" class="nav__item nav__item--fantasy-football-cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Fantasy Football Cheat Sheets</a></li>
	<li id="menu-item-442848" class="nav__item nav__item--dfs-daily-fantasy-football"><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/">DFS - Daily Fantasy Football</a></li>
	<li id="menu-item-442894" class="nav__item nav__item--nfl-game-predictions-and-picks"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">NFL Game Predictions and Picks</a></li>
	<li id="menu-item-442895" class="nav__item nav__item--fantasy-football-start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Fantasy Football Start/Bench Tool</a></li>
	<li id="menu-item-442898" class="nav__item nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li id="menu-item-442849" class="nav__item nav__item--news nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li id="menu-item-450179" class="nav__item nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li id="menu-item-450180" class="nav__item nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li id="menu-item-450181" class="nav__item nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li id="menu-item-450182" class="nav__item nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li id="menu-item-450183" class="nav__item nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li id="menu-item-442850" class="nav__item nav__item--stats nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li id="menu-item-442899" class="nav__item nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li id="menu-item-442900" class="nav__item nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li id="menu-item-442901" class="nav__item nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li id="menu-item-442902" class="nav__item nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li id="menu-item-442903" class="nav__item nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li id="menu-item-442904" class="nav__item nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li id="menu-item-442906" class="nav__item nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li id="menu-item-442851" class="nav__item nav__item--teams nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li id="menu-item-442917" class="nav__item nav__item--afc-east"><a href="#">AFC East</a></li>
	<li id="menu-item-442918" class="nav__item nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li id="menu-item-442919" class="nav__item nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li id="menu-item-442920" class="nav__item nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li id="menu-item-442921" class="nav__item nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li id="menu-item-442922" class="nav__item nav__item--afc-north"><a href="#">AFC North</a></li>
	<li id="menu-item-442923" class="nav__item nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li id="menu-item-442924" class="nav__item nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li id="menu-item-442925" class="nav__item nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li id="menu-item-442926" class="nav__item nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li id="menu-item-442927" class="nav__item nav__item--afc-south"><a href="#">AFC South</a></li>
	<li id="menu-item-442928" class="nav__item nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li id="menu-item-442929" class="nav__item nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li id="menu-item-442930" class="nav__item nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li id="menu-item-442931" class="nav__item nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li id="menu-item-442932" class="nav__item nav__item--afc-west"><a href="#">AFC West</a></li>
	<li id="menu-item-442933" class="nav__item nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li id="menu-item-442934" class="nav__item nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li id="menu-item-442936" class="nav__item nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li id="menu-item-442935" class="nav__item nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li id="menu-item-442937" class="nav__item nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li id="menu-item-442938" class="nav__item nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li id="menu-item-442939" class="nav__item nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li id="menu-item-442940" class="nav__item nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li id="menu-item-442941" class="nav__item nav__item--washington-ft"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-football-team">Washington FT</a></li>
	<li id="menu-item-442942" class="nav__item nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li id="menu-item-442943" class="nav__item nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li id="menu-item-442944" class="nav__item nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li id="menu-item-442945" class="nav__item nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li id="menu-item-442946" class="nav__item nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li id="menu-item-442947" class="nav__item nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li id="menu-item-442948" class="nav__item nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li id="menu-item-442949" class="nav__item nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li id="menu-item-442950" class="nav__item nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li id="menu-item-442951" class="nav__item nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li id="menu-item-442952" class="nav__item nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li id="menu-item-442953" class="nav__item nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li id="menu-item-442954" class="nav__item nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li id="menu-item-442955" class="nav__item nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li id="menu-item-442956" class="nav__item nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li id="menu-item-442852" class="nav__item nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li id="menu-item-442911" class="nav__item nav__item--fantasy-football-nfl-depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Fantasy Football NFL Depth Charts</a></li>
<li id="menu-item-442854" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-442914" class="nav__item nav__item--nfl-draft"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">NFL Draft</a></li>
<li id="menu-item-450426" class="nav__item nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li id="menu-item-450427" class="nav__item nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li id="menu-item-442855" class="nav__item nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-457401" class="post-457401 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl-coaching-change-fantasy-football-impact tag-fantasy-football tag-jeff-ulbrich tag-mike-lafleur tag-new-york-jets tag-nfl-coaching-changes tag-robert-saleh tag-sam-darnold article--no-image" itemscope
				itemtype="http://schema.org/NewsArticle">

				<link itemprop="mainEntityofPage" href="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"/>
		<meta itemprop="url" content="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png">
	</div>
	<meta itemprop="name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com">
</div>
<div class="article__title article__title--no-image ">
	<h1 class="article__headline">2021 NFL coaching changes: New York Jets</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject" href="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg" data-image-src="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg">
			<link itemprop="url" href="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg" />
		</span>
	</div>
<h1 class="article__headline article__headline--mobile">2021 NFL coaching changes: New York Jets</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">2021 NFL coaching changes: New York Jets</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p>

	By <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a></span></span> 
		<span class="post-date updated">February 23, 2021 2:42 am</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
					Follow					@DMDorey				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a></span></span> |
		<span itemprop="datePublished" content="2021-02-23T02:42:49-05:00">
			February 23, 2021 2:42 am		</span>
		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
		Follow @DMDorey	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p>Two years with Adam Gase as head coach and play-caller, and the Jets nosedived to the bottom of the standings and rankings. Despite having the 1.03 pick in 2018 with Sam Darnell, the Jets finished No. 32 in quarterback fantasy points on a team that lost 14 games and always had to throw. Despite spending the big bucks on acquiring Le&#8217;Veon Bell two years ago, they ended up dumping him during the season and ranked No. 31 in running back fantasy points.  They ranked No. 30 in tight end fantasy points though they&#8217;ve been there for many years.</p>
<p>They even held a firm grasp on the No. 1 overall pick this year but ruined that with a late-season win. The beleaguered franchise hasn&#8217;t had a winning record in five years and ranked near the worst in all offensive categories almost every season.</p>
<p>Gase and his crew were sent packing, finally, in January and they tabbed one of the hotter coaching candidates for the new head coach gig &#8211; Robert Saleh. He comes fresh from four years as the 49ers defensive coordinator, and the entirety of his 15 years coaching the NFL came from the defensive side of the ball. He inherits a team with a far better defense than offense. The Jets ranked roughly average in most defensive categories and was Top-10 against the run.</p>
<p>By contrast, the 49ers played through a nightmare season thanks to injuries and COVD-19 and yet his defense still ranked near the top in all categories and ended No. 1 in rushing touchdowns allowed (12), passing yards allowed (3,514) and overall yardage allowed (5.211).</p>
<p>Saleh brought the 49ers passing game coordinator Mike LaFleur along with him to run the Jets&#8217; offense. Saleh&#8217;s forte has always been defense, so LaFleur will have considerable imprint on the offensive scheme. Like Salaeh, LaFleur spent his last four years with the 49ers under offensive-minded Kyle Shanahan. LaFleur is 33 years old and has coached in the NFL only since 2014. This will be his first time as an offensive coordinator in the league, though he filled the role back during his three years at Saint Joseph&#8217;s. LaFleur is the little brother of the Packers head coach Matt LaFleur.</p>
<p>Jeff Ulbrich fills in as the defensive coordinator and had a ten-year career as a linebacker for the 49ers. After spending a few seasons coaching special teams in Seattle, and then linebackers /special teams at UCLA, he&#8217;s been in Atlanta where he coached linebackers and then served as the defensive coordinator starting mid-season during their coaching shake-up.</p>
<p><strong style="font-size: 30px; font-style: italic;">Coaching tendencies</strong></p>
<p><strong>Head coach Robert Saleh</strong> &#8211; The Jets reverse course from their last foray into a hunt for a new head coach. Adam Gase brought in offensive credentials and the all-too-brief specter of a productive and innovative offense. Saleh is a player-friendly and intense coach that coached alongside the offenses of the Seahawks and 49ers. He&#8217;s considered a prime catch for the Jets and someone who should be better up to the task of returning the franchise back  into respectability. Considering that he ran the defense in San Francisco for four years and brought along Mike LaFleur from there, the Jets will attempt to import the 49ers style and scheme on both sides of the ball.</p>
<p>Given that the 49ers did as well despite dealing with rampant injuries last year bodes well for the Jets and their  lackluster roster. And Saleh and both of his coordinators are in their first NFL season in their roles. Couple that with a roster in transition and a rebuild won&#8217;t happen over night. Then again, the Jets were 2-14 last year so the bar is not that high to consider his first season as a success.</p>
<p>Saleh will have a hand in the defense but he&#8217;s there to create a winning culture and get the franchise back on track. One of the criticisms of Adam Gase was that he was too involved with the offense to the detriment of running an entire team.</p>
<p>He&#8217;ll install that aggressive, &#8220;All Gas, No Brakes&#8221; defensive scheme but allow Jeff Ulbrich to direct the defensive plays. Saleh&#8217;s job is to motivate and coach up players on both sides of the ball and to import the 49ers-style culture. The Jets ranked No. 30 in penalty yards last season and that&#8217;s also a  focus for the team.</p>
<p>Saleh will run the same 4-3 that he had with the 49ers and the Jets already used that scheme last year, though officially they were a 3-4. The transition shouldn&#8217;t be a problem.</p>
<p><strong>Offensive coordinator Mike LaFleur</strong> &#8211; LaFleur spent the last three seasons as the passing game coordinator with the 49ers and they tied an NFL record with 13 different players catching a touchdown in 2019. He brings in a scheme that uses all receivers including tight ends. George Kittle&#8217;s breakout came with LaFleur handling the passing. The offense will always seek to establish the run first to set up the pass.</p>
<p>This is a complicated and diverse attack that will take time to install. The 49ers ranked in the Top 6 for each of the last three years and yet never featured a running back with more than 153 carries in a season. Injuries had an obvious impact, but this is not the sort of offense that relies on one primary back to any large extent. The backfield totaled in the Top-5 in fantasy points for the last two years and yet never featured any back.</p>
<p>Under LaFleur, the passing offense was average at best thanks mostly to Jimmy Garoppolo&#8217;s inability to stay healthy. And while the 49ers spent high draft picks on wide receivers for the last two seasons, they haven&#8217;t produced any wideout with more than 802 yards in the last three years. Again &#8211; most of them were injured at some point each year.</p>
<p>The offensive scheme that LaFleur will import will employ a committee backfield. The offensive line isn&#8217;t nearly as good as he had in San Francisco, so the results are not likely to produce any top running back at least initially. But this is a scheme that threw 80 to 90 completions to running backs.</p>
<p><strong>Defensive coordinator Jeff Ulbrich</strong> &#8211; With only six years experience as a linebackers coach, Ulbrich helps to install and run the defense for Saleh. He&#8217;ll bring an energetic presence to accompany his experience with both coaching and playing. Ulbrich played with Saleh for one year in Seattle when he was a special teams assistant back in 2011.</p>
<p>Ulbrich is in a great situation being given the rebuilding job with the Jets defense while working under Saleh&#8217;s direction. He&#8217;ll call the defensive plays and is another high-energy, player-friendly coach looking to install a better culture.</p>
<aside class="related shortcode shortcode--related">
				<h2 class="related__header">Related</h2><a
			class="block block--related"
			href="https://thehuddle.com/2021/02/15/2021-nfl-coaching-change-tracker/"
			data-track="thehuddle-in-article-related-curated"
			
		><h2 class="block__title">2021 NFL coaching change tracker</h2></a></aside>
<h2><strong>Personnel changes</strong></h2>
<p>There could be significant and wide-ranging player moves for 2021, while installing new offensive and defensive schemes. First and foremost, there&#8217;s no certainty who the quarterback will be. Sam Darnell hasn&#8217;t remotely lived up to his 1.03 draft selection though there&#8217;s diversity in how the blame gets assigned.  The Jets appeared to be a lock to win the Trevor Lawrence sweepstakes but then fell to 1.02 with a late-season win.  There&#8217;s plenty of speculation as to what happens with Darnell, but the Jets are playing it very close to the vest and there may not be any clarity until that 1.02 pick is announced.</p>
<p>The Jets backfield has no primary back with Le&#8217;Veon Bell gone during last season and Frank Gore becoming a free agent yet again. The Jets have to acquire new blood to carry the ball.</p>
<p>The receivers are a marginal grouping of Jamison Crowder, Breshad Perriman (free agent), and Denzel Mims. Chris Herndon is the top tight end but only managed 31 catches in 2020. The shelves are pretty bare for the offense but a total rebuild is on the way.</p>
<p>The Jets have $71 million in cap space, so they can jump into the free agent arena armed with cash. The also own the 1.02, 1.23, 2.02, 3.02, and 3.23 picks in the draft over the first two days. That&#8217;s three of the top 34 players and all should be year-one contributors. This is likely to be the most changed roster in all of the NFL in terms of offensive skill players.</p>
<p><strong style="font-size: 30px; font-style: italic;">Fantasy football takeaway</strong></p>
<p>The Jets lacked fantasy-relevant players under Adam Gase. And he left behind arguably less than when he took over in 2019 despite higher draft picks and trades. The defense was already better than most but has been saddled with an ineffective offense that did them no favors.</p>
<p>The reality is that the Jets do not look to be dramatically better for fantasy football for at least this initial season under Saleh. There&#8217;s an unsettled quarterback situation that is likely to end up relying on a rookie learning a new scheme along with the rest of the offense.</p>
<p>There are currently no running backs with any fantasy value and even after they add one or more backs to upgrade, the scheme is not one that will just hand the ball off to the same guy 24 times every week. It will be a committee backfield with rushers, third-down backs and receiving backs.</p>
<p>The passing scheme under LaFleur is likely to be just as diverse as the 49ers used. That means the mediocre crew of wideouts are even less likely to see one player step up and dominate short of drafting a first-round wideout. Even then &#8211; the passing game will be a work in progress.</p>
<p>There&#8217;s value in a dynasty vein this year, but the league&#8217;s worst offense on 2020 doesn&#8217;t project to make much progress in their first season.</p>
</div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
						
						
						
						<p class="post-tags post-tags--hide"><a href="https://thehuddle.com/tag/fantasy-football/" rel="tag">Fantasy Football</a>, <a href="https://thehuddle.com/tag/jeff-ulbrich/" rel="tag">Jeff Ulbrich</a>, <a href="https://thehuddle.com/tag/mike-lafleur/" rel="tag">Mike LaFleur</a>, <a href="https://thehuddle.com/tag/new-york-jets/" rel="tag">New York Jets</a>, <a href="https://thehuddle.com/tag/nfl-coaching-changes/" rel="tag">NFL Coaching Changes</a>, <a href="https://thehuddle.com/tag/robert-saleh/" rel="tag">Robert Saleh</a>, <a href="https://thehuddle.com/tag/sam-darnold/" rel="tag">Sam Darnold</a>, <a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" rel="category tag">NFL Coaching Change with fantasy football impact</a></p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2021/02/23/2021-nfl-coaching-changes-new-york-jets/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/02/18/2021-nfl-coaching-changes-miami-dolphins/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-1"
		title="2021 NFL coaching changes: Miami Dolphins"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14959902.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14959902.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2021 NFL coaching changes: Miami Dolphins" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">5d ago</span>
		<h2><a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="https://thehuddle.com/2021/02/18/2021-nfl-coaching-changes-miami-dolphins/"
				title="2021 NFL coaching changes: Miami Dolphins" itemprop="url">
				2021 NFL coaching changes: Miami Dolphins			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/02/16/2021-nfl-coaching-changes-seattle-seahawks/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-2"
		title="2021 NFL coaching changes: Seattle Seahawks"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_14806696.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_14806696.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2021 NFL coaching changes: Seattle Seahawks" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">6 shares</span><span class="block__time block__time--mobile">1w ago</span>
		<h2><a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="https://thehuddle.com/2021/02/16/2021-nfl-coaching-changes-seattle-seahawks/"
				title="2021 NFL coaching changes: Seattle Seahawks" itemprop="url">
				2021 NFL coaching changes: Seattle Seahawks			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/02/15/2021-nfl-coaching-change-tracker/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-3"
		title="2021 NFL coaching change tracker"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/01/ecc575d6-157d-4521-b684-a1ac6cd6acf3-AP_Jaguars_Meyer_Football.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/01/ecc575d6-157d-4521-b684-a1ac6cd6acf3-AP_Jaguars_Meyer_Football.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2021 NFL coaching change tracker" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">1 share</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="https://thehuddle.com/2021/02/15/2021-nfl-coaching-change-tracker/"
				title="2021 NFL coaching change tracker" itemprop="url">
				2021 NFL coaching change tracker			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/19/2021-nfl-free-agency-fantasy-football-running-backs-preview/"
						title="2021 NFL free agency: fantasy football running backs preview"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_15443871.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_15443871.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL free agency: fantasy football running backs preview" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/19/2021-nfl-free-agency-fantasy-football-running-backs-preview/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/19/2021-nfl-free-agency-fantasy-football-running-backs-preview/"
			title="2021 NFL free agency: fantasy football running backs preview"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>15</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Fantasy football player movement</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/19/2021-nfl-free-agency-fantasy-football-running-backs-preview/"
						title="2021 NFL free agency: fantasy football running backs preview"
						itemprop="url" 						>
							2021 NFL free agency: fantasy football running backs preview					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 19, 2021 10:27 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>The running back landscape will look much different in 2021 with all of the impending free agents poised to move about. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/18/carson-wentz-traded-indianapolis-colts-reunion-frank-reich-fantasy-football/"
						title="Carson Wentz being traded to Colts is a win for fantasy football"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/09/13417853-e1569972325820.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/09/13417853-e1569972325820.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Carson Wentz being traded to Colts is a win for fantasy football" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/18/carson-wentz-traded-indianapolis-colts-reunion-frank-reich-fantasy-football/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/18/carson-wentz-traded-indianapolis-colts-reunion-frank-reich-fantasy-football/"
			title="Carson Wentz being traded to Colts is a win for fantasy football"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>8</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/general-fantasy-football-analysis/" class="category" itemprop="articleSection">General Fantasy Football Analysis, Tips, Strategy and Advice</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/18/carson-wentz-traded-indianapolis-colts-reunion-frank-reich-fantasy-football/"
						title="Carson Wentz being traded to Colts is a win for fantasy football"
						itemprop="url" 						>
							Carson Wentz being traded to Colts is a win for fantasy football					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 18, 2021 1:23 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Can Carson Wentz resurrect his ailing career after being traded to the Colts?  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/18/2021-nfl-coaching-changes-miami-dolphins/"
						title="2021 NFL coaching changes: Miami Dolphins"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14959902.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14959902.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL coaching changes: Miami Dolphins" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/18/2021-nfl-coaching-changes-miami-dolphins/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/18/2021-nfl-coaching-changes-miami-dolphins/"
			title="2021 NFL coaching changes: Miami Dolphins"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/18/2021-nfl-coaching-changes-miami-dolphins/"
						title="2021 NFL coaching changes: Miami Dolphins"
						itemprop="url" 						>
							2021 NFL coaching changes: Miami Dolphins					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 18, 2021 1:03 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Dolphins turn to dual offensive coordinators. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/16/2021-nfl-coaching-changes-seattle-seahawks/"
						title="2021 NFL coaching changes: Seattle Seahawks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_14806696.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_14806696.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL coaching changes: Seattle Seahawks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/16/2021-nfl-coaching-changes-seattle-seahawks/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/16/2021-nfl-coaching-changes-seattle-seahawks/"
			title="2021 NFL coaching changes: Seattle Seahawks"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>6</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/16/2021-nfl-coaching-changes-seattle-seahawks/"
						title="2021 NFL coaching changes: Seattle Seahawks"
						itemprop="url" 						>
							2021 NFL coaching changes: Seattle Seahawks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 16, 2021 8:21 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Seattle turns over the offense to a Sean McVay disciple with hopes of toppling its divisional foe. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/15/nfl-free-agency-fantasy-football-quarterbacks-preview/"
						title="2021 NFL free agency: fantasy football quarterbacks preview"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_15204549.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_15204549.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL free agency: fantasy football quarterbacks preview" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/15/nfl-free-agency-fantasy-football-quarterbacks-preview/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/15/nfl-free-agency-fantasy-football-quarterbacks-preview/"
			title="2021 NFL free agency: fantasy football quarterbacks preview"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>12</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Fantasy football player movement</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/15/nfl-free-agency-fantasy-football-quarterbacks-preview/"
						title="2021 NFL free agency: fantasy football quarterbacks preview"
						itemprop="url" 						>
							2021 NFL free agency: fantasy football quarterbacks preview					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 15, 2021 7:55 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Examining possible free-agent moves from a fantasy football perspective. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/15/2021-nfl-coaching-change-tracker/"
						title="2021 NFL coaching change tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/01/ecc575d6-157d-4521-b684-a1ac6cd6acf3-AP_Jaguars_Meyer_Football.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/01/ecc575d6-157d-4521-b684-a1ac6cd6acf3-AP_Jaguars_Meyer_Football.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL coaching change tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/15/2021-nfl-coaching-change-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/15/2021-nfl-coaching-change-tracker/"
			title="2021 NFL coaching change tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/15/2021-nfl-coaching-change-tracker/"
						title="2021 NFL coaching change tracker"
						itemprop="url" 						>
							2021 NFL coaching change tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 15, 2021 1:33 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Fantasy-ranked depth charts for NFL teams </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/13/fantasy-football-klint-kubiak-minnesota-vikings/"
						title="2021 NFL coaching changes: Minnesota Vikings"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_15340355.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_15340355.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL coaching changes: Minnesota Vikings" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/13/fantasy-football-klint-kubiak-minnesota-vikings/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/13/fantasy-football-klint-kubiak-minnesota-vikings/"
			title="2021 NFL coaching changes: Minnesota Vikings"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>6</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/13/fantasy-football-klint-kubiak-minnesota-vikings/"
						title="2021 NFL coaching changes: Minnesota Vikings"
						itemprop="url" 						>
							2021 NFL coaching changes: Minnesota Vikings					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 13, 2021 2:25 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>The Vikings turn to a familiar face following offensive coordinator Gary Kubiak&#8217;s second retirement. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/12/2021-nfl-coaching-changes-atlanta-falcons/"
						title="2021 NFL coaching changes: Atlanta Falcons"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_14782947.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_14782947.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL coaching changes: Atlanta Falcons" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/12/2021-nfl-coaching-changes-atlanta-falcons/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/12/2021-nfl-coaching-changes-atlanta-falcons/"
			title="2021 NFL coaching changes: Atlanta Falcons"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/12/2021-nfl-coaching-changes-atlanta-falcons/"
						title="2021 NFL coaching changes: Atlanta Falcons"
						itemprop="url" 						>
							2021 NFL coaching changes: Atlanta Falcons					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 12, 2021 12:54 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Falcons turn to ex-Titan coaches to lead the team. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/11/fantasy-football-marcus-brady-los-angeles-chargers/"
						title="2021 NFL coaching changes: Indianapolis Colts"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_15485395.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/USATSI_15485395.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL coaching changes: Indianapolis Colts" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/11/fantasy-football-marcus-brady-los-angeles-chargers/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/11/fantasy-football-marcus-brady-los-angeles-chargers/"
			title="2021 NFL coaching changes: Indianapolis Colts"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/11/fantasy-football-marcus-brady-los-angeles-chargers/"
						title="2021 NFL coaching changes: Indianapolis Colts"
						itemprop="url" 						>
							2021 NFL coaching changes: Indianapolis Colts					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 11, 2021 1:36 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>The 2021 Colts may look much different on offense, despite an internal coordinator promotion. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/10/2021-nfl-coaching-changes-jacksonville-jaguars/"
						title="2021 NFL coaching changes: Jacksonville Jaguars"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/02/usatsi_7475404-1024x690-1.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/02/usatsi_7475404-1024x690-1.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL coaching changes: Jacksonville Jaguars" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/02/10/2021-nfl-coaching-changes-jacksonville-jaguars/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/02/10/2021-nfl-coaching-changes-jacksonville-jaguars/"
			title="2021 NFL coaching changes: Jacksonville Jaguars"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/02/10/2021-nfl-coaching-changes-jacksonville-jaguars/"
						title="2021 NFL coaching changes: Jacksonville Jaguars"
						itemprop="url" 						>
							2021 NFL coaching changes: Jacksonville Jaguars					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 10, 2021 4:26 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Jaguars turn to a new coaching staff for turnaround </p>

				
				
			</div>
		</article>
	</div>
<a href="https://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget widget--login widget--box" id="login_widget-3">
<div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget--forum widget--box" id="forum_widget-4">
<div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="https://tools.thehuddle.com/season">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="https://tools.thehuddle.com/weekly">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Stats Matchups</a></li>
<li id="menu-item-453426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453426"><a href="https://thehuddle.com/2020/05/07/2020-nfl-schedule-team-by-week-grid/">Schedule: Team-by Week Grid</a></li>
<li id="menu-item-453427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453427"><a href="https://thehuddle.com/2020/05/07/2020-nfl-schedule-weekly-grid/">Schedule: Weekly Grid</a></li>
<li id="menu-item-453428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453428"><a href="https://thehuddle.com/2020/05/07/2020-nfl-schedule-release-bye-weeks/">Schedule: Bye Weeks</a></li>
</ul><a href="https://thehuddle.com/fantasy-football-statistics/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><a href="http://www.thehuddle.com/podcast/"><img width="1000" height="1000" src="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg 1000w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=150,150 150w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=300,300 300w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=768,768 768w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=600,600 600w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=100,100 100w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=340,340 340w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=32,32 32w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=50,50 50w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=64,64 64w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=96,96 96w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=128,128 128w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></div><div class="widget widget--links widget--box" id="links_widget-8">
<div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="https://tools.thehuddle.com/nfl-depth-charts">2021 fantasy depth charts</a></li>
<li id="menu-item-457177" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457177"><a href="https://thehuddle.com/2021/02/15/2021-nfl-coaching-change-tracker/">2021 NFL coaching change tracker</a></li>
<li id="menu-item-457194" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457194"><a href="https://thehuddle.com/2021/01/25/fantasy-football-2021-player-movement-tracker/">2021 fantasy football player movement tracker</a></li>
<li id="menu-item-457195" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457195"><a href="https://thehuddle.com/2021/01/25/2021-nfl-top-free-agent-tracker/">2021 NFL top free-agent tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7">
<div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="https://tools.thehuddle.com/nfl-depth-charts">2021 fantasy depth charts</a></li>
<li id="menu-item-457196" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457196"><a href="https://thehuddle.com/2021/01/25/2021-nfl-top-free-agent-tracker/">2021 NFL top free-agent tracker</a></li>
<li id="menu-item-457201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457201"><a href="https://thehuddle.com/2021-nfl-draft-order/">2021 NFL Draft order</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-3">
<div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/logo-usat-footer-1.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448091"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
	<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/icon-huddle.png" alt="Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com">
				<a class="mobile-nav__breadcrumb" href="https://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-guide mobile-nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2020-fantasy-football-league-draft-preview-rankings-cheatsheets-sleepers/">Draft Guide</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2020&#038;week=0">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-projections"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2020&#038;week=0">Fantasy football projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-standard">Top 200 Overall</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-ppr">Top 200 PPR</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li class="mobile-nav__item mobile-nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--inseason mobile-nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">Inseason</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy Football Player Rankings / Projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Fantasy Football Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--dfs-daily-fantasy-football"><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/">DFS - Daily Fantasy Football</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfl-game-predictions-and-picks"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">NFL Game Predictions and Picks</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Fantasy Football Start/Bench Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--news mobile-nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li class="mobile-nav__item mobile-nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--stats mobile-nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li class="mobile-nav__item mobile-nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--teams mobile-nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--afc-east"><a href="#">AFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-north"><a href="#">AFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li class="mobile-nav__item mobile-nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li class="mobile-nav__item mobile-nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-south"><a href="#">AFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li class="mobile-nav__item mobile-nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li class="mobile-nav__item mobile-nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li class="mobile-nav__item mobile-nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-west"><a href="#">AFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li class="mobile-nav__item mobile-nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li class="mobile-nav__item mobile-nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-ft"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-football-team">Washington FT</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li class="mobile-nav__item mobile-nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li class="mobile-nav__item mobile-nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li class="mobile-nav__item mobile-nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--fantasy-football-nfl-depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Fantasy Football NFL Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-draft"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/">NFL Draft</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li class="mobile-nav__item mobile-nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/usat-logo-mobile-off-canvas-1.png">
		</a>
	</div>

<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="https://tools.thehuddle.com/login" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??/wp-includes/css/dashicons.min.css,/wp-includes/js/thickbox/thickbox.css?m=1614009856' type='text/css' media='all' />
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1' id='sharethrough-native-responsive-js'></script>
<script id='usatoday-sticky-inline-videos-script-js-extra'>
var stickyInlineVideosOptions = {"side":"right","hide":"Hide video"};
</script>
<script id='lawrence-ads-js-js-extra'>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"60","refresh_type":"all","distance":"2000","active":"0"}};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJydjsEKwjAQRH/INLQHwYP4KbImS9002cRk05K/twqCiAfrdWbeY/SSlIksyKLligGLrgUkWmjKw5KRDeoQbfVrA1YVkylJ0a7oBBlCrCydKzv9v4dBaMbzmGEmaZ+y5OtI/GZ7BUXITE0Re2JUM1mMT923/OeHK+/pot2tYm6diXEi3AIHIN6yB/v4dgrHft8P+/4wDIO7AzjlmFA='></script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0' id='lawrence-confiant-js-js'></script>
<script id='wasabi-article-js-extra'>
var wasabiFacebookReferral = "0";
</script>
<script id='wasabi-main-js-extra'>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script id='huddle-user-nav-js-extra'>
var huddleUser = {"name":"Huddle User","cookie":"session","logoutAPI":"https:\/\/api.thehuddle.com\/User\/Logout"};
</script>
<script id='huddle-login-debug-js-extra'>
var huddleLoginDebugData = {"is_member":"","user_data":[]};
</script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/thehuddle.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJytkd0OgjAMhV/IMUjU4IXxWbqtgeJ+CNsEfHrHBSqJF0C8a8/6nTZnvG+ZdDagDbzVsSLrefQQnIKRzYKG58i0A8VwSJMKFW++1MyQzRp/4P/wWuvTgwdBExsDab+Ds/CgCgK59cd/YE8KBXQ7SOgCSY07SAMbcg41sjoqpXFCaf2+JRg9diwlNeNkpY4K/fSWWjQCt/3/0l67JLIUZax+bQg1ybtww7tIQzdzLc7FMc8v5alsXhAFCeQ='></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin' id='sop-script-js'></script>
<script type='text/javascript' src='https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/ats_smg.js?m=1612816960g'></script>
<script src='https://stats.wp.com/e-202108.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'175784887',post:'457401',tz:'-5',srv:'thehuddle.com'} ]);
	_stq.push([ 'clickTrackerInit', '175784887', '457401' ]);
</script>
</body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
