<!DOCTYPE html>
<!--[if IE 8]> <html lang="en-US" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en-US" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Which rookies leave the NFL draft with the highest fantasy value?" />
<meta name="keywords" content="fantasy football,2021 nfl draft, devonta smith, ja&#039;marr chase, javonte williams, jaylen waddle, kadarius toney, kyle pitts, michael carter, najee harris, rashod bateman, rhamondre stevenson, travis etienne, trevor lawrence,fantasy football rookie analysis, nfl draft" />
<title>Top 12 fantasy football rookies</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//ads.rubiconproject.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Feed" href="https://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Comments Feed" href="https://thehuddle.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thehuddle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??-eJydkEtuwzAMRC9UmTDSOPCi6DY36JqWiJqJLAkilcC3j2LXSIEGXWTJzzwOB67JcLC+OBKwIuBYFAYf7dl4HjLmGURnT83EoakLb1AVNgaloDAVk3z55iAghNmOQB5F2aZMG+sOzbWt5EyKomJW+kKVp9iNWQQ1OpwfRyr6PFfDngOZCzuKq+tngz9YHWmiX1SP10zB0jb4QsGBX5TBsThXY/onohNpwvp533SL6Z/6LvmcPtqu7d/3u/bQ3QDl55dg' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script id='amazon-adsystem-js-extra'>
var amznAcctId = ["3090"];
</script>
<script id='amazon-adsystem-js-before'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId[0], adServer: "googletag"});
</script>
<script src='https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/bidder-manager.js?ver=5.7.1' id='amazon-adsystem-js'></script>
<script src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=5.7.1' id='sonobi-adsystem-js'></script>
<script src='//ads.rubiconproject.com/prebid/10968_USAToday_Sports.js?ver=5.7.1' id='lawrence_magnite_header_bidder_script-js'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.7.1' id='lawrence-ads-ias-js'></script>
<script id='lawrence-ads-ias-js-after'>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZoYWpgZGRuVkWAK9fIh4='></script>
<script id='lawrence-tealium-js-extra'>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","content-market-name":"thehuddle","page-has-video":"no","page-has-gallery":"0","page-canonical-url":"https:\/\/thehuddle.com\/2021\/05\/02\/top-12-fantasy-football-rookies\/","content-ssts-section":"sports","content-ssts-subsection":"sports:thehuddle","content-ssts-topic":"sports:thehuddle","content-ssts-subtopic":"sports:thehuddle","page-experience-type":"desktop","content-type":"story pages","content-id":"458427","content-headline":"Top 12 fantasy football rookies","content-date-published":"2021-05-02T23:41:35Z","content-byline":"David Dorey","content-contributor-names":"David Dorey","content-article-length":"2315","content-keywords":"2021 NFL draft,DeVonta Smith,Ja'Marr Chase,Javonte Williams,Jaylen Waddle,Kadarius Toney,Kyle Pitts,Michael Carter,Najee Harris,Rashod Bateman,Rhamondre Stevenson,Travis Etienne,Trevor Lawrence","content-title":"Top 12 fantasy football rookies |  | "};
</script>
<script id='lawrence-tealium-js-before'>
			window.gciAnalyticsUAID = "SMG-TEALIUM-THEHUDDLE";
			gciDataLayer["page-full-url"]    = window.location.href;
			gciDataLayer["content-name"]     = window.location.pathname;
			gciDataLayer["page-referer"]     = document.referrer;
			gciDataLayer["page-has-gallery"] = Boolean(parseInt(gciDataLayer["page-has-gallery"], 10));
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1' id='lawrence-tealium-js'></script>
<script id='lawrence-tealium-js-after'>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0' id='lawrence-confiant-js'></script>
<script id='usatoday-gallery-js-extra'>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-166840762-5","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-166840762-5","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJylkN0KwjAMhV/IrtSfiRfis9Qum+nari6pc29vB05EQRjeJefwHXIihyhMFxgCy+hSg4FkIs1dpUcxCzqiaLRz0CPkjQiYpCXJoB0m//TGwtJK/pOXqIpZH7IlbqpYfwbyBTy85Tk99BAMTCy1GIXD0Iq6M4lEjfcluL2mqYHXGJZgDs8zSoym/frBz5Ox6l90njN78kdVqsN2t1H70j4AYBSbaQ=='></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-1.js?ver=5.7.1' id='the-huddle-eu-redirect-1-js'></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-2.js?ver=5.7.1' id='the-huddle-eu-redirect-2-js'></script>
<link rel="https://api.w.org/" href="https://thehuddle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thehuddle.com/wp-json/wp/v2/posts/458427" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thehuddle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thehuddle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://thehuddle.com/?p=458427' />
<link rel="alternate" type="application/json+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2021%2F05%2F02%2Ftop-12-fantasy-football-rookies%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2021%2F05%2F02%2Ftop-12-fantasy-football-rookies%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta name="gdpr" content="false" />

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle",
		"mainEntityOfPage": {
			"@type": "WebPage",
			"@id": "https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		},
		"url": "https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/",
		"headline": "Top 12 fantasy football rookies",
		"thumbnailUrl": "https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15338164.jpg?w=192&#038;h=150&#038;crop=1",
		"image": "https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15338164.jpg?w=192&#038;h=150&#038;crop=1",
		"datePublished": "2021-05-02T23:41:35Z",
		"dateModified": "2021-05-02T23:41:35Z",
		"articleSection": "Fantasy Football Rookie Analysis",
		"creator": ["David Dorey"],
		"author": {
			"@type": "Person",
			"name": "David Dorey"
		},
		"keywords": ["2021 NFL draft","DeVonta Smith","Ja&#039;Marr Chase","Javonte Williams","Jaylen Waddle","Kadarius Toney","Kyle Pitts","Michael Carter","Najee Harris","Rashod Bateman","Rhamondre Stevenson","Travis Etienne","Trevor Lawrence"],
	"publisher": {
		"@type": "Organization",
		"name": "Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com",
		"logo": {
			"@type": "ImageObject",
			"url": "https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
		}
	}
}
</script>
<style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.newsletter-modal {
	border-top: solid 8px #dd9933;
}

.article__back {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.listicle__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#dd9933, #dd9933)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

.smg-event__ctabutton {
	background-color: #dd9933;
	box-shadow: 0 2px 0 0 #dd9933;
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/" />

<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.addBidder( 'magnite' );
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video', 'ignoreRefresh' : true } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Top 12 fantasy football rookies" />
<meta property="og:url" content="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/" />
<meta property="og:description" content="Which rookies are most likely to offer fantasy value for 2020?" />
<meta property="article:published_time" content="2021-05-03T03:41:35+00:00" />
<meta property="article:modified_time" content="2021-05-03T03:41:35+00:00" />
<meta property="og:site_name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
<meta property="og:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15338164.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Top 12 fantasy football rookies" />
<meta name="twitter:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15338164.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=180" />
<meta name="msapplication-TileImage" content="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=270" />

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-458427 single-format-standard">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://thehuddle.com"
				title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
				class="branding__logo-link "
			>
				<img
					src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
					alt="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="https://www.usatoday.com/sports/" target="_blank" title="USA TODAY Sports">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/03/USATODAY_Sports_Log.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-450451" class="nav__item nav__item--draft-guide nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2020-fantasy-football-league-draft-preview-rankings-cheatsheets-sleepers/">Draft Guide</a>
<ul class="sub-menu">
	<li id="menu-item-442874" class="nav__item nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2020&#038;week=0">Cheat Sheets</a></li>
	<li id="menu-item-442875" class="nav__item nav__item--fantasy-football-projections"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2020&#038;week=0">Fantasy football projections</a></li>
	<li id="menu-item-442876" class="nav__item nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-standard">Top 200 Overall</a></li>
	<li id="menu-item-442877" class="nav__item nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-ppr">Top 200 PPR</a></li>
	<li id="menu-item-442878" class="nav__item nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li id="menu-item-442879" class="nav__item nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442880" class="nav__item nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442881" class="nav__item nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li id="menu-item-442847" class="nav__item nav__item--inseason nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">Inseason</a>
<ul class="sub-menu">
	<li id="menu-item-442896" class="nav__item nav__item--fantasy-football-player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy Football Player Rankings / Projections</a></li>
	<li id="menu-item-442897" class="nav__item nav__item--fantasy-football-cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Fantasy Football Cheat Sheets</a></li>
	<li id="menu-item-442848" class="nav__item nav__item--dfs-daily-fantasy-football"><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/">DFS - Daily Fantasy Football</a></li>
	<li id="menu-item-442894" class="nav__item nav__item--nfl-game-predictions-and-picks"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">NFL Game Predictions and Picks</a></li>
	<li id="menu-item-442895" class="nav__item nav__item--fantasy-football-start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Fantasy Football Start/Bench Tool</a></li>
	<li id="menu-item-442898" class="nav__item nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li id="menu-item-442849" class="nav__item nav__item--news nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li id="menu-item-450179" class="nav__item nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li id="menu-item-450180" class="nav__item nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li id="menu-item-450181" class="nav__item nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li id="menu-item-450182" class="nav__item nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li id="menu-item-450183" class="nav__item nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li id="menu-item-442850" class="nav__item nav__item--stats nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li id="menu-item-442899" class="nav__item nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li id="menu-item-442900" class="nav__item nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li id="menu-item-442901" class="nav__item nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li id="menu-item-442902" class="nav__item nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li id="menu-item-442903" class="nav__item nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li id="menu-item-442904" class="nav__item nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li id="menu-item-442906" class="nav__item nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li id="menu-item-442851" class="nav__item nav__item--teams nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li id="menu-item-442917" class="nav__item nav__item--afc-east"><a href="#">AFC East</a></li>
	<li id="menu-item-442918" class="nav__item nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li id="menu-item-442919" class="nav__item nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li id="menu-item-442920" class="nav__item nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li id="menu-item-442921" class="nav__item nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li id="menu-item-442922" class="nav__item nav__item--afc-north"><a href="#">AFC North</a></li>
	<li id="menu-item-442923" class="nav__item nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li id="menu-item-442924" class="nav__item nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li id="menu-item-442925" class="nav__item nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li id="menu-item-442926" class="nav__item nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li id="menu-item-442927" class="nav__item nav__item--afc-south"><a href="#">AFC South</a></li>
	<li id="menu-item-442928" class="nav__item nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li id="menu-item-442929" class="nav__item nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li id="menu-item-442930" class="nav__item nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li id="menu-item-442931" class="nav__item nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li id="menu-item-442932" class="nav__item nav__item--afc-west"><a href="#">AFC West</a></li>
	<li id="menu-item-442933" class="nav__item nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li id="menu-item-442934" class="nav__item nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li id="menu-item-442936" class="nav__item nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li id="menu-item-442935" class="nav__item nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li id="menu-item-442937" class="nav__item nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li id="menu-item-442938" class="nav__item nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li id="menu-item-442939" class="nav__item nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li id="menu-item-442940" class="nav__item nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li id="menu-item-442941" class="nav__item nav__item--washington-ft"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-football-team">Washington FT</a></li>
	<li id="menu-item-442942" class="nav__item nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li id="menu-item-442943" class="nav__item nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li id="menu-item-442944" class="nav__item nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li id="menu-item-442945" class="nav__item nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li id="menu-item-442946" class="nav__item nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li id="menu-item-442947" class="nav__item nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li id="menu-item-442948" class="nav__item nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li id="menu-item-442949" class="nav__item nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li id="menu-item-442950" class="nav__item nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li id="menu-item-442951" class="nav__item nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li id="menu-item-442952" class="nav__item nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li id="menu-item-442953" class="nav__item nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li id="menu-item-442954" class="nav__item nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li id="menu-item-442955" class="nav__item nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li id="menu-item-442956" class="nav__item nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li id="menu-item-442852" class="nav__item nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li id="menu-item-442911" class="nav__item nav__item--fantasy-football-nfl-depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Fantasy Football NFL Depth Charts</a></li>
<li id="menu-item-442854" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-442914" class="nav__item nav__item--nfl-draft-central"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2021-nfl-draft-central/">NFL Draft Central</a></li>
<li id="menu-item-450426" class="nav__item nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li id="menu-item-450427" class="nav__item nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li id="menu-item-442855" class="nav__item nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-458427" class="post-458427 post type-post status-publish format-standard has-post-thumbnail hentry category-fantasy-football-rookie-analysis category-nfl-draft-picks-players-fantasy-football-analysis tag-2021-nfl-draft tag-devonta-smith tag-jamarr-chase tag-javonte-williams tag-jaylen-waddle tag-kadarius-toney tag-kyle-pitts tag-michael-carter tag-najee-harris tag-rashod-bateman tag-rhamondre-stevenson tag-travis-etienne tag-trevor-lawrence" itemscope
				itemtype="http://schema.org/NewsArticle">

				<link itemprop="mainEntityofPage" href="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"/>
		<meta itemprop="url" content="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png">
	</div>
	<meta itemprop="name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com">
</div>
<div class="article__title ">

	
	<h1 class="article__headline">Top 12 fantasy football rookies</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
			<img width="1000" height="600" src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15338164.jpg?w=100&amp;h=600&amp;crop=1&amp;h=60" class="article__image wp-post-image lazy-load" alt loading="lazy" data-lazy-src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15338164.jpg?w=1000&amp;h=600&amp;crop=1"><noscript><img width="1000" height="600" src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15338164.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" loading="lazy" /></noscript>			<meta itemprop="url" content="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15338164.jpg">
		</span>
		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Top 12 fantasy football rookies</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" class="" itemprop="articleSection">Fantasy Football Rookie Analysis</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Top 12 fantasy football rookies</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p>

	By <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a></span></span> 
		<span class="post-date updated">May 2, 2021 11:41 pm</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
					Follow					@DMDorey				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a></span></span> |
		<span itemprop="datePublished" content="2021-05-02T23:41:35-04:00">
			May 2, 2021 11:41 pm		</span>
		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
		Follow @DMDorey	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p>The 2021 NFL draft had plenty of hype with a rich set of quarterbacks and wide receivers. That held with five quarterbacks drafted over the first 15 picks and five wide receivers selected in the first round, including three over the first ten picks. Where the draft disappointed was with running backs. That was a function of the devaluing of the position by NFL offenses and a lack of confidence that the incoming rookies could provide more than a role in a committee backfield or as roster depth.</p>
<p>For dynasty purposes, this draft should deliver several long-term elite players and even a few running backs could emerge, if only eventually. For redraft leagues, this class has potential but less than most years. The best wideouts mostly went to average passing teams. The best running backs mostly ended up on teams that already have a primary back. Quarterbacks usually take a year or two before delivering fantasy-relevant stats but Trevor Lawrence may challenge that rule of thumb.</p>
<p>To follow are the Top-12 fantasy football rookies as of the day after the draft considering their outlook for 2021. Certainly, much will change in the coming months. James Robinson was an undrafted nobody one year ago.</p>
<p>Clyde-Edwards Helaire and D&#8217;Andre Swift were the top backs drafted last year, and neither delivered on their promise. Jonathan Taylor joined a crowded backfield, but one Marlon Mack injury later and Taylor produced a hot start to his career. Justin Jefferson was the fifth wideout selected and yet dominated the position. You just never know and that&#8217;s part of the fun.</p>
<p><strong>1. <a href="https://thehuddle.com/2021/04/03/fantasy-football-nfl-draft-najee-harris-alabama/">RB Najee Harris &#8211; Alabama</a> (PIT 1.24), 6’2&#8243;, 230 lbs., 4.45</strong></p>
<p>The top fantasy rookie has to be Najee Harris out of the Alabama Machine. He was the rare four-year running back that started the last two with stellar results. He would have been highly drafted in 2020 but returned to post 1,486 rushing yards, 43 catches for 425 yards and a total of 30 touchdowns during the Crimson Tide&#8217;s latest National Championship run.</p>
<p>Harris has every opportunity to become the next Le&#8217;Veon Bell in Pittsburgh. He offers a well-rounded set of talents and never has to come off the field. More importantly, he has minimal competition for touches with only Benny Snell and Anthony McFarland below him. Harris is the only rookie back that is a slam dunk for a fulltime role.</p>
<p><strong>2.</strong> <strong><a href="https://thehuddle.com/2021/04/09/fantasy-football-nfl-draft-jamarr-chase-lsu/">WR Ja&#8217;Marr Chase &#8211; LSU</a> (CIN 1.05), 6’0&#8243;, 208 lbs., 4.38</strong></p>
<p>Ja&#8217;Marr Chase elected to sit out 2020 due to COVID concerns and as the first wideout selected, it certainly didn&#8217;t harm his perceived value. While he only started for one season at LSU, he blew up for 84 catches for 1,780 yards and 20 touchdowns while the Tigers won the National Championship. All he did in that game was catch nine passes for 221 yards and two scores versus Clemson.</p>
<p>Oh yes, and his quarterback that season was Joe Burrow. The same one that becomes his quarterback in the NFL and who lobbied for the Bengals to select him over a much-needed upgrade to the offensive line. If you liked Chase&#8217;s ex-teammate, Justin Jefferson, last year, realize that Chase had a bigger 2019 than Jefferson and gets to continue to play with Burrow.</p>
<p><strong>3. <a href="https://thehuddle.com/2021/04/13/rookie-rundown-te-kyle-pitts-florida/">TE Kyle Pitts &#8211; Florida</a> (ATL 1.04), 6’6&#8243;, 240 lbs., 4.44</strong></p>
<p>Kyle Pitts fantasy value is already considered elite, and he has yet to catch an NFL pass. The ex-Gator just became the highest-drafted tight end in NFL history. A three-year player, his junior season saw him catch 43 passes for 770 yards and 12 touchdowns, and that was only playing in eight games because of a facial injury and a concussion. To term him a &#8220;physical freak&#8221; may be an understatement. Pitts is a towering 6-6 and 240 pounds and yet runs a 4.45 40-time. That&#8217;s faster than most running backs.</p>
<p>Pitts joins the Falcons in the first year of HC Arthur Smith, and while he possesses all the attributes of an elite wideout, he will remain a tight end. Matt Ryan promises a powerful passing attack, and Pitts will have to share with Julio Jones and Calvin Ridley. But Jones is no lock to remain with the team and should he leave, Pitts could step up into significant fantasy play even as a rookie. He enters the NFL with arguably a higher upside than any other tight end in history and in the thinnest position in fantasy football. He shows up as the No. 1 pick in some fantasy football dynasty drafts.</p>
<p><strong>4. <a href="https://thehuddle.com/2021/04/14/rookie-rundown-rb-michael-carter-north-carolina/">RB Michael Carter &#8211; NC</a> (NYJ 4.02), 5’8&#8243;, 199 lbs., 4.5</strong></p>
<p>The &#8220;other back&#8221; at North Carolina wasn&#8217;t drafted until four others were  selected, but he has a lower bar to playing time than the rest. The four-year Tarheel finished with 1,512 total yards and eleven scores as a senior sharing the backfield with Javonte Williams. He&#8217;s a bit undersized but averaged 8.0 yards per carry last season. He may not have the physical specs of a prototypical NFL back, but he brings great rushing skills in vision and agility.</p>
<p>Carter was expected to go to a team looking for a dangerous third-down back that can offer as much as a receiver as a rusher. He has that. But he also joins a Jets team in the middle of yet another rebuilding. The depth chart only holds Tevin Coleman, La&#8217;Mical Perine and Josh Adams. Carter will be part of a Jets committee, but he already looks like the best of the bunch.</p>
<p><strong>5. <a href="https://thehuddle.com/2021/04/15/rookie-rundown-wr-devonta-smith-alabama/">WR DeVonta Smith &#8211; Alabama</a> (PHI 1.1), 6’0&#8243;, 166 lbs., 4.37</strong></p>
<p>The upside with Smith is immense. All he did was win the Heisman as a wide receiver for the first time in about three decades. He set all-time receiving records at Alabama. And just won the National Championship where he was the MVP while posting 12 catches for 215 yards in the first half before injuring his finger (it&#8217;s fine). I mean, come on &#8211; what more could you want?</p>
<p>Ends up, a bigger frame would be nice since he was finally measured away from the Alabama PR department, and he was 6-0 and just 166 pounds. That&#8217;s lighter than any other elite NFL wideout in history, and on a lanky frame. But he reunites with Jalen Hurts who he played with for two seasons (2017-2018), and the Eagles are also in a rebuild with a shakeup to the depth charts. He has minimal competition to become the No. 1 wideout and should end up as the primary as early as Week 1. He has a golden chance to serve up a cup of shut-up juice to his critics yet again.</p>
<p><strong>6. <a href="https://thehuddle.com/2021/03/31/fantasy-football-nfl-draft-javonte-williams-north-carolina/">RB Javonte Williams &#8211; NC</a> (DEN 2.03), 5’10&#8243;, 220 lbs., 4.58</strong></p>
<p>Javonte Williams was the top running back on many draft boards and the Tarheel comes to the NFL as the prototypical back in every measurement. The junior comes off a season with 1,445 total yards while catching 25 passes and rushing for 7.3 yards per carry. Better yet, he&#8217;s smart and powerful with a violent style of running that translates very well into the NFL.</p>
<p>What goes against him are two factors. One &#8211; he is not the fastest back but his game is more running over than running away. Two &#8211; he lands on a Denver team that already has former first-round pick Melvin Gordon as their primary back. Gordon is in the final year of his contract, so 2022 may very well see Williams as the clear workhorse. And Gordon tends to get dinged up anyway, so this season still holds promise. But Williams has to get past Gordon in order to realize his full potential.</p>
<p><strong>7. <a href="https://thehuddle.com/2021/03/30/fantasy-football-nfl-draft-jaylen-waddle-alabama/">WR Jaylen Waddle &#8211; Alabama</a> (MIA 1.06), 5’10&#8243;, 182 lbs., 4.37</strong></p>
<p>Several teams thought Jaylen Waddle was the best wide receiver in the draft, and he could prove to be as much. He was limited as part of a highly-talented Crimson Tide depth chart but excelled when given the chance. His 2020 season was cut short with a broken ankle but he averaged 21.1 yards on his 28 catches to that point. Waddle is blazingly fast with a sub-4.4 40-time and over half of his touchdowns for Alabama were over 50 yards in length.</p>
<p>He reunites with Tua Tagovailoa that should lessen the learning curve and he&#8217;s  compared to Tyreek Hill who is almost the same size and speed. There&#8217;s a new install of an offense for the team to learn and Devante Parker and Will Fuller will also heavily figure into the game plan. But it is only a question of time before Waddle assumes the No. wideout role for the Fins.</p>
<p><strong>8. <a href="https://thehuddle.com/2021/03/11/nfl-draft-travis-etienne-clemson/">RB Travis Etienne &#8211; Clemson (JAC 1.25)</a>, 5’10&#8243;, 205 lbs., 4.45</strong></p>
<p>Most analysts were divided as to who was the top rookie running back &#8211; Travis Etienne or Najee Harris. The Clemson star was the all-time rushing leader in the ACC after four years with the Tigers. Twice he topped 1,600 rushing yards in a season and then caught 48 passes for 588 yards last season to show that he was just as effective as a receiver.  He&#8217;s a three-down back that is a game-breaker whenever he has the ball. Squint your eyes when you watch him on tape, and he&#8217;s Alvin Kamara shredding defenses in all kinds of ways.</p>
<p>When the Jaguars drafted him, there were groans from both Etienne fans and  James Robinson dynasty owners. This is an odd pairing of the best undrafted running back in NFL history with an elite back toting a suitcase full of every imaginable accolade for a college back. Robinson dominated the backfield with 240 rushes and 49 receptions in 2020. Now there&#8217;s a committee brewing in the new offense by HC Urban Meyer and OC Darrell Bevell. It smacks of D&#8217;Andre Smith in Detroit last year though Etienne is better. The potential is there for elite fantasy numbers. At least eventually.</p>
<p><strong>9. <a href="https://thehuddle.com/2021/04/20/rookie-rundown-wr-kadarius-toney-florida/">WR Kadarius Toney &#8211; Florida</a> (NYG 1.20), 6’0&#8243;, 193 lbs., 4.39</strong></p>
<p>Kadarius Toney was a quarterback in high school and even played as a running back for one season for the Gators. His career stats showed marginal use until his senior year when he focused solely on being the No. 1 wideout for Florida. He caught 70 passes for 984 yards and ten scores while adding 19 rushes for 161 yards and another touchdown. He was also a returner for special teams.  Toney is only starting to tap into how good he can be and his electric ability with the ball gained him the name of &#8220;human joystick&#8221;.</p>
<p>He was drafted by a Giants team that revamped their receivers with the addition of Kenny Golladay as the clear No. 1 wideout. Sterling Shepard will also remain on the outside but Toney could fill a slot role that has the potential for fantasy relevance even as a rookie. If OC Jason Garrett gets inventive, Toney offers the ability to catch, run or even pass on the rare trick play. And play returner.</p>
<p><strong>10. <a href="https://thehuddle.com/2021/04/21/fantasy-football-nfl-draft-rashod-bateman-minnesota/">WR Rashod Bateman &#8211; Minnesota</a> (BAL 1.27), 6’0&#8243;, 190 lbs., 4.39</strong></p>
<p>The Golden Gophers relied on Rashod Bateman since he was a freshman and he broke out as a sophomore with 1,239 receiving yards and 11 touchdowns. He turned in a hefty 20.3 yards per catch that year and was looking forward to his junior season. The team originally planned to play in the spring due to COVID-19 but then opted to play in the fall. The season was still cut short after five games with positive test results so Bateman&#8217;s fine 2019 performance remains his measurement.</p>
<p>He&#8217;s a disciplined route runner that can make highlight clips. The Ravens spent their first-round pick on Bateman trying to upgrade what was the least productive set of wideouts in the NFL last year. Dead last in targets, catches and receiving yards as a group despite spending their first-round pick on Marquise Brown in 2019 as the first receiver selected that year. The Ravens also brought in Sammy Watkins so Bateman&#8217;s rookie year is likely to be less productive than desired, but he carries the potential that merits drafting for a fantasy bench.</p>
<p><strong>11. <a href="https://thehuddle.com/2021/03/24/fantasy-football-nfl-draft-rhamondre-stevenson-oklahoma/">RB Rhamondre Stevenson &#8211; Oklahoma</a> (NE 4.15), 6’0&#8243;, 246 lbs., 4.64</strong></p>
<p>The ex-Sooner never rushed for more than 665 yards on 101 carries in his two seasons as a starter, but he ran for 2,111 yards at Cerritos College before transferring. Stevenson is a throwback to the bruising days of the past and presents a big load to handle for defenders at 246 pounds. His downfall is his speed (4.64 40-time) and a lack of receiving experience.</p>
<p>Landing with the Patriots makes sense given their penchant for a backfield committee that divides up the different roles. Stevenson should figure into the rotation and there is a chance that either Damien Harris or Sony Michel doesn&#8217;t stay on the roster all summer. Stevenson joins that always confusing backfield but he has the opportunity to earn more work on a team that looks to run the ball more often.</p>
<p><strong>12. <a href="https://thehuddle.com/2021/03/12/rookie-rundown-qb-trevor-lawrence-clemson/">QB Trevor Lawrence &#8211; Clemson</a> (JAC 1.01), 6’6&#8243;, 220 lbs., 4.7</strong></p>
<p>The man born to play quarterback finally made his ascension to destiny. Trevor Lawrence was one of the highest-rated quarterback prospects in years and checks every desirable box for the position both physically and mentally. He carries the &#8220;generational talent&#8221; tag and lands with a rebuilding Jaguars franchise headed up by HC Urban Meyers.</p>
<p>It is exceedingly rare for any rookie quarterback to merit a fantasy start since that says they are in the Top-10 for the position in their first year. And the reality is that the Jaguars have a new scheme to install with new players. Chances are that Lawrence won&#8217;t produce enough to consider as a fantasy start. But &#8211; his level of talent suggests he might be the first backup fantasy quarterback taken in most leagues.</p>
</div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
						
						
						
						<p class="post-tags post-tags--hide"><a href="https://thehuddle.com/tag/2021-nfl-draft/" rel="tag">2021 NFL draft</a>, <a href="https://thehuddle.com/tag/devonta-smith/" rel="tag">DeVonta Smith</a>, <a href="https://thehuddle.com/tag/jamarr-chase/" rel="tag">Ja'Marr Chase</a>, <a href="https://thehuddle.com/tag/javonte-williams/" rel="tag">Javonte Williams</a>, <a href="https://thehuddle.com/tag/jaylen-waddle/" rel="tag">Jaylen Waddle</a>, <a href="https://thehuddle.com/tag/kadarius-toney/" rel="tag">Kadarius Toney</a>, <a href="https://thehuddle.com/tag/kyle-pitts/" rel="tag">Kyle Pitts</a>, <a href="https://thehuddle.com/tag/michael-carter/" rel="tag">Michael Carter</a>, <a href="https://thehuddle.com/tag/najee-harris/" rel="tag">Najee Harris</a>, <a href="https://thehuddle.com/tag/rashod-bateman/" rel="tag">Rashod Bateman</a>, <a href="https://thehuddle.com/tag/rhamondre-stevenson/" rel="tag">Rhamondre Stevenson</a>, <a href="https://thehuddle.com/tag/travis-etienne/" rel="tag">Travis Etienne</a>, <a href="https://thehuddle.com/tag/trevor-lawrence/" rel="tag">Trevor Lawrence</a>, <a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" rel="category tag">Fantasy Football Rookie Analysis</a>, <a href="https://thehuddle.com/category/nfl-draft-picks-players-fantasy-football-analysis/" rel="category tag">NFL Draft</a></p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2021/05/02/top-12-fantasy-football-rookies/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/05/01/2021-nfl-draft-day-3-fantasy-football-recap/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-1"
		title="2021 NFL Draft: Day 3 fantasy football recap"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15116248.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15116248.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2021 NFL Draft: Day 3 fantasy football recap" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">2d ago</span>
		<h2><a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" class="category" itemprop="articleSection">Fantasy Football Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="https://thehuddle.com/2021/05/01/2021-nfl-draft-day-3-fantasy-football-recap/"
				title="2021 NFL Draft: Day 3 fantasy football recap" itemprop="url">
				2021 NFL Draft: Day 3 fantasy football recap			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-2-fantasy-football-recap/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-2"
		title="2021 NFL Draft: Day 2 fantasy football recap"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15139042.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15139042.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2021 NFL Draft: Day 2 fantasy football recap" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">15 shares</span><span class="block__time block__time--mobile">3d ago</span>
		<h2><a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" class="category" itemprop="articleSection">Fantasy Football Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-2-fantasy-football-recap/"
				title="2021 NFL Draft: Day 2 fantasy football recap" itemprop="url">
				2021 NFL Draft: Day 2 fantasy football recap			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-1-fantasy-football-recap/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-3"
		title="2021 NFL Draft: Day 1 fantasy football recap"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15986951.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15986951.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="2021 NFL Draft: Day 1 fantasy football recap" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">6 shares</span><span class="block__time block__time--mobile">3d ago</span>
		<h2><a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" class="category" itemprop="articleSection">Fantasy Football Rookie Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-1-fantasy-football-recap/"
				title="2021 NFL Draft: Day 1 fantasy football recap" itemprop="url">
				2021 NFL Draft: Day 1 fantasy football recap			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-team/"
						title="2021 NFL Draft results: by team"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15049185.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15049185.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL Draft results: by team" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-team/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-team/"
			title="2021 NFL Draft results: by team"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-draft-picks-players-fantasy-football-analysis/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-team/"
						title="2021 NFL Draft results: by team"
						itemprop="url" 						>
							2021 NFL Draft results: by team					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 2, 2021 1:18 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Tracking all of the 2021 NFL Draft picks by the their selecting teams. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-round/"
						title="2021 NFL Draft results: by round"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15987112.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15987112.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL Draft results: by round" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-round/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-round/"
			title="2021 NFL Draft results: by round"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-draft-picks-players-fantasy-football-analysis/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-round/"
						title="2021 NFL Draft results: by round"
						itemprop="url" 						>
							2021 NFL Draft results: by round					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 2, 2021 1:18 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Tracking all of the 2021 NFL Draft picks by round selected </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-position/"
						title="2021 NFL Draft results: by position"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/05/7df7c38a-0fca-4b33-8476-aca15a8aa80e-Lawrence.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/7df7c38a-0fca-4b33-8476-aca15a8aa80e-Lawrence.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL Draft results: by position" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-position/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-position/"
			title="2021 NFL Draft results: by position"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-draft-picks-players-fantasy-football-analysis/" class="category" itemprop="articleSection">NFL Draft</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-position/"
						title="2021 NFL Draft results: by position"
						itemprop="url" 						>
							2021 NFL Draft results: by position					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 2, 2021 1:17 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Tracking all of the 2021 NFL Draft picks sorted by position </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/01/fantasy-football-2021-player-movement-tracker/"
						title="2021 fantasy football player movement tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14956035.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14956035.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 fantasy football player movement tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/05/01/fantasy-football-2021-player-movement-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/05/01/fantasy-football-2021-player-movement-tracker/"
			title="2021 fantasy football player movement tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Fantasy football player movement</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/01/fantasy-football-2021-player-movement-tracker/"
						title="2021 fantasy football player movement tracker"
						itemprop="url" 						>
							2021 fantasy football player movement tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 1, 2021 10:39 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2020 NFL off-season player movement tracker. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/01/2021-nfl-draft-day-3-fantasy-football-recap/"
						title="2021 NFL Draft: Day 3 fantasy football recap"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15116248.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15116248.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL Draft: Day 3 fantasy football recap" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/05/01/2021-nfl-draft-day-3-fantasy-football-recap/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/05/01/2021-nfl-draft-day-3-fantasy-football-recap/"
			title="2021 NFL Draft: Day 3 fantasy football recap"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" class="category" itemprop="articleSection">Fantasy Football Rookie Analysis</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/05/01/2021-nfl-draft-day-3-fantasy-football-recap/"
						title="2021 NFL Draft: Day 3 fantasy football recap"
						itemprop="url" 						>
							2021 NFL Draft: Day 3 fantasy football recap					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">May 1, 2021 5:55 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Day 3 of the NFL draft&#8217;s impact on fantasy football.  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-2-fantasy-football-recap/"
						title="2021 NFL Draft: Day 2 fantasy football recap"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15139042.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15139042.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL Draft: Day 2 fantasy football recap" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/04/30/2021-nfl-draft-day-2-fantasy-football-recap/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-2-fantasy-football-recap/"
			title="2021 NFL Draft: Day 2 fantasy football recap"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>15</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" class="category" itemprop="articleSection">Fantasy Football Rookie Analysis</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-2-fantasy-football-recap/"
						title="2021 NFL Draft: Day 2 fantasy football recap"
						itemprop="url" 						>
							2021 NFL Draft: Day 2 fantasy football recap					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 30, 2021 11:31 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Making sense of all the fantasy-relevant picks from Day 2 of the NFL draft.  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/30/2021-nfl-top-free-agent-tracker/"
						title="2021 NFL top free-agent tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/12/13829254-e1577118963418.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/12/13829254-e1577118963418.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL top free-agent tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/04/30/2021-nfl-top-free-agent-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/04/30/2021-nfl-top-free-agent-tracker/"
			title="2021 NFL top free-agent tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Fantasy football player movement</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/30/2021-nfl-top-free-agent-tracker/"
						title="2021 NFL top free-agent tracker"
						itemprop="url" 						>
							2021 NFL top free-agent tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 30, 2021 2:40 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2020 NFL off-season free-agent tracker. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-1-fantasy-football-recap/"
						title="2021 NFL Draft: Day 1 fantasy football recap"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15986951.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15986951.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 NFL Draft: Day 1 fantasy football recap" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/04/30/2021-nfl-draft-day-1-fantasy-football-recap/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-1-fantasy-football-recap/"
			title="2021 NFL Draft: Day 1 fantasy football recap"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>6</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" class="category" itemprop="articleSection">Fantasy Football Rookie Analysis</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/30/2021-nfl-draft-day-1-fantasy-football-recap/"
						title="2021 NFL Draft: Day 1 fantasy football recap"
						itemprop="url" 						>
							2021 NFL Draft: Day 1 fantasy football recap					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 30, 2021 12:04 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Sorting through all of the newest additions to the 2021 fantasy football draft pool. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/27/fantasy-football-nfl-draft-dyami-brown-north-carolina/"
						title="Rookie Rundown: WR Dyami Brown, North Carolina"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15198905.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/04/USATSI_15198905.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Rookie Rundown: WR Dyami Brown, North Carolina" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/04/27/fantasy-football-nfl-draft-dyami-brown-north-carolina/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/04/27/fantasy-football-nfl-draft-dyami-brown-north-carolina/"
			title="Rookie Rundown: WR Dyami Brown, North Carolina"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>5</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-rookie-analysis/" class="category" itemprop="articleSection">Fantasy Football Rookie Analysis</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/27/fantasy-football-nfl-draft-dyami-brown-north-carolina/"
						title="Rookie Rundown: WR Dyami Brown, North Carolina"
						itemprop="url" 						>
							Rookie Rundown: WR Dyami Brown, North Carolina					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 27, 2021 6:04 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Brown&#8217;s vertical game is a touchdown waiting to happen. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/27/rookie-rundown-wr-tylan-wallace-oklahoma-state/"
						title="Rookie Rundown: WR Tylan Wallace, Oklahoma State"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/04/usatsi_11537069.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/04/usatsi_11537069.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Rookie Rundown: WR Tylan Wallace, Oklahoma State" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/04/27/rookie-rundown-wr-tylan-wallace-oklahoma-state/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/04/27/rookie-rundown-wr-tylan-wallace-oklahoma-state/"
			title="Rookie Rundown: WR Tylan Wallace, Oklahoma State"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1</span>
		share	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/" class="category" itemprop="articleSection">Fantasy football player analysis tips and advice</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/04/27/rookie-rundown-wr-tylan-wallace-oklahoma-state/"
						title="Rookie Rundown: WR Tylan Wallace, Oklahoma State"
						itemprop="url" 						>
							Rookie Rundown: WR Tylan Wallace, Oklahoma State					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">April 27, 2021 3:44 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Tylan Wallace offers a mature, speedy package for the NFL. </p>

				
				
			</div>
		</article>
	</div>
<a href="https://thehuddle.com" class="article__back">More Huddle</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget widget--login widget--box" id="login_widget-3">
<div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget--forum widget--box" id="forum_widget-4">
<div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424381"><a href="https://tools.thehuddle.com/season">Season-to-Date Stats</a></li>
<li id="menu-item-424382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424382"><a href="https://tools.thehuddle.com/weekly">Weekly Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Stats Matchups</a></li>
<li id="menu-item-453426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453426"><a href="https://thehuddle.com/2020/05/07/2020-nfl-schedule-team-by-week-grid/">Schedule: Team-by Week Grid</a></li>
<li id="menu-item-453427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453427"><a href="https://thehuddle.com/2020/05/07/2020-nfl-schedule-weekly-grid/">Schedule: Weekly Grid</a></li>
<li id="menu-item-453428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453428"><a href="https://thehuddle.com/2020/05/07/2020-nfl-schedule-release-bye-weeks/">Schedule: Bye Weeks</a></li>
</ul><a href="https://thehuddle.com/fantasy-football-statistics/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><a href="http://www.thehuddle.com/podcast/"><img width="1000" height="1000" src="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg 1000w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=150,150 150w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=300,300 300w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=768,768 768w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=600,600 600w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=100,100 100w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=340,340 340w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=32,32 32w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=50,50 50w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=64,64 64w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=96,96 96w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=128,128 128w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></div><div class="widget widget--links widget--box" id="links_widget-8">
<div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="https://tools.thehuddle.com/nfl-depth-charts">2021 fantasy depth charts</a></li>
<li id="menu-item-457177" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457177"><a href="https://thehuddle.com/2021/02/26/2021-nfl-coaching-change-tracker/">2021 NFL coaching change tracker</a></li>
<li id="menu-item-457194" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457194"><a href="https://thehuddle.com/2021/05/01/fantasy-football-2021-player-movement-tracker/">2021 fantasy football player movement tracker</a></li>
<li id="menu-item-457195" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457195"><a href="https://thehuddle.com/2021/04/30/2021-nfl-top-free-agent-tracker/">2021 NFL top free-agent tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7">
<div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="https://tools.thehuddle.com/nfl-depth-charts">2021 fantasy depth charts</a></li>
<li id="menu-item-457196" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457196"><a href="https://thehuddle.com/2021/04/30/2021-nfl-top-free-agent-tracker/">2021 NFL top free-agent tracker</a></li>
<li id="menu-item-457572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457572"><a href="https://thehuddle.com/2021-nfl-draft-central/">2021 NFL Draft Central</a></li>
<li id="menu-item-458421" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-458421"><a href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-team/">2021 NFL Draft results: by team</a></li>
<li id="menu-item-458422" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-458422"><a href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-round/">2021 NFL Draft results: by round</a></li>
<li id="menu-item-458423" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-458423"><a href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-position/">2021 NFL Draft results: by position</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-3">
<div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="https://www.usatoday.com/sports/" rel="nofollow" target="_blank">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/logo-usat-footer-1.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448091"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
	<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/icon-huddle.png" alt="Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com">
				<a class="mobile-nav__breadcrumb" href="https://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--draft-guide mobile-nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2020-fantasy-football-league-draft-preview-rankings-cheatsheets-sleepers/">Draft Guide</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2020&#038;week=0">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-projections"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2020&#038;week=0">Fantasy football projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-standard">Top 200 Overall</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-ppr">Top 200 PPR</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li class="mobile-nav__item mobile-nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2020/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--inseason mobile-nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">Inseason</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy Football Player Rankings / Projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Fantasy Football Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--dfs-daily-fantasy-football"><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/">DFS - Daily Fantasy Football</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfl-game-predictions-and-picks"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">NFL Game Predictions and Picks</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Fantasy Football Start/Bench Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--news mobile-nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li class="mobile-nav__item mobile-nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--stats mobile-nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li class="mobile-nav__item mobile-nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--teams mobile-nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--afc-east"><a href="#">AFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-north"><a href="#">AFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li class="mobile-nav__item mobile-nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li class="mobile-nav__item mobile-nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-south"><a href="#">AFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li class="mobile-nav__item mobile-nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li class="mobile-nav__item mobile-nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li class="mobile-nav__item mobile-nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-west"><a href="#">AFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li class="mobile-nav__item mobile-nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li class="mobile-nav__item mobile-nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-ft"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-football-team">Washington FT</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li class="mobile-nav__item mobile-nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li class="mobile-nav__item mobile-nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li class="mobile-nav__item mobile-nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--fantasy-football-nfl-depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Fantasy Football NFL Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-draft-central"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2021-nfl-draft-central/">NFL Draft Central</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li class="mobile-nav__item mobile-nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="https://www.usatoday.com/sports/"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/usat-logo-mobile-off-canvas-1.png">
		</a>
	</div>

<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="https://tools.thehuddle.com/login" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??/wp-includes/css/dashicons.min.css,/wp-includes/js/thickbox/thickbox.css?m=1618502276' type='text/css' media='all' />
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1' id='sharethrough-native-responsive-js'></script>
<script id='usatoday-sticky-inline-videos-script-js-extra'>
var stickyInlineVideosOptions = {"side":"right","hide":"Hide video"};
</script>
<script id='lawrence-ads-js-js-extra'>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"60","refresh_type":"all","distance":"2000","active":"0"}};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJydj0EOwjAMBD9EiHoBekA8BZnEgNvEKYnTkt9DkYoqxIFy9Ho93tVDp0xgQRYtV/SYdE4gwUJRDoaIbFD7YLN7bsCqZCJ1knSTdAcRfMgs6yat9P8cBqEej5cIPUk5nh3elxMZXBEyaQ6eXEoQHGW/mOqJs6DyaAlG4HxW75ef2M7lC/GMOwnp6W6LInbEqHqyGF45v+k/Zx170kk3t4yxrE0ILeGSYw/ES/xgx2wHv682Vb2t6t2mbh5T69z8'></script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0' id='lawrence-confiant-js-js'></script>
<script id='wasabi-article-js-extra'>
var wasabiFacebookReferral = "0";
</script>
<script id='wasabi-main-js-extra'>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"1440\":{\"follow\":false,\"minWidth\":1024,\"stickTime\":4}}"};
</script>
<script id='huddle-user-nav-js-extra'>
var huddleUser = {"name":"Huddle User","cookie":"session","logoutAPI":"https:\/\/api.thehuddle.com\/User\/Logout"};
</script>
<script id='huddle-login-debug-js-extra'>
var huddleLoginDebugData = {"is_member":"","user_data":[]};
</script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/thehuddle.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJytkd0OgjAMhV/IuRAV44XxWcrWQHE/hG4CPr3jApXECyDetWf9Tpsz2TVCeRfQBdmYWJJjGRmC1zCISTDwHITxoAX2aVKjlvWXurfk9jXv5D+8lvp0wFDQyMZAhjdwDh5UQiC//PgPzKSxgHYDCW0gZXADaWFFzqFCUUWtDY4oLd83ByNjK1JSE05OmaiRx7fUoi1w3f/P7Y1PokhRxvLXhlCRuhe+fxdp6GavWZ5djqdDds7rFxAvCeU='></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin' id='sop-script-js'></script>
<script type='text/javascript' src='https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/ats_smg.js?m=1619453176g'></script>
<script src='https://stats.wp.com/e-202118.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'175784887',post:'458427',tz:'-4',srv:'thehuddle.com'} ]);
	_stq.push([ 'clickTrackerInit', '175784887', '458427' ]);
</script>
</body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
