<!DOCTYPE html>
<!--[if IE 8]> <html lang="en-US" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en-US" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Quick rundown of the games from Sunday with a fantasy football perspective" />
<meta name="keywords" content="fantasy football,fantasy football game reviews,game analysis" />
<title>Sunday Snippets &#8211; Week 2</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//ads.rubiconproject.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Feed" href="https://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com &raquo; Comments Feed" href="https://thehuddle.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thehuddle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??-eJydkc1OwzAQhF8Ix0QVKBwQV96A88Zetduuf+S1W/z2OClBQSkIcdxZz2i+tb5EZYLP6LOOXPbkRReBHCxUtRESOnq32shG65p2p1sYecPFosyPLEnWIwdzUkxjglS15MrYOfJbx1G0Q0uAjG7qsx4iQ8WkGPdg6t/sbbeev5kWZFe+IAUhmYNGBslkYsKl/wSSmpzRqhgki7oSzSRyM/bHS07Rp9o6M3lUZ7IYrpe6tdjE5kMjWaUyXBJ6g8viDQRG+qdNvxZr29f8cqIj5giNvL/v+rn1pzB5Xtxz/7jrh2HYPT18ANBJ4Zk=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script id='amazon-adsystem-js-extra'>
var amznAcctId = ["3090"];
</script>
<script id='amazon-adsystem-js-before'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId[0], adServer: "googletag"});
</script>
<script src='https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/bidder-manager.js?ver=5.8.1' id='amazon-adsystem-js'></script>
<script src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=5.8.1' id='sonobi-adsystem-js'></script>
<script src='//ads.rubiconproject.com/prebid/10968_USAToday_Sports.js?ver=5.8.1' id='lawrence_magnite_header_bidder_script-js'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.8.1' id='lawrence-ads-ias-js'></script>
<script id='lawrence-ads-ias-js-after'>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZMRBZWJoYZQEAr3siIw=='></script>
<script id='lawrence-tealium-js-extra'>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","content-market-name":"thehuddle","page-has-video":"no","page-has-gallery":"0","page-canonical-url":"https:\/\/thehuddle.com\/2021\/09\/19\/sunday-snippets-week-2-2\/","content-ssts-section":"sports","content-ssts-subsection":"sports:thehuddle","content-ssts-topic":"sports:thehuddle","content-ssts-subtopic":"sports:thehuddle","page-experience-type":"desktop","content-type":"story pages","content-id":"460455","content-headline":"Sunday Snippets - Week 2","content-date-published":"2021-09-19T23:39:30Z","content-byline":"David Dorey","content-contributor-names":"David Dorey","content-article-length":"2818","content-keywords":"Fantasy Football Game Reviews","content-title":"Sunday Snippets \u2013 Week 2 |  | "};
</script>
<script id='lawrence-tealium-js-before'>
			window.gciAnalyticsUAID = "SMG-TEALIUM-THEHUDDLE";
			gciDataLayer["page-full-url"]    = window.location.href;
			gciDataLayer["content-name"]     = window.location.pathname;
			gciDataLayer["page-referer"]     = document.referrer;
			gciDataLayer["page-has-gallery"] = Boolean(parseInt(gciDataLayer["page-has-gallery"], 10));
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1' id='lawrence-tealium-js'></script>
<script id='lawrence-tealium-js-after'>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0' id='lawrence-confiant-js'></script>
<script id='usatoday-gallery-js-extra'>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-166840762-5","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-166840762-5","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJylkNEOgjAMRX/IsYBRn4zfMreCHduY6yby944ECNHESExf2nt7bpry3jPZuQgucm9Sg454IhE7JQY2C8Ija4QxEBDyRASRuCYeQRhMdvKGQtOO/5OXSPms99lij7Kofg5cBAw4Ja2E95h4AwurHSP6AE7CCFKLnhl0Las7mYjV+NyC63saH2EFui2YweuMUkTZfrzy68mowkLnPrMXey6P+/KU61DpF09TttQ='></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-1.js?ver=5.8.1' id='the-huddle-eu-redirect-1-js'></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-2.js?ver=5.8.1' id='the-huddle-eu-redirect-2-js'></script>
<link rel="https://api.w.org/" href="https://thehuddle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thehuddle.com/wp-json/wp/v2/posts/460455" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thehuddle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thehuddle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.1" />
<link rel='shortlink' href='https://thehuddle.com/?p=460455' />
<link rel="alternate" type="application/json+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2021%2F09%2F19%2Fsunday-snippets-week-2-2%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2021%2F09%2F19%2Fsunday-snippets-week-2-2%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle",
		"mainEntityOfPage": {
			"@type": "WebPage",
			"@id": "https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		},
		"url": "https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/",
		"headline": "Sunday Snippets - Week 2",
		"thumbnailUrl": "https://thehuddle.com/wp-content/uploads/sites/74/2021/09/00144bf8-081a-441a-a1ab-7c376b03e8ff-titans_seahawks_141.jpg?w=192&#038;h=150&#038;crop=1",
		"image": "https://thehuddle.com/wp-content/uploads/sites/74/2021/09/00144bf8-081a-441a-a1ab-7c376b03e8ff-titans_seahawks_141.jpg?w=192&#038;h=150&#038;crop=1",
		"datePublished": "2021-09-19T23:39:30Z",
		"dateModified": "2021-09-19T23:39:30Z",
		"articleSection": "Game Analysis",
		"creator": ["David Dorey"],
		"author": {
			"@type": "Person",
			"name": "David Dorey"
		},
		"keywords": ["Fantasy Football Game Reviews"],
	"publisher": {
		"@type": "Organization",
		"name": "Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com",
		"logo": {
			"@type": "ImageObject",
			"url": "https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
		}
	}
}
</script>
<style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link,
.parsely__post_meta .parsely__post_section {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.newsletter-modal {
	border-top: solid 8px #dd9933;
}

.article__back {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.listicle__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#dd9933, #dd9933)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

.smg-event__ctabutton {
	background-color: #dd9933;
	box-shadow: 0 2px 0 0 #dd9933;
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover,
.parsely .posts-parsely .post .post__title a:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/" />

<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.addBidder( 'magnite' );
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video', 'ignoreRefresh' : true } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Sunday Snippets - Week 2" />
<meta property="og:url" content="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/" />
<meta property="og:description" content="Sunday game reviews from a fantasy perspective" />
<meta property="article:published_time" content="2021-09-20T03:39:30+00:00" />
<meta property="article:modified_time" content="2021-09-20T03:39:30+00:00" />
<meta property="og:site_name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com" />
<meta property="og:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/00144bf8-081a-441a-a1ab-7c376b03e8ff-titans_seahawks_141.jpg?w=825&#038;h=551&#038;crop=1" />
<meta property="og:image:width" content="825" />
<meta property="og:image:height" content="551" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Sunday Snippets - Week 2" />
<meta name="twitter:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/00144bf8-081a-441a-a1ab-7c376b03e8ff-titans_seahawks_141.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=180" />
<meta name="msapplication-TileImage" content="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.header__sponsor {
    right: 450px;
}		</style>
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-460455 single-format-standard">

	<div class="noskim">
		
		<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
			</div>

	<div id="wrapper">

		<div class="noskim">
			
			<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>
		</div>

		<div class="wrapper-holder">

			<div class="noskim">
				<div
	class="branding branding--section"
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://thehuddle.com"
				title="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
				class="branding__logo-link "
			>
				<img
					src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
					alt="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

		<span class="header__sponsor">
					<div id='acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo'); });</script></div>				</span>
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="https://www.usatoday.com/sports/" target="_blank" title="USA TODAY Sports">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/03/USATODAY_Sports_Log.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-458721" class="nav__item nav__item--myhuddle nav__item--parent"><a href="https://tools.thehuddle.com/myhuddle/custom">myHuddle</a>
<ul class="sub-menu">
	<li id="menu-item-458722" class="nav__item nav__item--custom-leagues"><a href="https://tools.thehuddle.com/myhuddle/custom">Custom Leagues</a></li>
	<li id="menu-item-458723" class="nav__item nav__item--player-tracking"><a href="https://tools.thehuddle.com/myhuddle/player-tracking">Player Tracking</a></li>
	<li id="menu-item-458724" class="nav__item nav__item--account-information"><a href="https://tools.thehuddle.com/myhuddle/account-information">Account Information</a></li>
	<li id="menu-item-458725" class="nav__item nav__item--subscription-status"><a href="https://tools.thehuddle.com/myhuddle/subscription-status">Subscription Status</a></li>
</ul>
</li>
<li id="menu-item-450451" class="nav__item nav__item--draft-guide nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2021-fantasy-football-draft-guide/">Draft Guide</a>
<ul class="sub-menu">
	<li id="menu-item-442874" class="nav__item nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2021&#038;week=0">Cheat Sheets</a></li>
	<li id="menu-item-442875" class="nav__item nav__item--fantasy-football-projections"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2021&#038;week=0">Fantasy football projections</a></li>
	<li id="menu-item-442876" class="nav__item nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-standard">Top 200 Overall</a></li>
	<li id="menu-item-442877" class="nav__item nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-ppr">Top 200 PPR</a></li>
	<li id="menu-item-442878" class="nav__item nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li id="menu-item-442879" class="nav__item nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442880" class="nav__item nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442881" class="nav__item nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li id="menu-item-442847" class="nav__item nav__item--inseason nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">Inseason</a>
<ul class="sub-menu">
	<li id="menu-item-442896" class="nav__item nav__item--fantasy-football-player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy Football Player Rankings / Projections</a></li>
	<li id="menu-item-442897" class="nav__item nav__item--fantasy-football-cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Fantasy Football Cheat Sheets</a></li>
	<li id="menu-item-442848" class="nav__item nav__item--dfs-daily-fantasy-football"><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/">DFS - Daily Fantasy Football</a></li>
	<li id="menu-item-442894" class="nav__item nav__item--nfl-game-predictions-and-picks"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">NFL Game Predictions and Picks</a></li>
	<li id="menu-item-442895" class="nav__item nav__item--fantasy-football-start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Fantasy Football Start/Bench Tool</a></li>
	<li id="menu-item-442898" class="nav__item nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li id="menu-item-442849" class="nav__item nav__item--news nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li id="menu-item-450179" class="nav__item nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li id="menu-item-450180" class="nav__item nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li id="menu-item-450181" class="nav__item nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li id="menu-item-450182" class="nav__item nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li id="menu-item-450183" class="nav__item nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li id="menu-item-442850" class="nav__item nav__item--stats nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li id="menu-item-442899" class="nav__item nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li id="menu-item-442900" class="nav__item nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li id="menu-item-442901" class="nav__item nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li id="menu-item-442902" class="nav__item nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li id="menu-item-442903" class="nav__item nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li id="menu-item-442904" class="nav__item nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li id="menu-item-442906" class="nav__item nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li id="menu-item-442851" class="nav__item nav__item--teams nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li id="menu-item-442917" class="nav__item nav__item--afc-east"><a href="#">AFC East</a></li>
	<li id="menu-item-442918" class="nav__item nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li id="menu-item-442919" class="nav__item nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li id="menu-item-442920" class="nav__item nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li id="menu-item-442921" class="nav__item nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li id="menu-item-442922" class="nav__item nav__item--afc-north"><a href="#">AFC North</a></li>
	<li id="menu-item-442923" class="nav__item nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li id="menu-item-442924" class="nav__item nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li id="menu-item-442925" class="nav__item nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li id="menu-item-442926" class="nav__item nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li id="menu-item-442927" class="nav__item nav__item--afc-south"><a href="#">AFC South</a></li>
	<li id="menu-item-442928" class="nav__item nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li id="menu-item-442929" class="nav__item nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li id="menu-item-442930" class="nav__item nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li id="menu-item-442931" class="nav__item nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li id="menu-item-442932" class="nav__item nav__item--afc-west"><a href="#">AFC West</a></li>
	<li id="menu-item-442933" class="nav__item nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li id="menu-item-442934" class="nav__item nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li id="menu-item-442936" class="nav__item nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li id="menu-item-442935" class="nav__item nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li id="menu-item-442937" class="nav__item nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li id="menu-item-442938" class="nav__item nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li id="menu-item-442939" class="nav__item nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li id="menu-item-442940" class="nav__item nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li id="menu-item-442941" class="nav__item nav__item--washington-ft"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-football-team">Washington FT</a></li>
	<li id="menu-item-442942" class="nav__item nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li id="menu-item-442943" class="nav__item nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li id="menu-item-442944" class="nav__item nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li id="menu-item-442945" class="nav__item nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li id="menu-item-442946" class="nav__item nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li id="menu-item-442947" class="nav__item nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li id="menu-item-442948" class="nav__item nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li id="menu-item-442949" class="nav__item nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li id="menu-item-442950" class="nav__item nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li id="menu-item-442951" class="nav__item nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li id="menu-item-442952" class="nav__item nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li id="menu-item-442953" class="nav__item nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li id="menu-item-442954" class="nav__item nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li id="menu-item-442955" class="nav__item nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li id="menu-item-442956" class="nav__item nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li id="menu-item-442852" class="nav__item nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li id="menu-item-442911" class="nav__item nav__item--fantasy-football-nfl-depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Fantasy Football NFL Depth Charts</a></li>
<li id="menu-item-442854" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-442914" class="nav__item nav__item--nfl-draft-central"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2021-nfl-draft-central/">NFL Draft Central</a></li>
<li id="menu-item-450426" class="nav__item nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li id="menu-item-450427" class="nav__item nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li id="menu-item-442855" class="nav__item nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
		</ul>
		<ul class="nav__social nav__social--section">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

				
							</div>

			<div id="main" class="site-main no-more-heroes">

				<div class="noskim">
									</div>

<div class="noskim">
	</div>

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		<div class="noskim">
					</div>

		
			<article id="post-460455" class="post-460455 post type-post status-publish format-standard has-post-thumbnail hentry category-game-analysis tag-fantasy-football-game-reviews article--no-image" itemscope
				itemtype="http://schema.org/NewsArticle">

				<div class="noskim">
					<link itemprop="mainEntityofPage" href="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"/>
		<meta itemprop="url" content="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png">
	</div>
	<meta itemprop="name" content="Fantasy football rankings, sleepers, news and award-winning advice - TheHuddle.com">
</div>
<div class="article__title article__title--no-image ">

	
	<h1 class="article__headline">Sunday Snippets - Week 2</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject" href="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg" data-image-src="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg">
			<link itemprop="url" href="https://thehuddle.com/wp-content/plugins/usatoday-plugins/wasabi/images/logo-usat-large.jpg" />
		</span>
	</div>
<h1 class="article__headline article__headline--mobile">Sunday Snippets - Week 2</h1>

					<header class="entry-header  ">

						
<h2 class="">
	<a href="https://thehuddle.com/category/game-analysis/" class="" itemprop="articleSection">Game Analysis</a></h2>

						
						<div id="headline">
							<h1 class="entry-title" itemprop="name headline">Sunday Snippets - Week 2</h1>
													</div>

						
						
						<div class="meta-info single-headline" id="entry-byline">
							
<p>

	By <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a></span></span> 
		<span class="post-date updated">September 19, 2021 11:39 pm</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
					Follow					@DMDorey				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
						</div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo'); });</script></div>
					</header>

					
									</div>

				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						<div class="noskim">
							
							<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

							
							<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a></span></span> |
		<span itemprop="datePublished" content="2021-09-19T23:39:30-04:00">
			September 19, 2021 11:39 pm ET		</span>
		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/DMDorey" class="twitter-follow-button" data-show-count="false">
		Follow @DMDorey	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


													</div>

						<div class="articleBody" itemprop="articleBody"><p>Taking a quick rundown of the Sunday NFL games with a fantasy perspective.</p>
<p><b>NO 7, CAR 26<br />
</b>How the tables turn! The only rational conclusion is that the Panthers can beat the Packers 63-10. The Saints were everything that the Packers were last week. Jameis Winston only threw for 111 yards and two interceptions (now, I remember him). He ran in a touchdown just to ensure there would be zero fantasy value from anyone, even Alvin Kamara, who rushed for five yards on eight carries and caught four passes for 25 yards. Just a dead effort and no way yet to know who these Saints really are. They travel to New England this week.</p>
<p>Sam Darnold threw for 305 yards and two scores, so scratch the Saints&#8217; secondary as impenetrable. DJ Moore (8-79, TD) was the only standout receiver while Christian McCaffrey ran for 72 yards and a touchdown, plus caught five passes for 65 yards. Robby Anderson hasn&#8217;t fared as well with Darnold, but the Panthers are now 2-0 and heading to Houston.</p>
<p><b>CIN 17, CHI  20<br />
</b>The Bears led this 20-3 until the final four minutes when the Bengals finally moved the ball. Joe Mixon ran for 69 yards on 20 rushes but only caught a two-yard pass. Joe Burrow passed for 207 yards and two touchdowns, but both came at the end of the game, and he had three interceptions. Ja&#8217;Marr Chase (2-54, TD) saved his day with a 42-yard score with four minutes left. Tee Higgins (6-60, TD) caught his score with three minutes left to play, and Tyler Boyd led the group with seven catches for 70 yards.</p>
<p>The Bears won thanks mainly to a first-quarter score to Allen Robinson (2-24, TD) and a returned interception for a touchdown. Andy Dalton left with a knee injury, and Justin Fields only completed six of 13 passes for 60 yards and one interception. He also ran for 31 yards but didn&#8217;t look nearly as impressive in his first extensive action. David Montgomery ran for 61 yards and caught three passes for 18 yards, but the offense sputtered no matter which quarterback was under center. Playing in Cleveland next week means figuring out the offense in a hurry.</p>
<p><b>HOU 21, CLE 31<br />
</b>The Texans lost by ten, but they led 14-7 in the second quarter and looked like they were about to have their second upset of the year. Tyrod Taylor ran for a touchdown but pulled a hamstring. The rookie Davis Mills took over with marginal success completing 8-of-18 for 102 yards and a score to Brandin Cooks (9-78, TD). No other Texans&#8217; receiver gained more than 25 yards or had more than two catches. Mark Ingram (14-41) was still the leading rusher only it did not matter this week. The Texans host the surprising Panthers this week in a game where anything can happen.</p>
<p>The Browns struggled early against the Texans, and Baker Mayfield was injured but returned the next series. He only threw for 213 yards and a score with rookie Demetric Felton (2-51, TD) leading the receivers after Jarvis Landry left injured. Nick Chubb ran for 95 yards and a 26-yard touchdown while Kareem Hunt gained 51 yards on his 13 rushes. The Browns already have Odell Beckham every week and now Landry is out. The offense prefers to run, but starting wideouts are still a need. The Browns  host the Bears this week.</p>
<p><b>LAR 27, IND 24<br />
</b>Close game  with the Colts never giving up. Matt Stafford threw for 278 yards and two touchdowns, but much of that came late, and almost all of it went to Cooper Kupp (9-163, 2 TD). Robert Woods settled for 64 yards on five catches. The backfield was split between Darrell Henderson (13-53, TD) and Sony Michel (10-46), who did almost all of his damage in the second half. The Rams defense didn&#8217;t look nearly as dominating as Week 1, but in the end &#8211; good enough. The Rams host the Buccaneers on Sunday.</p>
<p>The Colts had the lead in the fourth quarter but could not hang on. Carson Wentz threw for 247 yards and another score to Zack Pascal (5-38, TD) this week. Michael Pittman faced a great secondary and still turned in eight catches for 123 yards. Jonathan Taylor only gained 51 yards on 15 rushes. The only notable was that Jack Doyle accounted for five catches for 64  yards. The Colts faced a great Rams team and nearly beat them. The Colts travel to the Titans this week.</p>
<p><b>DEN 23, JAC 13<br />
</b>The Jaguars scored a touchdown pass on their opening series but never again until a 102-yard kickoff return touchdown late in the fourth quarter. Trevor Lawrence only threw for 118 yards and the one early score with two interceptions while looking more like just a rookie than a rookie phenom. James Robinson reasserted his dominance in the backfield with 11 runs for 37 yards over Carlos Hyde&#8217;s two carries for seven yards.  Marvin Jones (6-55, TD) was the only wideout of any note. The Jaguars host the Cardinals this week, so it may still be a while before the offense kicks in.</p>
<p>Teddy Bridgewater passed for 328 yards and two scores between Noah Fant (4-33, TD) and Tim Patrick (3-37, TD). Courtland Sutton blew up with nine receptions for 159 yards as the only receiver with more than 38 yards. The backfield continues to be a split affair between Javonte Williams (13-64) and Melvin Gordon (13-31). This win was brought to you by Sutton, who the Jags just had no answer for this week. The Broncos  host the Jets this week, so everything is looking up.</p>
<p><b>BUF 35, MIA 0</b></p>
<p>The Dolphins lost Tua Tagovailoa in the first four minutes, and he took the keys to the offense with him. Jacoby Brissett only threw for 169 yards and one interception in this shutout. Jalen Waddle (6-48) and DeVante Parker (5-42) were the top receivers in a game that they needed to throw badly (and did). Miles Gaskin only ran for 25 yards but caught four passes for 21 yards.  If Tagovailoa remains out, the Dolphins fortunes take a major hit judging by this home loss. They travel to Las Vegas this week.</p>
<p>The Bills didn&#8217;t have any offensive explosion as the score might suggest. Devin Singletary (13-82, TD) opened the game with a 46-yard touchdown run. Zack Moss was active and ran eight times for 26 yards with two touchdowns in the fourth quarter when both sides just wanted to go home. Stefon Diggs was the only notable receiver with 60 yards and a score on four catches, but the Bills had a light day once Tagovailoa left. The Bills host Washington this week.</p>
<p><b>NE 25, NYJ 6<br />
</b>The rookie Zach Wilson was the difference-maker here but only because he threw for 210 yards and four interceptions. Jamison Crowder was a game-time scratch, and the Patriots realized they needed to shut down Corey Davis (2-8) to stop the passing game. The rookie Michael Carter had a better game with 59 yards on 11 carries and two receptions for 29 yards. Ty Johnson ran 12 times for 50 yards and even Tevin Coleman had five rushes for 24 yards. In the end, nothing really matters when the quarterback throws four interceptions. The Jets head to Denver this week.</p>
<p>The Patriots didn&#8217;t do much other than field interceptions. Damien Harris ran for 62 yards and a score on 16 carries, while James White (5-20, TD) also was the lead receiver with 45 yards on six catches. Mac Jones settled for 186 yards and no scores but also no turnovers. The Jets couldn&#8217;t get their offense into gear, and the Pats coasted to an easy victory,  and no receivers mattered. The Pats host the Saints this week for what could be a tougher matchup, depending on which Saints show up.</p>
<p><b>SF 17, PHI 11<br />
</b>The 49ers&#8217; defense played a solid game, even if the offense struggled to do much. Jimmy Garoppolo passed for 189 yards and one score without  sharing anything with Trey Lance. Elijah Mitchell ran for 42 yards on 17 carries and added two runs for 11 yards for a more sedate outing than last week. James Hasty ran for 38 yards on five catches and caught four passes for 21 yards that all diminished what Mitchell did. Jimmy Garoppolo also ran in a touchdown to further impact the backfield. Trey Sermon finally saw the field and ran for eight yards, got hit, lost a fumble and then left injured. Deebo Samuel (6-93) remains the top receiver while Brandon Aiyuk (1-6) proved that 2020 is definitely over. George Kittle was limited to only 17 yards on four catches. The 49ers  host the Packers on Sunday.</p>
<p>The Eagles&#8217; offense sputtered badly. Miles Sanders only ran 13 times for 55 yards plus a four-yard catch. Jalen Hurts ran for 82 yards and one score, but only passed for 190 yards. And 91 yards came on a completion to Quez Watkins (2-117). No other receiver gained over 24 yards. The Eagles looked sharp last week but ineffective on offense for Week 2.  They head to Dallas for their first divisional meeting of the year.</p>
<p><b>LV 26, PIT 17<br />
</b>The Raiders are a surprise team this year. They played without Josh Jacobs and relied mostly on Peyton Barber (13-32) while Kenyan Drake ran for just nine yards and caught five passes for 46 yards. Derek Carr is enjoying the best start to a season in his career. He threw for 382 yards and two scores. Henry Ruggs (5-113, TD) is finally living up to expectations, and Darren Waller (5-65) had a &#8220;down game&#8221; after a slow start. The Raiders have already beaten the Ravens and Steelers, and now host the Dolphins.</p>
<p>Najee Harris scored his first NFL touchdown when he caught five passes for 43 yards, but he still only rushed for 38 yards on ten carries. And JuJu Smith-Schuster ran in the three-yard touchdown while also catching six passes for 41 yards. Ben Roethlisberger threw for 295 yards and just the one touchdown. Diontae Johnson (9-105) and Chase Claypool (3-70) were the top receivers, and Johnson was injured on the final play. The offensive line is a glaring weakness that undermines the offense. The Steelers  host the Bengals</p>
<p><b>ATL 25, TB 48<br />
</b>The Falcons lost again, but at least the offense showed up. The rushing effort remains anemic, and Cordarrelle Patterson (7-11, TD) took away the lone rushing score from Mike Davis (9-38), who added seven catches for only 25 yards. The best development was Matt Ryan throwing for 300 yards and two scores. Kyle Pitts still has not scored, but he led the Falcons with five catches for 73 yards. Calvin Ridley (7-63, TD) showed life again while Patterson turned five receptions into 58 yards and another touchdown. No other receivers gained more than 28 yards. The Falcons head to New York to face the Giants still searching for that first win.</p>
<p>The Buccaneers were only ahead 28-25 entering the fourth quarter but had no problem closing the game out when safety Mike Edwards returned two interceptions for a touchdown over the final eight minutes. The backfield is still a mess with Ronald Jones (6-27) and Leonard Fournette (11-52) splitting the work, but Fournette added four catches for 24 yards while Giovani Bernard was limited to just two short receptions. Tom Brady once again enjoyed a stellar outing at home versus a bad secondary. He pasted the Falcons for 276 yards and five touchdowns. Mike Evans (5-75, 2 TD) and Rob Gronkowski (4-39, 2 TD) both doubled up on scores, while Chris Godwin (4-62, TD) settled for just one. The Buccaneers opened the year against two of the weakest secondaries while at home. Now they have to travel to play a road game against the Rams.</p>
<p><b>MIN 33, ARI 34<br />
</b>This is a game that fantasy football loves. The Vikings put up a great fight and nearly took the upset. Dalvin Cook ran for 131 yards and added two catches for 17 yards. Kirk Cousins passed for 244 yards and three touchdowns between KJ Osborn (5-91, TD), Justin Jefferson (6-65, TD), and Adam Thielen (6-39, TD). The Vikings took the lead in the fourth quarter but couldn&#8217;t quite hold on. The Viking host the Seahawks on Sunday.</p>
<p>Yet another monster game for Kyler Murray who scored on his five rushes for 31 yards, and he passed for 400 yards and three touchdowns. Ronald Moore (7-114, TD) led the receivers, and tight end Maxx Williams (7-94) turned in a career-best game. DeAndre Hopkins (4-54, TD) and A.J. Green (3-44, TD) both scored with lesser yardage than Christian Kirk (3-65). The rushing effort was marginal again, but Edmonds added five catches for 29 yards to his 46 rushing yards. The Cardinals won the game, and the offense remains powerful so long as Kyler Murray is there. The defense took a step down this week. The Cards  head to Jacksonville for Week 3.</p>
<p><b>DAL 20, LAC 17</b></p>
<p>The Cowboys won on the final play, but both teams managed better defense than expected.  Dak Prescott was held to only 237 passing yards and no scores for a rare dud game. CeeDee Lamb (8-81) was the only receiver with more than 37 yards. Ezekiel Elliott ran for 71 yards on 16 carries and caught two passes for 26 yards, while Tony Pollard handled 13 rushes for 109 yards and a touchdown, plus three receptions for 31 yards as the better back this week.  The Cowboys finally have their home opener this week versus the Eagles.</p>
<p>The Chargers&#8217; bad luck with close games continues. Austin Ekeler was held to 54 yards on nine carries, but added a team-high nine catches for 61 yards. Justin Herbert passed for 338 yards and one score with two very costly interceptions. Keenan Allen (4-108) and Mike Williams (7-91, TD) both enjoyed the Cowboys&#8217; lack of cornerbacks but no other receivers managed more than 21 yards. As has been the case in the last couple of seasons, the Chargers had it taken away at the end. They head to Kansas City this week, where keeping it close is harder to do.</p>
<p><b>TEN 33 , SEA 30 OT<br />
</b> This was  the only overtime game of Week 2. Derrick Henry got rolling in the second half, and by the time the dust settled, he had gained 182 yards and three touchdowns on 35 carries, plus a career-high six catches for 55 yards. Ryan Tannehill passed for 347 yards and no scores, thanks to Henry. Julio Jones (6-128) was the only notable receiver, while A.J. Brown finished with just three catches for 43 yards.</p>
<p>The Titans trailed 30-16 in the fourth quarter before Henry got on track, kicked off by his 60-yard touchdown run. His third touchdown of the second half tied the game in regulation. In overtime, the Titans won on their second series after the defense stuffed the Seahawks back to their one-yard line where they punted. The Titans are back, and King Henry continues to rule. They host the Colts this week.</p>
<p>The Seahawks seemed to have the game in hand before their offense went cold late in the game, and they could no longer stop Henry. Chris Carson only gained 31 yards on 13 carries but ran in two scores. Russell Wilson threw for 343 yards and two scores but only used five receivers. Tyler Lockett (8-178, TD) again starts the season on a torrid pace, while DK Metcalf (6-53) is still waiting for his normal big game. Fred Swaine (5-95, TD) turned in his first NFL touchdown and highest-career yardage. The Seahawks just ran out of gas in the fourth quarter while the Titans suddenly kept getting better. The Seahawks travel to Minnesota this week for another shootout.</p>
<h2><strong>Game-o-the-week</strong></h2>
<p><b>KC 35, BAL 36<br />
</b> Almost all of the afternoon games and this Sunday night game were contenders for the best fantasy game. The Ravens went into overtime in Week 1 and lost, but showed grit in giving the Chiefs more than they could handle. The game was decided when Clyde Edwards-Helaire lost a fumble at the BAL-32 yard line with 1:26 left to play. The Ravens battled back from 17-28 to get the win.</p>
<p>Edwards-Helaire only ran for 46 yards on 13 carries and had no receptions.  Damien Williams even came in to steal the 2-yard touchdown from him. Patrick Mahomes threw for 343 yards and three touchdowns, with Travis Kelce (7-109, TD) turning in another monster game. Tyreek  Hill was held to only 14 yards on three catches by the Ravens though both Byron Pringle (2-63, TD) and Demarcus Robinson (3-46, TD) enjoyed better games than usual. It was a tight game and the Chiefs couldn&#8217;t stop the Ravens in the fourth quarter. They  host the Chargers this week for their first divisional matchup.</p>
<p>Lamar Jackson put the team on his back and won the game. He ran for 107 yards on 16 rushes with two touchdowns, plus threw for 239 yards and a score as well. Ty&#8217;Son Williams was again the most effective back with 77 yards on 13 runs, plus 16 yards from two catches, but once again, Latavius Murray scored the rushing touchdown. Williams could have scored once but lost the fumble at the goal line that Devin DuVernay recovered for the score. Marquise Brown (6-113, TD) enjoyed one of his best games, and Mark Andrews pitched in five catches for 57 yards. But this win was all about Jackson. The Ravens travel to Detroit for Week 3.</p>
</div>

						<div class="noskim">
							<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
							
							
							
							<p class="post-tags post-tags--hide"><a href="https://thehuddle.com/tag/fantasy-football-game-reviews/" rel="tag">Fantasy Football Game Reviews</a>, <a href="https://thehuddle.com/category/game-analysis/" rel="category tag">Game Analysis</a></p>
							<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2021/09/19/sunday-snippets-week-2-2/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
						</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="noskim">
			<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions"
		data-track="thehuddlefeaturedstories thehuddlemore-related-1"
		title="Game predictions and player projections: Week 2"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14957526.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14957526.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Game predictions and player projections: Week 2" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">5d ago</span>
		<h2><a href="https://thehuddle.com/category/game-analysis/" class="category" itemprop="articleSection">Game Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions"
				title="Game predictions and player projections: Week 2" itemprop="url">
				Game predictions and player projections: Week 2			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/09/12/sunday-snippets-week-1-3/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-2"
		title="Sunday Snippets - Week 1"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/09/c1ae9ca8aa2445f082159f0eeb5b9c0d.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/c1ae9ca8aa2445f082159f0eeb5b9c0d.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Sunday Snippets - Week 1" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">2 shares</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="https://thehuddle.com/category/game-analysis/" class="category" itemprop="articleSection">Game Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="https://thehuddle.com/2021/09/12/sunday-snippets-week-1-3/"
				title="Sunday Snippets - Week 1" itemprop="url">
				Sunday Snippets - Week 1			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions"
		data-track="thehuddlefeaturedstories thehuddlemore-related-3"
		title="Game predictions and player projections: Week 1"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/09/0fbe2a68-8f6e-4f59-8702-a3789a14a130-GTY_1282199138.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/0fbe2a68-8f6e-4f59-8702-a3789a14a130-GTY_1282199138.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Game predictions and player projections: Week 1" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="https://thehuddle.com/category/game-analysis/" class="category" itemprop="articleSection">Game Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions"
				title="Game predictions and player projections: Week 1" itemprop="url">
				Game predictions and player projections: Week 1			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/19/gameday-inactives-injuries-and-weather-week-2-2/"
						title="Gameday inactives, injuries and weather: Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/09/USATSI_16747807.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/USATSI_16747807.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Gameday inactives, injuries and weather: Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/19/gameday-inactives-injuries-and-weather-week-2-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/19/gameday-inactives-injuries-and-weather-week-2-2/"
			title="Gameday inactives, injuries and weather: Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>16</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-inactives/" class="category" itemprop="articleSection">Fantasy football player inactives</a>						<span class="block__time block__time--mobile">6hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/19/gameday-inactives-injuries-and-weather-week-2-2/"
						title="Gameday inactives, injuries and weather: Week 2"
						itemprop="url" 						>
							Gameday inactives, injuries and weather: Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 19, 2021 6:57 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Week 2&#8217;s weather, injury updates and gameday inactives. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/18/fantasy-football-prop-bet-payday-week-2/"
						title="NFL Player Prop Bet Payday: Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14929325.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14929325.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NFL Player Prop Bet Payday: Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/18/fantasy-football-prop-bet-payday-week-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/18/fantasy-football-prop-bet-payday-week-2/"
			title="NFL Player Prop Bet Payday: Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-betting-odds-and-lines/" class="category" itemprop="articleSection">NFL Betting Odds and Lines</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/18/fantasy-football-prop-bet-payday-week-2/"
						title="NFL Player Prop Bet Payday: Week 2"
						itemprop="url" 						>
							NFL Player Prop Bet Payday: Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 18, 2021 11:45 am ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cletis-cutts/" title="Posts by Cletis Cutts" class="author url fn" rel="author">Cletis Cutts</a>													</span>
					</p>
				</footer>

				<p>These Week 2 player prop bets are money in the bank!  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/fantasy-football-injury-report-week-2/"
						title="Fantasy football injury report: Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/09/USATSI_15326090.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/USATSI_15326090.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football injury report: Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/17/fantasy-football-injury-report-week-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/17/fantasy-football-injury-report-week-2/"
			title="Fantasy football injury report: Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>19</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-injury-analysis/" class="category" itemprop="articleSection">Fantasy Football Injury Analysis</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/fantasy-football-injury-report-week-2/"
						title="Fantasy football injury report: Week 2"
						itemprop="url" 						>
							Fantasy football injury report: Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 17, 2021 8:08 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/rydodson/" title="Posts by Ryan Dodson" class="author url fn" rel="author">Ryan Dodson</a>													</span>
					</p>
				</footer>

				<p>Latest status of fantasy football weapons who are on the mend entering Week 2.  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/vegas-odds-chart-for-daily-fantasy-football-play-week-2-2/"
						title="Vegas odds chart for daily fantasy football play: Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14956586.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14956586.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Vegas odds chart for daily fantasy football play: Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/17/vegas-odds-chart-for-daily-fantasy-football-play-week-2-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/17/vegas-odds-chart-for-daily-fantasy-football-play-week-2-2/"
			title="Vegas odds chart for daily fantasy football play: Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>2</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/dfs-daily-fantasy-football-picks-strategy-tips/" class="category" itemprop="articleSection">DFS - Daily Fantasy Football player picks and tips</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/vegas-odds-chart-for-daily-fantasy-football-play-week-2-2/"
						title="Vegas odds chart for daily fantasy football play: Week 2"
						itemprop="url" 						>
							Vegas odds chart for daily fantasy football play: Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 17, 2021 11:34 am ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>A snapshot look at the NFL betting lines and odds for Week 2 sports betting and DFS action. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/six-points-with-david-dorey-19/"
						title="Six points with David Dorey"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/09/46c7fb23-1e71-464c-8312-05e7c8aeeacd-_elijah-mitchell.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/46c7fb23-1e71-464c-8312-05e7c8aeeacd-_elijah-mitchell.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Six points with David Dorey" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/17/six-points-with-david-dorey-19/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/17/six-points-with-david-dorey-19/"
			title="Six points with David Dorey"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>9</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/" class="category" itemprop="articleSection">Fantasy football player analysis tips and advice</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/six-points-with-david-dorey-19/"
						title="Six points with David Dorey"
						itemprop="url" 						>
							Six points with David Dorey					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 17, 2021 3:39 am ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Friday&#8217;s quick look at six fantasy items to know </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/dfs-fantasy-football-favorite-pro-plays-week-2/"
						title="DFS Fantasy Football: Favorite Pro Plays - Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/09/USATSI_16741424.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/USATSI_16741424.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="DFS Fantasy Football: Favorite Pro Plays - Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/17/dfs-fantasy-football-favorite-pro-plays-week-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/17/dfs-fantasy-football-favorite-pro-plays-week-2/"
			title="DFS Fantasy Football: Favorite Pro Plays - Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>20</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/dfs-daily-fantasy-football-picks-strategy-tips/" class="category" itemprop="articleSection">DFS - Daily Fantasy Football player picks and tips</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/dfs-fantasy-football-favorite-pro-plays-week-2/"
						title="DFS Fantasy Football: Favorite Pro Plays - Week 2"
						itemprop="url" 						>
							DFS Fantasy Football: Favorite Pro Plays - Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 17, 2021 1:30 am ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/windailysports/" title="Posts by Jason Mezrahi, WinDailySports.com" class="author url fn" rel="author">Jason Mezrahi, WinDailySports.com</a>													</span>
					</p>
				</footer>

				<p>WinDailySports&#8217; CEO Jason Mezrahi checks in with his top Week 2 DFS fantasy football for FanDuel and DraftKings  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/fantasy-football-dfs-domination-week-2-2/"
						title="Fantasy Football DFS Domination: Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/07/usatsi_13214673.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/07/usatsi_13214673.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy Football DFS Domination: Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/17/fantasy-football-dfs-domination-week-2-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/17/fantasy-football-dfs-domination-week-2-2/"
			title="Fantasy Football DFS Domination: Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>32</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/dfs-daily-fantasy-football-picks-strategy-tips/" class="category" itemprop="articleSection">DFS - Daily Fantasy Football player picks and tips</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
					<span class="icon--key category--members"></span>					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/17/fantasy-football-dfs-domination-week-2-2/"
						title="Fantasy Football DFS Domination: Week 2"
						itemprop="url" 						>
							Fantasy Football DFS Domination: Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 17, 2021 1:29 am ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/newclearharley/" title="Posts by Harley Schultz" class="author url fn" rel="author">Harley Schultz</a>													</span>
					</p>
				</footer>

				<p>Breaking down the top players and sleepers for DraftKings and FanDuel for Week 2 DFS fantasy football </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/16/the-best-fantasy-football-gamble-of-week-2/"
						title="The best fantasy football gamble of Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/09/USATSI_16141706.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/09/USATSI_16141706.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="The best fantasy football gamble of Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/16/the-best-fantasy-football-gamble-of-week-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/16/the-best-fantasy-football-gamble-of-week-2/"
			title="The best fantasy football gamble of Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>101</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/dfs-daily-fantasy-football-picks-strategy-tips/" class="category" itemprop="articleSection">DFS - Daily Fantasy Football player picks and tips</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/16/the-best-fantasy-football-gamble-of-week-2/"
						title="The best fantasy football gamble of Week 2"
						itemprop="url" 						>
							The best fantasy football gamble of Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 16, 2021 6:52 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Can you smellellell what this Charger is Cookin&#8217;? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/16/nfl-picks-office-pool-pickem-week-2-2/"
						title="NFL Picks: Office pool pick&#039;em - Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14955439.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14955439.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NFL Picks: Office pool pick&#039;em - Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/16/nfl-picks-office-pool-pickem-week-2-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/16/nfl-picks-office-pool-pickem-week-2-2/"
			title="NFL Picks: Office pool pick&#039;em - Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>37</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-betting-odds-and-lines/" class="category" itemprop="articleSection">NFL Betting Odds and Lines</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/16/nfl-picks-office-pool-pickem-week-2-2/"
						title="NFL Picks: Office pool pick&#039;em - Week 2"
						itemprop="url" 						>
							NFL Picks: Office pool pick&#039;em - Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 16, 2021 2:57 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/huddle-staff/" title="Posts by Huddle Staff" class="author url fn" rel="author">Huddle Staff</a>													</span>
					</p>
				</footer>

				<p>Check out our staff&#8217;s weekly pick&#8217;em against the spread and straight up. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/16/betting-the-nfl-line-week-2-2/"
						title="Betting the NFL Line: Week 2"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2019/08/13214099-e1566872599983.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2019/08/13214099-e1566872599983.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Betting the NFL Line: Week 2" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2021/09/16/betting-the-nfl-line-week-2-2/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2021/09/16/betting-the-nfl-line-week-2-2/"
			title="Betting the NFL Line: Week 2"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-betting-odds-and-lines/" class="category" itemprop="articleSection">NFL Betting Odds and Lines</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2021/09/16/betting-the-nfl-line-week-2-2/"
						title="Betting the NFL Line: Week 2"
						itemprop="url" 						>
							Betting the NFL Line: Week 2					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 16, 2021 1:01 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cletis-cutts/" title="Posts by Cletis Cutts" class="author url fn" rel="author">Cletis Cutts</a>													</span>
					</p>
				</footer>

				<p>Don&#8217;t just be lucky. Make smarter betting decisions for Week 2. </p>

				
				
			</div>
		</article>
	</div>
<a href="https://thehuddle.com" class="article__back">More Huddle</a>

					</div>

	</div><!-- #content -->
</div><!-- #primary -->

<div class="noskim">
	
<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget widget--login widget--box" id="login_widget-3">
<div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget_text widget widget_custom_html" id="custom_html-3"><div class="heading-small"><h2>DraftLab</h2></div><div class="textwidget custom-html-widget"><a target="_blank" href="https://rotolab.com/ordering.htm" rel="noopener"><img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/08/banner-draftlab-300x200_UPDATED.png" alt="RotoLab" border="0"/></a></div></div><div class="widget widget--forum widget--box" id="forum_widget-4">
<div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-424381"><a href="https://tools.thehuddle.com/season">Season-to-Date Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Stats Matchups</a></li>
<li id="menu-item-453426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453426"><a href="https://thehuddle.com/2021/05/12/2021-nfl-schedule-team-by-week-grid/">Schedule: Team-by Week Grid</a></li>
<li id="menu-item-453427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453427"><a href="https://thehuddle.com/2021/05/12/2021-nfl-schedule-weekly-matchups/">Schedule: Weekly Grid</a></li>
<li id="menu-item-453428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453428"><a href="https://thehuddle.com/2021/05/12/2021-nfl-schedule-release-bye-weeks/">Schedule: Bye Weeks</a></li>
</ul><a href="https://thehuddle.com/fantasy-football-statistics/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><a href="http://www.thehuddle.com/podcast/"><img width="1000" height="1000" src="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg 1000w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=150,150 150w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=300,300 300w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=768,768 768w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=600,600 600w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=100,100 100w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=340,340 340w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=32,32 32w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=50,50 50w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=64,64 64w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=96,96 96w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=128,128 128w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></div><div class="widget widget--links widget--box" id="links_widget-8">
<div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="https://tools.thehuddle.com/nfl-depth-charts">2021 fantasy depth charts</a></li>
<li id="menu-item-457177" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457177"><a href="https://thehuddle.com/2021/02/26/2021-nfl-coaching-change-tracker/">2021 NFL coaching change tracker</a></li>
<li id="menu-item-457194" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457194"><a href="https://thehuddle.com/2021/05/01/fantasy-football-2021-player-movement-tracker/">2021 fantasy football player movement tracker</a></li>
<li id="menu-item-457195" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457195"><a href="https://thehuddle.com/2021/04/30/2021-nfl-top-free-agent-tracker/">2021 NFL top free-agent tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7">
<div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="https://tools.thehuddle.com/nfl-depth-charts">2021 fantasy depth charts</a></li>
<li id="menu-item-457196" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457196"><a href="https://thehuddle.com/2021/04/30/2021-nfl-top-free-agent-tracker/">2021 NFL top free-agent tracker</a></li>
<li id="menu-item-457572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457572"><a href="https://thehuddle.com/2021-nfl-draft-central/">2021 NFL Draft Central</a></li>
<li id="menu-item-458421" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-458421"><a href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-team/">2021 NFL Draft results: by team</a></li>
<li id="menu-item-458422" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-458422"><a href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-round/">2021 NFL Draft results: by round</a></li>
<li id="menu-item-458423" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-458423"><a href="https://thehuddle.com/2021/05/02/2021-nfl-draft-results-by-position/">2021 NFL Draft results: by position</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-3">
<div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="https://www.usatoday.com/sports/" rel="nofollow" target="_blank">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/logo-usat-footer-1.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448091"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			Show More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "Show More Information";
		var footer_collapse_text = "Show Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
</div>

			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div class="noskim">
		<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
		<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/icon-huddle.png" alt="Fantasy football rankings, sleepers, news and award-winning advice &#8211; TheHuddle.com">
				<a class="mobile-nav__breadcrumb" href="https://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--myhuddle mobile-nav__item--parent"><a href="https://tools.thehuddle.com/myhuddle/custom">myHuddle</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--custom-leagues"><a href="https://tools.thehuddle.com/myhuddle/custom">Custom Leagues</a></li>
	<li class="mobile-nav__item mobile-nav__item--player-tracking"><a href="https://tools.thehuddle.com/myhuddle/player-tracking">Player Tracking</a></li>
	<li class="mobile-nav__item mobile-nav__item--account-information"><a href="https://tools.thehuddle.com/myhuddle/account-information">Account Information</a></li>
	<li class="mobile-nav__item mobile-nav__item--subscription-status"><a href="https://tools.thehuddle.com/myhuddle/subscription-status">Subscription Status</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--draft-guide mobile-nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2021-fantasy-football-draft-guide/">Draft Guide</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets?year=2021&#038;week=0">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-projections"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections?year=2021&#038;week=0">Fantasy football projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-standard">Top 200 Overall</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-ppr">Top 200 PPR</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li class="mobile-nav__item mobile-nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--inseason mobile-nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">Inseason</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy Football Player Rankings / Projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Fantasy Football Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--dfs-daily-fantasy-football"><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/">DFS - Daily Fantasy Football</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfl-game-predictions-and-picks"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">NFL Game Predictions and Picks</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Fantasy Football Start/Bench Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--news mobile-nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li class="mobile-nav__item mobile-nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--stats mobile-nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li class="mobile-nav__item mobile-nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--teams mobile-nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--afc-east"><a href="#">AFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-north"><a href="#">AFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li class="mobile-nav__item mobile-nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li class="mobile-nav__item mobile-nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-south"><a href="#">AFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li class="mobile-nav__item mobile-nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li class="mobile-nav__item mobile-nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li class="mobile-nav__item mobile-nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-west"><a href="#">AFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li class="mobile-nav__item mobile-nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li class="mobile-nav__item mobile-nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-ft"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-football-team">Washington FT</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li class="mobile-nav__item mobile-nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li class="mobile-nav__item mobile-nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li class="mobile-nav__item mobile-nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--fantasy-football-nfl-depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Fantasy Football NFL Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-draft-central"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2021-nfl-draft-central/">NFL Draft Central</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li class="mobile-nav__item mobile-nav__item--place-bet-at-betmgm"><a title="Place NFL bets" target="_blank" rel="noopener" href="https://gtly.to/Y-kogGCCv">Place bet at BetMGM</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="https://www.usatoday.com/sports/"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/usat-logo-mobile-off-canvas-1.png">
		</a>
	</div>

<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="https://tools.thehuddle.com/login" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??/wp-includes/css/dashicons.min.css,/wp-includes/js/thickbox/thickbox.css?m=1631638942' type='text/css' media='all' />
<script id='lawrence-ga-create-js-after'>
ga('create', 'UA-166840762-5', {'name' : 'FishburneGATracker'});
</script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1' id='sharethrough-native-responsive-js'></script>
<script id='usatoday-sticky-inline-videos-script-js-extra'>
var stickyInlineVideosOptions = {"side":"right","hide":"Hide video"};
</script>
<script id='lawrence-ads-js-js-extra'>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"60","refresh_type":"all","distance":"2000","active":"0"}};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJydj9EOwjAIRX/I2qhRn4yfYrDFyWzpbOlm/97NZGYxPjjDE5fL4aK7RpnAgixarugx6ZxAgoWiHHQR2aD2wWbXT8CqZCI1knSddAMRfMgsyzot9P8cBqEWT1WElqScLg4f84kMrgiZNAWPLiUIjrKfTfXEWVB5tAQDcNqr98lPbONyRTzhjkLq3beiiB0xqpYshlfOb/rPWYc/6azre8ZYliaEG+GcZQ/Ec/xgh2xHf1jtNqt9X9t1/QRThtzl'></script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0' id='lawrence-confiant-js-js'></script>
<script id='wasabi-article-js-extra'>
var wasabiFacebookReferral = "0";
</script>
<script id='wasabi-main-js-extra'>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"1440\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script id='huddle-user-nav-js-extra'>
var huddleUser = {"name":"Huddle User","cookie":"session","logoutAPI":"https:\/\/api.thehuddle.com\/User\/Logout"};
</script>
<script id='huddle-login-debug-js-extra'>
var huddleLoginDebugData = {"is_member":"","user_data":[]};
</script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/thehuddle.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://thehuddle.com/_static/??-eJytkd0OgjAMhV/IuaBRr4zP0m0NFPdDWCfg0zsuUEm8AGJ20531O11OZdcIHTyjZ9nYVJKPMkXgYGAQk2DhOQgbwAjsc6dBI+svde/I7+u4k//wWurTQQRFI5uYbNzAeXhQCUxh+ec/cCSDCtoNJLRM2uIG0sGKnLlCUSVjLI4oLZ83B1PEVuSkJpy8tslgHN/yFZ3Cdfuf29uQRZGjTOWvCVyRvqvQv4vcdHPX4nwsLvmcDvULEAQJ3A=='></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin' id='sop-script-js'></script>
<script type='text/javascript' src='https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/ats_smg.js?m=1631717152g'></script>
<script src='https://stats.wp.com/e-202138.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.1',blog:'175784887',post:'460455',tz:'-4',srv:'thehuddle.com'} ]);
	_stq.push([ 'clickTrackerInit', '175784887', '460455' ]);
</script>
	</div>
</body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
