<!DOCTYPE html>
<!--[if IE 8]> <html lang="en-US" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en-US" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>
	
	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thehuddle.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://thehuddle.com/wp-content/themes/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="NFL free agency will drastically help reshape the fantasy football landscape as the new league year begins." />
<meta name="keywords" content="nfl free agents and fantasy football impact, 2022 fantasy football, 2022 nfl free agency, 2022 nfl free agents, fantasy football, free agency, nfl free agency, nfl free agents" />
<title>Fantasy football: 2022 NFL free agency roundup</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Fyyk73gmBrqBAqTmXbDKv_XLUqfou40EFimkQMXNZqc" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//ads.rubiconproject.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Feed" href="https://thehuddle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Huddle &raquo; Comments Feed" href="https://thehuddle.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thehuddle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.4"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??-eJydUdFOwzAM/CGyUDSB+oB45Q94nLzE6rwlaRS7Hfl70nabOq1ChUefc5e7sz5HZdogGERH1zUUWHcM0lrI6gHgA6SYIJy04SV4U+An/SfJhJ6+7b3ehN3EKBjXWeTxkSUWvXetOSlH+wQpa5bscOMpPDKOrD1aAnToBz/zITrImJTDBkxeRy+7+XxHukb23S0kIyRz0OiAhUxMePU/BEkFFrQqtiyspkRjEl6UlUP5ctaRg3PCYFD71naFpMEqNomiTD0FEOpx1yToSfL6wwxOT7lU4Cig6sliOwkuLda7vCy+gGFP/6Tpz87aculfGj+iRChFVs+banR9AQbOh3+vXrdvL3VVb+sfruogqw==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script id='amazon-adsystem-js-extra'>
var amznAcctId = ["3090"];
</script>
<script id='amazon-adsystem-js-before'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId[0], adServer: "googletag"});
</script>
<script src='https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/bidder-manager.js?ver=5.8.4' id='amazon-adsystem-js'></script>
<script src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=5.8.4' id='sonobi-adsystem-js'></script>
<script src='//ads.rubiconproject.com/prebid/10968_USAToday_Sports.js?ver=5.8.4' id='lawrence_magnite_header_bidder_script-js'></script>
<script async src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.8.4' id='lawrence-ads-ias-js'></script>
<script id='lawrence-ads-ias-js-after'>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script type="text/javascript" src="https://thehuddle.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZibmBsaWxsUkWAK94IiA=" ></script><script id='lawrence-tealium-js-extra'>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","content-market-name":"thehuddle","page-has-video":"no","page-has-gallery":"0","page-canonical-url":"https:\/\/thehuddle.com\/2022\/03\/14\/fantasy-football-2022-nfl-free-agency-roundup\/","content-ssts-section":"sports","content-ssts-subsection":"sports:thehuddle","content-ssts-topic":"sports:thehuddle","content-ssts-subtopic":"sports:thehuddle","page-experience-type":"desktop","content-type":"story pages","content-id":"464257","content-headline":"Fantasy football: 2022 NFL free agency roundup","content-date-published":"2022-03-14T19:58:16Z","content-byline":"Cory Bonini","content-contributor-names":"Cory Bonini","content-article-length":"2104","content-keywords":"2022 fantasy football,2022 NFL free agency,2022 NFL free agents,Fantasy Football,free agency,NFL free agency,nfl free agents","content-title":"Fantasy football: 2022 NFL free agency roundup |  | "};
</script>
<script id='lawrence-tealium-js-before'>
			window.gciAnalyticsUAID = "SMG-TEALIUM-THEHUDDLE";
			gciDataLayer["page-full-url"]    = window.location.href;
			gciDataLayer["content-name"]     = window.location.pathname;
			gciDataLayer["page-referer"]     = document.referrer;
			gciDataLayer["page-has-gallery"] = Boolean(parseInt(gciDataLayer["page-has-gallery"], 10));
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1' id='lawrence-tealium-js'></script>
<script id='lawrence-tealium-js-after'>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0' id='lawrence-confiant-js'></script>
<script id='usatoday-gallery-js-extra'>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-166840762-5","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-166840762-5","dfpid":"","pid":"SMG_TheHuddle","ads":{"poster":"\/7103\/SMG_TheHuddle\/300x250_1g\/sports\/fantasy\/football.general","tablet":"\/7103\/SMG_TheHuddle\/728x90_1gt\/sports\/fantasy\/football.general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/thehuddle3\/prod\/utag.js"};
</script>
<script type="text/javascript" src="https://thehuddle.com/_static/??-eJylkOEOgjAMhF/IsUCIhh/GZ5mjYMc25rqJvL0jAUI0MRL/tXf9Ls3xwTHZ2wA2cKdji5Z4JBH6WoxsEYRD1gqtwSOkjQgCcUU8gNAYzeyNmaID/ycvUu2SPiSLPfKs+DlwFdDjnLQR3mPCDQxsbrQYPFgJE0gdOqbRdqzpZSTW4HMPru5xKsIItHswjdcFpYCy+6jy68tY+5VOc2Iv5pwfy1NR5VVZqRdPprbm" ></script><script src='//s3.amazonaws.com/smg-gdpr/geo-check-1.js?ver=5.8.4' id='the-huddle-eu-redirect-1-js'></script>
<script src='//s3.amazonaws.com/smg-gdpr/geo-check-2.js?ver=5.8.4' id='the-huddle-eu-redirect-2-js'></script>
<link rel="https://api.w.org/" href="https://thehuddle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thehuddle.com/wp-json/wp/v2/posts/464257" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thehuddle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thehuddle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://thehuddle.com/?p=464257' />
<link rel="alternate" type="application/json+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2022%2F03%2F14%2Ffantasy-football-2022-nfl-free-agency-roundup%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thehuddle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthehuddle.com%2F2022%2F03%2F14%2Ffantasy-football-2022-nfl-free-agency-roundup%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle",
		"mainEntityOfPage": {
			"@type": "WebPage",
			"@id": "https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		},
		"url": "https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/",
		"headline": "Fantasy football: 2022 NFL free agency roundup",
		"thumbnailUrl": "https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17553771.jpg?w=192&#038;h=150&#038;crop=1",
		"image": "https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17553771.jpg?w=192&#038;h=150&#038;crop=1",
		"datePublished": "2022-03-14T19:58:16Z",
		"dateModified": "2022-03-14T20:00:51Z",
		"articleSection": "NFL free agents and fantasy football impact",
		"creator": ["Cory Bonini"],
		"author": {
			"@type": "Person",
			"name": "Cory Bonini"
		},
		"keywords": ["2022 fantasy football","2022 NFL free agency","2022 NFL free agents","Fantasy Football","free agency","NFL free agency","nfl free agents"],
	"publisher": {
		"@type": "Organization",
		"name": "The Huddle",
		"logo": {
			"@type": "ImageObject",
			"url": "https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
		}
	}
}
</script>
<style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.parsely__post_meta .parsely__post_section {
	color: #dd9933;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #dd9933;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #dd9933;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #dd9933;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #dd9933;
}

.newsletter-modal {
	border-top: solid 8px #dd9933;
}

.article__back {
	border-color: #dd9933;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.listicle__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #dd9933;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#dd9933, #dd9933)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #dd9933;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #dd9933;
	}
}

.smg-event__ctabutton {
	background-color: #dd9933;
	box-shadow: 0 2px 0 0 #dd9933;
}
</style>
<style type="text/css">
.category--members,
.login__heading,
.stack__link:hover,
.article__login.article__login p > a,
.article__login .login__header,
.links__menu .menu-item a:hover,
.zone__link:hover .zone__title,
.forum__menu .menu-item a:hover,
.forum__view-all:hover,
.parsely .posts-parsely .post .post__title a:hover {
	color: #dd9933;
}

.article__login {
	border-top-color: #dd9933;
}

.login__button {
	background-color: #dd9933;
}

.header-box h2 {
	border-bottom-color: #dd9933;
}

</style>
<link rel="canonical" href="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/" />

<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.addBidder( 'magnite' );
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video', 'ignoreRefresh' : true } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Fantasy football: 2022 NFL free agency roundup" />
<meta property="og:url" content="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/" />
<meta property="og:description" content="NFL free agency will drastically help reshape the fantasy football landscape as the new league year begins." />
<meta property="article:published_time" content="2022-03-14T23:58:16+00:00" />
<meta property="article:modified_time" content="2022-03-15T00:00:51+00:00" />
<meta property="og:site_name" content="The Huddle" />
<meta property="og:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17553771.jpg?w=1024&#038;h=576&#038;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Fantasy football: 2022 NFL free agency roundup" />
<meta name="twitter:image" content="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17553771.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/thehuddle" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=180" />
<meta name="msapplication-TileImage" content="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/cropped-icon-huddle2-1.png?w=270" />

	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-464257 single-format-standard theme-lawrence">

	<div class="noskim">
		
		<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
			</div>

	<div id="wrapper">

		<div class="noskim">
			
			<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>
		</div>

		<div class="wrapper-holder">

			<div class="noskim">
				
<div id="header-wrapper">
<div
	class="branding branding--section"
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://thehuddle.com"
				title="The Huddle"
				class="branding__logo-link "
			>
				<img
					src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"
					alt="The Huddle"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

		<span class="header__sponsor">
					<div id='acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo'); });</script></div>				</span>
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://thehuddle.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Huddle" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="https://www.usatoday.com/sports/" target="_blank" title="USA TODAY Sports">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/03/USATODAY_Sports_Log.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-458721" class="nav__item nav__item--myhuddle nav__item--parent"><a href="https://tools.thehuddle.com/myhuddle/custom">myHuddle</a>
<ul class="sub-menu">
	<li id="menu-item-458722" class="nav__item nav__item--custom-leagues"><a href="https://tools.thehuddle.com/myhuddle/custom">Custom Leagues</a></li>
	<li id="menu-item-458723" class="nav__item nav__item--player-tracking"><a href="https://tools.thehuddle.com/myhuddle/player-tracking">Player Tracking</a></li>
	<li id="menu-item-458724" class="nav__item nav__item--account-information"><a href="https://tools.thehuddle.com/myhuddle/account-information">Account Information</a></li>
	<li id="menu-item-458725" class="nav__item nav__item--subscription-status"><a href="https://tools.thehuddle.com/myhuddle/subscription-status">Subscription Status</a></li>
</ul>
</li>
<li id="menu-item-450451" class="nav__item nav__item--draft-guide nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2021-fantasy-football-draft-guide/">Draft Guide</a>
<ul class="sub-menu">
	<li id="menu-item-442874" class="nav__item nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets">Cheat Sheets</a></li>
	<li id="menu-item-442875" class="nav__item nav__item--fantasy-football-projections"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy football projections</a></li>
	<li id="menu-item-442876" class="nav__item nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-standard">Top 200 Overall</a></li>
	<li id="menu-item-442877" class="nav__item nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-ppr">Top 200 PPR</a></li>
	<li id="menu-item-442878" class="nav__item nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li id="menu-item-442879" class="nav__item nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442880" class="nav__item nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li id="menu-item-442881" class="nav__item nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li id="menu-item-442847" class="nav__item nav__item--inseason nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">Inseason</a>
<ul class="sub-menu">
	<li id="menu-item-442896" class="nav__item nav__item--fantasy-football-player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy Football Player Rankings / Projections</a></li>
	<li id="menu-item-442897" class="nav__item nav__item--fantasy-football-cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Fantasy Football Cheat Sheets</a></li>
	<li id="menu-item-442848" class="nav__item nav__item--dfs-daily-fantasy-football"><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/">DFS - Daily Fantasy Football</a></li>
	<li id="menu-item-442894" class="nav__item nav__item--nfl-game-predictions-and-picks"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">NFL Game Predictions and Picks</a></li>
	<li id="menu-item-442895" class="nav__item nav__item--fantasy-football-start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Fantasy Football Start/Bench Tool</a></li>
	<li id="menu-item-442898" class="nav__item nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li id="menu-item-442849" class="nav__item nav__item--news nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li id="menu-item-450179" class="nav__item nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li id="menu-item-450180" class="nav__item nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li id="menu-item-450181" class="nav__item nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li id="menu-item-450182" class="nav__item nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li id="menu-item-450183" class="nav__item nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li id="menu-item-442850" class="nav__item nav__item--stats nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li id="menu-item-442899" class="nav__item nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li id="menu-item-442900" class="nav__item nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li id="menu-item-442901" class="nav__item nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li id="menu-item-442902" class="nav__item nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li id="menu-item-442903" class="nav__item nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li id="menu-item-442904" class="nav__item nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li id="menu-item-442906" class="nav__item nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li id="menu-item-442851" class="nav__item nav__item--teams nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li id="menu-item-442917" class="nav__item nav__item--afc-east"><a href="#">AFC East</a></li>
	<li id="menu-item-442918" class="nav__item nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li id="menu-item-442919" class="nav__item nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li id="menu-item-442920" class="nav__item nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li id="menu-item-442921" class="nav__item nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li id="menu-item-442922" class="nav__item nav__item--afc-north"><a href="#">AFC North</a></li>
	<li id="menu-item-442923" class="nav__item nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li id="menu-item-442924" class="nav__item nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li id="menu-item-442925" class="nav__item nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li id="menu-item-442926" class="nav__item nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li id="menu-item-442927" class="nav__item nav__item--afc-south"><a href="#">AFC South</a></li>
	<li id="menu-item-442928" class="nav__item nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li id="menu-item-442929" class="nav__item nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li id="menu-item-442930" class="nav__item nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li id="menu-item-442931" class="nav__item nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li id="menu-item-442932" class="nav__item nav__item--afc-west"><a href="#">AFC West</a></li>
	<li id="menu-item-442933" class="nav__item nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li id="menu-item-442934" class="nav__item nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li id="menu-item-442936" class="nav__item nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li id="menu-item-442935" class="nav__item nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li id="menu-item-442937" class="nav__item nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li id="menu-item-442938" class="nav__item nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li id="menu-item-442939" class="nav__item nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li id="menu-item-442940" class="nav__item nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li id="menu-item-442941" class="nav__item nav__item--washington-commanders"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-commanders">Washington Commanders</a></li>
	<li id="menu-item-442942" class="nav__item nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li id="menu-item-442943" class="nav__item nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li id="menu-item-442944" class="nav__item nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li id="menu-item-442945" class="nav__item nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li id="menu-item-442946" class="nav__item nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li id="menu-item-442947" class="nav__item nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li id="menu-item-442948" class="nav__item nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li id="menu-item-442949" class="nav__item nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li id="menu-item-442950" class="nav__item nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li id="menu-item-442951" class="nav__item nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li id="menu-item-442952" class="nav__item nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li id="menu-item-442953" class="nav__item nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li id="menu-item-442954" class="nav__item nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li id="menu-item-442955" class="nav__item nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li id="menu-item-442956" class="nav__item nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li id="menu-item-442852" class="nav__item nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li id="menu-item-442911" class="nav__item nav__item--fantasy-football-nfl-depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Fantasy Football NFL Depth Charts</a></li>
<li id="menu-item-442854" class="nav__item nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li id="menu-item-442914" class="nav__item nav__item--nfl-draft-central"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2022-nfl-draft-central/">NFL Draft Central</a></li>
<li id="menu-item-450426" class="nav__item nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li id="menu-item-442855" class="nav__item nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
<li id="menu-item-462603" class="nav__item nav__item--buy-tickets"><a href="https://www.ticketsmarter.com/?utm_source=thehuddle.com&#038;utm_medium=mainnavlink&#038;utm_campaign=gannett">Buy Tickets</a></li>
		</ul>
		<ul class="nav__social nav__social--section">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/thehuddle" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/TheHuddle" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>
</div>

				
							</div>

			<div id="main" class="site-main no-more-heroes">

				<div class="noskim">
									</div>

<div class="noskim">
	</div>

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		<div class="noskim">
					</div>

		
			<article id="post-464257" class="post-464257 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl-free-agents tag-2022-fantasy-football tag-2022-nfl-free-agency tag-2022-nfl-free-agents tag-fantasy-football tag-free-agency tag-nfl-free-agency tag-nfl-free-agents" itemscope
				itemtype="http://schema.org/NewsArticle">

				<div class="noskim">
					<link itemprop="mainEntityofPage" href="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png"/>
		<meta itemprop="url" content="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/logo-huddle-header.png">
	</div>
	<meta itemprop="name" content="The Huddle">
</div>
<div class="article__title ">

	
	<h1 class="article__headline">Fantasy football: 2022 NFL free agency roundup</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
			<img width="1000" height="600" src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17553771.jpg?w=100&amp;h=600&amp;crop=1&amp;h=60" class="article__image wp-post-image lazy-load" alt loading="lazy" data-lazy-src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17553771.jpg?w=1000&amp;h=600&amp;crop=1"><noscript><img width="1000" height="600" src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17553771.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" loading="lazy" /></noscript>			<meta itemprop="url" content="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17553771.jpg">
		</span>
		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Fantasy football: 2022 NFL free agency roundup</h1>

					<header class="entry-header  ">

						
<h2 class="">
	<a href="https://thehuddle.com/category/nfl-free-agents/" class="" itemprop="articleSection">NFL free agents and fantasy football impact</a></h2>

						
						<div id="headline">
							<h1 class="entry-title" itemprop="name headline">Fantasy football: 2022 NFL free agency roundup</h1>
													</div>

						
						
						<div class="meta-info single-headline" id="entry-byline">
							
<p>

	By <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a></span></span> 
		<span class="post-date updated">March 14, 2022 7:58 pm</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
					Follow					@Cory_Bonini				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
						</div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo'); });</script></div>
					</header>

					
									</div>

				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						<div class="noskim">
							
							<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">23</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

							
							<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a></span></span> | 
				<span class="article__author__date" itemprop="datePublished" content="2022-03-14T19:58:16-04:00">
			March 14, 2022 7:58 pm ET		</span>
		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/Cory_Bonini" class="twitter-follow-button" data-show-count="false">
		Follow @Cory_Bonini	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


													</div>

						<div class="articleBody" itemprop="articleBody"><p>Now that NFL free agency is upon us, we&#8217;ll run through the fantasy football outlooks for trades, re-signings, midrange players, and tag recipients.</p>
<p>This analysis will be updated as players sign/re-sign in free agency, so be sure to check back regularly.</p>
<h2>Signed with new team or traded</h2>
<ul>
<li><strong><a href="https://thehuddle.com/2022/03/08/fantasy-football-fallout-russell-wilson-traded-to-broncos/">QB Russell Wilson, Denver Broncos</a></strong></li>
<li><a href="https://thehuddle.com/2022/03/12/browns-acquire-amari-cooper-from-cowboys/"><strong>WR Amari Cooper, Cleveland Browns</strong></a></li>
<li><strong><a href="https://thehuddle.com/2022/03/09/fantasy-football-reaction-washington-acquires-carson-wentz-from-colts/">QB Carson Wentz, Washington Commanders</a></strong></li>
</ul>
<p><strong>WR Christian Kirk, Jacksonville Jaguars</strong>: Arizona&#8217;s leading receiver in 2021, thanks to a DeAndre Hopkins injury, will head to Duval County to catch passes from Trevor Lawrence. The fifth-year wideout is a capable deep threat and should step right in to fill the role vacated by DJ Chark Jr. hitting free agency. The Jaguars have a proven head coach in Doug Pederson to get the most out of Lawrence, and adding pieces around the franchise QB likely isn&#8217;t finished with the Kirk signing. There&#8217;s risk here, and Kirk has been inconsistent in his career, but we have erratic WR2 production within reach at what will be a reasonable price tag.</p>
<p><strong>QB Mitchell Trubisky, Pittsburgh Steelers</strong>: The former No. 2 overall pick fizzled out playing for an overmatched Chicago Bears coaching staff and spent a year backing up Josh Allen in Buffalo. Trubisky was given a two-year deal from the Steelers and has weapons around him to reestablish himself as a viable fantasy quarterback. He isn&#8217;t a lock to start, though that is the presumption in a year of weak rookie QBs, a feeble free-agent class, and shaky depth on the Pittsburgh roster. The structure of the Steelers as an organization should provide Trubisky all of the tools to succeed, and gamers are doing themselves a disservice by writing him off. Healthy skepticism is warranted. Outright dismissal is foolish.</p>
<p><strong>RB Chase Edmonds, Miami Dolphins</strong>: The Dolphins will feature a zone-blocking system under new head coach Mike McDaniel, and Edmonds&#8217; versatility will come in handy for those in PPR scoring. It&#8217;s unclear how much of a touch split to expect percentage-wise with Myles Gaskin, and it wouldn&#8217;t be a surprise if the Dolphins add a hammer to this backfield. Edmonds is a weak third running back in standard scoring and a safer option in reception-rewarding settings.</p>
<p><strong>TE Evan Engram, Jacksonville Jaguars</strong>: One of the most talented tight ends in the NFL is the latest player to join the Jags in free agency. The team desperately needed to put more playmakers around Trevor Lawrence, and Engram provides the young quarterback a dangerous weapon from the slot. Doug Pederson is known for his creativity, and his system has consistently produced fantasy-relevant tight ends. The only thing left is for Engram to hold up his end of the bargain and stay healthy in his age-28 season. He&#8217;s worthy of a borderline TE1 selection in deeper formats. There&#8217;s legitimate concern he won&#8217;t see enough volume for added PPR worth, and he&#8217;s never been a huge TD guy, so keep your expectations in check.</p>
<p><strong>WR Cedrick Wilson Jr., Miami Dolphins</strong>: The former Dallas Cowboy picked an opportune time to post career-best stats (45-602-6) in a 2021 contract year. In 2022, he&#8217;ll enter a West Coast offense, which will be familiar enough for a smooth transition. He takes a step backward at quarterback, the Dolphins have several capable receiving outlets in DeVante Parker, Jaylen Waddle, Mike Gesicki and a few pass-catching backs. The system will resemble that of the San Francisco 49ers, which means we could see some trickery involved to manufacture plays for the danger open-field runner. Wilson is a late-round flier who may even be a little overhyped.</p>
<p><strong>QB Teddy Bridgewater, Miami Dolphins</strong>: The well-traveled veteran enters the picture in Miami as an experienced insurance policy in the event Tua Tagovailoa falters. Even if Bridgewater ends up in the starting lineup at some point, he&#8217;s not viable outside of two-QB leagues.</p>
<p><strong>TE C.J. Uzomah, New York Jets</strong>: The former Cincinnati Bengal enjoyed a career season in 2021 and his line was still a modest 49-493-5. The three-year, $24 million deal is a hefty price tag for a 29-year-old who is best known for his blocking skills, but he provides quarterback Zach Wilson a sneaky-athletic weapon who rarely sees a double-team. In an optimistic light, Uzomah is in for another low-volume, TD-dependent campaign.</p>
<h2>Re-signed/extensions</h2>
<p><strong>QB Kirk Cousins, Minnesota Vikings</strong>: Minnesota extended Cousins a year, increasing his 2022 salary to $40 million and guaranteeing his 2023 contract for $35 mill. His return may not push the Vikes ahead of Green Bay in the NFC North, but it&#8217;s a win for fantasy football continuity from an offense that won&#8217;t see a great deal of change from 2021, despite a new regime. Cousins is a low-end QB1 who&#8217;ll once again be drafted as a backup in fantasy, presenting some value if you miss out on an elite passer.</p>
<p><strong>WR Michael Gallup, Dallas Cowboys</strong>: Gallup coming off a torn ACL suffered in Week 17 is apparently of no concern for Dallas as it traded Amari Cooper to Cleveland before agreeing to a massive extension with the Colorado State product. Gallup should be ready by November after undergoing surgery in early February, dramatically reducing his fantasy football appeal. While nine months is enough to be physically ready after knee reconstruction, trusting the knee and getting back into game shape tends to take around a year. Gallup is worth a late-round pick to stash for depth but shouldn&#8217;t be counted on as a key component in your championship plans.</p>
<p><strong>QB Aaron Rodgers, Green Bay Packers</strong>: Four years and 200 million reasons later, Rodgers&#8217; flirtation with leaving Titletown came to an end with a record-breaking extension. The Packers have to address tight end and find a way to compensate Davante Adams to his liking, but the core of this offense returns intact. There shouldn&#8217;t be much of a drop-off in fantasy production from the NFL&#8217;s back-to-back MVP.</p>
<p><strong>TE Zach Ertz, Arizona Cardinals</strong>: A midseason trade in 2021 sent Ertz from Philly to the desert, and the veteran didn&#8217;t disappoint. He stepped up in an offense that was without its starting quarterback and top receiving target for a stretch of games, and the Cards rewarded the 31-year-old with a three-year extension. Arizona should keep him involved enough to warrant low-end TE1 consideration in drafts.</p>
<blockquote class="wp-embedded-content" data-secret="t92kPVJtOx"><p><a href="https://thehuddle.com/2022/03/14/2022-fantasy-football-player-movement-tracker/">2022 fantasy football player movement tracker</a></p></blockquote>
<p><iframe class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" title="&#8220;2022 fantasy football player movement tracker&#8221; &#8212; The Huddle" src="https://thehuddle.com/2022/03/14/2022-fantasy-football-player-movement-tracker/embed/#?secret=t92kPVJtOx" data-secret="t92kPVJtOx" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
<p><strong>WR Josh Reynolds, Detroit Lions</strong>: Reynolds isn&#8217;t a needle-mover in fantasy, per se, but he has an opportunity in what will be his first full offseason with Detroit to gain some ground. The Lions are likely to add another receiver to the mix, but Reynolds will be granted every opportunity to be among the top three wideouts for the Lions. He&#8217;s a deep-league flier, largely due to his past connection with QB Jared Goff, although his max value depends upon where Detroit turns in free agency.</p>
<p><strong>WR Braxton Berrios, New York Jets</strong>: The diminuative slot receiver stepped up nicely late in the year for the Jets, and with Jamison Crowder also a free agent, the Jets chose the younger, cheaper option. Berrios&#8217; primary competitor for targets figures to be WR Elijah Moore, but less than 17 percent of the 2021 rookie&#8217;s snaps came from the inside. Berrios, on the other hand, saw 60.9 percent of his plays come from the slot where Crowder resided for 68.4 percent of his plays. There&#8217;s reasonable flex sleeper potential here in deeper PPR drafts.</p>
<p><strong>TE Ian Thomas, Carolina Panthers</strong>: Carolina secured Thomas with a contract extension, and he&#8217;ll compete with Tommy Tremble for the majority of targets at the position. There&#8217;s really no draft-worthy fantasy value here, but his utility could gain steam in DFS if Deshaun Watson is acquired. Put a pin in this one and we&#8217;ll revisit it as more is known. Thomas also faces five misdemeanor charges from a 2021 alleged incident, so a short suspension could await.</p>
<p><strong>TE Mo Alie-Cox, Indianapolis Colts</strong>: The retirement of Jack Doyle probably improved the odds of Alie-Cox returning to the roster, but the Colts likely aren&#8217;t done adding to the positional depth. Alie-Cox landed a three-year, $18 million deal &#8212; good money for his resume, but it&#8217;s not prohibitive in terms of bringing in another starting-caliber option. The position is thinning on the wire, however. At any rate, the Colts have a TE-friendly system and a 6-foot-5, former basketball player coming off a career-high four touchdown grabs in a part-time role. Alie-Cox could prove to be a sneaky flier in large fantasy leagues, presuming the Colts can figure out this quarterback situation.</p>
<p><strong>TE Will Dissly, Seattle Seahawks</strong>: There really isn&#8217;t much in the way of fantasy appeal here on the surface, but we&#8217;ve seen Dissly show off a few times in his injury-ravaged career. No quarterback in sight for the time being only further works against predicting Dissly&#8217;s worth. He&#8217;ll score a few touchdowns and frustrate gamers with inconsistency. Leave him for the occasional DFS lineup or prop bet.</p>
<h2>Franchise/transition tagged</h2>
<p><strong>WR Chris Godwin, Tampa Bay Buccaneers</strong>: The second straight franchise tagging for Godwin has the team working to reach a long-term deal with him, and that has been accelerated with the return of Tom Brady creating a massive need to free up cap space. Godwin is coming off an ACL tear and probably won&#8217;t be himself until at least the midpoint of the season, if not later, but he has WR3 appeal in PPR drafts with upside for the occasional WR1 outburst once he&#8217;s fully recovered.</p>
<p><strong>TE Dalton Schultz, Dallas Cowboys</strong>: Dallas sent Amari Cooper packing, freeing up considerable work. Some of those targets will head Schultz&#8217;s direction, and after two strong years in a row, he&#8217;s a midrange TE1 for most scoring formats. It&#8217;s unlikely the Stanford alum will take a step into the &#8220;Big 3&#8221; of TEs if Travis Kelce, Mark Andrews and Darren Waller all remain on the field, but there&#8217;s no reason a healthy Schultz cannot reprise his 2021 TE4 placement in a battle with oft-injured George Kittle.</p>
<p><strong>TE David Njoku, Cleveland Browns</strong>: Njoku&#8217;s return to the Browns is mildly surprising in relation to his lack of involvement (53 targets in 15 games last year). The Kevin Stefanski offense likes to deploy two tight ends, and the system has used Austin Hooper less as a receiver than expected when he was given a bag of cash just a few offseasons ago. Long story short, even after trading Odell Beckham last year and releasing Jarvis Landry this week, Njoku isn&#8217;t a draftable fantasy option in the vast majority of traditional leagues.</p>
<p><strong>TE Mike Gesicki, Miami Dolphins</strong>: The Penn Stater will have to wait before testing the market for the first time in his career as Miami takes one of the top tight ends off the market. He should enjoy a strong season in South Beach if quarterback Tua Tagovailoa continues to grow as a passer. The incoming West Coast offense thrives by utilizing tight ends more than most, and Mike McDaniel&#8217;s system will push the ball down the seam. Gesicki could be poised for his best season to date.</p>
<p><strong>WR Davante Adams, Green Bay Packers</strong>: Adams was franchise tagged but informed the team he will not play without receiving a long-term deal. The two sides currently are far apart, per reports, so we&#8217;ll have to remain patient. Given Adams&#8217; past comments about not leaving money on the table due to his humble beginnings, it&#8217;s difficult to see him actually sitting out NFL games.</p>
<h2>Unsigned notables</h2>
<ul>
<li><strong>Quarterbacks</strong>: Jameis Winston, Jacoby Brissett, Marcus Mariota, Ryan Fitzpatrick, Cam Newton, Andy Dalton</li>
<li><strong>Running backs</strong>: Leonard Fournette, Cordarrelle Patterson, James White, Melvin Gordon, Sony Michel, Rashaad Penny, Phillip Lindsay, David Johnson, Ronald Jones, Marlon Mack, Darrel Williams, J.D. McKissic, Jerick McKinnon, Devonta Freeman, Latavius Murray, Raheem Mostert, Jeff Wilson, Tarik Cohen</li>
<li><strong>Wide receivers</strong>: Allen Robinson, Odell Beckham Jr., JuJu Smith-Schuster, DJ Chark Jr., Russell Gage, T.Y. Hilton, Tre&#8217;Quan Smith, Marquez Valdes-Scantling, Jamison Crowder, Sammy Watkins, Keelan Cole, Jakeem Grant, A.J. Green, Emmanuel Sanders, Byron Pringle, Demarcus Robinson, Zay Jones</li>
<li><strong>Tight ends</strong>: Rob Gronkowski, O.J. Howard, Blake Jarwin, Robert Tonyan, Gerald Everett, Jared Cook, Eric Ebron, Hayden Hurst, Kyle Rudolph, Jimmy Graham, Anthony Firkser, Tyler Conklin</li>
</ul>
</div>

						<div class="noskim">
							<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
							
							
							
							<p class="post-tags post-tags--hide"><a href="https://thehuddle.com/tag/2022-fantasy-football/" rel="tag">2022 fantasy football</a>, <a href="https://thehuddle.com/tag/2022-nfl-free-agency/" rel="tag">2022 NFL free agency</a>, <a href="https://thehuddle.com/tag/2022-nfl-free-agents/" rel="tag">2022 NFL free agents</a>, <a href="https://thehuddle.com/tag/fantasy-football/" rel="tag">Fantasy Football</a>, <a href="https://thehuddle.com/tag/free-agency/" rel="tag">free agency</a>, <a href="https://thehuddle.com/tag/nfl-free-agency/" rel="tag">NFL free agency</a>, <a href="https://thehuddle.com/tag/nfl-free-agents/" rel="tag">nfl free agents</a>, <a href="https://thehuddle.com/category/nfl-free-agents/" rel="category tag">NFL free agents and fantasy football impact</a></p>
							<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">23</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thehuddle"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
		data-short-url=""
		data-track="thehuddlestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thehuddle.com/2022/03/14/fantasy-football-2022-nfl-free-agency-roundup/"
			data-short-url=""
			data-track="thehuddlestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
						</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="noskim">
			<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>MORE HUDDLE <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/07/20/fantasy-football-los-angeles-rams-cam-akers-todd-gurley/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-1"
		title="Where should the Rams turn after losing Cam Akers?"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/07/USATSI_16225737.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/07/USATSI_16225737.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Where should the Rams turn after losing Cam Akers?" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">20 shares</span><span class="block__time block__time--mobile">20 Jul 21</span>
		<h2><a href="https://thehuddle.com/category/fantasy-football-injury-analysis/" class="category" itemprop="articleSection">Fantasy Football Injury Analysis</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-1" href="https://thehuddle.com/2021/07/20/fantasy-football-los-angeles-rams-cam-akers-todd-gurley/"
				title="Where should the Rams turn after losing Cam Akers?" itemprop="url">
				Where should the Rams turn after losing Cam Akers?			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/05/19/fantasy-football-players-entering-a-contract-year-in-2021/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-2"
		title="Fantasy football: Players entering a contract year in 2021"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15436821.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/05/USATSI_15436821.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Fantasy football: Players entering a contract year in 2021" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">28 shares</span><span class="block__time block__time--mobile">19 May 21</span>
		<h2><a href="https://thehuddle.com/category/nfl-free-agents/" class="category" itemprop="articleSection">NFL free agents and fantasy football impact</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-2" href="https://thehuddle.com/2021/05/19/fantasy-football-players-entering-a-contract-year-in-2021/"
				title="Fantasy football: Players entering a contract year in 2021" itemprop="url">
				Fantasy football: Players entering a contract year in 2021			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://thehuddle.com/2021/03/30/fantasy-football-free-agency-roundup-3/"
		data-track="thehuddlefeaturedstories thehuddlemore-related-3"
		title="Fantasy football free agency roundup"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2021/03/USATSI_15544284-e1619625688747.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://thehuddle.com/wp-content/uploads/sites/74/2021/03/USATSI_15544284-e1619625688747.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Fantasy football free agency roundup" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">7 shares</span><span class="block__time block__time--mobile">30 Mar 21</span>
		<h2><a href="https://thehuddle.com/category/nfl-free-agents/" class="category" itemprop="articleSection">NFL free agents and fantasy football impact</a></h2>

		<p>
			<a data-track="thehuddlefeaturedstories thehuddlemore-related-3" href="https://thehuddle.com/2021/03/30/fantasy-football-free-agency-roundup-3/"
				title="Fantasy football free agency roundup" itemprop="url">
				Fantasy football free agency roundup			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>THE LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/14/2022-nfl-top-free-agent-tracker/"
						title="2022 NFL top free-agent tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2018/12/usatsi_11746088.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2018/12/usatsi_11746088.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2022 NFL top free-agent tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/14/2022-nfl-top-free-agent-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/14/2022-nfl-top-free-agent-tracker/"
			title="2022 NFL top free-agent tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Fantasy football player movement</a>						<span class="block__time block__time--mobile">1hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/14/2022-nfl-top-free-agent-tracker/"
						title="2022 NFL top free-agent tracker"
						itemprop="url" 						>
							2022 NFL top free-agent tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 14, 2022 7:40 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2022 NFL offseason free-agent tracker. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/14/2022-fantasy-football-player-movement-tracker/"
						title="2022 fantasy football player movement tracker"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14959543.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/09/USATSI_14959543.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2022 fantasy football player movement tracker" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/14/2022-fantasy-football-player-movement-tracker/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/14/2022-fantasy-football-player-movement-tracker/"
			title="2022 fantasy football player movement tracker"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/player-movement/" class="category" itemprop="articleSection">Fantasy football player movement</a>						<span class="block__time block__time--mobile">4hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/14/2022-fantasy-football-player-movement-tracker/"
						title="2022 fantasy football player movement tracker"
						itemprop="url" 						>
							2022 fantasy football player movement tracker					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 14, 2022 5:01 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>2022 NFL off-season player movement tracker. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/14/2022-fantasy-football-brian-daboll-new-york-giants/"
						title="2022 NFL coaching changes: New York Giants"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17593306.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17593306.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2022 NFL coaching changes: New York Giants" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/14/2022-fantasy-football-brian-daboll-new-york-giants/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/14/2022-fantasy-football-brian-daboll-new-york-giants/"
			title="2022 NFL coaching changes: New York Giants"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>3</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">6hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/14/2022-fantasy-football-brian-daboll-new-york-giants/"
						title="2022 NFL coaching changes: New York Giants"
						itemprop="url" 						>
							2022 NFL coaching changes: New York Giants					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 14, 2022 2:50 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Can Brian Daboll get the most out of Daniel Jones in 2022? </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/13/fantasy-football-tom-brady-unretires-tampa-bay-buccaneers/"
						title="Tom Brady unretires to rejoin Buccaneers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17552849.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17552849.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Tom Brady unretires to rejoin Buccaneers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/13/fantasy-football-tom-brady-unretires-tampa-bay-buccaneers/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/13/fantasy-football-tom-brady-unretires-tampa-bay-buccaneers/"
			title="Tom Brady unretires to rejoin Buccaneers"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>11</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/" class="category" itemprop="articleSection">Fantasy football player analysis tips and advice</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/13/fantasy-football-tom-brady-unretires-tampa-bay-buccaneers/"
						title="Tom Brady unretires to rejoin Buccaneers"
						itemprop="url" 						>
							Tom Brady unretires to rejoin Buccaneers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 13, 2022 8:22 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>The GOAT unretires to rejoin the Tampa Bay Buccaneers. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/12/browns-acquire-amari-cooper-from-cowboys/"
						title="Browns acquire Amari Cooper from Cowboys"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17524555.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17524555.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Browns acquire Amari Cooper from Cowboys" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/12/browns-acquire-amari-cooper-from-cowboys/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/12/browns-acquire-amari-cooper-from-cowboys/"
			title="Browns acquire Amari Cooper from Cowboys"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/" class="category" itemprop="articleSection">Fantasy football player analysis tips and advice</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/12/browns-acquire-amari-cooper-from-cowboys/"
						title="Browns acquire Amari Cooper from Cowboys"
						itemprop="url" 						>
							Browns acquire Amari Cooper from Cowboys					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 12, 2022 3:10 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Amari Cooper lands in Cleveland in exchange for a fifth-round pick </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/11/2022-nfl-coaching-changes-chicago-bears/"
						title="2022 NFL coaching changes: Chicago Bears"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17594591.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17594591.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2022 NFL coaching changes: Chicago Bears" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/11/2022-nfl-coaching-changes-chicago-bears/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/11/2022-nfl-coaching-changes-chicago-bears/"
			title="2022 NFL coaching changes: Chicago Bears"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/11/2022-nfl-coaching-changes-chicago-bears/"
						title="2022 NFL coaching changes: Chicago Bears"
						itemprop="url" 						>
							2022 NFL coaching changes: Chicago Bears					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 11, 2022 3:25 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/david-dorey/" title="Posts by David Dorey" class="author url fn" rel="author">David Dorey</a>													</span>
					</p>
				</footer>

				<p>Bears turn to Luke Getsy to run the offense. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/10/2022-nfl-nathaniel-hackett-denver-broncos/"
						title="2022 NFL coaching changes: Denver Broncos"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17579153.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17579153.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2022 NFL coaching changes: Denver Broncos" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/10/2022-nfl-nathaniel-hackett-denver-broncos/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/10/2022-nfl-nathaniel-hackett-denver-broncos/"
			title="2022 NFL coaching changes: Denver Broncos"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>2</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/10/2022-nfl-nathaniel-hackett-denver-broncos/"
						title="2022 NFL coaching changes: Denver Broncos"
						itemprop="url" 						>
							2022 NFL coaching changes: Denver Broncos					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 10, 2022 11:40 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Denver finally has its franchise QB to pair with a new head coach. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/09/fantasy-football-reaction-washington-acquires-carson-wentz-from-colts/"
						title="Fantasy football reaction: Washington acquires Carson Wentz from Colts"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17479619.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17479619.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football reaction: Washington acquires Carson Wentz from Colts" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/09/fantasy-football-reaction-washington-acquires-carson-wentz-from-colts/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/09/fantasy-football-reaction-washington-acquires-carson-wentz-from-colts/"
			title="Fantasy football reaction: Washington acquires Carson Wentz from Colts"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>17</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/fantasy-football-trade-analysis/" class="category" itemprop="articleSection">Fantasy football trade analysis</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/09/fantasy-football-reaction-washington-acquires-carson-wentz-from-colts/"
						title="Fantasy football reaction: Washington acquires Carson Wentz from Colts"
						itemprop="url" 						>
							Fantasy football reaction: Washington acquires Carson Wentz from Colts					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 9, 2022 2:42 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>The good and the bad of Washington acquiring Carson Wentz.  </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/09/2022-nfl-coaching-changes-new-orleans-saints/"
						title="2022 NFL coaching changes: New Orleans Saints"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17388183.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17388183.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2022 NFL coaching changes: New Orleans Saints" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/09/2022-nfl-coaching-changes-new-orleans-saints/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/09/2022-nfl-coaching-changes-new-orleans-saints/"
			title="2022 NFL coaching changes: New Orleans Saints"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>0</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/nfl-coaching-change-fantasy-football-impact/" class="category" itemprop="articleSection">NFL Coaching Change with fantasy football impact</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/09/2022-nfl-coaching-changes-new-orleans-saints/"
						title="2022 NFL coaching changes: New Orleans Saints"
						itemprop="url" 						>
							2022 NFL coaching changes: New Orleans Saints					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 9, 2022 11:49 am ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Continuity in mind, Dennis Allen returns to the sidelines in his second stint as a head coach. </p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/08/fantasy-football-fallout-russell-wilson-traded-to-broncos/"
						title="Fantasy football fallout: Russell Wilson traded to Broncos"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17481576.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thehuddle.com/wp-content/uploads/sites/74/2022/03/USATSI_17481576.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Fantasy football fallout: Russell Wilson traded to Broncos" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://thehuddle.com/2022/03/08/fantasy-football-fallout-russell-wilson-traded-to-broncos/';">
	<div class="reply-block">
		<a
			data-track="thehuddlemostrecent"
			href="https://thehuddle.com/2022/03/08/fantasy-football-fallout-russell-wilson-traded-to-broncos/"
			title="Fantasy football fallout: Russell Wilson traded to Broncos"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>59</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://thehuddle.com/category/fantasy-football-player-analysis-tips-advice-picks/" class="category" itemprop="articleSection">Fantasy football player analysis tips and advice</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
										<a
						data-track="thehuddlemostrecent"
						href="https://thehuddle.com/2022/03/08/fantasy-football-fallout-russell-wilson-traded-to-broncos/"
						title="Fantasy football fallout: Russell Wilson traded to Broncos"
						itemprop="url" 						>
							Fantasy football fallout: Russell Wilson traded to Broncos					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">March 8, 2022 6:50 pm ET </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://thehuddle.com/author/cory-bonini/" title="Posts by Cory Bonini" class="author url fn" rel="author">Cory Bonini</a>													</span>
					</p>
				</footer>

				<p>Fantasy football reaction to Russell Wilson trade  </p>

				
				
			</div>
		</article>
	</div>
<a href="https://thehuddle.com" class="article__back">More Huddle</a>

					</div>

	</div><!-- #content -->
</div><!-- #primary -->

<div class="noskim">
	
<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget widget--login widget--box" id="login_widget-3">
<div class="login login--sidebar">
	<div class="login__wrap icon--key">
		<div class="login__text">
			<h2 class="login__heading">Join The Huddle for full access.</h2>
			<p class="login__body">Your #1 source for fantasy football information</p>
			<ul class="login__items">
				<li>Cheat sheets</li>
				<li>Sleepers</li>
				<li>Player Rankings</li>
				<li>Draft Tools</li>
				<li>24/7 Updates</li>
			</ul>
		</div>
		<a href="http://thehuddle.com/site/join.php" class="login__button">Create an Account</a>
	</div>
</div>
</div><div class="widget widget--forum widget--box" id="forum_widget-4">
<div class="header-box">
	<h2>Fantasy Statistics</h2>
</div>

<ul id="menu-statistics-menu" class="forum__menu"><li id="menu-item-424381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-424381"><a href="https://tools.thehuddle.com/season">Season-to-Date Stats</a></li>
<li id="menu-item-424383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424383"><a href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
<li id="menu-item-425284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425284"><a href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
<li id="menu-item-424384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424384"><a href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
<li id="menu-item-424386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424386"><a href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchups</a></li>
<li id="menu-item-424385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424385"><a href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Stats Matchups</a></li>
<li id="menu-item-453426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453426"><a href="https://thehuddle.com/2021/05/12/2021-nfl-schedule-team-by-week-grid/">Schedule: Team-by Week Grid</a></li>
<li id="menu-item-453427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453427"><a href="https://thehuddle.com/2021/05/12/2021-nfl-schedule-weekly-matchups/">Schedule: Weekly Grid</a></li>
<li id="menu-item-453428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-453428"><a href="https://thehuddle.com/2021/05/12/2021-nfl-schedule-release-bye-weeks/">Schedule: Bye Weeks</a></li>
</ul><a href="https://thehuddle.com/fantasy-football-statistics/" class="forum__view-all">View All&hellip;</a>
</div><div class="widget widget_media_image" id="media_image-3"><a href="http://www.thehuddle.com/podcast/"><img width="1000" height="1000" src="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg" class="image wp-image-429990 alignnone attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg 1000w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=150,150 150w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=300,300 300w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=768,768 768w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=600,600 600w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=100,100 100w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=340,340 340w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=32,32 32w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=50,50 50w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=64,64 64w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=96,96 96w, https://thehuddle.com/wp-content/uploads/sites/74/2017/09/blitz.jpg?resize=128,128 128w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></div><div class="widget widget--links widget--box" id="links_widget-8">
<div class="header-box ">
	<h2>Player Movement</h2>
	</div>

<ul id="menu-player-movement-menu" class="links__menu"><li id="menu-item-463866" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-463866"><a href="https://thehuddle.com/2022/01/26/2022-nfl-coaching-change-tracker/">2022 NFL coaching change tracker</a></li>
<li id="menu-item-463955" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-463955"><a href="https://thehuddle.com/2022/03/14/2022-nfl-top-free-agent-tracker/">2022 NFL top free-agent tracker</a></li>
<li id="menu-item-424963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424963"><a href="https://tools.thehuddle.com/nfl-depth-charts">2022 fantasy depth charts</a></li>
<li id="menu-item-457194" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-457194"><a href="https://thehuddle.com/2021/05/01/fantasy-football-2021-player-movement-tracker/">2021 fantasy football player movement tracker</a></li>
</ul></div><div class="widget widget--links widget--box" id="links_widget-7">
<div class="header-box ">
	<h2>Fantasy Resources</h2>
	</div>

<ul id="menu-resources-menu" class="links__menu"><li id="menu-item-424713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424713"><a href="https://tools.thehuddle.com/nfl-depth-charts">2022 fantasy depth charts</a></li>
<li id="menu-item-457572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457572"><a href="https://thehuddle.com/2022-nfl-draft-central/">2022 NFL Draft Central</a></li>
<li id="menu-item-463954" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-463954"><a href="https://thehuddle.com/2022/03/14/2022-nfl-top-free-agent-tracker/">2022 NFL top free-agent tracker</a></li>
<li id="menu-item-464191" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-464191"><a href="https://thehuddle.com/2022/03/14/2022-fantasy-football-player-movement-tracker/">2022 fantasy football player movement tracker</a></li>
</ul></div><div class="widget widget--forum widget--box" id="forum_widget-3">
<div class="header-box">
	<h2>Huddle Forums</h2>
</div>

<ul id="menu-forums-menu" class="forum__menu"><li id="menu-item-424628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424628"><a href="http://forums.thehuddle.com/index.php?/forum/3-nfl-fantasy-football/">Fantasy Football Forum</a></li>
<li id="menu-item-424629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424629"><a href="http://forums.thehuddle.com/index.php?/forum/6-fantasy-football-advice/">Fantasy Advice Forum</a></li>
<li id="menu-item-424630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424630"><a href="http://forums.thehuddle.com/index.php?/forum/108-individual-defensive-players/">IDP Forum</a></li>
<li id="menu-item-424637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-424637"><a href="http://forums.thehuddle.com/index.php?/forum/155-find-a-league-find-an-owner/">Find a League/Owner Forum</a></li>
</ul><a href="http://forums.thehuddle.com/" class="forum__view-all">View All&hellip;</a>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="https://www.usatoday.com/sports/" rel="nofollow" target="_blank">
			<img src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/logo-usat-footer-1.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-435660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435660"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448091"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435659"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-435661"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428292"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a>		</p>
	</div>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
</div>

			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div class="noskim">
		<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
		<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://thehuddle.com/wp-content/uploads/sites/74/2016/06/icon-huddle.png" alt="The Huddle">
				<a class="mobile-nav__breadcrumb" href="https://thehuddle.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/thehuddle" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/TheHuddle" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--myhuddle mobile-nav__item--parent"><a href="https://tools.thehuddle.com/myhuddle/custom">myHuddle</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--custom-leagues"><a href="https://tools.thehuddle.com/myhuddle/custom">Custom Leagues</a></li>
	<li class="mobile-nav__item mobile-nav__item--player-tracking"><a href="https://tools.thehuddle.com/myhuddle/player-tracking">Player Tracking</a></li>
	<li class="mobile-nav__item mobile-nav__item--account-information"><a href="https://tools.thehuddle.com/myhuddle/account-information">Account Information</a></li>
	<li class="mobile-nav__item mobile-nav__item--subscription-status"><a href="https://tools.thehuddle.com/myhuddle/subscription-status">Subscription Status</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--draft-guide mobile-nav__item--parent"><a title="Fantasy football draft guide preview" href="https://thehuddle.com/2021-fantasy-football-draft-guide/">Draft Guide</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--cheat-sheets"><a title="Fantasy football cheat sheets and rankings" href="https://tools.thehuddle.com/cheatsheets">Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-projections"><a title="Fantasy football projections and rankings" href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy football projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-overall"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-standard">Top 200 Overall</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-ppr"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-ppr">Top 200 PPR</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-200-qb-heavy"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-qb-heavy">Top 200 QB Heavy</a></li>
	<li class="mobile-nav__item mobile-nav__item--10-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-10-team">10-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--12-team-auction-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-12-team">12-Team Auction Cheat Sheet</a></li>
	<li class="mobile-nav__item mobile-nav__item--keeper-dynasty-cheat-sheet"><a href="https://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/dynasty">Keeper/Dynasty Cheat Sheet</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--inseason mobile-nav__item--parent"><a href="https://thehuddle.com/in-season-fantasy-football/">Inseason</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-player-rankings-projections"><a href="https://tools.thehuddle.com/fantasy-football-projections">Fantasy Football Player Rankings / Projections</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-cheat-sheets"><a href="https://tools.thehuddle.com/cheatsheets">Fantasy Football Cheat Sheets</a></li>
	<li class="mobile-nav__item mobile-nav__item--dfs-daily-fantasy-football"><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/">DFS - Daily Fantasy Football</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfl-game-predictions-and-picks"><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions">NFL Game Predictions and Picks</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-football-start-bench-tool"><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list">Fantasy Football Start/Bench Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-tools-and-articles-by-day"><a href="https://thehuddle.com/in-season-fantasy-football/">All Tools and Articles (by day)</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--news mobile-nav__item--parent"><a title="Fantasy football NFL news and injuries" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0">News</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--top-fantasy-football-news"><a title="Top fantasy football news and tips" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=1">Top fantasy football news</a></li>
	<li class="mobile-nav__item mobile-nav__item--qb-news-and-notes"><a title="NFL QB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=QB">QB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--rb-news-and-notes"><a title="NFL RB fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=RB">RB news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--wr-news-and-notes"><a title="NFL WR fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=WR">WR news and notes</a></li>
	<li class="mobile-nav__item mobile-nav__item--te-news-and-notes"><a title="NFL TE fantasy football news and notes" href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/?feed=0&#038;position=TE">TE news and notes</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--stats mobile-nav__item--parent"><a href="https://thehuddle.com/fantasy-football-statistics/">Stats</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--season-to-date-by-position"><a title="NFL and fantasy football statistics: Season-to-date" href="https://tools.thehuddle.com/season">Season-to-Date (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--weekly-by-position"><a title="NFL and fantasy football statistics: Weekly by position" href="https://tools.thehuddle.com/weekly">Weekly (by position)</a></li>
	<li class="mobile-nav__item mobile-nav__item--fantasy-box-scores"><a title="NFL and fantasy football statistics: Box scores" href="https://tools.thehuddle.com/stats/box-scores">Fantasy Box Scores</a></li>
	<li class="mobile-nav__item mobile-nav__item--strength-of-schedule-tool"><a title="NFL tools: Strength of schedule" href="https://tools.thehuddle.com/stats/strength-of-schedule">Strength of Schedule Tool</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-rankings"><a title="NFL tools: Team position fantasy football rankings" href="https://tools.thehuddle.com/stats/team_position_rankings">Team Position Rankings</a></li>
	<li class="mobile-nav__item mobile-nav__item--team-position-ranks-matchup"><a title="NFL tools: Team position fantasy football ranking matchups" href="https://tools.thehuddle.com/stats/team-position-rank-matchups">Team Position Ranks Matchup</a></li>
	<li class="mobile-nav__item mobile-nav__item--game-statistics-matchup"><a title="NFL and fantasy football statistics: Game matchup" href="https://tools.thehuddle.com/stats/game-stat-matchups">Game Statistics Matchup</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--teams mobile-nav__item--parent"><a href="http://tools.thehuddle.com/teams">Teams</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--afc-east"><a href="#">AFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--buffalo-bills"><a title="Buffalo Bills fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/25/buffalo-bills">Buffalo Bills</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-dolphins"><a title="Miami Dolphins fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/7/miami-dolphins">Miami Dolphins</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-england-patriots"><a title="New England Patriots fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/1/new-england-patriots">New England Patriots</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-jets"><a title="New York Jets fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/22/new-york-jets">New York Jets</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-north"><a href="#">AFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--baltimore-ravens"><a title="Baltimore Ravens fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/24/baltimore-ravens">Baltimore Ravens</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-browns"><a title="Cleveland Browns fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/29/cleveland-browns">Cleveland Browns</a></li>
	<li class="mobile-nav__item mobile-nav__item--cincinnati-bengals"><a title="Cincinnati Bengals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/23/cincinnati-bengals">Cincinnati Bengals</a></li>
	<li class="mobile-nav__item mobile-nav__item--pittsburgh-steelers"><a title="Pittsburgh Steelers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/18/pittsburgh-steelers">Pittsburgh Steelers</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-south"><a href="#">AFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-texans"><a title="Houston Texans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/11/houston-texans">Houston Texans</a></li>
	<li class="mobile-nav__item mobile-nav__item--indianapolis-colts"><a title="Indianapolis Colts fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/19/indianapolis-colts">Indianapolis Colts</a></li>
	<li class="mobile-nav__item mobile-nav__item--jacksonville-jaguars"><a title="Jacksonville Jaguars fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/13/jacksonville-jaguars">Jacksonville Jaguars</a></li>
	<li class="mobile-nav__item mobile-nav__item--tennessee-titans"><a title="Tennessee Titans fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/30/tennessee-titans">Tennessee Titans</a></li>
	<li class="mobile-nav__item mobile-nav__item--afc-west"><a href="#">AFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-broncos"><a title="Denver Broncos fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/8/denver-broncos">Denver Broncos</a></li>
	<li class="mobile-nav__item mobile-nav__item--kansas-city-chiefs"><a title="Kansas City Chiefs fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/31/kansas-city-chiefs">Kansas City Chiefs</a></li>
	<li class="mobile-nav__item mobile-nav__item--las-vegas-raiders"><a title="Las Vegas Raiders fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/10/las-vegas-raiders">Las Vegas Raiders</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-chargers"><a title="Los Angeles Chargers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/3/los-angeles-chargers">Los Angeles Chargers</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-east"><a href="#">NFC East</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-cowboys"><a title="Dallas Cowboys fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/6/dallas-cowboys">Dallas Cowboys</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-giants"><a title="New York Giants fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/17/new-york-giants">New York Giants</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-eagles"><a title="Philadelphia Eagles fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/28/philadelphia-eagles">Philadelphia Eagles</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-commanders"><a title="Washington Football Team fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/4/washington-commanders">Washington Commanders</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-north"><a href="#">NFC North</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bears"><a title="Chicago Bears fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/27/chicago-bears">Chicago Bears</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-lions"><a title="Detroit Lions fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/2/detroit-lions">Detroit Lions</a></li>
	<li class="mobile-nav__item mobile-nav__item--green-bay-packers"><a title="Green Bay Packers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/14/green-bay-packers">Green Bay Packers</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-vikings"><a title="Minnesota Vikings fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/16/minnesota-vikings">Minnesota Vikings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-south"><a href="#">NFC South</a></li>
	<li class="mobile-nav__item mobile-nav__item--atlanta-falcons"><a title="Atlanta Falcons fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/12/atlanta-falcons">Atlanta Falcons</a></li>
	<li class="mobile-nav__item mobile-nav__item--carolina-panthers"><a title="Carolina Panthers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/15/carolina-panthers">Carolina Panthers</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-saints"><a title="New Orleans Saints fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/5/new-orleans-saints">New Orleans Saints</a></li>
	<li class="mobile-nav__item mobile-nav__item--tampa-bay-bucs"><a title="Tampa Bay Buccaneers fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/20/tampa-bay-buccaneers">Tampa Bay Bucs</a></li>
	<li class="mobile-nav__item mobile-nav__item--nfc-west"><a href="#">NFC West</a></li>
	<li class="mobile-nav__item mobile-nav__item--arizona-cardinals"><a title="Arizona Cardinals fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/26/arizona-cardinals">Arizona Cardinals</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-rams"><a title="Los Angeles Rams fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/9/los-angeles-rams">Los Angeles Rams</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-francisco-49ers"><a title="San Francisco fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/32/san-francisco-49ers">San Francisco 49ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--seattle-seahawks"><a title="Seattle Seahawks fantasy football news, statistics, roster" href="https://tools.thehuddle.com/nfl-team/21/seattle-seahawks">Seattle Seahawks</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--players"><a href="https://tools.thehuddle.com/playerLanding">Players</a></li>
<li class="mobile-nav__item mobile-nav__item--fantasy-football-nfl-depth-charts"><a title="Fantasy football NFL depth charts" href="https://tools.thehuddle.com/nfl-depth-charts">Fantasy Football NFL Depth Charts</a></li>
<li class="mobile-nav__item mobile-nav__item--forums"><a href="http://forums.thehuddle.com/">Forums</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-draft-central"><a title="2020 NFL Draft: Round-by-round picks" href="https://thehuddle.com/2022-nfl-draft-central/">NFL Draft Central</a></li>
<li class="mobile-nav__item mobile-nav__item--nfl-betting-picks-and-tips"><a title="NFL betting picks, tips, odds and lines" target="_blank" rel="noopener" href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/">NFL betting picks and tips</a></li>
<li class="mobile-nav__item mobile-nav__item--about"><a href="https://thehuddle.com/about-2/">About</a></li>
<li class="mobile-nav__item mobile-nav__item--buy-tickets"><a href="https://www.ticketsmarter.com/?utm_source=thehuddle.com&#038;utm_medium=mainnavlink&#038;utm_campaign=gannett">Buy Tickets</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-435660" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-448091" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-435659" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-435661" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
<li id="menu-item-428292" class="mobile-nav__item mobile-nav__item--about-the-huddle"><a href="https://thehuddle.com/about-2/">About The Huddle</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thehuddle.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="https://www.usatoday.com/sports/"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://thehuddle.com/wp-content/uploads/sites/74/2020/08/usat-logo-mobile-off-canvas-1.png">
		</a>
	</div>

<nav
	class="user-nav "
	style="display: none;"
	id="usernavWrapper"
>
			<a href="http://thehuddle.com/site/join.php" class="user-nav__item">
			Subscribe
		</a>
		<a href="https://tools.thehuddle.com/login" class="user-nav__item">
			Sign In
		</a>
		<a href="http://thehuddle.com/site/help.php" class="user-nav__item">Help</a>
</nav>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><link rel='stylesheet' id='all-css-0' href='https://thehuddle.com/_static/??/wp-includes/css/dashicons.min.css,/wp-includes/js/thickbox/thickbox.css?m=1647039334' type='text/css' media='all' />
<script id='lawrence-ga-create-js-after'>
ga('create', 'UA-166840762-5', {'name' : 'FishburneGATracker'});
</script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1' id='sharethrough-native-responsive-js'></script>
<script id='usatoday-sticky-inline-videos-script-js-extra'>
var stickyInlineVideosOptions = {"side":"right","hide":"Hide video"};
</script>
<script id='lawrence-ads-js-js-extra'>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"60","refresh_type":"all","distance":"2000","active":"0"}};
</script>
<script type="text/javascript" src="https://thehuddle.com/_static/??-eJydj0EOwjAMBD9EiEAI1APiKZVJDLhNnJI4Lfk9FAlUIQ6Uo9fr8a4eOmUCC7JouaDHpHMCCRaKcjBEZIPaB5vdYwNWJROpk6SbpDuI4ENmWTZpof/nMAj1WJ8j9CSlPjm8zScyuCJk0hT8cilBcJT9bKonzoLKoyUYgdNZvV9+YjuXz8QT7ktID3dbFLEjRtWTxfDM+U3/OevYk466uWaMZWlCaAnnHHsgnuMHO2Y7+P1qu9mtq1W1qZo7U9nc9w==" ></script><script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0' id='lawrence-confiant-js-js'></script>
<script id='wasabi-article-js-extra'>
var wasabiFacebookReferral = "0";
</script>
<script id='wasabi-main-js-extra'>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"1440\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script id='huddle-user-nav-js-extra'>
var huddleUser = {"name":"Huddle User","cookie":"session","logoutAPI":"https:\/\/api.thehuddle.com\/User\/Logout"};
</script>
<script id='huddle-login-debug-js-extra'>
var huddleLoginDebugData = {"is_member":"","user_data":[]};
</script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/thehuddle.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type="text/javascript" src="https://thehuddle.com/_static/??-eJytkdEOgjAMRX/IsWCMhgfjt3SsgWK3EbYJ+PWOB1QSH4D41t713DZ3sm9F6WxAG2TLsSLrZfQQnIZRzALDcxTsQAsc0qRGLZsvNTNks8Yf5D+81vr04EHRxMZA7HdwFh5UQSC3/vgP7Emjgm4HCV2gknEHaWBDzqFGUUetGSeU1u9bgtFjJ1JSM0625KjRT2+pRaNw2/8v7dklUaQoY/VrQ6ipvCs3vIs0dDPX/Hy6HIu8OBXNCxBXCe4=" ></script><script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin' id='sop-script-js'></script>
<script type="text/javascript" src="https://thehuddle.com/wp-content/themes/usatoday-lawrence/js/ats_smg.js?m=1647291949g" ></script><script src='https://stats.wp.com/e-202211.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.1',blog:'175784887',post:'464257',tz:'-4',srv:'thehuddle.com'} ]);
	_stq.push([ 'clickTrackerInit', '175784887', '464257' ]);
</script>
	</div>
</body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
